OpenWrt Forum Archive

Topic: Is this router based on the infineon danube?

The content of this topic has been archived between 24 Mar 2018 and 1 May 2018. Unfortunately there are posts – most likely complete pages – missing.

J2 has a 3.3V serial lines (TX, RX, GNC and Vcc) and 6 unknown pines. I've tried to load a linux kernel through the serial port with no luck. There is a person, blogic, who alledgely has been able to boot linux in this board, but there is no instructions nor manual.

Also, I've read that the WIFI calibration data is stored somewhere in the flash memory and that booting linux can erase and overwrite that data leaving the atheros chip useless.

I have a pretty similar modem on my hands & I've managed to get serial console to the device - tho i can't login with it.
Am I wired something wrong or is this common with these boxes ?

Hello,

I have apartially  working OpenWRT (no dsl, no voip, no wireless) without writing to flash ram (u-boot loaded from serial to ram, kernel+ramdisk fs loaded from ethernet)
If someone wants to try, send a  msg.

Could you explain the procedure in more detail?
I mean, how did you prepare the image for it to work from the ram, how did you load uboot in ram, etc., etc.
Thanks.

I'd like to also know this.

Hello,

I am out of home, but from the well of memory:

configure u-boot-lantiq  as easy50712_DDR166M_ramboot (from make menuconfig in openwrt)

You need to connect to serial port 1
Access BRN bootloader (press spacebar three times when required to do)
press ! to enter admin mode

load uboot.bin at 0xa0400000 (M a0400000)
go 0xa0400000 (Y a0400000)

You need some patches in order to access lan through RTL8306 switch,

Do you guys know if I have to bridge some points or such to get access to BRN or anything at all, there aren't any way to access it at the moment, or not even access to the linux console with serial. My board is bewan ibox with my ISP's customized firmware.

Here is a pic from my board: http://img201.imageshack.us/img201/1562/dsc00005ci.jpg
And beginning of the boot: http://pastebin.com/J9sJvmW4

@Jokinen, no, on the 7908 you don't have to do anything special to access the bootloader, on yours it appears there's no option.
The danube has also an internal boot rom that must be enabled with a couple of resistors, but I don't know the details.
Also, the 7908 doesn't run Linux and there's no shell access through the serial port.

It does run the linux (can see the bootlog over the serial), just can't access the shell like you said.
It's a shame since this is nothing more than a paperweight as it is now... I'll just have to wait and hope that someone finds those resistors out since I'm not skilled enough to do that by myself.

Yes, your runs linux, mine doesn't.
Edit: oh, and if yours runs linux, they have to release the sources and a means of rebuilding and flashing them.
See http://www.gpl-violations.org/

(Last edited by pippolippi on 14 Sep 2010, 21:10)

Thanks for the info, but I think many people have already notified my ISP for GPL violation without any reaction from their part.
And it seems they have released one really old source code of that firmware, but no way to flash it back...

Have you tried to press CTRL-C or send break early in the boot process?
If that does not work, you can try to set jumpers J16 and J21 to use UART boot mode.

I have tried both, no success so far. Thanks anyways.

UART boot mode didn't work? Thats very strange. In that case, How did you generate the image? How did you load it?

The device does say that it's in UART mode, but there is absolutely I can do. I haven't generated any images since I cannot disturb the boot process in any way.

it is waiting for the bootloader over the serial line.You should send the u-boot.asc, I think in raw mode, but i am not sure.

Should it reply something as I write in to it or just wait blindly ? Im sure I have working TTL adapter & im fairly sure I'm using the right pins for TX / RX, but as I write it doesnt reply at all...
My pins are like in following picture: http://i.imgur.com/CC981.png

It actually booted my self generated u-boot.asc - thanks a million!

ADSL works. LEDS somehow. Trying USB.

ngp, are you booting of nfs or have you written openwrt to the flash ?
If you're using nfs, do you have some tips how to get it working ?
I've compiled new kernel with nfs support, confirmed that my nfs share works but still i am getting this error: VFS: Cannot open root device "nfs" or unknown-block(0,255)

Edit: got it working, had to manually add some packages to kernels .config file.

Those who wanna know, those packages were:
CONFIG_ROOT_NFS=y (obviously)
CONFIG_NET=y
CONFIG_INET=y
CONFIG_IP_PNP=y
CONFIG_IP_PHP_DHCP=y
CONFIG_NETWORK_FILESYSTEMS=y

(Last edited by Jokinen on 17 Sep 2010, 19:08)

Im kinda out of ideas, the kernel loads just fine, and so does the rootfs, but as soon as i mount jffs2 the kernel panics.
Here is the bootlog: http://pastebin.com/V04z11Ku

And also, I had to edit u-boots sources to match up my flashes block size, otherwise i couldnt save variables & erase flash correctly.

Hi Jokinen,
can you enable the kernel symbol table? Then we might get a better hint for what goes wrong.

Hi Jokinen,

it's still difficult to see the real problem.
In my kernel (2.6.33.7, build from trunk), I don't see any call to "__copy_user" from "jffs2_scan_medium" or its sub-functions.
So maybe some overflow or memory corruption?

But you said, you had to adapt u-boot to a different block size? So maybe there is a problem in the jffs2-code?

I'm sorry I cannot help you further, but maybe some other linux developer has more ideas.

I tried to look at jffs2 related code, but my skills aren't good enough to do anything special by myself. Thanks for the idea tho.

Sorry, posts 51 to 50 are missing from our archive.