OpenWrt Forum Archive

Topic: OpenWRT Kamikaze on TP-link tl-wa501g?

The content of this topic has been archived between 31 Aug 2014 and 5 May 2018. Unfortunately there are posts – most likely complete pages – missing.

thanks for replying how to leave free space for the jffs overlay after rootf as i stated before the link

http://wiki.x-wrt.org/index.php/Kamikaze_Installation
is dead now so i don't have proper commands to writeimages vi redboot

following output in redboot

RedBoot> ^C
RedBoot> fis list
Name              FLASH addr  Mem addr    Length      Entry point
RedBoot           0xBFC00000  0xBFC00000  0x00010000  0x00000000
vmlinux.bin.l7    0xBFC10000  0x80033800  0x000C0000  0x80033800
rootfs            0xBFCB0000  0x80033800  0x00110000  0x80033800
FIS directory     0xBFDE0000  0xBFDE0000  0x0000F000  0x00000000
RedBoot config    0xBFDEF000  0xBFDEF000  0x00001000  0x00000000
RedBoot> fis free
  0xBFDC0000 .. 0xBFDE0000

RedBoot> fis load -l kernel
Image loaded from 0x80033800-0x8028df2c


i just read the post a few pages back where u say that quote

The atheros-2.6 kernel is built with the load and entry address set at 0x80041000.
so i ereased the flash and wrote the kernel with command

RedBoot> fis create -r 0x80041000 -e 0x80041000 vmlinux.bin.l7


the output in redboot are

RedBoot> fis list
Name              FLASH addr  Mem addr    Length      Entry point
RedBoot           0xBFC00000  0xBFC00000  0x00010000  0x00000000
vmlinux.bin.l7    0xBFC10000  0x80041000  0x000A0000  0x80041000
rootfs            0xBFCB0000  0x80033800  0x00110000  0x80033800
FIS directory     0xBFDE0000  0xBFDE0000  0x0000F000  0x00000000
RedBoot config    0xBFDEF000  0xBFDEF000  0x00001000  0x00000000
RedBoot> fis free
  0xBFDC0000 .. 0xBFDE0000

RedBoot> fis load -l vmlinux.bin.l7
Image loaded from 0x80041000-0x80214e60

Still the same problem changes is not written

ADDITIONAL INFORMATION:

description of the leds:

the sys led keeps flashing as it should
the wlan light does not blink it just lights up there


thanks for the response

(Last edited by drekthar on 11 Jul 2011, 07:13)

found some commands to view the mtd partions in the flash and  i tried to write something but to no avail

root@TPLink-mpcs_v2:~# touch /jffs/test
root@TPLink-mpcs_v2:~#                   (nothing)
root@TPLink-mpcs_v2:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00010000 00010000 "RedBoot"
mtd1: 000a0000 00010000 "vmlinux.bin.l7"
mtd2: 00130000 00010000 "rootfs"
mtd3: 00080000 00010000 "rootfs_data"
mtd4: 0000f000 0000f000 "FIS directory"
mtd5: 00001000 00001000 "RedBoot config"
mtd6: 00010000 00010000 "boardconfig"

root@TPLink-mpcs_v2:~# ls /dev/mtdblock*
/dev/mtdblock0  /dev/mtdblock2  /dev/mtdblock4  /dev/mtdblock6
/dev/mtdblock1  /dev/mtdblock3  /dev/mtdblock5



thanks for ur help so far
couldn't have done anything without with it

(Last edited by drekthar on 11 Jul 2011, 07:14)

Fixed my problem i erased the flashed and changed the order of flashing , i flashed the rootfs first then the kernel this i think created the jffs overlay right after the squash filesystem anyway now i can write changes i want to thank XSSA for the help he has done

can anyone tell me now how to set this router as a repeater ( repeater i mean a repeater bridge) with wpa ccmp encryption is it possible on a atheros chipset

any help is appreciated

TO XSSA

i have been reading instructions on how to set this router up as a repeater and since this router has the atheros chip it can't do the client bridge setup so i went for the client mode using MASQUERADE  here http://wiki.openwrt.org/doc/recipes/rou … figuration

after setting  it up
and when i try to reconfigure the wireless network with the command
ifup wan
wifi

i get the following error
udhcpc (v1.11.2) started
udhcpc: socket(AF_PACKET): Address family not supported by protocol

did u include the af_packet.ko module in your build

how do i load this module to openwrt and install it using the insmod name command


thanks in advance

(Last edited by drekthar on 13 Jul 2011, 18:15)

wpa-supplicant-mini  is not installed but i want use this router with wpa encrypton  as client mode and opkg is not included so  is there any other way to install wpa-supplicant

I made new kernel with all options included so you can setup wpa/2-psk wifi clients. Bridged clients are also can be configured, but there compatibility issues with some access points.
Try to add this string in /etc/config/wireless section config 'wifi-iface'
option 'mode' 'sta'
option 'wds' '1'

Broadcom based APs need to be configured with allowed bridging or client will fail to associate with this option enabled. Atheros based APs seems to be not affected.

the output in redboot are

RedBoot> fis list
Name              FLASH addr  Mem addr    Length      Entry point
RedBoot           0xBFC00000  0xBFC00000  0x00010000  0x00000000
vmlinux.bin.l7    0xBFC10000  0x80041000  0x000A0000  0x80041000
rootfs            0xBFCB0000  0x80033800  0x00110000  0x80033800
FIS directory     0xBFDE0000  0xBFDE0000  0x0000F000  0x00000000
RedBoot config    0xBFDEF000  0xBFDEF000  0x00001000  0x00000000
RedBoot> fis free
  0xBFDC0000 .. 0xBFDE0000

So you can see 2 free blocks in your setup but jffs will use only free space inside rootfs partition. So flash rootfs not with -l 0x110000 but -l 0x130000
and if 'fis free' will give you no output you will prepare maximum space for jffs.

THANKS MAN
Sorry for the late reply and thanks for the info very helpful...... i will try this out immediately and post my progress in this forum as fast as i can

also the ap i am trying to client bridge does not support wds so i cannot go for this option any instruction on how to client bridge in this ap will be wonderfull

(Last edited by drekthar on 14 Jul 2011, 22:31)

Hi!

Please help me! My wr340GD firmware 4.7.7. I'm trying upgrade wr340v5_linux.bin, but not working.

Thanks.

hello sarkany

u have to downgrade ur firmware the member XSSA told me this u should drop him a email

hope this helped

To XSSA

i have been googling around to find out whether it was possible to client bridge an atheros based router in openwrt as it is possible in dd-wrt and i came across this script hack from gargoyle which is called ARPNAT ..explained in detail at this link http://projectgus.com/2010/03/wireless- … h-openwrt/  it turns out dd-wrt uses this script in their firmware to implement client bridge

cheers

Thanks drekthar!

I'm flashing. now working ip 192.168.1.55 root/ar2317, but no webinterface.
Sorry, my bad english.

This build is not a production image it is merely a very smalll barebones linux that the tp-link firmware can accept
read all the post on this forim before trying... including XSSA post  THIS IS MEMBER XSSA BUILD U SHOULD PM OR EMAIL HIM 

QUOTE "XSSA"

Tp_Link TL-WR340G/D and any other Tp-links with vxworks onboard is not stated anywhere as supported devices and until yesterday there was no opportunity to work with it w/o soldering and flashing bootloader and linux into chip directly.

There is also no way to flash production OpenWrt through TP-Link's WEB directly, because of many limitations and most of it is it can accept only images less then 1179648 bytes long(hardcoded in firmware) and even less in practice.

What I gave for community is NOT a production firmware!!! There are no working DHCP server on this image, no WiFi, no WEB, no SSH and rootfs is not writable in sense of saving changes on reboot - it's aim is only to fit it into specs TP-Link's web can accept it, reflash bootloader, prepare eeprom  and give you, guys, starting point to put your own Linux images on it w/o soldering and so on. And let you start coding. There is also oportunity in it to revert all back to original VxWorks,

(Last edited by drekthar on 18 Jul 2011, 12:47)

Sorry.

I installed openwrt-atheros-vmlinux.lzma and rootsq.rom.
Thanks.

(Last edited by sarkany on 18 Jul 2011, 13:23)

lowac u should drop member xssa a line all the vxkiller in this forum is his i am sure he will help u...

ok Thx for help ..

cliver drop xssa a line and he will respond to u he made all the vxkillers in this forum and saranky would u  mind mentioning what do u intend from openwrt

(Last edited by drekthar on 19 Jul 2011, 16:06)

Cliver, image for tp-link tl-wa501g with AR2313 chipset and rtl8201 phy needs to be tested on real hardware. Are you ready to screw up and solder console port?

xssa wrote:

Cliver, image for tp-link tl-wa501g with AR2313 chipset and rtl8201 phy needs to be tested on real hardware. Are you ready to screw up and solder console port?

YES
I have the wire soldered to the motherboard to see what happens. I want to test the vxkiller under my responsibility. then informs what happens.

I'm also ready for testing. tpl-WA500G.  Maybe Xssa will tell us a little bit on how to prepare imge with redboot ..
sorry if I wrote something wrong ..

someone email so he can post a new link to the image

any progress ? .... (wa-500g)
I found tx .. there are missing some resistors .. or jumper

AR2315 rev 0x00000090 startup...                                                                     
Attached TCP/IP interface to ae unit 0                                                               
Attaching interface lo0...done                                                                       
                                                                                                     
USRCONF : g_size = 20428                                                                             
Name = MODULE_USR_CONF_T , size = 12                                                                 
Name = UC_IEEE802_1X_CFG_DATA_T , size = 512                                                         
Name = UC_ADVANCED_CFG_T , size = 16                                                                 
Name = UC_ARP_CFG_T , size = 652                                                                     
Name = UC_BPA_CFG_DATA_T , size = 912                                                                
Name = UC_DDNS_T , size = 1480                                                                       
Name = UC_DHCPC_CFG_DATA_T , size = 416                                                              
Name = UC_DHCPS_CFG_AND_STATIC_T , size = 708                                                        
Name = UC_FIRE_WALL_STATE_T , size = 1992
Name = UC_FORWARD_VIRTUAL_SERVE_CLASS_T , size = 1572
Name = UC_LAN_CFG_DATA_T , size = 16
Name = UC_L2TP_CFG_DATA_T , size = 1472
Name = UC_MAC_CONFIG_T , size = 80
Name = UC_PPPOE_CFG_DATA_T , size = 1600
Name = UC_NTP_PREFER_SRV_CFG_DATA_T , size = 28
Name = UC_STATIC_IP_CFG_DATA_T , size = 144
Name = UC_SATTIC_ROUTE_CFG_DATA_T , size = 328
Name = UC_MANAGE_USERS_T , size = 64
Name = UC_UTILITIES_T , size = 16
Name = UC_WANCONNTYPE_T , size = 16
Name = UC_WLAN_CFG_T , size = 5164
Name = UC_OPMODE_CFG_T , size = 4
Name = UC_PPTP_CFG_DATA_T , size = 1472
Name = UC_NETWORK_PSEUDO_T , size = 4
Name = UC_QOS_ROUTER_CONF_FLASH_T , size = 740
Name = UC_DHCPP_CFG_DATA_T , size = 1008
dsInit 1
wlanBridgeInit(): ucGetOpMode() 3
wireless access point starting...
wlan0 Ready
TDD


                            Software Platform for ARM
  Copyright(C) 2001-2004 by TP-LINK TECHNOLOGIES CO., LTD.
  Creation date: Jun  8 2009, 17:14:35

  Press CTRL-B to enter bootmenu...

  Boot Menu:
     1:  Download application program
     2:  Modify Bootrom password
     3:  Exit the menu
     4:  Reboot
     5:  User commond line
        Enter your choice(1-4):

looking for rx ... found
and only works :5

        Enter your choice(1-4):5


Please Input debug cmd:help
command         description
-------------------------------
help            print all commands
task            print task information
stack           print task stack
e               exit

Please Input debug cmd:

i try load other firmware ..
. without  Vxkiller ... nothing to do ...
update  .. when i type some single char exp. k

        Enter your choice(1-4):k


  NAME        ENTRY       TID    PRI   STATUS      PC       SP     ERRNO  DELAY
---------- ------------ -------- --- ---------- -------- -------- ------- -----
tExcTask   801aeae4     807f4a70   0 PEND       801d0d70 807f4950       0     0
tLogTask   801b3d74     807f1ee0   0 PEND       801d0d70 807f1dc8       0     0
bootromTask8004f8b0     80522460   8 READY      801c9ab8 80522260  3d0002     0
tWlanCal   800e7560     80591d20  10 PEND       801d0d70 80591c30       0     0
tApCserv   800d53b0     805283f0  10 PEND       801d0d70 80528308       0     0
Detectd    80022de4     8051d700  40 DELAY      801c8828 8051d678       0   254
timerMgt   80142fd4     8051f970  48 PEND+T     801455b4 8051f8f8  3d0004    12
endRecvTask80051674     8053d8b0  49 PEND+T     801d0d70 8053d798  3d0004     1
tNetTask   80187bd4     807a4380  50 PEND       801455b4 807a42f0       0     0
tApHouseKee800d58e0     8052d640  50 DELAY      801c8828 8052d590       0  2229
802_1X     8008b6d0     80523710 150 PEND+T     801455b4 80523690  3d0004     7
usrRebootd 8005eb88     806efa30 202 PEND+T     801d0d70 806ef950  3d0004    62
tFWCONF    800875e8     80748280 203 DELAY      801c8828 807481f8       0   121
mud0_80    8002fe30     804f4a50 203 PEND+T     801455b4 804f4810  3d0002   843
sysExLogd  800206f0     80755020 240 PEND       801455b4 80754c08  3d0002     0
tddp       8013d110     803bb560 249 PEND+T     801455b4 803bb358  3d0002    61

or : m

        Enter your choice(1-4):m
558

FREE LIST:
   num    addr       size
  ---- ---------- ----------
     1 0x807fb1f0      16176
     2 0x807f5e60         96
     3 0x806ecae0         96
     4 0x802e84e0     854032
     5 0x8079f280        224


SUMMARY:
 status    bytes     blocks   avg block  max block
 ------ ---------- --------- ---------- ----------
current
   free     870624         5     174124     854032
  alloc    4469264       566       7896          -
cumulative
  alloc    4473520       600       7455          -

:k shows task list i can get now more info i :5 task  print task information

I build some redboot image for some other devices ..
Any one knows how to add to the www image ?
Any sugestions are welcome ...

Sorry if this is not about the thread ..

(Last edited by lowac on 2 Aug 2011, 22:21)

i get the followig errors when i try to  associate the wr340g as wireless client with wpa-psk encryption


udhcpc (v1.11.2) started
enable_atheros(wifi0): Failed to set up wpa_supplicant for interface ath0
Sending discover...
udhcpc: sendto: Network is down
root@TPLink-mpcs_v2:~# udhcpc: ioctl 0x8933 failed: No such device
udhcpc: bind: No such device


my /etc/config/wireless

config 'wifi-device' 'wifi0'
        option 'type' 'atheros'
        option 'channel' '6'

config 'wifi-iface'
        option 'device' 'wifi0'
        option 'network' 'wan'
        option 'mode' 'sta'
        option 'wds' '1'
        option 'key' '1'
        option 'key1' '*********'
        option 'txpower' '19'
        option 'ssid' '******'
        option 'encryption' 'psk'

/etc/config/network

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'ifname' 'eth0'
        option 'type' 'bridge'
        option 'proto' 'static'
        option 'netmask' '255.255.255.0'
        option 'dns' '192.168.1.100'
        option 'gateway' '192.168.1.100'
        option 'ipaddr' '192.168.1.55'

config 'interface' 'wan'
       option 'proto' 'dhcp'

Bridge information

root@TPLink-mpcs_v2:/etc/config# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          8000.940c6df6d82b       yes             eth0

thanks in advance

(Last edited by drekthar on 20 Aug 2011, 21:38)