OpenWrt Forum Archive

Topic: New Release Candidate

The content of this topic has been archived between 15 Apr 2018 and 2 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

It is well known fact that it takes time to build quality, and sometimes
more time than expected. The OpenWrt developers would like to announce
the availability of OpenWrt Kamikaze 8.09 RC1.
You can find it at

Release Candidate 1 for Kamikaze 8.09

New changes/features include:

    * Busybox upgraded to 1.11.2
    * Kernel upgrades for all targets
    * uClibc upgraded to 0.9.29
    * Firewall rewrite, fully modular netfilter/iptables support
        - Syntax of /etc/config/firewall converted to UCI
    * ipkg package manager replaced with opkg
        - package lists moved to ramdisk, lists are not retained between reboots.
        - `opkg update' must be run after each reboot before new packages are installed
    * Broadcom 47xx running reliably with the new Kernel, including b43 wireless driver
        - WEP, WDS and multi-SSID not yet supported
    - AP mode and STA mode are supported with WPA, WPA2, or no encryption
    * IMQ and Traffic shaping fixed with newer kernels (2.6.25+)
    * Sysupgrade for x86, broadcom and adm5120
    * New web interface (LuCI, Lua Configuration Interface)
    * New HAL and driver for Atheros based WiFi cards
    * Attention towards the integration of security updates
    * Build system cleanup
    * Package maintaining and updates between releases

Supported targets:

    * AMD Alchemy (MeshCube)
    * Atheros AR531x/231x based routers
    * Atheros AR71xx based routers
    * Atmel AVR32
    * Broadcom 47xx based routers (Linux 2.4 and 2.6)
    * Infineon/ADMtek ADM5120
    * Infineon Danube/TwinPass
    * Intel IXP42x/43x
    * MagicBox
    * MikroTik RouterBoard 532
    * RDC SoC
    * Texas Instruments AR7
    * User-Mode Linux (source code release only)
    * x86 based boards

Known Issues:
    * New uClibc version breaks ABI compatibility with older releases.
    * Wireless no longer supported on older Broadcom devices (bcm4710/bcm94702)
      - Support was dropped in upstream Broadcom wl driver and b43
      - b43legacy (which adds support for such hardware) might be added in a future release

The OpenWrt Team

Great news!
Thanks to all developers for their efforts.
Will try this soon.

nbd wrote:

Known Issues:
    * New uClibc version breaks ABI compatibility with older releases

Some of asterisk users, including me, had encountered some issues on asterisk (need to run asterisk with "-vvv" switch) compiled with uClibc-0.9.29 (not sure if it's related to this 1779). Does the new uClibc version include fixes for this?

Congrats to all on all the hard work that has been put in on getting this together.

Now I can stop building the trunk tongue

First of all, thank you. b43legacy would be more than welcome (especially if it would not take another year to get it out - but I understand you are doing this for free, so I just want to say, that it would make me happy, if it were released soon).

Does wifi work with 2.6 and broadcom? I happen to own asus wl500gp (and wl500g, which is no longer supported, I fear, I hope the new gp version is).

This announcement indicates that 2.6 should work on my WL-500gp, but it doesn't really work. The AP comes up, and I can connect to it, but after a bit of traffic goes though, I lose the association and cannot re-associate. The rest of the router is perfectly fine.
Am I experiencing an isolated issue? Or should I not be using 2.6 on this router?

Broadcom47xx 2.6 with b43 still has some issues that an a compat-wireless might solve. We will make sure b43legacy works as well.

Did you leave out the word "upgrade?"

Broadcom47xx 2.6 with b43 still has some issues that an a compat-wireless <upgrade> might solve. We will make sure b43legacy works as well.

If not, what did you mean? Thanks for the great work, and I look forward to continued testing.

broadcom 47xx needs to be migrated to 2.6.27 before we can fully take advantage of the new mac80211 stuff.
this won't happen in 8.09, but probably in the release after that.

Any timeline? I'm running trunk, and don't mind continuing to run trunk. I love testing/breaking things smile

No idea. I'm not working on that at the moment.

I successfully build and run 8.09_rc1 + LuCI (trunk) on the router in my signature smile

If you're not experiencing the same wireless stops working problem I am, can you post your config? I'd like to give it a try.


candrews wrote:

umiki seems to have gotten it to work, but I can't find any patches or any further progress.

It is working more or less. I have tried different kernel and compat-wireless versions, the latest is kernel + compat-wireless-2008-11-03 + hostapd 0.6.5 (hostapd has to be upgraded for compat-wireless-2008-11-03 to work). Wireless transfer speeds are ok (~2200 Kb/sec, AP mode with WPA2 encryption) and it does not drop wireless connections (that often, it seems to be stable for days). Unfortunately another - rather annoying - problem has appeared: when connecting directly to the router using wireless, ssh (and samba) seem to freeze after a short time (connection to the internet in the same time is fine). If I connect to a desktop computer first (using wireless, through the router) and then connect to the router from that computer with ssh, it works fine (it is a bit mysterious to me).

It sounds like your router works far better than mine! Can you post your patches at ? I'd love to try them out, and see what I can contribute.

Some comments to the developers:

- There is an image for BR-6104K and BR-6104KP, the KP suggests usb support, but there is none, maybe nice to add this.
- Both images BR-6104K and BR-6104KP are to big. (1.9M) you cant save any changes, add or remove anything, because there are to
   few erase blocks. Maybe it's better remove some options (i.e. netfilter  modules) and let the user install them if needed.
   Also you may create an option to create a small base system with usb support and a script that downloads extra modules and packages
   to usb stick the first time it is booted. This way you make shure you have enough space on the flash chip left for changes and you allow
   the user to enjoy the full possibilitys.

Running fine on WL500Gp with Toshiba WLL4050-D4 (5004 & 5213) Atheros with madwifi injection drivers.

Thank you all very much for all the effort of creating this distribution!

PS: I met Luci, she's pretty sexy too! wink

Tested on a WBR2-G54...

Broadcom 47xx based routers (Linux 2.4) - Works
Broadcom 47xx based routers (Linux 2.6) - Doesn't Work

After some more testing i'm not happy to report that wget is not working on the ADM5210 (BR-6104K and BR-6104KP routers).
My router is behind a router / modem, wich should be no problem, because i've got two ADM5120 based routers (sweex LB00021 and Edimax BR-6104KP), they both work with the Midge / Kamikaze 2,4 firmware (wget works perfect) but the new openwrt firmware fails.
Also creating firmware with the trunk gives the same results.

Wget gives a time-out during connect. I can ping the sites, but wget just don't works....

Has anyone tried if the asterisk-1.4.24 will work on this RC1? I rebuilt the SVN tree (r13168) with uClibc-0.9.29 and asterisk-1.4.24 and asterisk- failed to run with the same issue pointed out on this link.

Working well on my single port Fonera.

working (with patches) on my bcm63xx (Comtrend 536)

   lan working
   usb 1.1 working
   wifi bcm43xx working

   adls not tested

Thanks for your great effort

openmedia wrote:

Working well on my single port Fonera.

With or without asterisk?