OpenWrt Forum Archive

Topic: support for DLINK DIR-615 Hw:D1

The content of this topic has been archived between 24 Feb 2015 and 6 May 2018. Unfortunately there are posts – most likely complete pages – missing.

-=niki=- wrote:

Tried your patch, but I think I did something wrong.

PowerLED turns off after few seconds
Connecting wire to WAN or LAN ports results in a fast flashing LED (of the assigned Port)
Connection to Box fails

have you set ip address of your pc to 192.168.1.2? it comes no dhcp set up by default.
i think the flashing led means the connection is correct.

(Last edited by widewing on 9 Apr 2013, 08:08)

No, my IP was set to 192.168.1.10

My D3 didn't show that behaviour.

-=niki=- wrote:

Tried your patch, but I think I did something wrong.

PowerLED turns off after few seconds
Connecting wire to WAN or LAN ports results in a fast flashing LED (of the assigned Port)
Connection to Box fails

odd... after a svn up & a clean rebuild my router behaves exactly the same as what you said.
I noticed that the kernel is about to upgraded to 3.8 recently, is that related?

(Last edited by widewing on 9 Apr 2013, 17:09)

In other words:

changing line in trunk/target/linux/ramips/Makefile to

LINUX_VERSION:=3.7.10

should do the trick??? I'll give it a try

In fact i'm very confused that there is "files-3.7" moved from "files", but where is "files-3.8"?

widewing wrote:

hi gregd, does this patch work for your box?
i'm really busy the following days, so if you've tested, please help to submit them. :-)

Hi widewing,

I spent some time yesterday investigating this and I think I've got it working (on AA). Basically, you were spot on with missing RT305X_GPIO_MODE_MDIO 'or' when initializing GPIO. However, you patch was initializing GPIO twice.

The patch below is a refined version and is adjusted to AA:

Index: target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c
===================================================================
--- target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c       (revision 35572)
+++ target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c       (working copy)
@@ -22,6 +22,9 @@
 #define DIR_300B_GPIO_LED_STATUS_AMBER 8
 #define DIR_300B_GPIO_LED_STATUS_GREEN 9
 #define DIR_300B_GPIO_LED_WPS          13
+
+#define DIR_615D_GPIO_LED_WPS_RED      13
+#define DIR_615D_GPIO_LED_WPS_BLUE     11
 /*
  * NOTE: The wan led is also connected to the switch, both
  * switch and gpio must be active to make it light up
@@ -83,6 +86,34 @@
        }
 };

+static struct gpio_led dir_615d_leds_gpio[] __initdata = {
+       {
+               .name           = "d-link:amber:status",
+               .gpio           = DIR_300B_GPIO_LED_STATUS_AMBER,
+               .active_low     = 1,
+       }, {
+               .name           = "d-link:green:status",
+               .gpio           = DIR_300B_GPIO_LED_STATUS_GREEN,
+               .active_low     = 1,
+       }, {
+               .name           = "d-link:amber:wan",
+               .gpio           = DIR_300B_GPIO_LED_WAN_AMBER,
+               .active_low     = 1,
+       }, {
+               .name           = "d-link:green:wan",
+               .gpio           = DIR_300B_GPIO_LED_WAN_GREEN,
+               .active_low     = 1,
+       }, {
+               .name           = "d-link:blue:wps",
+               .gpio           = DIR_615D_GPIO_LED_WPS_BLUE,
+               .active_low     = 1,
+       }, {
+               .name           = "d-link:red:wps",
+               .gpio           = DIR_615D_GPIO_LED_WPS_RED,
+               .active_low     = 1,
+       }
+};
+
 static struct gpio_led dir_620_leds_gpio[] __initdata = {
        {
                .name           = "d-link:amber:status",
@@ -131,6 +162,24 @@
                                  dir_300b_leds_gpio);
 }

+static void __init dir_615d_init(void)
+{
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT |
+                  RT305X_GPIO_MODE_MDIO);
+        rt305x_register_flash(0);
+
+        rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_LLLLW;
+        rt305x_register_ethernet();
+        ramips_register_gpio_buttons(-1, DIR_300B_KEYS_POLL_INTERVAL,
+                                     ARRAY_SIZE(dir_300b_gpio_buttons),
+                                     dir_300b_gpio_buttons);
+        rt305x_register_wifi();
+        rt305x_register_wdt();
+
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(dir_615d_leds_gpio),
+                                 dir_615d_leds_gpio);
+}
+
 static void __init dir_620a1_init(void)
 {
        dir_common_init();
@@ -149,7 +187,7 @@
             dir_300b_init);

 MIPS_MACHINE(RAMIPS_MACH_DIR_615_D, "DIR-615-D", "D-Link DIR-615 D",
-            dir_300b_init);
+            dir_615d_init);

 MIPS_MACHINE(RAMIPS_MACH_DIR_620_A1, "DIR-620-A1", "D-Link DIR-620 A1",
             dir_620a1_init);
Index: target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
===================================================================
--- target/linux/ramips/base-files/lib/preinit/06_set_iface_mac (revision 36157)
+++ target/linux/ramips/base-files/lib/preinit/06_set_iface_mac (working copy)
@@ -28,7 +28,8 @@
                ;;
        dir-300-b1 |\
        dir-300-b2 |\
-       dir-600-b1)
+       dir-600-b1 |\
+       dir-615-d)
                 mac=$(ramips_get_mac_binary devdata 16388)
                 ifconfig eth0 hw ether $mac 2>/dev/null
                 ;;
Index: target/linux/ramips/base-files/etc/uci-defaults/network
===================================================================
--- target/linux/ramips/base-files/etc/uci-defaults/network  (revision 36157)
+++ target/linux/ramips/base-files/etc/uci-defaults/network  (working copy)
@@ -164,7 +164,8 @@
        dir-300-b1 |\
        dir-300-b2 |\
-       dir-600-b1)
+       dir-600-b1 |\
+       dir-615-d)
                lan_mac=$(ramips_get_mac_binary devdata 16388)
                wan_mac=$(/usr/sbin/maccalc add "$lan_mac" 1)
                ;;

I experienced a problem with config/network when doing a sysupgrade. Basically, the switch configuration did not seem right. Full tftp flash of factory firmware should solve it or run 'firstboot' command after sysupgrade.



And here are the builds for Attitude Adjustment:
dir-615d-factory: https://mega.co.nz/#!94kziKYY!Bl0TXHhh8vDonGmcyY6RZSFe34g8WWZn0OF50-GAzbE
dir-615d-sysupgrade: https://mega.co.nz/#!th9jkCSI!UZNzLWaf9kg_mWVxYEF8YXL4KaESPO39JUtTLj5WHvA


Update:
It looks like this does not work with the latest AA branch/trunk. There must have been somewhere a commit that breaks something. I am tempted to say that the problem is in uci network initialization and set_iface_mac. Hopefully, I will try it tomorrow

(Last edited by gregd72002 on 17 Apr 2013, 23:14)

There seem to be more serious problem. I just created an AA build with old ramips ethernet drivers and the router does not initialize correctly.

When using AA r35531 it works perfectly with old ramips and new ramips ethernet. So there must have been a change in AA after r35531 that breaks something.

Here are all the changes:
https://dev.openwrt.org/log/branches/at … sfph_mail=


- I can also confirm that r35782 works perfectly fine with latest ethernet drivers
- so does r35891
- so does r36354 ...

(Last edited by gregd72002 on 23 Apr 2013, 16:22)

I must have mis-compiled something. Below is an updated version.
AA-r36354 (aka final?) openwrt-ramips-rt305x-dir-615-d-squashfs:
sysupgrade: https://mega.co.nz/#!IllW3LzT!DkK9TSfL9x05gUu7L7HIhUvdqaZzPDyDDbS6uio-H7A
factory: https://mega.co.nz/#!pocSEJrJ!dBOqxB5fsbc-5w7VEYUsAiAtn_4x8n-mBDns_W9ph60

Patch:

diff -rupN AA.orig/target/linux/ramips/base-files/etc/uci-defaults/network AA/target/linux/ramips/base-files/etc/uci-defaults/network
--- AA.orig/target/linux/ramips/base-files/etc/uci-defaults/network     2013-04-23 14:11:47.000000000 +0100
+++ AA/target/linux/ramips/base-files/etc/uci-defaults/network  2013-04-18 17:54:30.000000000 +0100
@@ -163,7 +163,8 @@ ramips_setup_macs()

        dir-300-b1 |\
        dir-300-b2 |\
-       dir-600-b1)
+       dir-600-b1 |\
+       dir-615-d)
                lan_mac=$(ramips_get_mac_binary devdata 16388)
                wan_mac=$(/usr/sbin/maccalc add "$lan_mac" 1)
                ;;
diff -rupN AA.orig/target/linux/ramips/base-files/lib/preinit/06_set_iface_mac AA/target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
--- AA.orig/target/linux/ramips/base-files/lib/preinit/06_set_iface_mac 2013-04-23 14:11:47.000000000 +0100
+++ AA/target/linux/ramips/base-files/lib/preinit/06_set_iface_mac      2013-04-18 17:54:56.000000000 +0100
@@ -28,7 +28,8 @@ preinit_set_mac_address() {
                ;;
        dir-300-b1 |\
        dir-300-b2 |\
-       dir-600-b1)
+       dir-600-b1 |\
+       dir-615-d)
                 mac=$(ramips_get_mac_binary devdata 16388)
                 ifconfig eth0 hw ether $mac 2>/dev/null
                 ;;
diff -rupN AA.orig/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c AA/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c
--- AA.orig/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c       2013-04-23 14:11:46.000000000 +0100
+++ AA/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c    2013-04-18 17:58:20.000000000 +0100
@@ -35,6 +35,9 @@
  */
 #define DIR_620_GPIO_LED_WPS_AMBER     11

+#define DIR_615D_GPIO_LED_WPS_RED      13
+#define DIR_615D_GPIO_LED_WPS_BLUE     11
+
 #define DIR_300B_GPIO_BUTTON_WPS       0       /* active low */
 #define DIR_300B_GPIO_BUTTON_RESET     10      /* active low */

@@ -83,6 +86,34 @@ static struct gpio_keys_button dir_300b_
        }
 };

+static struct gpio_led dir_615d_leds_gpio[] __initdata = {
+       {
+               .name           = "d-link:amber:status",
+               .gpio           = DIR_300B_GPIO_LED_STATUS_AMBER,
+               .active_low     = 1,
+       }, {
+               .name           = "d-link:green:status",
+               .gpio           = DIR_300B_GPIO_LED_STATUS_GREEN,
+               .active_low     = 1,
+       }, {
+               .name           = "d-link:amber:wan",
+               .gpio           = DIR_300B_GPIO_LED_WAN_AMBER,
+               .active_low     = 1,
+       }, {
+               .name           = "d-link:green:wan",
+               .gpio           = DIR_300B_GPIO_LED_WAN_GREEN,
+               .active_low     = 1,
+       }, {
+               .name           = "d-link:blue:wps",
+               .gpio           = DIR_615D_GPIO_LED_WPS_BLUE,
+               .active_low     = 1,
+       }, {
+               .name           = "d-link:red:wps",
+               .gpio           = DIR_615D_GPIO_LED_WPS_RED,
+               .active_low     = 1,
+       }
+};
+
 static struct gpio_led dir_620_leds_gpio[] __initdata = {
        {
                .name           = "d-link:amber:status",
@@ -131,6 +162,24 @@ static void __init dir_300b_init(void)
                                  dir_300b_leds_gpio);
 }

+static void __init dir_615d_init(void)
+{
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT |
+                  RT305X_GPIO_MODE_MDIO);
+        rt305x_register_flash(0);
+
+        rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_LLLLW;
+        rt305x_register_ethernet();
+        ramips_register_gpio_buttons(-1, DIR_300B_KEYS_POLL_INTERVAL,
+                                     ARRAY_SIZE(dir_300b_gpio_buttons),
+                                     dir_300b_gpio_buttons);
+        rt305x_register_wifi();
+        rt305x_register_wdt();
+
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(dir_615d_leds_gpio),
+                                 dir_615d_leds_gpio);
+}
+
 static void __init dir_620a1_init(void)
 {
        dir_common_init();
@@ -149,7 +198,7 @@ MIPS_MACHINE(RAMIPS_MACH_DIR_600_B2, "DI
             dir_300b_init);

 MIPS_MACHINE(RAMIPS_MACH_DIR_615_D, "DIR-615-D", "D-Link DIR-615 D",
-            dir_300b_init);
+            dir_615d_init);

 MIPS_MACHINE(RAMIPS_MACH_DIR_620_A1, "DIR-620-A1", "D-Link DIR-620 A1",
             dir_620a1_init);

Hope this works for everyone! (it does for me).

If it does I will submit the patch to the mailing list.

Thanks,
Gregory

(Last edited by gregd72002 on 24 Apr 2013, 12:16)

hi gregory, since the trunk kernel currently goes abnormally I turned to aa branch recently, and patched the patch and that works as expected. but i noticed that there are 2 wifi radio device listed in the page, one works while the other one not, i wonder if that is as expected?

widewing wrote:

hi gregory, since the trunk kernel currently goes abnormally I turned to aa branch recently, and patched the patch and that works as expected. but i noticed that there are 2 wifi radio device listed in the page, one works while the other one not, i wonder if that is as expected?

widewing, bb branch is currently experimental and as such the things are expected to be half working/broken. I'd say it will take another year or two before bb becomes 'release candidate'. At least this long it took for aa to become release candidate. I do not see any point of moving to bb given that the router works fine on aa.

Where do you see the 2 wifi devices? Can you post a log or screenshot somewhere?

Thanks a lot!

gregd72002 wrote:

widewing, bb branch is currently experimental and as such the things are expected to be half working/broken. I'd say it will take another year or two before bb becomes 'release candidate'. At least this long it took for aa to become release candidate. I do not see any point of moving to bb given that the router works fine on aa.

Where do you see the 2 wifi devices? Can you post a log or screenshot somewhere?

Thanks a lot!

Thanks, I see, so the AA release is what we shall wait for :-)

The wifi problem is all my mistake, that I restored older settings(of the trunk) and seems not exactly compatible, the radio1 device was then set up automatically by some mechanism.

(Last edited by widewing on 1 May 2013, 10:29)

By changing line 10 to line 14 of target/linux/ramips/dts/DIR-615-D.dts from

sysc@0 {
    ralink,pinmux = "i2c", "spi", "uartlite", "jtag", "mdio", "sdram", "rgmii";
    ralink,uartmux = "gpio";
    ralink,wdtmux = <1>;
};

to

sysc@0 {
    ralink,pinmux = "i2c", "spi", "uartlite", "jtag", "sdram", "rgmii";
    ralink,gpiomux = "mdio";
    ralink,uartmux = "gpio";
    ralink,wdtmux = <1>;
};

trunk works again for me smile

Hi!
I own a DIR-615 rev D1 router.
If download gregd72002 factory image, and upload it using emergancy room it works perfectly.
But my own images seems to be unusable, it looks like the router writes the firmware to flash but when the poewr LED stop flashing
yellow (reboot?) it goes steady yellow and nothing happens. The router doesn't seem to initialize correctly, and both ethernet and wireless doesn't work.

I have checked out Attitude Adjustment (tried both r36421 and latest r36855) and applied the above patch from gregd72002.
After doing that I basically did:
echo CONFIG_TARGET_ramips=y > .config
make defconfig
make prereq
make menuconfig
make V=99 2>&1 | tee ../build.log

The build process works and creates image (factory/sysupgrade):
bin/ramips/openwrt-ramips-rt305x-dir-615-d-squashfs-factory.bin
but it apears as if this image is not initializing the board properly. When using gregd72002's image, the power LED turns flashing green (and later steady grean),
but when using my image  the LED is flashing yellow for a minute or two and then turns yellow steady and nothing more .

Did I miss any step?
Thanks for any help.

(Last edited by kayak on 9 Jun 2013, 10:54)

I rebuilt the complete tree, and now it works, I think there were stale files lying around, doing stuff twice.
Sorry fo the noise.

kayak wrote:

I rebuilt the complete tree, and now it works, I think there were stale files lying around, doing stuff twice.
Sorry fo the noise.


Hy. I have a DIR-615 D1 version and I tried to flash version from gregd72002 and factory image doesn't work. it flashing but after flash luci interface doesn't work Can you post here a link where i can download your version?
Sorry for my bad english.

Thenx very much.
Regards.

epsoft wrote:
kayak wrote:

I rebuilt the complete tree, and now it works, I think there were stale files lying around, doing stuff twice.
Sorry fo the noise.


Hy. I have a DIR-615 D1 version and I tried to flash version from gregd72002 and factory image doesn't work. it flashing but after flash luci interface doesn't work Can you post here a link where i can download your version?
Sorry for my bad english.

Thenx very much.
Regards.

Luci is not compiled in. You need to install it separately using 'opkg'.

just telnet or ssh and install it.

thanx for your reply,

I have install Luci interface via opkg, but ethernet driver doesn't work on my DIR-615 D1 revision. What can I do?!

gregd72002 wrote:
epsoft wrote:
kayak wrote:

I rebuilt the complete tree, and now it works, I think there were stale files lying around, doing stuff twice.
Sorry fo the noise.


Hy. I have a DIR-615 D1 version and I tried to flash version from gregd72002 and factory image doesn't work. it flashing but after flash luci interface doesn't work Can you post here a link where i can download your version?
Sorry for my bad english.

Thenx very much.
Regards.

Luci is not compiled in. You need to install it separately using 'opkg'.

just telnet or ssh and install it.

epsoft wrote:

thanx for your reply,

I have install Luci interface via opkg, but ethernet driver doesn't work on my DIR-615 D1 revision. What can I do?!

gregd72002 wrote:
epsoft wrote:

Hy. I have a DIR-615 D1 version and I tried to flash version from gregd72002 and factory image doesn't work. it flashing but after flash luci interface doesn't work Can you post here a link where i can download your version?
Sorry for my bad english.

Thenx very much.
Regards.

Luci is not compiled in. You need to install it separately using 'opkg'.

just telnet or ssh and install it.

Are you sure you have the right version?

Check post #233
factory: https://mega.co.nz/#!pocSEJrJ!dBOqxB5fsbc-5w7VEYUsAiAtn_4x8n-mBDns_W9ph60
sysupgare: https://mega.co.nz/#!IllW3LzT!DkK9TSfL9x05gUu7L7HIhUvdqaZzPDyDDbS6uio-H7A

Hello,

I try to build the firmware of the trunk and get an error:

LZMA 4.65 : Igor Pavlov : Public domain : 2009-02-03
mkimage -A mips -O linux -T kernel -C lzma -a 0x80000000 -e 0x80000000 -n "MIPS OpenWrt Linux-3.10.4" -d /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-dir-610-a1.bin.lzma /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-dir-610-a1.uImage
Image Name:   MIPS OpenWrt Linux-3.10.4
Created:      Fri Aug 16 22:09:44 2013
Image Type:   MIPS Linux Kernel Image (lzma compressed)
Data Size:    960617 Bytes = 938.10 kB = 0.92 MB
Load Address: 80000000
Entry Point:  80000000
cat /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-dir-610-a1.uImage /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/root.squashfs > /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/openwrt-ramips-rt305x-dir-610-a1-squashfs-sysupgrade.bin
/media/sky/Ext/openwrt/staging_dir/host/bin/padjffs2 /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/openwrt-ramips-rt305x-dir-610-a1-squashfs-sysupgrade.bin 4 8 64 128 256
padding image to 005bc000
padding image to 005c0000
if [ `stat -c%s "/media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/openwrt-ramips-rt305x-dir-610-a1-squashfs-sysupgrade.bin"` -gt wrgn59_dlob.hans_dir610 ]; then echo "Warning: /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/openwrt-ramips-rt305x-dir-610-a1-squashfs-sysupgrade.bin is too big" >&2; else cp -fpR /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/openwrt-ramips-rt305x-dir-610-a1-squashfs-sysupgrade.bin /media/sky/Ext/openwrt/bin/ramips/openwrt-ramips-rt305x-dir-610-a1-squashfs-sysupgrade.bin; fi
bash: line 0: [: wrgn59_dlob.hans_dir610: integer expression expected
cat /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-dir-610-a1.bin.lzma /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/root.squashfs > /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/img_dir-610-a1.squashfs.tmp
if [ `stat -c%s "/media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/img_dir-610-a1.squashfs.tmp"` -gt $((wrgn59_dlob.hans_dir610 - 64)) ]; then echo "Warning: /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/img_dir-610-a1.squashfs.tmp is too big" >&2; else dd if=/media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-dir-610-a1.bin.lzma of=/media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-dir-610-a1.bin.lzma.padded bs=64k conv=sync; ( dd if=/media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-dir-610-a1.bin.lzma.padded bs=1 count=`expr \`stat -c%s /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-dir-610-a1.bin.lzma.padded\` - 64`; dd if=/media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/root.squashfs bs=64k conv=sync; ) > /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-dir-610-a1.tmp; /media/sky/Ext/openwrt/staging_dir/host/bin/seama -i /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-dir-610-a1.tmp -m "dev=/dev/mtdblock/2" -m "type=firmware"; /media/sky/Ext/openwrt/staging_dir/host/bin/seama -s /media/sky/Ext/openwrt/bin/ramips/openwrt-ramips-rt305x-dir-610-a1-squashfs-factory.bin -m "signature=wrgn59_dlob.hans_dir610" -i /media/sky/Ext/openwrt/build_dir/target-mipsel_dsp_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-dir-610-a1.tmp.seama; fi
bash: wrgn59_dlob.hans_dir610 - 64: syntax error: invalid arithmetic operator (error token is ".hans_dir610 - 64")
make[5]: *** [install] Error 1
make[5]: Leaving directory `/media/sky/Ext/openwrt/target/linux/ramips/image'
make[4]: *** [install] Error 2
make[4]: Leaving directory `/media/sky/Ext/openwrt/target/linux/ramips'
make[3]: *** [install] Error 2
make[3]: Leaving directory `/media/sky/Ext/openwrt/target/linux'
make[2]: *** [target/linux/install] Error 2
make[2]: Leaving directory `/media/sky/Ext/openwrt'
make[1]: *** [/media/sky/Ext/openwrt/staging_dir/target-mipsel_dsp_uClibc-0.9.33.2/stamp/.target_install] Error 2
make[1]: Leaving directory `/media/sky/Ext/openwrt'
make: *** [world] Error 2

I know seems lazy to ask, but would you, gregd72002, be so kind as to compile your latest build with LUCI included?
Or is it really as easy as following Login with Telnet and then LUCI Installation?
I currently have up.whatever's Barrier Breaker r35227 with ipv6-support for dir-615-d installed on my DIR-615 (D3E) router and as that file is down, I would probably have to install the default D-Link firmware, if anything goes wrong. I am no layperson - I just want to be shure about that. (:

Edit: Found a backup of the Barrier Breaker r35227 with ipv6-support for dir-615-d  Download, so I'll just give it a try.
Edit2: Everything worked just fine.

(Last edited by zeroFX on 25 Sep 2013, 00:44)

Since ipv6-support was backported to attitude adjustment 12.09.1, I switched back to that instead of the unstable barrier braker.

Here's my build of AA 12.09.1 (revision 39395) with LuCI, ipv6-support and relayd:
openwrt-ramips-rt305x-dir-615-d-squashfs-factory.bin 2.9 MB

The patch is the same I used last year, neither the red wps led (guess my D3 doesn't have the red one) nor greg's MDIO fix (not needed for me) is included, so you probably should not use this with D1/D2 hardware. However, it works just fine on my D3 and native IPv6 works out of the box after creating the wan6 Interface as described on http://wiki.openwrt.org/doc/uci/network6#native.ipv6.connection.

Index: target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c
===================================================================
--- target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c    (revision 39395)
+++ target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c    (working copy)
@@ -22,6 +22,9 @@
 #define DIR_300B_GPIO_LED_STATUS_AMBER    8
 #define DIR_300B_GPIO_LED_STATUS_GREEN    9
 #define DIR_300B_GPIO_LED_WPS        13
+
+#define DIR_615D_GPIO_LED_WPS_BLUE     11
+
 /*
  * NOTE: The wan led is also connected to the switch, both
  * switch and gpio must be active to make it light up
@@ -109,6 +112,30 @@
     }
 };
 
+static struct gpio_led dir_615d_leds_gpio[] __initdata = {
+    {
+        .name        = "d-link:amber:status",
+        .gpio        = DIR_300B_GPIO_LED_STATUS_AMBER,
+        .active_low    = 1,
+    }, {
+        .name        = "d-link:green:status",
+        .gpio        = DIR_300B_GPIO_LED_STATUS_GREEN,
+        .active_low    = 1,
+    }, {
+        .name        = "d-link:amber:wan",
+        .gpio        = DIR_300B_GPIO_LED_WAN_AMBER,
+        .active_low    = 1,
+    }, {
+        .name        = "d-link:green:wan",
+        .gpio        = DIR_300B_GPIO_LED_WAN_GREEN,
+        .active_low    = 1,
+    }, {
+        .name        = "d-link:blue:wps",
+        .gpio        = DIR_615D_GPIO_LED_WPS_BLUE,
+        .active_low    = 1,
+    }
+};
+
 static void __init dir_common_init(void)
 {
     rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
@@ -131,6 +158,13 @@
                   dir_300b_leds_gpio);
 }
 
+static void __init dir_615d_init(void)
+{
+    dir_common_init();
+    ramips_register_gpio_leds(-1, ARRAY_SIZE(dir_615d_leds_gpio),
+                  dir_615d_leds_gpio);
+}
+
 static void __init dir_620a1_init(void)
 {
     dir_common_init();
@@ -149,7 +183,7 @@
          dir_300b_init);
 
 MIPS_MACHINE(RAMIPS_MACH_DIR_615_D, "DIR-615-D", "D-Link DIR-615 D",
-         dir_300b_init);
+         dir_615d_init);
 
 MIPS_MACHINE(RAMIPS_MACH_DIR_620_A1, "DIR-620-A1", "D-Link DIR-620 A1",
          dir_620a1_init);
Index: target/linux/ramips/base-files/etc/uci-defaults/network
===================================================================
--- target/linux/ramips/base-files/etc/uci-defaults/network    (revision 39395)
+++ target/linux/ramips/base-files/etc/uci-defaults/network    (working copy)
@@ -164,7 +164,8 @@
 
     dir-300-b1 |\
     dir-300-b2 |\
-    dir-600-b1)
+    dir-600-b1 |\
+    dir-615-d)
         lan_mac=$(ramips_get_mac_binary devdata 16388)
         wan_mac=$(/usr/sbin/maccalc add "$lan_mac" 1)
         ;;
Index: target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
===================================================================
--- target/linux/ramips/base-files/lib/preinit/06_set_iface_mac    (revision 39395)
+++ target/linux/ramips/base-files/lib/preinit/06_set_iface_mac    (working copy)
@@ -29,7 +29,8 @@
         ;;
     dir-300-b1 |\
     dir-300-b2 |\
-    dir-600-b1)
+    dir-600-b1 |\
+    dir-615-d)
                 mac=$(ramips_get_mac_binary devdata 16388)
                 ifconfig eth0 hw ether $mac 2>/dev/null
                 ;;

(Last edited by up.whatever on 26 Jan 2014, 12:33)

gnowak84 wrote:
gregd72002 wrote:

Dir-615-D2 build (Attitude Adjustment r35531) with old ramips ethernet drivers
https://mega.co.rnz/#!p8tC1JYL!D0kssW1XulmJ19Yz7Yk7DiSZZsUGEFSOiNo_AYFUjPg

It features the default configuration so you will need opkg install luci or anything else you may want.
By default the opkg uses official AA RC1 repository dated Nov 2012: http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ramips/rt305x/packages/
but it is compiled from recent AA trunk so there might be some minor issues when using AA RC1 packages (especially luci)

Hi, Sorry for a lame question, but is it possible to use an older version of LuCI with it? I can nonfirm ethernet works great with this version.
Many thanks

I have Dir-615-D2 build and I currently using ddwrt and router is set to be repeter and it works fin, unfortunately my provider uses https authentication and i can't use ddwrt version of wget to do the login,

My idea is to use openwrt as it is quite small and I can install wget with ssl support,
can somebody advise if this is possible.
Also how difficult to configure openwrt to work as repeater?
and is this is the best build for Dir-615-D2 "(Attitude Adjustment r35531) with old ramips ethernet drivers
https://mega.co.rnz/#!p8tC1JYL!D0kssW1XulmJ19Yz7Yk7DiSZZsUGEFSOiNo_AYFUjPg"????

I'm also looking for repeater mode using dir-615 d3. I want to connect a second lan (own subnet & dhcp-server) to the old lan with the internet router.

I'm currently also running dd-wrt in Repeater mode connecting to the old lan, and a virtual interface (same pw, but different SSID) for wireless second lan clients. Everything is working great, all the second lan clients(wired & wireless) can all access internet. But I would love to use openwrt instead with all its possibilities. Is this currently possible with openwrt?

Tried 12.09 (Attitude Adjustment) but I couldn't find repeater mode, virtual interface, or n-only mode in LuCI. I suppose editing the .conf files manually and try that way is the way to go from here. I connected to the dir-615 while running dd-wrt to look at the .conf files, but everything is stored in nvram so no .conf files there.

The discussion might have continued from here.