OpenWrt Forum Archive

Topic: support for DLINK DIR-615 Hw:D1

The content of this topic has been archived between 24 Feb 2015 and 6 May 2018. Unfortunately there are posts – most likely complete pages – missing.

hi guys, i have a D1, i compiled the firmware from source with the old ethernet driver, and flashed it from the emergency room. but nothing works except the LAN1 port.
LAN1 port is working but very unstable, I can telnet it, last for about 1 minute,with severe delay, then the session drops.
except for that, nothing works, other ports, wireless(not listed in ifconfig and iwconfig), the LEDs
I noticed that some of you have the D1 and made it work. Can you share the experiences of how to config the kernel and what modifications should be done before compile?
I cannot open dropbox or mediafire from my network, so i didn't test if @cheche 's build work for me.

I have compile a new version.(same location) I notice that wireless does not work at all:

phy0 -> rt2x00lib_request_eeprom_file: Error - Failed to request EEPROM.
rt2800_wmac: probe of rt2800_wmac.0 failed with error -2

I know that I have to modify trunk/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
but no idea what values to extract

http://dl.dropbox.com/u/31323343/openwr … actory.bin
@gendouhydeist here is the config file
https://www.dropbox.com/s/l8j8820gpzk3m … -d1.config
@widewing send me a pm and I will forward to you this file

(Last edited by cheche on 15 Sep 2012, 13:17)

@123serge123 I did a  hexdump -C /dev/mtd2 and I got
00000000  52 30 01 01 00 0c 43 30 52 28 ff ff ff ff ff ff
But I do not know what it means.
I have found a patch similar to what we need for dir-615d1 http://patchwork.openwrt.org/patch/1917/

Shit, I just  found the right partition:
hexdump -C /dev/mtd1
00004000

(Last edited by cheche on 18 Jul 2012, 22:22)

Ok,
Create a new target and wifi works for me. I have open a ticket with a patch
https://dev.openwrt.org/ticket/11883

You can download this version in the same url as published before.
- Power LED does not seem to work.
- All interfaces got same MAC address

(Last edited by cheche on 19 Jul 2012, 03:27)

cheche wrote:

@123serge123 I did a  hexdump -C /dev/mtd2 and I got
00000000  52 30 01 01 00 0c 43 30 52 28 ff ff ff ff ff ff
But I do not know what it means.

It means that correct(?) eeprom for rt3052 exists at offset 0 /dev/mtd2 or "devconf" flash partition (correspondance may be seen in /proc/mtd or in ramips/image/Makefile). So you need correct partition & offset in get-eeprom script

123serge123 wrote:

So you need correct partition & offset in get-eeprom script

Change that, but it did not make any different. The error disappear when apply that patch (nothing to do with eeprom script)

@cheche

qasdfdsaq wrote:

Argh, sorry - missed your post before.

In the latest trunk, lines 292 to 306 set the VLAN configuration. You'll want to replace those lines with:

    case RT305X_ESW_VLAN_CONFIG_LLLLW:
        rt305x_esw_set_vlan_id(esw, 0, 1);
        rt305x_esw_set_vlan_id(esw, 1, 2);
        rt305x_esw_set_vlan_id(esw, 2, 3);

        rt305x_esw_set_pvid(esw, RT305X_ESW_PORT4, 2);
        rt305x_esw_set_pvid(esw, RT305X_ESW_PORT3, 3);

        rt305x_esw_set_vmsc(esw, 0,
                BIT(RT305X_ESW_PORT0) | BIT(RT305X_ESW_PORT1) |
                BIT(RT305X_ESW_PORT2) | BIT(RT305X_ESW_PORT6));
        rt305x_esw_set_vmsc(esw, 1,
                BIT(RT305X_ESW_PORT4) | BIT(RT305X_ESW_PORT6));
        rt305x_esw_set_vmsc(esw, 2, BIT(RT305X_ESW_PORT3) | BIT(RT305X_ESW_PORT6));
        break;
This sets port 3 (physically labelled port 1, next to the WAN port) to VLAN 2, whereas the WAN port is VLAN1 and port 2-4 are VLAN0.

I tried this patch it seems that it didn't have a tag, tried ifconfig and route -n it didn't have it's own interface.

0.0.0.0         192.168.224.1   0.0.0.0         UG    0      0        0 eth0.2
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan
192.168.224.0   0.0.0.0         255.255.224.0   U     0      0        0 eth0.2
292    case RT305X_ESW_VLAN_CONFIG_LLLLW:
293        rt305x_esw_set_vlan_id(esw, 0, 1);
294        rt305x_esw_set_vlan_id(esw, 1, 2);
295        rt305x_esw_set_pvid(esw, RT305X_ESW_PORT4, 2);
296
297        rt305x_esw_set_vmsc(esw, 0,
298                BIT(RT305X_ESW_PORT0) | BIT(RT305X_ESW_PORT1) |
299                BIT(RT305X_ESW_PORT2) | BIT(RT305X_ESW_PORT3) |
300                BIT(RT305X_ESW_PORT6));
301        rt305x_esw_set_vmsc(esw, 1,
302                BIT(RT305X_ESW_PORT4) | BIT(RT305X_ESW_PORT6));
303        break;
304
305    case RT305X_ESW_VLAN_CONFIG_WLLLL:
306        rt305x_esw_set_vlan_id(esw, 0, 1);
307        rt305x_esw_set_vlan_id(esw, 1, 2);
308        rt305x_esw_set_pvid(esw, RT305X_ESW_PORT0, 2);
309
310        rt305x_esw_set_vmsc(esw, 0,
311                BIT(RT305X_ESW_PORT1) | BIT(RT305X_ESW_PORT2) |
312                BIT(RT305X_ESW_PORT3) | BIT(RT305X_ESW_PORT4) |
313                BIT(RT305X_ESW_PORT6));
314        rt305x_esw_set_vmsc(esw, 1,
315                BIT(RT305X_ESW_PORT0) | BIT(RT305X_ESW_PORT6));
316        break;

qasdfdsaq said that I should overwrite the 292 - 306 but it would break the case RT305X_ESW_VLAN_CONFIG_WLLLL so i don't really know I patch it correctly that's why I only put on 292 - 303.

cheche wrote:

Ok,
Create a new target and wifi works for me. I have open a ticket with a patch
https://dev.openwrt.org/ticket/11883

also what router are you using? the wireless and LED patch doesn't work for me at all, I have D4 hardware.

(Last edited by gendouhydeist on 31 Jul 2012, 02:04)

@gendouhydeist Your patch looks right to me, but I am not a expert (not even a novice ) . I have a D1 version.  I just upgrade ticket,and files for revision r32919 (not tested) maybe is worth a try.

May I ask for compiled .bin version for DIR-615 D1? I don't exacly know what to do with that patch.

i got a selfcompiled firmware running on the D1. But the internet port is nuts somehow.

- link is up
- dhcp works
- udp ping and such works
- opkg update stalls / fails ... wierd
- wifi doesnt seem to work, some eeprom fault

https://dl.dropbox.com/u/85940151/openw … actory.bin

ping shows a packetloss of at least 28%

no , do i need to apply it to latest trunk ? where do i put the patches ? will they help me on my wired connection packet loss ?

i sticked to ownagefools instructions the pages before .... but without the patches

check  ,tried your firmware ...

- 100 % packet loss on internet interfase , lan is accessible
- internet interface can do dhcp , but no communication possible after that

@cheche ok another test showed 36% packet loss , but still high .. i cant get tcp connections with this

@SirDodger: I know that it does not work. But I do not know why, or where is the problem. Last time I show, the MAC  addresses where wrong. But Wifi was working.

(Last edited by cheche on 15 Sep 2012, 14:08)

hmm ok , do we have a ticket for the ethernet problems ?

cheche wrote:

Shit, I just  found the right partition:
hexdump -C /dev/mtd1
00004000

I can confirm this position for my DIR-615-D3.

I built 12.09 and trunk from svn some days ago; in both versions the default for dir-615-d seems to be to dump from the beginning of mtd2 which is wrong for my d3! On first boot I got the wrong mac-address and non-functional wireless. I could enable wireless in luci, but the wlan-led status was inverted (on by default, off when wireless enabled) and I could neither see the SSID nor connect to it from a client.

Guided by this thread and https://forum.openwrt.org/viewtopic.php?id=36037 I grepped through my mtd-partitions looking for "52 30" and I found it at /dev/mtd1 offset 0x4000, followed by the real wireless mac adress. Executed

dd if=/dev/mtd1 of=/lib/firmware/RT305X.eeprom bs=1 skip=16384 count=272

followed by reboot and wlan as well as the led was working great on 12.09! On trunk I had to remove the "ht_capab"-options and luci didn't detect the wireless-n capability; otherwise it was working great there as well.

Is DIR-615-D3 considered officially supported in 12.09? Is it too late to file a bug-report to fix the eeprom dump before 12.09 is declared final?

I didn't apply any patches, userspace support for dir-615-d is in trunk and 12.09 since late november: https://dev.openwrt.org/changeset/34375 … adjustment

All you have to do is checkout attitude_adjustment via svn, in menuconfig select target Ralink RT288x/RT3xxx and subtarget RT305x. Finally run make and you get a working firmware image (openwrt-ramips-rt305x-dir-615-d-squashfs-factory.bin) which can be flashed in recovery mode. The only problem I encountered was the eeprom error, which I fixed by running the dd command of my previous post in openwrt and rebooting. The proper fix is editing /etc/hotplug.d/firmware/10-rt2x00-eeprom.

(Last edited by up.whatever on 19 Dec 2012, 18:45)

Flashed your Image to DIR-615-D1 via 30/30/30

Lan ports seems to be broken... there is no connection possible sad
Any suggestions for that Problem??
Hardware should be nearly the same, isn't it???

Sorry, posts 201 to 200 are missing from our archive.