OpenWrt Forum Archive

Topic: TP Link WR1043ND 11n gigabit router

The content of this topic has been archived between 20 Jul 2013 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Right. So then my wirless conf is as it should be. But the issue still stand and I'd like to have my N-suppor, and that should work, togehter with that the WLAN should not be unst

hey danielholm,

look for the option "noscan" in the wireless configuration file. that solved my problem i had with the 300mbit mode using openwrt!

philk87 wrote:

hey danielholm,

look for the option "noscan" in the wireless configuration file. that solved my problem i had with the 300mbit mode using openwrt!

Thank you, I'll try that as fast as I get home!

philk87 wrote:

hey danielholm,

look for the option "noscan" in the wireless configuration file. that solved my problem i had with the 300mbit mode using openwrt!

There is no option named "noscan" in /etc/config/wireless. SHould it be there or shouldn't it?

oh well, then try this:

log into your router via telnet/ssh and type in

uci set wireless.radio0.noscan=1
uci commit
reboot

and you`re done smile

philk87 wrote:

oh well, then try this:

log into your router via telnet/ssh and type in

uci set wireless.radio0.noscan=1
uci commit
reboot

and you`re done smile

And now it works! Thank you!

Back to N+B support and no drops.

This is my WiFi config and I can't get speed higher than 59MBit/s. Looks like 802.11n wont start. Can anyone help?

config 'wifi-device' 'radio0'
    option 'type' 'mac80211'
    option 'macaddr' '00:00:00:00:00:00'
    list 'ht_capab' 'SHORT-GI-40'
    list 'ht_capab' 'DSSS_CCK-40'
    option 'hwmode' '11ng'
    option 'noscan' '1'
    option 'channel' '2'
    option 'txpower' '24'
    option 'htmode' 'HT40+'
    option 'country' 'US'

config 'wifi-iface'
    option 'device' 'radio0'
    option 'network' 'lan'
    option 'mode' 'ap'
    option 'ssid' 'ssid'
    option 'key' 'key'
    option 'macfilter' 'allow'
    list 'maclist' '00:00:00:00:00:00'
    option 'encryption' 'psk-mixed'

The psk-mixed encryption is not really suitable for 11n - set psk2 (WPA2-PSK with CCMP).
Note that the ui status display shows an *average* bitrate over *all* connected clients, if you want to see the per client rates run "iw dev wlan0 station dump" on the AP or "iw dev wlan0 link" on the client.

jow wrote:

The psk-mixed encryption is not really suitable for 11n - set psk2 (WPA2-PSK with CCMP).
Note that the ui status display shows an *average* bitrate over *all* connected clients, if you want to see the per client rates run "iw dev wlan0 station dump" on the AP or "iw dev wlan0 link" on the client.

thanks, i change the encryption and now have 65MBit/s on my HTC Desire S. I think my smartphone do not allow WiFi N to run faster sad

jow wrote:

The psk-mixed encryption is not really suitable for 11n - set psk2 (WPA2-PSK with CCMP).
Note that the ui status display shows an *average* bitrate over *all* connected clients, if you want to see the per client rates run "iw dev wlan0 station dump" on the AP or "iw dev wlan0 link" on the client.

Thanks for the tip. Do you know whether there are issues combining psk and n-mode too? Any clue as to why?

After four months of stability heaven, I have had some weeks with occasional stability issues on the router. Still early in the hunt for cause (the occasional aspect makes reproducing difficult). Right now I suspect a newly acquired HTC Sensation to somehow be the trigger. I have changed from psk to psk2 authentication and set the noscan option. I will report if I know more, maybe a good occasion to compile the latest and greatest openwrt code again smile

I tried to set it like this:

config 'wifi-device' 'radio0'
        option 'type' 'mac80211'
        option 'macaddr' '74:ea:3a:a4:fc:00'
        option 'channel' '11'
        option 'disabled' '0'
        option 'country' 'SI'
        option 'txpower' '20'
#
        list 'ht_capab' 'SHORT-GI-40'
        list 'ht_capab' 'DSSS_CCK-40'
        option 'hwmode' '11ng'
        option 'noscan' '1'
        option 'htmode' 'HT40+'

/etc/config/network restart

wlan0: IEEE 802.11 Configured HT40 secondary channel (15) not found from the channel list of current mode (1) IEEE 802.11g
wlan0: IEEE 802.11 Configured channel (11) not found from the channel list of current mode (1) IEEE 802.11g
wlan0: IEEE 802.11 Hardware does not support configured channel
Could not select hw_mode and channel. (-4)
wlan0: Unable to setup interface.
rmdir[ctrl_interface]: No such file or directory
udhcpc: setting dns domain: sd-lj.si
Failed to start hostapd for phy0

You cannot use HT40+ with channel 11.
11+4 = 15 -> no channel 15 exists.
Try HT40- => 11-4 = 7

jow wrote:

You cannot use HT40+ with channel 11.
11+4 = 15 -> no channel 15 exists.
Try HT40- => 11-4 = 7

thank you

with those settings it's not stable. is there anything else I can try or is 11g the best I can hope for?

I have just built an image that includes usb storage, ext4, autofs4, nano, luci, luci-ssl, dropbear etc for a total of 100 packages.  It is looking stable and the base files are showing as 103-r30310.    But I can't enable the wifi because I don't seem to know what to do either in the Luci screens or on the command line.

What am I doing that is so stupid?

Any help would be greatly appreciated.

Actually, it's all in the wiki. A good start is the page for the 1043, from there you should find your way.

I found the wiki topic wireless.essentials.   Turns out I did not include the kmod-ath9k package.   Now the wireless works but keeps disconnecting me when the wan side is down.  If the wan side is up then the wireless seems to want to stay up.   

Is this a 'feature'? 

Also, I am using this router as a dumb access point as per the wiki but to get a wan connection working I have to connect to the gateway router with the ethernet cable plugged into a lan.  How I get the wan port up?

Thanks for the help everyone.

Hello
I have 2 TL-WR1043ND v1.8
One of them, I flashed Backfire 10.03.1-rc6.
After that he ceased to light up the LED WAN and WAN port does not work.
Replacement of SPI-Flash router with a working restores his work.
Back SPI-Flash and Flash Backfire 10.03.1-rc4 and trunk - not working WAN port.
Features SPI-Flash to flash outside the router I have not.
Do not tell that it is possible to be done.

Guys, dont try the latest trunk (13th feb, 2012), it'll brick your device.
Well, I had to get the router into failsafe and download another firmware using ftp.

Back to RC5 again.

hi all, i'm new happy owner of tl-wr1043nd and have a big problem. Read a lof of discussions and papers about "flashing" original firmware, so i did.

Cross original WEBgui uploaded new firmware like openwrt-ar71xxgeneric-tl-wr1043nd-v1-squashfs-factory.bin. So, everything seems to be good, bud new webgui is not. Ping on 192.168.1.1 not active, destination is unreachable.
So, unpluged power, pluged power and than pushed "QSS" - failsafe mode. OK, router repeated on ping, so telnet 192.168.1.1 , mount_root, mtd -r erase rootfs_data and at the end reboot -f.

New terminal, ping 192.168.1.1 - nothing, Failsafe mode, telnet 192.168.1.1, passwd XXXX, once more XXX and get like something that filesystem is only for read or what...

Has any1 some idea what to do now? It was not cheap and now it is only for decoration.... many many tnx, Jan.

of course, model is tl-wr1043nd, ver 1.8

(Last edited by W3pH4ck on 14 Feb 2012, 13:15)

Try to reflash it while in failsafe:
- set up a "test" wired connection on my pc, with static IP 192.168.1.2, gateway 192.168.1.1, netmask 255.255.255.0
- set up an ftp server on my pc with guest login without password (proftpd), listening on 192.168.1.2
- put new firmware in the guest ftp shared folder (newfirmware.bin)
- booted the router in failsafe mode
- plugged network cables
- telnet 192.168.1.1
- checked at least 12-13 MiB free RAM with "free" and at least 8 MiB free space on /swap with "df"
- cd /tmp
- wget ftp://guest@192.168.1.2/newfirmware.bin
- mtd -r write newfirmware.bin firmware
- wait for reboot AND some further seconds after reboot

RC5 worked best for mine: http://downloads.openwrt.org/backfire/1 … actory.bin

http://img855.imageshack.us/img855/1272/tlwn1043ndfree.png

not swap.... or is it ok?

I actually did a file copy test WAN to LAN and the Trunk outperformed the Backfire.
I suspect it is due to the Switch Driver RTL8366RB available on Trunk not available on Backfire.
Roughly the results is as follow
100+Mbps - Backfire
200-300Mbps - Trunk + Switch Driver

so, better and faster in windows :-)) BUT no effect, what is wrong?


http://img339.imageshack.us/img339/6706/allinoneb.jpg