OpenWrt Forum Archive

Topic: TP Link WR1043ND 11n gigabit router

The content of this topic has been archived between 20 Jul 2013 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

The second screenshot is from the downstairs AP? And it’s the same laptop in both? So it should work in theory. Are they both 1043NDs?

Does it display anything interesting when you run « wifi » on the shell?


EDIT
And does it show the same?

root@plink:~# cat /sys/kernel/debug/ieee80211/phy0/ht40allow_map 
2412 HT40  +
2417 HT40  +
2422 HT40  +
2427 HT40  +
2432 HT40 -+
2437 HT40 -+
2442 HT40 -+
2447 HT40 -+
2452 HT40 -+
2457 HT40 - 
2462 HT40 - 
2467 HT40 - 
2472 HT40 - 
2484 Disabled
root@plink:~# cat /sys/kernel/debug/ieee80211/phy0/channel_type
ht20
root@plink:~# grep -i ht /sys/kernel/debug/ieee80211/phy0/ath9k/*_eeprom -r
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 2GHz HT20 :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 2GHz HT40 :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 5Ghz HT20 :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 5Ghz HT40 :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/modal_eeprom:     HT40 Power Inc. :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/modal_eeprom:  HT40 Switch Settle :         45
/sys/kernel/debug/ieee80211/phy0/ath9k/modal_eeprom:     HT40 Power Inc. :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/modal_eeprom:  HT40 Switch Settle :         56

(Last edited by towolf on 11 Apr 2012, 01:14)

What is your wifi card model?

towolf wrote:

The second screenshot is from the downstairs AP? And it’s the same laptop in both? So it should work in theory. Are they both 1043NDs?

Does it display anything interesting when you run « wifi » on the shell?


EDIT
And does it show the same?

root@plink:~# cat /sys/kernel/debug/ieee80211/phy0/ht40allow_map 
2412 HT40  +
2417 HT40  +
2422 HT40  +
2427 HT40  +
2432 HT40 -+
2437 HT40 -+
2442 HT40 -+
2447 HT40 -+
2452 HT40 -+
2457 HT40 - 
2462 HT40 - 
2467 HT40 - 
2472 HT40 - 
2484 Disabled
root@plink:~# cat /sys/kernel/debug/ieee80211/phy0/channel_type
ht20
root@plink:~# grep -i ht /sys/kernel/debug/ieee80211/phy0/ath9k/*_eeprom -r
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 2GHz HT20 :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 2GHz HT40 :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 5Ghz HT20 :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 5Ghz HT40 :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/modal_eeprom:     HT40 Power Inc. :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/modal_eeprom:  HT40 Switch Settle :         45
/sys/kernel/debug/ieee80211/phy0/ath9k/modal_eeprom:     HT40 Power Inc. :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/modal_eeprom:  HT40 Switch Settle :         56

The second screenshot is from the 1043ND with OpenWRT loaded in my room. I show a picture for a better understanding:

http://www.abload.de/img/topologieafuiv.png

When I'm using the same channel like the router downstairs, then I'm unable to connect with more than 130mbps to the OpenWRT device. The signal from the DD-WRT device is weak in my room, so I don't know why I can't force 40MHz bandwidth.

I will edit this post and write the settings from the command line later.

1. EDIT: The DD-WRT firmware is a little bit buggy, I'm unable to connect with more than 130mbps. So it uses just one non-overlapping channel. That's also the reason why I'm testing the OpenWRT firmware. It would be cool to force the 40MHz bandwidth otherwise every little mobilephone with tethering in my little village would decreasing my wireless speed.

2. EDIT: Here are the outputs of the commands.

root@OpenWrt:~# wifi
Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr **:**:**:**:**:** and ssid 'OpenWrt'
random: Cannot read from /dev/random: Resource temporarily unavailable
random: Only 0/20 bytes of strong random data available from /dev/random
random: Not enough entropy pool available for secure operations
WPA: Not enough entropy in random pool for secure operations - update keys later when the first station connects
root@OpenWrt:~# cat /sys/kernel/debug/ieee80211/phy0/ht40allow_map
2412 HT40  +
2417 HT40  +
2422 HT40  +
2427 HT40  +
2432 HT40 -+
2437 HT40 -+
2442 HT40 -+
2447 HT40 -+
2452 HT40 -+
2457 HT40 -
2462 HT40 -
2467 HT40 -
2472 HT40 -
2484 HT40
root@OpenWrt:~# cat /sys/kernel/debug/ieee80211/phy0/channel_type
ht40-
root@OpenWrt:~# grep -i ht /sys/kernel/debug/ieee80211/phy0/ath9k/*_eeprom -r
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 2GHz HT20 :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 2GHz HT40 :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 5Ghz HT20 :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 5Ghz HT40 :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/modal_eeprom:     HT40 Power Inc. :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/modal_eeprom:  HT40 Switch Settle :         45
/sys/kernel/debug/ieee80211/phy0/ath9k/modal_eeprom:     HT40 Power Inc. :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/modal_eeprom:  HT40 Switch Settle :         56
root@OpenWrt:~#

(Last edited by DerUltrazauberer on 11 Apr 2012, 10:52)

Anyone successfully using this router with vlan trunking? I want to seperate vlan id8 coming from wan and send it to port 4 of the switch, where my media receiver is plugged in. Vlan id7 should go to all other devices on the network, because it contains the normal internet traffic.

The normal internet is working, but the iptv receiver doesn't show any picture. Here's my config:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option proto 'pppoe'
    option username 'xxxxxxxxxxxxxxxxxxxxxxxx#001@t-online.de'
    option password 'myPassword'
    option ifname 'eth0.7'

config interface 'iptv'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.0.1'
    option netmask '255.255.255.0'
    option ifname 'eth0.2'

config interface 'wan_vlan8'
    option proto 'dhcp'
    option _orig_ifname 'eth0.8'
    option _orig_bridge 'true'
    option ifname 'eth0.8'

config switch
    option name 'rtl8366rb'
    option reset '1'
    option enable_vlan '1'
    option enable_vlan4k '1'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '1'
    option ports '1 2 3 5t'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '2'
    option ports '4 5t'

config switch_vlan
    option device 'rtl8366rb'
    option ports '0t 5t'
    option vlan '7'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '8'
    option ports '0t 5t'
config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    option network 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'wan'
    option network 'wan'
    option input 'REJECT'
    option output 'ACCEPT'
    option masq '1'
    option mtu_fix '1'
    option forward 'REJECT'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fe80::/10'
    option src_port '547'
    option dest_ip 'fe80::/10'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config zone
    option name 'wan_iptv'
    option network 'wan_vlan8'
    option input 'REJECT'
    option output 'ACCEPT'
    option masq '1'
    option log '1'
    option forward 'REJECT'

config forwarding
    option src 'lan'
    option dest 'wan_iptv'

config rule
    option name 'Allow-DHCP-Renew-iptv'
    option src 'wan_iptv'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping-iptv'
    option src 'wan_iptv'
    option proto 'icmp'
    option icmp_type 'echo_request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6-iptv'
    option src 'wan_iptv'
    option proto 'udp'
    option src_ip 'fe80::/10'
    option src_port '547'
    option dest_ip 'fe80::/10'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option src 'wan_iptv'
    option proto 'igmp'
    option target 'ACCEPT'

config rule
    option src 'wan_iptv'
    option proto 'udp'
    option dest 'lan'
    option dest_ip '224.0.0.0/4'
    option target 'ACCEPT'
########################################################
#
#   Example configuration file for the IgmpProxy
#   --------------------------------------------
#
#   The configuration file must define one upstream
#   interface, and one or more downstream interfaces.
#
#   If multicast traffic originates outside the
#   upstream subnet, the "altnet" option can be
#   used in order to define legal multicast sources.
#   (Se example...)
#
#   The "quickleave" should be used to avoid saturation
#   of the upstream link. The option should only
#   be used if it's absolutely nessecary to
#   accurately imitate just one Client.
#
########################################################

##------------------------------------------------------
## Enable Quickleave mode (Sends Leave instantly)
##------------------------------------------------------
quickleave


##------------------------------------------------------
## Configuration for eth0 (Upstream Interface)
##------------------------------------------------------
phyint eth0.8 upstream  ratelimit 0  threshold 1
    altnet 217.0.119.0/24
    altnet 193.158.35.0/24
    altnet 239.35.0.0/16
    altnet 192.168.0.0/24


##------------------------------------------------------
## Configuration for eth1 (Downstream Interface)
##------------------------------------------------------
phyint br-iptv downstream  ratelimit 0  threshold 1


##------------------------------------------------------
## Configuration for eth2 (Disabled Interface)
##------------------------------------------------------
phyint br-lan disabled
phyint pppoe-wan disabled

Any ideas what's going wrong?

And why I can't access the internet, when my laptop is connected to port 4 (the media receiver port)?

I get an IP of the 192.168.0.0 net, also right DNS settings, but I can't browse the web on this port? Maybe that's the problem why the media receiver won't show me any picture.

I Was thinking of getting one of these routers. Been saving up since a couple of weeks. I intend on using this as a File Server + RSS FEED Torrent Downloader + HTTP downloader + Fileshare downloader + Reboot or reboot my modem when internet isn't connecting. What do you guys suggest? Should i go for this router? Will the stock 32MB ram Be enough for this? Or will i have to put a 64MB chip? From where are ull getting the RAM chips? and i am thinking if i get this, i might hand it over to a professional to solder on. Also if its in warranty, and i replace the chip, and it doesn't work after replacing the chip, do you think i can get it RMA'd?

Can you guys list out some of the successful ram chips? not only the ones that "may work" as listed on the wiki. I need to know which one will work for sure. tongue

Also i have heard that the CPU utilization while downloading torrents is like 90-100%. is there any way to overclock the processor? or make this run more efficient? or should i wait for a better model Router? with a better CPU?

Im new to OpenWRT. Currently got a DIR300 With DD-WRT.

Nearly all TP-Link routers have the Atheros chipset with 400 MHz clocked. Or you go for the TP-Link TL-WR2543ND. It has also OpenWRT support and 64MB of RAM. But the same CPU clock speed like the 1043ND.

PS: My 1043ND is working fine with IPTV now! ;-)

EDIT: What's about the new TL-WDR4300. Promising hardware, but's very new. http://wiki.openwrt.org/toh/tp-link/tl-wdr4300

(Last edited by DerUltrazauberer on 21 Jun 2012, 09:57)

I must say, the hardware on that looks interesting, but might be double the cost of the WR1043ND, But woah, i love the hardware. What is the price of it?

hmm, what issue was ur 1043ND giving with your IPTV ?

But the CPU of the WR2543 is an older one as compared to the 1043, is that right? What's the cost of thaT?..

TPLINk is sure comming up with some great routers. I thought it was some cheap chinese stuff. Although i'm not a fan of the housing and shape of the 1043ND, but its a very powerful router smile  From what i read smile

Have any of you guys tried hooking up an LCD to this baby? big_smile

Having issues with latest trunk and the 1043.  It freezes with only the power light on.  Tailing the logs there is no message before the freeze and only a power reset corrects the issue.  Anyone have any ideas what's going on.  I have two 1043's and both are doing the same.

romand wrote:

Having issues with latest trunk and the 1043.  It freezes with only the power light on.  Tailing the logs there is no message before the freeze and only a power reset corrects the issue.  Anyone have any ideas what's going on.  I have two 1043's and both are doing the same.

Try an older version? there are probably some bugs with the version you are using. :S

Are you running any extra daemons?

Has anyone achieved full 300Mbps wireless n with this router?

You can't achieve "full 300Mbps" with any router[1], not even half of it.

[1] 450 MBit/s 3-stream routers neither get close to 300 MBit/s netto throughput, 802.11ac and 802.11ad should of course.

I'll rephrase the question, can anyone get a faster connection than 65Mbps with this router and an iPad 3 or iPhone 4?

No, since both the iPad 3 and iPhone 4 contain single stream 11n radios which top out at 65Mbps phy data rate. You'd need 2 streams to reach 150Mbps and three streams to reach 300Mbps.

Since im using openwrt on this router, im having this kernel error once or twice a day. Usually when im skypeing or downloding torrets:

[203391.320000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x000286c0
[203391.330000] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up
[244025.000000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x000084c0
[244025.010000] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up
[244025.030000] ath: phy0: Failed to stop TX DMA, queues=0x004!
[244025.350000] ath: phy0: Failed to stop TX DMA, queues=0x004!
[244025.640000] ath: phy0: Failed to stop TX DMA, queues=0x004!
.
.
.
[338056.780000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x000286c0
[338056.790000] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up

When this happens, wifi disappear for a couple of minutes.
I tried HT20 and HY40, and nothing changed.
Tested on 10.03.1 and 12.09 beta. Nothing changed....
any ideas?

Uh, Oh.

I thought it was 100% stable. Guess its 99.9%... I can live with that...
thanks!

dioromi wrote:

Uh, Oh.

I thought it was 100% stable. Guess its 99.9%... I can live with that...
thanks!

Certainly. Take a look at the bug comments. There are some stuff you could try and perhaps even remove the issue. Like CCMP/TKIP, WPA2, channels and stuff. Mine is actually working great.

And thank you for giving me a heads up for 12.09! I didnt even know about that release. But it is on its way now!

I updated OpenWRT to trunk r33624. Now the IGMPPROXY config file is moved to /etc/config/igmpproxy. The file has a new structure. I can't find the documentation how to disable some interfaces.

phyint br-lan disabled
phyint pppoe-wan disabled
phyint lo disabled

This is how some entries in the old config look like. How they are look in the new structure? It must be something like this:

config phyint
        option network iptv
        option direction downstream

I search for the right "option" parameter.

And a last question: I consider to upgrade the RAM of the 1043ND. But I don't know the improvements of this. What would be better after upgrade? Is it a good idea to upgrade the RAM?

I ask here because I want something to solder. ;-)

(Last edited by DerUltrazauberer on 7 Oct 2012, 14:04)

I got my 3rd TL-WR1043ND router today, its v1.10, I put Attitude Adjustment 12.09-beta2 on it, then upgraded the memory to 64MB and it seems to be running fine. All 64MB was detected automatically. The board is still a rev1.1, but the JTAG and serial are unsoldered, making it easy to install pin headers. Also the flash chip is a SOP8 instead of a SOP16 like my two v1.08 boards, though there are pads to install either kind.

I can post the log from stock serial startup if anyone wants to see it, and pictures I took before modding the board are at this link.

PunBB bbcode test

(Last edited by sockeye on 6 Dec 2012, 23:20)

sockeye wrote:

I got my 3rd TL-WR1043ND router today, its v1.10, I put Attitude Adjustment 12.09-beta2 on it, then upgraded the memory to 64MB and it seems to be running fine. All 64MB was detected automatically. The board is still a rev1.1, but the JTAG and serial are unsoldered, making it easy to install pin headers. Also the flash chip is a SOP8 instead of a SOP16 like my two v1.08 boards, though there are pads to install either kind.

I can post the log from stock serial startup if anyone wants to see it, and pictures I took before modding the board are at this link.

PunBB bbcode test


Got any 64MB chips left?  Can you tell me, with the 64MB ram, what is the largest torrent file you can download? :S

Yes I have more 64MB chips. My server does the torrent duties, so Im not sure what difference 64MB would make for that.

Howcome the chip is by Windband? and why did you stick that tape? I thought hynix rams were mostly compatible with this board. Never heard of this chip.

Can you try running some torrents on it just for testing purposes?

Would you be able to post (mail)  the ram chip if not required tongue ? if not, where did you get it from?

Winbond is the stock 32MB chip, I think Winbond was on v1.8 boards too. The tape is to keep everything in place when I swapped the memory. I was about to do the swap and thought I would take some pictures first and didn't want to waste the tape so I left it on. I used Samsung chips I take off SODIMM laptop memory. They are not in the compatible list on the wiki, but they work just fine.

This was my 8th router I've swapped the memory on, and this picture shows a bare SODIMM with all the chips removed (both sides are bare). I have another matching Samsung SODIMM with all 8 chips to use and found some Hynix SODIMM too for when I run out of the Samsung.


https://lh6.googleusercontent.com/-Bzfx179mxTQ/UL__RKlKdPI/AAAAAAAABOM/_41L3se8Bww/s640/IMG_7505.JPG

sockeye wrote:

Winbond is the stock 32MB chip, I think Winbond was on v1.8 boards too. The tape is to keep everything in place when I swapped the memory. I was about to do the swap and thought I would take some pictures first and didn't want to waste the tape so I left it on. I used Samsung chips I take off SODIMM laptop memory. They are not in the compatible list on the wiki, but they work just fine.

This was my 8th router I've swapped the memory on, and this picture shows a bare SODIMM with all the chips removed (both sides are bare). I have another matching Samsung SODIMM with all 8 chips to use and found some Hynix SODIMM too for when I run out of the Samsung.


https://lh6.googleusercontent.com/-Bzfx179mxTQ/UL__RKlKdPI/AAAAAAAABOM/_41L3se8Bww/s640/IMG_7505.JPG


Any more Pictures? And pictures of the samsung SODIMM?