OpenWrt Forum Archive

Topic: WZR-HP-G300NH Support

The content of this topic has been archived between 6 Feb 2018 and 3 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Just purchased the wzr-hp-g300nh and tried stock buffalo, dd-wrt and now openwrt firmware.  Openwrt has been by far the best thus far.  Only complaint I have thus far is the bandwidth I appear to be getting with wifi.  I have another older AP (DIR-615 v.A1) in the same general vicinity and I am getting ~4.5mb when transferring files from a file server to a client machine.  Client is using wifi, server has a 100mb connection, no gig card in it yet.  With the g300nh, I am lucky if I average 1.5mb.

Pretty stock openwrt setup.  Some port forwarding configured, added some collectd packages and a luci-app-statistics package, and modifed the dnsmasq setup slightly.  Adjusted transmit power to  30dBm (read in a dd-wrt forum that the g300nh cannot take much more due to heat issues).  Other than that, pretty stock.

I would have expected some better speeds, anyone have any suggestions?

root@Everest:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:1D:73:B4:6C:D2 
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:689976 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1295566 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:39740323 (37.8 MiB)  TX bytes:1913445259 (1.7 GiB)

eth0      Link encap:Ethernet  HWaddr 00:1D:73:B4:6C:D2 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1400305 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1201679 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1275803714 (1.1 GiB)  TX bytes:1347766848 (1.2 GiB)
          Interrupt:4

eth1      Link encap:Ethernet  HWaddr 00:1D:73:B4:6C:D3 
          inet addr:76.113.220.54  Bcast:255.255.255.255  Mask:255.255.252.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1803764 errors:0 dropped:0 overruns:0 frame:0
          TX packets:687103 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1946187589 (1.8 GiB)  TX bytes:47013124 (44.8 MiB)
          Interrupt:5

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:5 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:399 (399.0 B)  TX bytes:399 (399.0 B)

mon.wlan0 Link encap:UNSPEC  HWaddr 00-1D-73-B4-6C-D2-00-00-00-00-00-00-00-00-00-00 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6957 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4708624 (4.4 MiB)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:1D:73:B4:6C:D2 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:518145 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1325218 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:54270810 (51.7 MiB)  TX bytes:1873181346 (1.7 GiB)

Hi all. I am a big time noob trying to install openwrt on the wzr-hp-g300nh because i was disappointed with ddwrt.
I was following the installation process on the wiki but I am having lots of trouble with flashing the router-- to tftp the .bin i am using powershell on windows 7, and get errors when i try to add a static arp for the router, so i get timed out when i try to tftp the .bin (I had all firewalls disabled). Im also not sure about the "Set computer interface to IP address in the 192.168.11.x range (e.g. 192.168.11.2)" step- I can manually set my computer's ip address to 192.168.11.2 through the network settings but then it wont connect to any network/communicate with the router unless its set to 'obtain ip address automatically.' I have no experience with linux so i was hoping that I'd be able to do this through windows but am afraid it may be too complicated. Sorry if my mistakes in this process are real stupid! I thought i should just give up and settle for ddwrt but want to give this a try. Any help or advice would be greatly appreciated!

(Last edited by suilx on 28 Aug 2010, 11:41)

1. Press the Win keyboard key or click on the Start button.
2. Type cmd into the Start Search textbox.
3. Press Ctrl+Shift+Enter keyboard shortcut. Ctrl-Shift-Enter is the general keyboard shortcut that triggers elevation to “Run as Administrator”.
4. Press Alt+C or press Continue to confirm the UAC elevation warning prompt.
5. Type "netsh int ipv4 set neighbor 192.168.11.1 <MAC address of router>"  replace <MAC address of router> with your router's MAC address.
6. Type arp -a
7. You should now see a static arp entry for 192.168.11.1.
8. Set your lan interface to 192.168.11.2, netmask 255.255.255.0, gateway 192.168.11.1.
9. Disconnect power from the router and leave it unpluged for at least 30 seconds.  Also disconnect any USB devices that are connected to the router (do not reconnect the USB device until OpenWrt is installed and running.
10. When you are ready to tftp the image to the router, start tftp first and then connect the power to the router.
11. If for some reason it doesn't work, go back to step 6.
12. If successful then set your lan interface back to obtain an IP address and DNS server address automatically.
13. Configure OpenWrt to your liking.

There is no need to delete the arp entry the we created with netsh unless you are on a large network, in which case you would probably be using a much more powerful router.

Charles

Thanks very much Charles. I was able to get openwrt going on my 300nh and now its working much better. I had to do something slightly different to add the static arp entry (I dont know if its a windows 7 thing), and in case it may help another windows user, I had to type:
"  netsh int ipv4 set neighbor "Local Area Connection" "192.168.11.1" "<MAC address of router>"   "

I also did not double check on the status of all firewalls before doing the tftp transfer, and at the very beginning I didn't know that the .bin file had to be in the system 32 file folder for the tftp transfer to work--maybe some additions can be made to the g300nh wiki under the windows section?

I had another question about transmit power: is there a certain configuration needed to achieve dBm higher than 27? If I enter it as 29 or 30 under admin>network>wifi>radio0,   it still shows up as 27 under essentials>network>wifi (this is @ 20 MHz),

also if someone could direct me toward info about being able to set limits on bandwidth per user on wifi/lan connection that would be greatly appreciated

Thanks again for all the help

Red-Bull wrote:

Hey.. i am running a wzr-hp-g300nh with backfire 10.03 and a la fonera with kamikaze as wlan client..
i am using psk2 aka wpa2
does any1 else here has problems with stablity of wifi connectivity ?
i noticed a lack of connection every few hours..
before with wrt54gl all fine sad

is THIS  the behaviour you're seeing?

How I got ushare Upnp media server running in 10.03.1-rc3
1. Install luci-app-ushare via 192.168.1.1 in your browser Administration mode:System -->software
2. I couldn't get it to work with the default initscript so I went to Services-->Initscripts and disbaled the ushare one and the ushare service should also be disabled in Services Ushare.
3. Open putty and login to 192.168.1.1 with your username and password type "route add -net 239.0.0.0 netmask 255.0.0.0 br-lan" to open up a upnp route (not 100% sure if this is necessary but do it anyway)
3. Type "cd /etc" to change directory to etc
4. type "ls" to list files and there should be one called ushare.conf
5. Open ushare.conf using the vi editor by typing "vi ushare.conf" then press I to go into input mode and type in the required settings (there is an explanation beside each one), only one you may not be certain of is interface which I set to br-lan and I set the port =49200 and if you put the webinterface to yes you can get a web interface by going to http://192.168.1.1:49200/web/ushare.html when finished press Esc to go out of input mode and type ":wq" to save and quit
6. change directory back to the root using "cd /" and run the command "ushare -x -D -f /etc/ushare.conf" where -x specifies xbox compatible mode as I have an xbox, -D specifies daemon mode (I couldn't get it to work without this) and -f specifies to use the config file you have just made.

Note this will not survive a reset and you have to run this everytime the router is rebooted

Only other issue was that I could only get it to work if I share a single directory, initially i had shared /mnt/usb/music, /mnt/usb/movies but none of the movies were showing up and the xbox just gave me a massive list of around 1000 folders contained in the music directory (there should have been 1700) with no way of searching them or sorting them and no access to my movies folder  so instead I shared /mnt/usb and now I can manually move to required directory, as it seems if you share a folder with tons of directories it only shows the first 1000 or so and you can't see the rest.
Also I had some .mp4 files that I had to rename to .avi in order to make the xbox play them.

All the ushare commands can be found here:http://linux.die.net/man/1/ushare

(Last edited by k4021 on 5 Oct 2010, 00:39)

You can put the "ushare -x -D -f /etc/ushare.conf" commandline into /etc/rc.local to make it start at every boot.

everest wrote:

Just purchased the wzr-hp-g300nh and tried stock buffalo, dd-wrt and now openwrt firmware.  Openwrt has been by far the best thus far.  Only complaint I have thus far is the bandwidth I appear to be getting with wifi.  I have another older AP (DIR-615 v.A1) in the same general vicinity and I am getting ~4.5mb when transferring files from a file server to a client machine.  Client is using wifi, server has a 100mb connection, no gig card in it yet.  With the g300nh, I am lucky if I average 1.5mb.

Pretty stock openwrt setup.  Some port forwarding configured, added some collectd packages and a luci-app-statistics package, and modifed the dnsmasq setup slightly.  Adjusted transmit power to  30dBm (read in a dd-wrt forum that the g300nh cannot take much more due to heat issues).  Other than that, pretty stock.

I would have expected some better speeds, anyone have any suggestions?

Have you fixed this problem, or it's still the case?

To get full 300Mbps you need to enable 2nd channel (40MHz bandwidth)

Operation mode: N+G+B
Channel width: 40MHz

And make sure that there is no noise on channel you selected.
My general advise would be to check what channel is suggested (in Auto selection mode) by stock firmware.
And try to select same channel manually in OpenWrt.

Than you can play with Extended Channel "Above"/"Below" settings.

My settings (works at 300Mbps):

root@Gargoyle:~# cat /etc/config/wireless

config 'wifi-device' 'radio0'
        option 'type' 'mac80211'
        option 'macaddr' 'd8:5d:4c:bf:25:b4'
        option 'hwmode' '11ng'
        list 'ht_capab' 'SHORT-GI-40'
        list 'ht_capab' 'TX-STBC'
        list 'ht_capab' 'RX-STBC1'
        list 'ht_capab' 'DSSS_CCK-40'
        option 'channel' '5'
        option 'htmode' 'HT40+'

config 'wifi-iface' 'cfg2'
        option 'device' 'radio0'
        option 'mode' 'ap'
        option 'network' 'lan'
        option 'wds' '1'
        option 'ssid' 'OWrt'
        option 'encryption' 'psk'
        option 'key' '<my secret key>'

You may try to change
       option 'htmode' 'HT40+'
to
       option 'htmode' 'HT40-'
and see if there is any difference.

jow wrote:

You can put the "ushare -x -D -f /etc/ushare.conf" commandline into /etc/rc.local to make it start at every boot.

Actually this doesn work but I finally figured it out if you use:

sleep 45
"ushare -x -D -f /etc/ushare.conf" commandline into /etc/rc.local
exit 0

then it works everytime - the problem was that ushare was loading up before the hard drive was ready so you need a 45s sleep command to give the hard drive time to mount and get ready for ushare to scan it.

(Last edited by k4021 on 21 Dec 2010, 22:55)

To be able to run at constant 300mbps in wifi crowded area i had to try all 1-11 channel and ht40+/- combinations. While buffalo firmware run at 300mbps from the start.

Does anyone know how to flash this router from OpenWRT back to DD-WRT or stock? I currently have DD-WRT build 15940 on my WZR and it's working okay, but I heard that this router is much better with OpenWRT. Wiki provides a guide on how to flash from DD-WRT to OpenWRT without tftp and it looks pretty simple. What I need now is a way to go back (either stock or DD-WRT will work fine) in case something goes wrong or once DD-WRT starts using ath9k.

I have Brainslayer's wzrg300nh_original.bin but I don't know what to do with it; I have heard that webflash will not work and isn't the bin too big for tftp? It's about 20 MB.

Download lastest firmware from Buffalo's website and then use tftp to flash it.  Remember that when using tftp with this router you have to set a static arp address for the router's default IP address of 192.168.11.1 and then when tftp'ing you use the default IP address of 192.168.11.1. 

Look at further up in this thread for windows 7 help. 

Charles

Any luck on overclocking the CPU on g300nh which is Atheros AR9132 rev 2?

I recently install backfire 10.03 on a buffalo wzr-hp-g300nh, i think it is the last released, and i did not have to install kmod-ath9k and wpad-mini. There were installed already. I have several issues with WDS links, but every is working fine for me right now. The problem you have with internet it may be anything, since you do not provide info of your router, left a copy of /etc/config/network and ifconfig, and i am sure we can reply a solution for you.

Hi everyone !

I migrated from DD-WRT to backfire 10.03.1-rc4 for my WZR-HP-G300NH yesterday.

OpenWrt works generally much better than DD-WRT, great. I have only one issue: I have IPTV box in one LAN port, and Multicast IPTV does not seem to work anymore.

In DD-WRT there was setting to enable Multicast (from WAN to LAN). Is this somehow possible in OpenWrt? Any help appreciated, thanks!

Bulk wrote:

Hi everyone !

I migrated from DD-WRT to backfire 10.03.1-rc4 for my WZR-HP-G300NH yesterday.

OpenWrt works generally much better than DD-WRT, great. I have only one issue: I have IPTV box in one LAN port, and Multicast IPTV does not seem to work anymore.

In DD-WRT there was setting to enable Multicast (from WAN to LAN). Is this somehow possible in OpenWrt? Any help appreciated, thanks!

If I remember correctly (I can´t check right now), Multicast is enabled by default, but you need to download and install the package igmpproxy. You will also need to make sure the firewall doesn´t block the packets.
Initially, try to disable the firewall completely, so you know you´ve got the multicast routing set up properly.

ilmarinen wrote:
Bulk wrote:

Hi everyone !

I migrated from DD-WRT to backfire 10.03.1-rc4 for my WZR-HP-G300NH yesterday.

OpenWrt works generally much better than DD-WRT, great. I have only one issue: I have IPTV box in one LAN port, and Multicast IPTV does not seem to work anymore.

In DD-WRT there was setting to enable Multicast (from WAN to LAN). Is this somehow possible in OpenWrt? Any help appreciated, thanks!

If I remember correctly (I can´t check right now), Multicast is enabled by default, but you need to download and install the package igmpproxy. You will also need to make sure the firewall doesn´t block the packets.
Initially, try to disable the firewall completely, so you know you´ve got the multicast routing set up properly.

OK, thanks for the info. I will try igmpproxy.

Installed igmpproxy successfully, but I think that I don't get igmpproxy.conf settings correct.

I have tried to figure it out but this seems quite complicated. Router IP address is 192.168.1.1, IPTV box address is 192.168.1.40, and DSL modem gets public IP address from ISP. And then there are ISP multicast source addresses. Don't really know how to configure those to configuration file. In DD-WRT it worked automatically.

Hello,

I have issues with wireless, on reboot the link speed is 130 Mbps for say 5 seconds, then it drops to 65 Mbps and stays there.

This is the OpenWrt build I installed (Backfire 10.03.1 RC4): http://downloads.openwrt.org/backfire/1 … 2-tftp.bin

Here's /etc/config/wireless (I modified it according to some of the suggestions in this thread, but no success):

config 'wifi-device' 'radio0'
        option 'type' 'mac80211'
        option 'macaddr' '00:24:a5:d8:11:04'
        option 'hwmode' '11ng'
        list 'ht_capab' 'SHORT-GI-40'
        list 'ht_capab' 'DSSS_CCK-40'
        list 'ht_capab' 'HT40-'
        list 'ht_capab' 'HT40+'
        list 'ht_capab' 'TX-STBC'
        list 'ht_capab' 'RX-STBC1'
        option 'disabled' '0'
        option 'txpower' '26'
        option 'htmode' 'HT40+'
        option 'channel' '6'

config 'wifi-iface'
        option 'device' 'radio0'
        option 'network' 'lan'
        option 'mode' 'ap'
        option 'encryption' 'psk2'
        option 'key' 'somethingsomethingsomething'
        option 'ssid' 'Honeypot'

The client is an Acer 1810 Timeline, with Intel(R) WiFi Link 1000 BGN adapter.

With stock fimware and another router I reached 300 Mbps easily, so I'm sure it's not about HW capabilites.

I do live in an area with quite some WLAN traffic, so yes interference may be a problem, but when I sit next the router would really expect the link rate to go up. I played with the channel settings but no success, the behaivour stays the same - start with 130, then after 5 seconds back to 65.

Any suggestions are highly appreciated!

Cheers,
jayrock

(Last edited by jayrock on 15 Jan 2011, 14:52)

Hi,

apparantly the settings are correct. I now get full 300 Mbps speed. Patience is all that was missing.

/jayrock

everest wrote:

Adjusted transmit power to  30dBm (read in a dd-wrt forum that the g300nh cannot take much more due to heat issues).

Could you tell how to do this?

Hello all, I'm considering installing OpenWRT on this router as I've been having some issues with packet loss with the default buffalo firmware. However on the first page of this topic, https://forum.openwrt.org/viewtopic.php … 81#p105481 there seems to be someone with a similar problem. I'm wondering if anyone else is having trouble with packet loss in games?

jayrock wrote:

Hi,

apparantly the settings are correct. I now get full 300 Mbps speed. Patience is all that was missing.

/jayrock

Hello,

short time joy, now I'm back to 65 Mbps. I tried to check the interference in my area but when going to Network -> Wireless -> Scan a message is shown that there are no entries yet in the section ("Diese Sektion enthält noch keine Einträge").

How can I perform a scan of the radio environment?

Thnx

jayrock

EDIT: OK, I got it now, seems that two of the notebooks I have switch down to 65 Mbps when running on battery. Plug in AC and it goes up to 300. So, apparantly no OpenWrt issue. Strange however that I never noticed this before, but then again, I didn't watch link rates so closely before.

EDIT2: It's in Windows 7 power plan, wireless. Set it to max.

(Last edited by jayrock on 16 Jan 2011, 20:18)

Hello, few days ago I upgraded my router from dd-wrt with newest firmware. And if I make any changes in wireless area, my router will stop to work. Some times it stops only wireless and wui. Other times it stops everything working... And one way which I know just tu reflash router again. Any suggestions? I reflashed it about 6 times...

Woraspvm wrote:

Hello, few days ago I upgraded my router from dd-wrt with newest firmware. And if I make any changes in wireless area, my router will stop to work. Some times it stops only wireless and wui. Other times it stops everything working... And one way which I know just tu reflash router again. Any suggestions? I reflashed it about 6 times...

I had the same problem while changing wifi settings using luci. Using ssh to connect router and change wifi settings works perfectly without lockups.

Sorry, posts 176 to 175 are missing from our archive.