OpenWrt Forum Archive

Topic: WZR-HP-G300NH Support

The content of this topic has been archived between 6 Feb 2018 and 3 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Maybe the wireless led was not supported at this time. The most relevant page is network -> wireless -> wl0. Changes are applied immediately if you hit "Save & Apply".

I don't quite remember but I think you have to configure the wireless led on the leds configuration page. Also make sure you have hostapd (for wpa/wpa2) and kmod-ath9k installed.

on network->WiFi page i have "This section contains no values yet" and nothing to edit it

Sounds like there is no driver installed.

correct - forget to install driver. now installed kmod-ath9k. still the same. checked vi /etc/wireless/config - it is empty

Try this:

rm /etc/config/wireless; wifi detect > /etc/config/wireless

Ok, now I have on Network-WifI-Radio0 with all sort if parameters. I checked "Enable"  and "save and apply" but still no wireless. Do I have to define Transmit power and if yes then what should i put there? Same about  HT mode.

sorry HT mode already defined - 20Mhz, so I suppose I should leave it this way. There is also additional files with country code and distance optimization. Do I need them or it is not critical.? Also below there is interfaces part - what should be done there?

make sure wpad-mini is installed, you need that for ap mode even if you do not use encryption

vladkon wrote:

i tried to play with the options that i saw in luci but none made wireless LED active. on which page/ section are the relevant parameters and what actually should be configured? wl0 interface? how do i apply changes that i make? i'm a novice to linux/openwrt so i'm looking for some basic advice.

This is how I set my led's up. 

Open Luci GUI and login.
Click Administration.
Now point to System and then click on LED configuration
You will need four entries here.

The first one:

LED Name:    Security
LED Device:    wzr-hp-g300nh:orange:security
Default state:    unchecked
Trigger:        Network Device
Device:        mon.wlan0
Trigger Mode:    check: Link on, Transmit and Receive

The second one:

LED Name:    Wireless
LED Device:    wzr-hp-g300nh:green:wireless
Default state:    unchecked
Trigger:        Network Device
Device:        wlan0
Trigger Mode:    check: Link on, Transmit and Receive

The third one:

LED Name:    Router
LED Device:    wzr-hp-g300nh:green:router
Default state:    unchecked
Trigger:        Network Device
Device:        eth1
Trigger Mode:    check: Link on, Transmit and Receive

The fourth one:

LED Name:    USB
LED Device:    wzr-hp-g300nh:blue:usb
Default state:    checked
Trigger:        nand-disk

jow wrote:

make sure wpad-mini is installed, you need that for ap mode even if you do not use encryption

Thanks a lot - that solved it! will try to configure led now..

ok, leds are working now, although usb led is always off even when i plug usb disk. should i install something else to detect it? another question - where can i define allowed mac addresses for mac filtering?

Do you have the necessary packages installed so that you can access the usb stick? Check to make sure the stick is actually working in the router. Some of my Sandisk USB sticks do not work on this router at all.

Sorry i've never bothered doing any mac filtering.

i can access the usb stick - i've even managed to install ntfs-3g and samba and share it, but the led is still "off".
regarding mac filtering according to some post on this forum it seems to be impossible with current version of openwrt - is this correct?
another issue - is it possible make some start up script to run first ntfs-3g and then samba? or may be at least ntfs-3g? i've came accross this script, but can't make it work.. http://blog.podspring.com/?tag=openwrt

Shouldn't the wiki page for this router be renamed to WZR-HP-G300NH (as opposed to WZR-HP-G300H)?
http://wiki.openwrt.org/inbox/buffalo/wzr-hp-g300h

When I first searched the wiki for the WZR-HP-G300NH, I couldn't find it.

LinkZ wrote:

Shouldn't the wiki page for this router be renamed to WZR-HP-G300NH (as opposed to WZR-HP-G300H)?
http://wiki.openwrt.org/inbox/buffalo/wzr-hp-g300h

When I first searched the wiki for the WZR-HP-G300NH, I couldn't find it.

It should, indeed.

Hello,

I am a beginner when it comes to Linux and OpenWrt.  I have the wzr-hp-g300nh and have a problem. 

I have successfully flashed openwrt and got that running.  I have installed the wireless package and the wpad package for security.  I have the wireless working with no security and the wired works with no issues.  Both the wired (desktop) and the wireless (laptop) connections connect to the router and can get to the internet with no issues.  The second I enable any type of security (I'm using the Luci gui) I lose my internet connection on both machines.  I can still talk to the router and use Luci on both the wired and wireless connections.  So I don't believe they are "disconnected" from the router, just not able to reach the outside world.  As soon as I turn off wpa2(or any other encryption)  and go no encryption, internet connection comes back.  I'm sure this is a beginner mistake or a configuration error on my part. 

Does anyone have any suggestions?

I am new to linux.  If there is some documentation I should read please point me in the right direction.  I did not see this issue in the wiki.  I may not have provided enough information to recieve help.  Please let me know what I should provide and I will do my best to do so.

Thank you for your time.

TedStriker wrote:

I have installed the wireless package and the wpad package for security.  [...] The second I enable any type of security (I'm using the Luci gui) I lose my internet connection on both machines.

I had a similar problem when I tried the wpad security.  I removed it and I installed hostapd and wpa-supplicant.  Now everything is stable.

Charles

cdhinch wrote:
TedStriker wrote:

I have installed the wireless package and the wpad package for security.  [...] The second I enable any type of security (I'm using the Luci gui) I lose my internet connection on both machines.

I had a similar problem when I tried the wpad security.  I removed it and I installed hostapd and wpa-supplicant.  Now everything is stable.

Charles

That's interesting.  Wpad is supposed to be hostapd + wpa-supplicant in one package.... shouldn't be any difference.

TedStriker - try enabling WPA/WPA2 and then typing "wifi" in a telnet... you should see if hostapd produces any errors.

(Last edited by LinkZ on 5 May 2010, 19:13)

jow wrote:

make sure wpad-mini is installed, you need that for ap mode even if you do not use encryption

So what all do you need installed i have hostapd, wpad-mini and ath9k installed and I can not get the wireless to work at all, yet i am able to configure everything like frequency and encryption. Also i am looking for a bandwidth monitor does anyone know of a package that will work.

From what I understand, you have to install *one* of these combinations.
- wpad (Client & AP mode)
- wpad-mini (Client & AP mode)
- wpa_supplicant (Client mode) + hostapd (AP mode)

Personally I get opkg file clash errors when trying to mix e.g. wpad-mini with hostapd.

(Last edited by MHOOO on 7 May 2010, 20:33)

Hello,


Wireless worked great with my g300NH But for the life of me I couldnt get my external USB2.0 automounted and Samba correctly setup... please bear in mind I'm a complete linux newbie doing all this:

I got access to the usb drive via telnet to the router & manually mounting the drive with ntfs-3g. Problem I had is ntfs-3g does not auto mount on boot. Whats a good work around when you cant reference ntfs-3g in the fstab file?

The second problem I had is with Samba. I was trying to get rid of the username/password prompt when accessing the drive from windows. Every time I edited the /etc/samba/smb.conf (with vi no less), saved, restarted the samba service then the conf file would revert back to the original file!  I tried different versions of Samba too.

Last problem is media sharing(DLNA), dident have time to figure that...

Thanks kindly

regarding 1) i found a script that should autostart ntfs-3g whem usb is mounted but can not make it work. you can check a link few posts earlier.
2) you should also edit smb.conf.template file

baddk wrote:

The second problem I had is with Samba. I was trying to get rid of the username/password prompt when accessing the drive from windows. Every time I edited the /etc/samba/smb.conf (with vi no less), saved, restarted the samba service then the conf file would revert back to the original file!  I tried different versions of Samba too.

The problem is that /etc/samba/smb.conf is a link to /tmp/smb.conf.  It is created whenever you restart samba or reboot.  The file that you need to edit is /etc/config/samba . 

For example if you want the following section in /etc/samba/smb.conf:

[tmp]
        path = /tmp
        read only = no
        guest ok = no
        create mask = 0700
        directory mask = 0700

You would put the following in /etc/config/samba:

config 'sambashare'
        option 'name' 'tmp'
        option 'path' '/tmp'
        option 'read_only' 'no'
        option 'guest_ok' 'no'
        option 'create_mask' '0700'
        option 'dir_mask' '0700'

For entries in the [global] section of /etc/samba/smb.conf you would put them under config 'samba' section of /etc/config/samba.

Just remember to replace any spaces with underscore characters.  (e.g., netbios name becomes netbios_name)

I hope this helps.

Charles

MHOOO wrote:

From what I understand, you have to install *one* of these combinations.
- wpad (Client & AP mode)
- wpad-mini (Client & AP mode)
- wpa_supplicant (Client mode) + hostapd (AP mode)

Personally I get opkg file clash errors when trying to mix e.g. wpad-mini with hostapd.

hostapd = AP mode (WPA/WPA2)
hostapd-mini = AP mode (WPA only)
wpa_supplicant = Client mode (WPA/WPA2)
wpa_supplicant-mini = Client mode (WPA only)
wpad = hostapd + wpa_supplicant (combined in 1 package)
wpad-mini = hostapd-mini + wpa_supplicant-mini (combined in 1 package)

You should only install one of the above packages.  Although you could install hostapd and wpa_supplicant separately, but simply installing wpad will have the same result (taking up less space).

Sorry, posts 126 to 125 are missing from our archive.