OpenWrt Forum Archive

Topic: WZR-HP-G300NH Support

The content of this topic has been archived between 6 Feb 2018 and 3 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Someone help me enable N mode. I have everything up and running but I can't connect at N speeds. I always connect at 130Mbps. I have tried the following so far:

uci set wireless.radio0.htmode=HT40

uci commit wireless

wifi

Thanks.

justin22885 wrote:

did you have internet access before you changed the router to 192.168.33.1?

nop ... i didn´t ... i don´t kown if was the protocal the the 1st router use, that way i change to pppoe .

ok, here is what my /etc/config/wireless file looks like

config 'wifi-device' 'radio0'
        option 'type' 'mac80211'
        option 'macaddr' <snip>
        option 'hwmode' '11ng'
        option 'htmode' 'HT40+'
        list 'ht_capab' 'HT40-'
        list 'ht_capab' 'HT40+'
        list 'ht_capab' 'SHORT-GI-40'
        list 'ht_capab' 'DSSS_CCK-40'
        option 'disabled' '0'
        option 'channel' '4'

config 'wifi-iface'
        option 'device' 'radio0'
        option 'network' 'lan'
        option 'mode' 'ap'
        option 'ssid' 'OpenWrt'
        option 'encryption' 'none'

I'm getting about 7MB-8MB it is faster than what it has ever been, but it would be nice if it would be even faster.

Maybe it has to do with the client's card/driver... I just got a huge kernel dump on my laptop!

Also there is a limit how much the disk can physically transfer.

Edit: Also there is a lot of wireless overhead for example on G network I can really only push out 2.7MB, so 13MB dosen't sound all that far off.

(Last edited by pyther on 4 Apr 2010, 01:08)

Okay, the reason why openwrt won't connect at 300Mbps is due to overlapping Bsses. My neighbourhood is crowded with over 15 APs and all the channels are being used , which is why openwrt doesn't let me enable full N. Any way I can stop it from scanning the area?

just use the old tftp method ring.. you know that otherwise you wouldnt have openwrt on there now

sonicj, ntfs-3g isnt a program youre going to see in the init scripts.. you have to manually mount ntfs-3g, if you want it to be a little smoother, youll probably want to reformat the drive youre trying to share to FAT, and use the luci-app-samba package to configure it.. as ntfs-3g would have to be done from the command-line... but for samba editing things from the command line gives you much more control

for either method you should have kmod-usb2 and kmod-usb-storage installed from the package manager, kmod-fs-vfat if you plan to use FAT, ntfs-3g if you want to use ntfs

to add your drive as a readable and writable ntfs drive, you have to open putty (if youre on windows) connect to the command line of openwrt and type "fdisk -l" and thatll list the connected devices, usually its /dev/sda1

then from the command line youre going to want to create a folder to mount this too... so i used mkdir /mnt, to make the /mnt directory, then to have the contents of the USB disk show up under this folder, i typed ntfs-3g /dev/sda1 /mnt

after doing this, your device will be readable and writable, and you can move into this directory by typing "cd /mnt" and from here you can use the "mkdir whatever" command to make new folders

after you have the folders you want to share completed, you open "/etc/samba/smb.conf"... since i installed nano from the package manager, i type "nano /etc/samba/smb.conf"

within the smb.conf file, youll set up samba, under the global section youll want to give it a netbios name.. this can be any name you want to recognize the drive with... and workgroup you should change to match the name of the network your computers are on... for me, since i use windows this will be "WORKGROUP".. the rest under this section is fine

under this section you start adding the name and location of your shares... an example of what this should look like is this

[Justin]
        path = /mnt/Justin
        valid users = Justin
        read only = no
        guest ok = no

[Shared]
        path = /mnt/Shared
        valid users = Justin
        read only = no
        guest ok = yes

where inside the brackets is the name of the share, im not sure this matters, valid users would be the username you want... and where it says path, this is the /mnt/folder you created and want to share, read only should be no, and guest on or off is your choice

after this youll want to set up a username and password for samba, to do this type "smbpasswd yourname password"

if it gives you the "no valid user found in /etc/passwd" you may have to edit the /etc/passwd file with a test editor and write a line like this

username:*:1000:1000:username:/home/username:/bin/false

just replace "username" with your name.. and run the smbpasswd command again and it should work.. once this is all done samba should be set up and running

do not be intimidated by any of this, its rather straightforward, im not that linux savvy at all.

slax, whats the configuration of network > wifi > radio0 look like?

i believe for wireless N at 300mb you have to be using 20mhz

(Last edited by justin22885 on 4 Apr 2010, 12:04)

All right... this firmware is driving nuts... i can't make the WIFI interface to work with my network.

I mean, after installing kmod-ath9k, i see a wireless interface/device: "RADIO0", or "wlan0"...

My latest goal is to use my wireless device (RADIO0/WLAN0) as a client... connect it to an AP (another router which has internet access)... and then use this connection as if it was my "WAN" port, the one that gives internet access to my local LAN (eth0)...

please give me some guidance, i'm completely lost with LuCI and openwrt... i have 0 experience with command lines (SSH!?...) or linux. Zero experience. so i'm using exclusively LuCI to configure the router. So far this is what i think i understand:

First of all, openwrt manages the hardware of the router like this:

eth0  = The classic 4 ports designed for LAN.
eth1  = The classic single WAN port that every router has. WAN = the "internet provider".
wlan0 = The wireless antennas (lol..)
br-lan= what the heck is this?. how is this considered an interface/device?.

Ok, at fist, i tried not to make this setup too much complicated... so i decided to use everything for what it's supposed to be used. I connected the WAN port (eth1) directly to one of the LAN ports of the MAIN router (the one that has internet)... and bingo, the buffalo router now has internet access..

Then, i connected my laptop to one of the 4 ports (eth0) on the buffalo router... and i had internet access!!!, everything works perfectly well...

All that was left at this point was setup the wlan0/radio0 as a DHCP AP... so i did this (LuCI UI):

Administration------> Network -----> WiFi ----> RADIO0--->

RADIO0 config


After doing this, i tried connecting to my just created wifi AP... and not surprise: limited connectivity... something was missing... so i went to:

Administration ---> Network ----> interfaces ---> and found this:

Network interfaces

So, i decided to create a new interface called "WIFI"... i've tried MANY tipes of configuration, bridged, unbridged... DHCP & static... i'm going nuts!, it doesn't work!...

can somebody please tell me if an interface called "wifi" is necessary?... if so, what settings should i use?...

do i have to create a new entry for this "wifi" interface in the DHCP tab?, any idea on the settings there?

Usually it is done this way:

1) navigate to network -> wireless -> radio0
- fill out ssid, channel, key etc.
- set network to wan
- set mode to client

2) navigate to network -> interfaces -> wan
- choose "custom" in the interface field and make it empty

3) reboot

~ JoW

justin, thanx for the detailed explanations & instructions! i'll try this out in a bit! cheers!
-sj

jow wrote:

Usually it is done this way:

1) navigate to network -> wireless -> radio0
- fill out ssid, channel, key etc.
- set network to wan
- set mode to client

2) navigate to network -> interfaces -> wan
- choose "custom" in the interface field and make it empty

3) reboot

~ JoW

for some reason the wifi network is not even trying to associate/connect to the AP...  wifi network

i did the changes you suggested, and this is how my interfaces look

I'll keep trying... but this is so confusing, only wired networking works.... any ideas?

Thanks in advance for the help.

This wrong. If you did what jow wrote the router maybe is connecting, but it doesn't have an ip address as you set the wireless to use the wan network, which doesn't have an ip address. Also the firewall rules are deny all incoming traffic on the wan interface.

Here is what you need to do (modified):

1) navigate to network -> wireless -> radio0
- fill out ssid, channel, key etc.
- set network to lan
- set mode to client

2) navigate to network -> interfaces -> wan
- choose "none" in the interface field and make it empty

3) navigate to network -> interfaces -> lan
- either select dhcp or a static ip in the interface field

Thanks pyther for your post... I'll try this this evening after work smile


Just one thing:

My lan has a static IP, 192.168.20.1... any device connected to this LAN is automatically assigned with an IP in that 192.168.20.X range thanks to DHCP...

Now,  my wireless device (RADIO0) is supposed to connect to the AP (as client), and provide with internet access my LAN.... I don't see how the configuration you suggested is going to work out with this idea in general...

Can't wait to try it out!...

But there's a hell of a learning curve for me... linux, and networking wise. This is fun smile

btw, @justin

Hey man, the info you have posted is really interesting indeed... Thank you so much for giving such detailed information and explanations for us, the new arrivals to this world of linux. As soon as get this networking problems fixed, I'll jump in  to the topic of sharing hard drives in NTFS format to the network.

(Last edited by lolcatz on 5 Apr 2010, 20:12)

Woops ignore what I said....

Do you want a completely separate network from the wireless AP or do you want your clients to be on the same network as the Wireless AP?

pyther:

Your suggestion is not going to work since bridging in client mode is not possible with ath9k.
Also the wan firewall does allow incoming dhcp responses, otherwise it would never work, even in wired setups.
And finally, Client Mode != AP.

~ JoW

pyther wrote:

Woops ignore what I said....

Do you want a completely separate network from the wireless AP or do you want your clients to be on the same network as the Wireless AP?

No, i want my local clients to be completely governed by my firewall and networking rules... all i want to do is transform my RADIO0 device into a "wireless WAN port"... i will provide this RADIO0 client with the DMZ mode from the main router/AP... so it gets a clean and fast internet connection smile

edit:
@jow

I'm not sure i understand what you said in your last post... am i missing something else in the DHCP configuration?... or what I'm trying to do is simply not viable...

sad

(Last edited by lolcatz on 5 Apr 2010, 20:25)

Hmm I did not realize that bridging is not supported with ath9k... that is good to know!

@jow I take it the firewall allows traffic that was initiated on the lan to come in on the wan?

btw sorry for the misinformation I provided earlier!

@lolcatz the stuff jow was talking about was direct towards me, AFAIK

(Last edited by pyther on 5 Apr 2010, 20:28)

No. As far as I know the ath9k driver/module should work as a client just fine. My laptop has a card that uses the ath9k module/driver and it connects to a wireless network without a problem (acting as a client). However, the ath9k can't act in client bridged mode.

http://www.dd-wrt.com/phpBB2/viewtopic.php?t=68 wrote:

Client bridged mode is more transparent than regular client mode in the sense that all devices, both in front of and behind the router in client bridged mode, are all on the same subnet. In client mode, it's more of a double-nat setup, where you have one nat (the client) behind another nat (the regular router).

EDIT: lolcatz deleted his/her last post

(Last edited by pyther on 5 Apr 2010, 20:39)

Ops, sorry about that... yeah, i was asking if the ath9k driver wouldn't work as a client on this router because of it's, or the router's limitations... but i felt my question was completely out of place.

If my daily routine allows me to do so... i will read and try to learn as much as i can about openwrt and clarify my networking doubts... i have an idea of what i want to do, but i don't know anything about networking...

Sadly is more likely that because of my daily routine i will have to wait for a working ddwrt release, which i understand a little bit more... and i know what to do in order to make things work just like i want to.. i have an older buffalo router with ddwrt installed running my network like i have mentioned before, and works perfectly well.

meanwhile I'll keep trying a little bit more with open wrt ... and wait for more suggestions on where to start tongue

(Last edited by lolcatz on 5 Apr 2010, 21:02)

jow wrote:

Usually it is done this way:
....

2) navigate to network -> interfaces -> wan
- choose "custom" in the interface field and make it empty

...
~ JoW

Why make it empty? Wouldn't we want to set it to wlan0 and then set the protocol to dhcp or static ip?

Because the option network in the wireless configuration already specifies which network the to-be-created vap is attached to.
It is bad practice to reference wireless ifnames in the network configuration:
  - wifi ifnames are not predictable, if you use multiple vaps you do not know which one becomes wlan0, which one wlan1 etc.
  - in wds setups, additional wifi ifnames are spawned on demand, so there could be wlan0.sta1, wlan0.sta2, ...
  - it might introduce race conditions since the wired network setup attempts to bring up wireless while the firmware is not even loaded yet

~ JoW

Ahh ok, I see that makes sense. Sorry for the noise!

Hello,

I've tried OpenWRT and found it doesn't really met my needs and is far too complicated for my simple network.  Can anyone here help me remove openwrt from my buffalo WZR-HP-G300NH and replace it with the stock firmware.  I have download the stock 1.72 firmware from Buffalo's site and have tried (many times) to TFTP the firmware onto the router with no luck.

Any help would be greatly appreciated.

Thanks!

econ101 wrote:

Hello,

I've tried OpenWRT and found it doesn't really met my needs and is far too complicated for my simple network.  Can anyone here help me remove openwrt from my buffalo WZR-HP-G300NH and replace it with the stock firmware.  I have download the stock 1.72 firmware from Buffalo's site and have tried (many times) to TFTP the firmware onto the router with no luck.

Any help would be greatly appreciated.

Thanks!

To revert back to the factory firmware you'd need to do the same procedure you used to install OpenWRT - except when you execute the tftp put command you'd need to specify the factory firmware image.

i.e.- tftp> put wzrhpg300nh-172

Sorry, posts 76 to 75 are missing from our archive.