OpenWrt Forum Archive

Topic: Tp-link Tl-wr703n

The content of this topic has been archived between 18 Mar 2015 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

I flashed the r29353 version,attached a usb hub, and connected a flash key as extroot.
It worked without problems.

But ,If I attach and mount another usb external harddisk.
Usb hub would disconnect when the harddisk is idle and suspended.

I don't know wheather there is a usb suspend/resume problem.
There isn't any parameter to disable autosuspend.

I simply write a script to wake up the disk every five minutes.

(Last edited by hamal on 3 Dec 2011, 17:35)

Hi,
I played with the config and changed the 3g modem device to /dev/ttyUSB2 and it started working fine. I assumed that all 3 devices are equal but apparently thats not true. When I used /dev/ttyUSB0 it caused the dongle to lock, and apparently 3g hotplug was triggering this too. So now I have my 3g connection working on firmware build from aind.

I want to configure the device as wireless AP and there are still some problems. I want to create bridged lan connection with wifie and eth0 and here is the output from wifi command:

Configuration file: /var/run/hostapd-phy0.conf
nl80211: Failed to add the bridge interface br-lan: Package not installed
nl80211 driver initialization failed.
rmdir[ctrl_interface]: No such file or directory
Failed to start hostapd for phy0

Do you know what package is missing and how to get it to work with this build?

Homer wrote:

Hi all,

I am a Newby and have also a TP-Link 703. I don´t have any Linux skills and my English is not very good. I flashed a Image via the original chinese gui with firmware update. With this Image (I dont know the version, but it seems a old one of openWTR) I´m not very lucky, because WiFi not working and no possibility for another firmwareupdate :-(
Have anyone a description for Dummies, step by step, how to flash?
Is it possible to flash via ethernet (tftp etc.), or only via seriell?
Which Image should I use?

Thanks in advance and sorry for my bad english!

if you're able to telnet or SSH into the machine, a command called "sysupgrade" should exist which you can use to flash new image. just scp or copy it to /tmp/ and then run that command with the first parameter being the new firmware's bin/img file.

Hello everyone I bought a Tl-wr703n specifically to use linux with it as many here, and I need it to work as a wireless access point for a network that will set it's ip address via dhcp. I want to use it as a fileserver and music player with a usb hub and usb sound card. I found this link to a firmware http://ubuntuone.com/5FEDGTZ1GfDbgY3CzHXuwQ on the forums, and was able to get it to run as specified as a router, but it had such a limited amount of free space, that I could not install kmod-fs-ext4 and block-mount for extroot without filling up the memory. I really must have restorefactory installed as i will probably end up bricking the device without it. (i know about serial, but I don't especially want to open this device right now) does anyone have a firmware that would fit me, (has necessary programs to set up AP mode wireless access point, enough space to install extroot, and restorefactory), otherwise what is the best revision of the trunk for me to build my own. my device is 1.5 if that matters.

Hi kobush,

In /etc/config/network, at least you should add option 'ifname' 'ppp0' and not use option 'auto' '0', please remove this line.

Hi all.
I managed to brick my router, dealing with openwrt.
The only think I can do now is ping 192.168.1.1 via ethernet. No telnet, no SSH, no wifi, etc. No luck with Reset - after boot, the led just stops.
Is there any method to unbrick the device without serial console?
Apologize for my English :-)

Hi chochobg, I´m also a newbie, but this answer helped me very well:
if you're able to telnet or SSH into the machine, a command called "sysupgrade" should exist which you can use to flash new image. just scp or copy it to /tmp/ and then run that command with the first parameter being the new firmware's bin/img file.
What is your mother language, maybe I can help you in german?

Hi all,

New WR703N (V1.5) owner, still on original firmware.

I saw the wiki page was edited recently and there's a link to a recent trunk snapshot (Nov 26 IIRC).
Is the no-failsafe-mode problem solved? if so, why is the warning message still on the wiki? which SVN revisions are safe and which are unsafe?

Thanks in advance,
R.

Hello again all, I have decided I probably will compile from source. Are there any special things to avoid, which is the most stable current revision for the 703n I also want to have external storage for a root any tutorial for doing that in the configuration? I've never done this before. Thanks in advance.

Homer wrote:

Hi chochobg, I´m also a newbie, but this answer helped me very well:
if you're able to telnet or SSH into the machine, a command called "sysupgrade" should exist which you can use to flash new image. just scp or copy it to /tmp/ and then run that command with the first parameter being the new firmware's bin/img file.
What is your mother language, maybe I can help you in german?

Hi,
Thank you for the reply.
As I wrote I don't have SSH or telnet access to my device.
My mother language is Bulgarian :-)

Regards,
Chocho

Homer wrote:

Hi chochobg, I´m also a newbie, but this answer helped me very well:
if you're able to telnet or SSH into the machine, a command called "sysupgrade" should exist which you can use to flash new image. just scp or copy it to /tmp/ and then run that command with the first parameter being the new firmware's bin/img file.
What is your mother language, maybe I can help you in german?

enter failesafe mode to reflash.to enter failsafe mode, just hit the reset button repetitively soon after the device is plugged into power.

sin wrote:

enter failesafe mode to reflash.to enter failsafe mode, just hit the reset button repetitively soon after the device is plugged into power.

Tried several times without success.

chochobg wrote:
sin wrote:

enter failesafe mode to reflash.to enter failsafe mode, just hit the reset button repetitively soon after the device is plugged into power.

Tried several times without success.

Try turning it on while holding down the reset button until the blue LED starts flashing very fast.

nemik wrote:
chochobg wrote:
sin wrote:

enter failesafe mode to reflash.to enter failsafe mode, just hit the reset button repetitively soon after the device is plugged into power.

Tried several times without success.

Try turning it on while holding down the reset button until the blue LED starts flashing very fast.

I tried, but the LED just turns off.

RaeNye wrote:

Hi all,

New WR703N (V1.5) owner, still on original firmware.

I saw the wiki page was edited recently and there's a link to a recent trunk snapshot (Nov 26 IIRC).
Is the no-failsafe-mode problem solved? if so, why is the warning message still on the wiki? which SVN revisions are safe and which are unsafe?

Thanks in advance,
R.

Is there a way to flash V1.5 with openwrt? I'm holding of my purchase because I saw some reports that said that it is not possible to flash openwrt on v1.5 versions sad

Has anybody put openwrt on wr703 v1.5?

sewnbacktogetherwrong

I have flash the snapshot of 5 Dec at V1.5 703n . (upgrade firmware from original  management web )

but the wireless is not active .

I can telnet / ssh to the openwrt  from the  wireline ethernet port(192.168.1.1) , but there is no web luci

question : Do the snapshot of 5 Dec include packages for web luci?
or something wrong during my upgrade/flash?

Thanks in advance.

ccwufu wrote:

sewnbacktogetherwrong

I have flash the snapshot of 5 Dec at V1.5 703n . (upgrade firmware from original  management web )

but the wireless is not active .

I can telnet / ssh to the openwrt  from the  wireline ethernet port(192.168.1.1) , but there is no web luci

question : Do the snapshot of 5 Dec include packages for web luci?
or something wrong during my upgrade/flash?

Thanks in advance.

openwrt trunk images (at least for wr703n) have wireless disabled by default and no web management package.
you can set your internet access to the device and use "opkg update" and "opkg install luci" for the web gui.

aind
thanks,

after comment out the "option disabled 1" in /etc/config/wireless
and /etc/init.d/network restart

the wireless port is active.

now I try to configure the openwrt with uci command.

I google and find some tips , but I'm not sure.
uci set network.wan.proto=none   
uci set network.lan.gateway=[upward router ip]   
uci set network.lan.dns=[upward router ip]   
uci set dhcp.lan.ignore=1

Hi I have a problem with setting the baud rate on the on board serial port on a TL-WR703N (ttyATH0).

I bought the ultra low cost and compact router in china. I plan to interface a PIC 16F628 with it using serial communication@9600 8N1. Everything works great except the fact that the serial port is transmitting in 115200 instead of 9600. I guess that the main problem is that I can’t get stty to work on the device. (it’s included in the ipkg, but not the opkg that the device is using). I have searched forum for days, but most solutions seems to be for USB2serial converters (FTDI)
This is the device I’m using:
http://wiki.openwrt.org/toh/tp-link/tl-wr703n

This is what I have done:
1.    installed this version of openwrt  http://downloads.openwrt.org/snapshots/ … actory.bin
2.    disabled serial console by adding “#” to /etc/inittab
3.    installed the following packages:
a.    opkg install picoterm empty
b.    opkg install coreutils
c.    opkg install microcom
d.    opkg install setserial
4.    I also manually copied stty to usr/sbin, but it does not seem to work… (http://www.jbprojects.net/projects/wifirobot/stty.tgz)

I’m testing it with the following command:
echo "hello" > /dev/ttyATH0
This works, I can receive the message on a pc running terminal program and hardware voltage level conversion. But it is with the wrong baud rate (still 115200).
I have tried the following commands:
empty -f picocom -b 9600 -p n -f n -l -r /dev/ttyATH0 -> (nothing happens)
empty -f picocom -b 9600 -p e -l -r /dev/ttyATH0 -> (nothing happens)
setserial /dev/ttyATH0 baud_base 9600 -> (Cannot set serial info: Invalid argument)

If I just run setserial I get this message:
root@OpenWrt:~# setserial /dev/ttyATH0 -> (/dev/ttyATH0, UART: undefined, Port: 0x0000, IRQ: 11)

During boot I have seen this message:
Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11) is a AR933X UART
So I tried the following command:
root@OpenWrt:~# setserial /dev/ttyATH0 port 0x18020000 irq 11 ->(Cannot set serial info: Device or resource busy)
I guess that getting a stty that works might solve the problem, but I can’t find it as a install package, and my manual install attempt didn’t work (was built for fonera kamikaze). Does anyone have any idea for how to proceed?

(Last edited by konow on 9 Dec 2011, 11:14)

konow wrote:

Hi I have a problem with setting the baud rate on the on board serial port on a TL-WR703N (ttyATH0).

I bought the ultra low cost and compact router in china. I plan to interface a PIC 16F628 with it using serial communication@9600 8N1. Everything works great except the fact that the serial port is transmitting in 115200 instead of 9600. I guess that the main problem is that I can’t get stty to work on the device. (it’s included in the ipkg, but not the opkg that the device is using). I have searched forum for days, but most solutions seems to be for USB2serial converters (FTDI)

I guess that getting a stty that works might solve the problem, but I can’t find it as a install package, and my manual install attempt didn’t work (was built for fonera kamikaze). Does anyone have any idea for how to proceed?

@konow

You need to update the following line in file target/linux/ar71xx/image/Makefile

tlwr703n_cmdline=board=TL-WR703N console=ttyATH0,115200

and change 115200 to 9600. Save the file and rebuild the firmware then flash it to your WR703N. The tty console baud rate is hard coded as kernel boot parameter.

I installed the firmware from http://www.ip6.ro/firmware/tp-link/wr703n/AP-BRIDGE_NO_WEB_INTERFACE/ thinking that i could plug in my 3g dongle and use the router as a wireless access point to access the dongles internet through wireless. It is acting as a bridge, and now i am in a situaton that i can only telnet the device in failsafe mode via an ethernet cable connected directly to my windows laptop, which has internet access via a 3g dongle. And i dont know how to give the device internet access to change firmware because i am using the ethernet port to telnet the device...Please tell me a good way to get the other luci-capable firmware on my computer to the device. I am lost:S

s7mx1 wrote:
konow wrote:

Hi I have a problem with setting the baud rate on the on board serial port on a TL-WR703N (ttyATH0).

I bought the ultra low cost and compact router in china. I plan to interface a PIC 16F628 with it using serial communication@9600 8N1. Everything works great except the fact that the serial port is transmitting in 115200 instead of 9600. I guess that the main problem is that I can’t get stty to work on the device. (it’s included in the ipkg, but not the opkg that the device is using). I have searched forum for days, but most solutions seems to be for USB2serial converters (FTDI)

I guess that getting a stty that works might solve the problem, but I can’t find it as a install package, and my manual install attempt didn’t work (was built for fonera kamikaze). Does anyone have any idea for how to proceed?

@konow

You need to update the following line in file target/linux/ar71xx/image/Makefile

tlwr703n_cmdline=board=TL-WR703N console=ttyATH0,115200

and change 115200 to 9600. Save the file and rebuild the firmware then flash it to your WR703N. The tty console baud rate is hard coded as kernel boot parameter.

Finally it works!!!
I got a working stty from Nemics post: https://forum.openwrt.org/viewtopic.php?pid=149335#p149335 Using stty on that one lets me set the baud rate on the ttyATH0 !
stty -F /dev/ttyATH0 raw speed 9600 -crtscts cs8 -parenb -cstopb

Nemic was also kind enough to give me the following network details for the distro:
"Its subnet is 192.168.3.1 and if you plug a computer into its LAN port, it should issue an IP by DHCP on the 192.168.3.x subnet."

(Last edited by konow on 9 Dec 2011, 23:34)

Hi aind,
I see that you have a new wr703n firmware,
Do you improve any function or give more function from verion r29337?

Vinh