OpenWrt Forum Archive

Topic: Tp-link Tl-wr703n

The content of this topic has been archived between 18 Mar 2015 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

sewnbacktogetherwrong wrote:

For those interested I have documented the step-by-step process to set the TL-WR703N up as a pen-testing drop box.  A USB drive is used to expand the storage space so it can hold nmap, openVPN, kismet, karma, dsniff, etc.
http://www.minipwner.com/index.php/minipwner-build

I also found that the Sharper Image portable phone chargers (available on Ebay, search for "sharper image charger") are just about the same size as the WR-703N itself and the router will run off of one for hours.

Kevin

Looks good Kevin, im going to have to try that! Can you post a link to the battery pack? I cant see anything that looks like it at the moment.

lizby wrote:

twinclouds--have you modified /etc/config/wireless, including removing or commenting out "option disabled 1"?  For security purposes, wireless is disabled by default.

Hi, lizby:
No.  I haven't I will edit it tonight.
Do you know how much memory luci needs?
Thanks.

I was updated my  Tp-link Tl-wr703n with firmware and added new password to it. But when i try to edit  /etc/config/network it shows below message.

root@OpenWrt:~# /etc/config/network
-ash: /etc/config/network: Permission denied

Please help me on edit network.

>Please help me on edit network.

Did you mean perhaps "nano /etc/config/network"?

hi..
I have only 56KB free memory left following are the packages installed, can I remove some packages. Also it does not allow me to edit the /etc/config/network file for 3g usb setting
attributes of /etc/config
drwxr-xr-x    1 root     root             0 Sep  8 15:46 config

attributes of /etc/config/network
-rw-r--r--    1 root     root           375 Sep  8 15:57 /etc/config/network

base-files - 98-r29557
base-files-network - 3
busybox - 1.19.3-9
chat - 2.4.5-4
comgt - 0.32-9
crda - 1.1.1-1
dnsmasq - 2.59-2
dropbear - 2011.54-1
firewall - 2-42
hotplug2 - 1.0-beta-4
ip - 2.6.39-1
iptables - 1.4.10-4
iptables-mod-conntrack - 1.4.10-4
iptables-mod-nat - 1.4.10-4
iw - 3.1-2
kernel - 2.6.39.4-1
kmod-ath - 2.6.39.4+2011-12-01-1
kmod-ath9k - 2.6.39.4+2011-12-01-1
kmod-ath9k-common - 2.6.39.4+2011-12-01-1
kmod-button-hotplug - 2.6.39.4-3
kmod-cfg80211 - 2.6.39.4+2011-12-01-1
kmod-crypto-aes - 2.6.39.4-1
kmod-crypto-arc4 - 2.6.39.4-1
kmod-crypto-core - 2.6.39.4-1
kmod-input-core - 2.6.39.4-1
kmod-input-gpio-keys-polled - 2.6.39.4-1
kmod-input-polldev - 2.6.39.4-1
kmod-ipt-conntrack - 2.6.39.4-1
kmod-ipt-core - 2.6.39.4-1
kmod-ipt-nat - 2.6.39.4-1
kmod-ipt-nathelper - 2.6.39.4-1
kmod-leds-gpio - 2.6.39.4-1
kmod-ledtrig-usbdev - 2.6.39.4-1
kmod-lib-crc-ccitt - 2.6.39.4-1
kmod-mac80211 - 2.6.39.4+2011-12-01-1
kmod-nls-base - 2.6.39.4-1
kmod-ppp - 2.6.39.4-1
kmod-pppoe - 2.6.39.4-1
kmod-usb-core - 2.6.39.4-1
kmod-usb-ohci - 2.6.39.4-1
kmod-usb-serial - 2.6.39.4-1
kmod-usb-serial-option - 2.6.39.4-1
kmod-usb-serial-wwan - 2.6.39.4-1
kmod-usb2 - 2.6.39.4-1
libc - 0.9.32-98
libgcc - 4.5-linaro-98
libip4tc - 1.4.10-4
libiwinfo - 21
libiwinfo-lua - 21
liblua - 5.1.4-8
libnl-tiny - 0.1-2
libuci - 2011-11-14.1-1
libuci-lua - 2011-11-14.1-1
libusb - 0.1.12-2
libxtables - 1.4.10-4
lua - 5.1.4-8
luci - trunk+svn8107-1
luci-app-firewall - trunk+svn8107-1
luci-i18n-english - trunk+svn8107-1
luci-lib-core - trunk+svn8107-1
luci-lib-ipkg - trunk+svn8107-1
luci-lib-lmo - trunk+svn8107-1
luci-lib-nixio - trunk+svn8107-1
luci-lib-sys - trunk+svn8107-1
luci-lib-web - trunk+svn8107-1
luci-mod-admin-core - trunk+svn8107-1
luci-mod-admin-full - trunk+svn8107-1
luci-proto-3g - trunk+svn8136-1
luci-proto-core - trunk+svn8107-1
luci-proto-ppp - trunk+svn8136-1
luci-sgi-cgi - trunk+svn8107-1
luci-theme-base - trunk+svn8107-1
luci-theme-openwrt - trunk+svn8107-1
mtd - 17
opkg - 618-2
ppp - 2.4.5-4
ppp-mod-pppoe - 2.4.5-4
swconfig - 10
uboot-envtools - 2011.06-4
uci - 2011-11-14.1-1
uhttpd - 30
usb-modeswitch - 1.2.0-2
usb-modeswitch-data - 20111023-1
wireless-tools - 29-4
wpad-mini - 20111103-2

Please advice

(Last edited by catchmahesh on 15 Jan 2012, 15:28)

lizby wrote:

>Please help me on edit network.

Did you mean perhaps "nano /etc/config/network"?

I simply use "vi /etc/config/network" and never had any problem.

catchmahesh wrote:

hi..
I have only 56KB free memory left following are the packages installed, can I remove some packages. Also it does not allow me to edit the /etc/config/network file for 3g usb setting
.....

Please advice

4MB of flash is not a lot of memory.  If you want to do anything serious, you might need extroot.  I haven't tried this but usually, you can connect a usb hub if you want hook more than one usb device to it.

BTW, with extroot, I eventually am able to run asterisk18 on it as a gtalk server.

Help needed!
I tried to do a sysupgrade using the image that I build with luci and the USB related packages.  However, when it said reboot, the light became constantly on.  I took the power off then on, start with lights on and no flashing stage.  I tried to get into fail safestate but nothing works.  I hooked up the serial console, but there was no output. 
One question I have is: for serial console to work, should the router normally get into the flashing stage?  Is the blue light constantly on a sign of permanent damage?
Not sure what had happened.  Is it dead permanently or if there's anything I can do?  Please help!

catchmahesh wrote:

hi..
I have only 56KB free memory left following are the packages installed, can I remove some packages...

Please advice

Look like you installed Luci. I did the same thing and found there was no room for anything else after! After flashing the firmware you should have about 1.5Mb

O.K. I found the problem for my serial console not working is that I had a bad CA42 cable.  After changed the CA42 cable, which was proven working on Dockstar and Pogoplug, I can see the output when the device is booting.  However, I cannot stop it to go into the uboot prompt.  I tried type tpl have no use.
BTW, I am using Putty on my PC.  Anybody did the same thing with success?  Thanks in advance.

hi.. I have screwd up the setting and also removed the network file. Now In the failsafe mode when I try to set the password using passwd it gives the following message

root@(none):/# passwd
Changing password for root
New password:
Retype password:
passwd: /etc/passwd: Read-only file system
passwd: can't update password file /etc/passwd

Attributes of the /etc/passwd
root@(none):/# ls -l /etc/passwd
-rw-r--r--    1 root     root           190 Nov 18  2011 /etc/passwd

please advice

hi.. I was able to restor the setting I did the following

1 In the failsafe mode I first executed firstboot
2 I was then able to set the password
3 Created the network file in /etc/config path
4 Enabled the wireless mode

I was then able to access the router using putty and option SSH

(Last edited by catchmahesh on 17 Jan 2012, 16:18)

Somehow, I can never get into failsafe mode.  The blue LED always stays on, never flashing after the failed sysupgrade.  Anyone have seen this?

twinclouds wrote:

BTW, with extroot, I eventually am able to run asterisk18 on it as a gtalk server.

Whow, this sounds awesome, do you have some links how to configure such setup?

twinclouds wrote:

Somehow, I can never get into failsafe mode.  The blue LED always stays on, never flashing after the failed sysupgrade.  Anyone have seen this?

hope you are pressing the the rest button in quick succession as soon as you power the router

catchmahesh wrote:
twinclouds wrote:

Somehow, I can never get into failsafe mode.  The blue LED always stays on, never flashing after the failed sysupgrade.  Anyone have seen this?

hope you are pressing the the rest button in quick succession as soon as you power the router

I did but nothing happened.

Nice JamesA!

James:
Nice job.  Can you access the ports from outside without opening the box?
I still not be able to connect to my bricked 703n.  When use the serial cable, I can see the output and eventually showed a kernel panic.  This was the result when I did sysupgrade through ssh.  After that, whenever I turn it on, the blue lights always on and never go to the blink stage. Make things worse, even using a serial cable, I cannot enter the uboot by typing 'tpl".  The display only showed some strange characters.  It is not dead yet but very sick sad.
I am waiting for getting another 703n.  However, I am really scared to do sysupgrade.  One question I have is, if I use the serial cable and tftp to flash the image, should I always use the factory image, even if I already have flashed it previously?
Thanks in advance for sharing your experience.

(Last edited by twinclouds on 20 Jan 2012, 01:02)

Thanks guys, glad you like it!

You can only access the port thats in the original place when the lid is on. I did cut the tab off the one corner which makes it a lot easier to open. I was thinking of adding a little pull cord or something to make it easy to open.

Hmm does sound like your 703 is a bit sick doesnt it! Sorry i cant add much to help, but i did think it was pretty hard to brick them and you should almost always be able to get into recovery mode. What happens if you hammer the reset button as soon as you power it up? Took me a few goes to the hang of it as it usually takes 10 or 15 seconds of pressing the button fast to get it.

Hi, JamesA:
Thank you for your reply.  I just got another one from China.  It is <100RMB (~$16).  Of course the key part is find someone bring it over.  I installed trunk factory.bin and installed luci and necessary USB support.  I have about 200K left.  Then I configured extroot with a 2G microSD with an adapter.  It works perfectly.  Now I have about 1.6G space to play with.  I installed Asterisk18 from trunk and it works with my gtalk.  Everything is fine so far.
However, when I wired the serial port, it still show the same behavior.  I can see the output but cannot stop the booting process by typing tpl quickly.  I think it is probably because of my cable.  I use a Nokia CA-42 cable that works well on my Dockstar and Pogoplug.  It may not be compatible with the 703n?  Now I am waiting for people coming back from their Chinese New Year vacation from China to bring some tested cables back for trying it out.  At least this time I didn't break the router smile.  Have you or anybody tried to use the CA-42 with success on 703n?  What type of interface chips (PL2303, PL2103, PL2303Hx) are known to work?  I am curious to know.

(Last edited by twinclouds on 20 Jan 2012, 21:25)

Im in the UK, got mine from China originally via ebay. Im going to order another one next pay day i think, just to play with smile

Nice work on exroot, i need to sort that out on mine. Im currently running Sam's NAS build, but i also want to flash back to stock and set it up a the minipwn listed earlier. Definatly need 2 of these lol!

Cant help on the cable sorry, ive not needed to hook mine up yet but i thought i saw something about those cables being fine. Im lucky as my motherboard still has a proper serial port on it.

twinclouds--I got a CA-42 to work on the wr703n.  Very briefly, though, before the pads pulled up, even though I used 30 awg kynar wire and was trying to handle it very carefully.  Now I need to see if I can get sufficient magnification to see if I can scrape a trace and retry.  For my next one I'm going to see if I can figure a way to spring-clamp connections to the RX & TX to try to avoid pulling up the pads.

Now, my wish for an enhanced version of this device (without modding):  a second usb, 8mb flash, 64mb ram, through-holes for the serial so that one can solder a header on.  I'd pay a whole extra $5.  (Thanks, JamesA, for documenting your very nice mod.)

(Last edited by lizby on 21 Jan 2012, 00:43)

I posted a "how-to" with lots of pictures showing how I added a serial port to the WR703 along with my choice for the level-shifter and how I hook it up. The how-to is here:

http://wiki.villagetelco.org/index.php? … _TL-WR703N

Once you have serial port access to the bootloader (uboot), you need to connect an ethernet cable from eth0 on the 703 to the ethernet port on your build machine. Set the IP address of the ethernet port on your build machine to 192.168.1.100. This is the default for the tftp server IP address on uboot. If you want to change it, you can use the setenv uboot command. However, I haven't tried that so YMMV. Finally, you need to have the tftp daemon running on your build machine and the default tftp download directory set to where your firmware image is. Then you can reflash the 703 firmware as follows:

hornet> tftpboot 0x81000000 openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin

Notice that I used the squashfs-factory.bin version of my built firmware NOT the squashfs-sysupgrade.bin version. If you didn't fat finger the filename for your image, you'll see lots of rows of pound signs on the console as your image is tranferred to the 703 memory. Next type,

hornet> erase 0x9f020000 +0x3c0000

This will wipe out your previous image in the 703 flash. Make sure you don't mess up the address or count and that the hex numbers start with 0x. Also don't forget the "+" in front of the count. When the erase completes (counts up to about 61 sectors), type:

hornet> cp.b 0x81000000 0x9f020000 0x3c0000

This copies your new image in memory to the flash part. Again, make sure you don't fat finger these addresses or the count and that they are all preceded with 0x. Also notice that unlike the erase command, you don't use the "+" in front of the count for the cp.b command. When the cp.b completes, boot up the new image as follows:

hornet> bootm 9f020000

Notice that bootm assumes the number is in hex. I believe it's OK to precede the address with 0x but I learned to do it without it and haven't tried it with the 0x myself. Again, YMMV.

That's it.

I found that going through the process of getting a working serial console for at least one of my 703's has made me a lot more comfortable about creating and testing builds. No matter how bad the build is, I still have access to uboot and can simply reflash with a "non-bricking" image. Once I know I have a good working image, I can apply the sysupgrade version of that image to my other 703's that don't have the serial port.

BTW..the other case where you flash with the squashfs-factory.bin version of the image is when you flash a new 703 that still has the TP-link factory firmware. After that, use the squashfs-factory.bin images when flashing via uboot/tftpboot and the squashfs-sysupgrade.bin images when flashing using the sysupgrade utility from within the openwrt running image on the target 703.

Cheers!

-Keith

Ooops..messed up the URL somehow. The posted URL takes you to a page that has a bunch of villagetelco howto's. Just look down the page for "TP-Link", click on that and then click on "Building a Serial Port for TL-WR703N".

-Keith