OpenWrt Forum Archive

Topic: Tp-link Tl-wr703n

The content of this topic has been archived between 18 Mar 2015 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

I've been trying to get installation to an ext2 formatted 2GB sd card to work, but it fails for 'lack of space'. Below is a summary of what I've done to set it up, and the resulting error:

~# less /etc/config/fstab #fstab setup to mount card on boot (& enabled)
config mount
        option target    /mnt/sd
        option device    /dev/sda1  # ext2 partition
        option fstype    ext4       # pretend it's ext4 to suit kmod-fs-ext4
        option options   rw,sync
        option enabled   1
        option enabled_fsck 1

~# ls /dev
bsg        mtd0ro     mtd4ro     mtdblock5  sda1       ttyS12     ttyS6
...                                                            #device recognised...
mtd0       mtd4       mtdblock4  sda        ttyS11     ttyS5

~# ls /mnt
sd #and mounts ok...

~# less /etc/profile
export PATH=$PATH:/mnt/sd/bin:/mnt/sd/sbin:/mnt/sd/usr/bin:/m
nt/sd/usr/sbin/ # editted to add paths to installed executables

~# less /etc/opkg.conf
src/gz attitude_adjustment http://downloads.openwrt.org/attitude_adjustment/12.
09-beta/ar71xx/generic/packages
dest root /
dest ram /tmp
dest sd /mnt/sd # added destination for installing executables
lists_dir ext /var/opkg-lists
option overlay_root /overlay

root@OpenWrt:/# opkg update
Downloading ... 
root@OpenWrt:/# opkg --dest sd install python-mini
Installing python-mini (2.7.3-1) to sd...
Collected errors:
 * verify_pkg_installable: Only have 628kb available on filesystem /mnt/sd/, pkg python-mini needs 1376
 * opkg_install_cmd: Cannot install package python-mini.
root@OpenWrt:/#

Which is very strange, considering this is a newly formatted 2GB card...

EDIT: figured it out - hadn't installed block-mount & enabled it with /etc/init.d/fstab enable. Just got to figure out the sym links now I think smile

(Last edited by denovo on 23 Oct 2012, 20:41)

Hello,

I'm trying to compile a custom firmware image for my TL-WR703N. When the compiling finishes my bin/ar71xx folder includes the following:

md5sums
openwrt-ar71xx-generic-root.squashfs
openwrt-ar71xx-generic-root.squashfs-64k
openwrt-ar71xx-generic-uImage-gzip.bin
openwrt-ar71xx-generic-uImage-lzma.bin
openwrt-ar71xx-generic-vmlinux.bin
openwrt-ar71xx-generic-vmlinux.elf
openwrt-ar71xx-generic-vmlinux.gz
openwrt-ar71xx-generic-vmlinux.lzma
packages

I was expecting to find openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-sysupgrade.bin and openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.img files here. Is this an indication that I've included too many packages, maybe the resulting images are too big for the router's limited memory? Or is there some other configuration I've missed in menuconfig? Maybe I need to inspect some log file to see what's happening?

Thanks for any clues.

You have included too much. (Image is too big) Took me a while to work that out when it happened to me!

Thanks robthebrew! I reset to the defaults and was a little more careful with my selection. That did the trick.

Hi All

I was in a rush (poor excuse!) and I updated my fresh 703N with the english bin file via the wireless connection and not static IP via ethernet. (Feeling very stupid).

Now I can't see my 703N on a wireless connection but it does pop up when plugged in via ethernet cable (but no web console via the 192.168.1.1 route).

Any ideas on how I bring it back to life? (step by step if possible) Thanks

EDIT: OpenWRT is alive and kicking but I can't load a new bin, please see below.

(Last edited by MattM on 12 Nov 2012, 16:17)

What english bin file???

I have a 703N with OpenWRT on it (in my attempts to have an English interface).

However I have now found the following (perfect!) https://forum.openwrt.org/viewtopic.php?id=36596 and want to remove OpenWRT and put the english 3020 bin file on the system.

The wireless network is configured and I can ping external websites.

I then SSH into WRT and enter the following

cd /tmp
wget http://IP:8080/firmware.bin (actual IP entered having used my computer IP plus the port configured in QuickShare - HTTP server) , at this stage it seems to time out for some reason despite it working in IE.

sysupgrade -v -F firmware.bin

Does the above seem logical? and any ideas why it times out?

Thanks

Matt

(Last edited by MattM on 12 Nov 2012, 16:11)

URGENT REQUEST FOR HELP

I've installed the sysupgrade mentioned in the thread.
Reason: i need lua aocket and can't get it work with the trunk version.
BUT: i can't connect the 703n to my wifi router.
PLZ could anyone help me either getting client mode working or tell me step by step hot to get lua socket to run.
Many thanks
PLZ PM me..

zeniitti wrote:

Okey, thanks for the reply. I have played with unix/linux few years ago and don't have all the commands clear in my mind so bare with me. First step could be to lose the RJ45 cable and make 703n wireless.

I went to the internet and found this pre-compiled firmware. I think that it contains all the necessary modules for my use. What you guys think?

Standard (Download)

    This is the standard ‘hacker’ image with a suite of goodies built in
        Luci – for easy configuration and setting
        USB Video support
            mjpg-streamer for webcam streaming
        USB Serial support
            belkin, ch431, cp210x, ftdi, option, pl2303, ti-usb
            ser2net for easy serial to Ethernet conversion
            stty for configuring serial
        Lua for simple scripting
            lualibusb
            luasocket
        USB ACM Support for 3G modems and other devices
        USB Storage and network filesystems
            ext4, nfs, ntfs, vfat
            block-mount for mounting extroot pivot overlays (i.e. adding USB storage for installing programs)

Any quick guides how to make wireless to work?

EDIT: I've managed to get the wifi working and it streams nicely.

I don't know anything about lua but connecting to  a wireless network in client mode is easy.

Your network configuration file should look something like this:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'wan'
        option proto 'dhcp'

config interface 'lan'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option type 'bridge'

Then, better if you add something like this in the end of your dhcp config file:

config dhcp wan
    option interface    wan
    option ignore    1

config dhcp lan
    option interface    lan
    option start    100
    option limit    150
    option leasetime    12h
    option force '1'

In this way you will be able to connect to the 703n easily by using the ethernet port.

And finally your wireless configuration file can be something like this:

config wifi-device 'radio0'
        option type 'mac80211'
        option phy 'phy0'
        option hwmode '11ng'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option txpower '27'
        option country 'US'
        option channel '1'

config wifi-iface 'wificlient'
        option device 'radio0'
        option mode 'sta'
        option network 'wan'
        option encryption 'psk2'
        option ssid 'serving_wifi_ssid'
        option key 'serving_wifi_password'

You need to change the options "channel", "ssid", "encryption" and "key" to match the ones from the wireless network you want to connect to.

That should be all.

I notice the last items in the DHCP config file aren't in quotes. Does this matter?

denovo wrote:

I notice the last items in the DHCP config file aren't in quotes. Does this matter?

The quotes are optional unless you want to include spaces in the value for that option.

Ah - thanks!

Dear All,
I can not see the 3g modem setting in my interface, is there a possibilty to download a package or a backup from one link the active 3g modem.
Thank you

MattM wrote:

Hi All

I was in a rush (poor excuse!) and I updated my fresh 703N with the english bin file via the wireless connection and not static IP via ethernet. (Feeling very stupid).

Now I can't see my 703N on a wireless connection but it does pop up when plugged in via ethernet cable (but no web console via the 192.168.1.1 route).

Any ideas on how I bring it back to life? (step by step if possible) Thanks

EDIT: OpenWRT is alive and kicking but I can't load a new bin, please see below.

I have exactly the same problem, anybody knows how to correct it? I can't connect to 703N at 192.168.1.1, scanned the whole /24 block with nmap, nothing. The device doesn't seem to be bricked as it can get into failsafe mode by pressing the reset button just like it is mentioned in the wiki

Similar problem here.

Flashed a v1.6 device with latest factory image, all went well, but after reboot - no dice.
Failsafe mode works (wait until first flash, hold reset for 1 sec, led flashes quickly), but can not get a single ping on 192.168.1.1.

Any ideas?

i have noob problem big_smile
- i wanted to disable dhcp so i put it on static adress 192.168.1.2
-wifi disabled
-ssh and telnet not finding anything
-i put on win7 static ip with gateway 192.168.1.2
but the router doesn't react. any solution with reset button maybe to put it in default state mode or i should find my soldering station

(Last edited by fpopic on 4 Oct 2015, 11:06)

@fpopic--try putting it in failsafe mode by powercycling and pressing and releasing the reset button when the blue first flashes (after being on for some seconds).  If it starts flashing fast, you should be able to telnet into 192.168.1.1.  From there, run "mount_root".  Then you should be able to edit /etc/config/network to see if something is wrong with your configuration.

If you don't see anything wrong, post the network file here.

thanks smile
any updates about opkg files packages? are they accessible with opkg ?

wget: bad address 'downloads.openwrt.org'
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/attitude_adjustment/12.09-beta/ar71xx/generic/packages/Packages.gz, wget returned 1.

(Last edited by fpopic on 12 Feb 2013, 08:49)

That download was working for me yesterday.
Are you sure you have an internet connection?

i dont know cause i merged lan with openwrt network and put dsl gateway and enabled and started

/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start

but ping and other things aren't working i tried with wireless connections too but it isn't working it shows as connected but diagnostic tools for web aren't showing positive result .

Hi there, I've finally got around to messing with my WR703N after leaving it sitting in its box since October.

I have one question for now and that is is there any way of getting it to read the serial output via usb of an arduino with the stock (either trunk snapshot or attitude adjustment) image? Or are the firmwares published on nemik.net/madox.net the best options (given I don't want to be compiling my own image as I would then have a thousand other questions to ask).

Thanks, Tom

Just saw this kickstarter project for a custom WR703N battery called Sofa. Might save some people upgrading to mini-routers with batteries...

denovo wrote:

Just saw this kickstarter project for a custom WR703N battery called Sofa. Might save some people upgrading to mini-routers with batteries...

just contributed - hope it gets off the ground - looks like a very useful piece of kit!

Sorry, posts 951 to 950 are missing from our archive.