OpenWrt Forum Archive

Topic: mwan3; multi-wan policy routing (general topic)

The content of this topic has been archived between 22 May 2013 and 6 May 2018. Unfortunately there are posts – most likely complete pages – missing.

This is the version i am using

# opkg install mwan3
Package mwan3 (1.6-2) installed in root is up to date

Is this not the latest version for the CC stable release?

trumee wrote:

I get the following error on starting mwan3. Also, when the ADSL cable is pulled out and re-inserted the ADSL connection doesnt come back on. Any idea what could be wrong?

#mwan3 start
uci: Entry not found
uci: Entry not found
uci: Entry not found
uci: Entry not found

As mentioned in this thread before, it is probably not mwan3 that is causing this error, but upnp. When you start mwan3, all hotplug events are triggered. Try to disable upnp and try again.

Adze wrote:

As mentioned in this thread before, it is probably not mwan3 that is causing this error, but upnp. When you start mwan3, all hotplug events are triggered. Try to disable upnp and try again.

Thanks. After disabling the upnp, the errors have gone away.

Please can you clairify whether luci-app-mwan3 version 1.4-3 in CC r46746 is stable for day to day use? I have read some reports in this thread that there are bugs in that release so wanted to check. I dont want to install trunk version of the whole firmware but would rather update only luci-app-mwan3 if possible?

Thanks

After installing luci-app-mwan3 1.4-3 , the uci errors have come back. UPNP is disabled.

Thu Nov  5 06:19:54 2015 daemon.err uhttpd[1215]: uci: Entry not found
Thu Nov  5 06:19:54 2015 daemon.err uhttpd[1215]: uci: Entry not found
Thu Nov  5 06:22:14 2015 daemon.err uhttpd[1215]: uci: Entry not found
Thu Nov  5 06:22:14 2015 daemon.err uhttpd[1215]: uci: Entry not found
Thu Nov  5 06:22:16 2015 daemon.err uhttpd[1215]: uci: Entry not found
Thu Nov  5 06:22:16 2015 daemon.err uhttpd[1215]: uci: Entry not found
Thu Nov  5 06:22:30 2015 daemon.err uhttpd[1215]: uci: Entry not found
Thu Nov  5 06:22:30 2015 daemon.err uhttpd[1215]: uci: Entry not found
Thu Nov  5 06:22:30 2015 daemon.err uhttpd[1215]: uci: Entry not found
Thu Nov  5 06:22:30 2015 daemon.err uhttpd[1215]: uci: Entry not found

Any idea what is the source of this and how can these be removed?

I have a single failover wan_wan2 rule defined. How can i trigger a ddns update when wan2 becomes the active wan connection after failover?

(Last edited by trumee on 5 Nov 2015, 05:20)

Hi, Adze, thanks a lot for your wonderful job! With mwan3 I could access the whole world and your product was the main reason why I chose OpenWrt rather than other firmware.

In my city, the bandwidth provided by the biggest ISP is limited to ~100kbps if accessing overseas (well, funny thing is that if accessing domestic sites it is 100Mbps.) So I must use a smaller ISP with poor performance in general, however providing much better service if accessing overseas which is >10Mbps along with the big ISP.

My idea is to setup dualwan solution on OpenWrt, going thru small ISP if the destination IP is overseas as wan, and going thru big ISP while domestic as wan2. And mwan3 makes everything happen perfectly.

However, I found the destination IP configuration seemed to limit the number of IP address to around 300. And there are about over 7000 IP rules (in the format of aa.bb.cc.dd/xx) for domestic so I had to manually separate those 7000 into smaller group (less than 300 for each, so about 26 rules as total) rather than just copy-paste only one big group in the destination IP column. Is there any possible to release this limitation? I ask for this favor because the number of IP segment allocated to countries changes quite frequently. Maintaining 26 rules rather than 1 is always a consumption of time.

Thanks a lot in advance! btw, my mwan3 file size is about 92k bytes. Guess it is the biggest one in this forum? Haha!

(Last edited by muronghan on 24 Nov 2015, 05:25)

muronghan wrote:

However, I found the destination IP configuration seemed to limit the number of IP address to around 300. And there are about over 7000 IP rules (in the format of aa.bb.cc.dd/xx) for domestic so I had to manually separate those 7000 into smaller group (less than 300 for each, so about 26 rules as total) rather than just copy-paste only one big group in the destination IP column. Is there any possible to release this limitation? I ask for this favor because the number of IP segment allocated to countries changes quite frequently. Maintaining 26 rules rather than 1 is always a consumption of time.

Ipset is your friend. You can create rules with ipset instead of destination ip. This way you only need one mwan3 rule per ISP. More information:

http://www.linuxjournal.com/content/adv … ions-ipset

Hi

I've asked already for help regarding VPN interfaces and the setup worked on 12.09 but the same configuration fails in CC and trunk. mwan3 reports nothing, both wwan and vpn interface are down. I can connect only using VPN connection but not main connection at the same time on different virtual wifi interface (except if VPN is disconnected).

what to do?

Adze wrote:
muronghan wrote:

However, I found the destination IP configuration seemed to limit the number of IP address to around 300. And there are about over 7000 IP rules (in the format of aa.bb.cc.dd/xx) for domestic so I had to manually separate those 7000 into smaller group (less than 300 for each, so about 26 rules as total) rather than just copy-paste only one big group in the destination IP column. Is there any possible to release this limitation? I ask for this favor because the number of IP segment allocated to countries changes quite frequently. Maintaining 26 rules rather than 1 is always a consumption of time.

Ipset is your friend. You can create rules with ipset instead of destination ip. This way you only need one mwan3 rule per ISP. More information:

http://www.linuxjournal.com/content/adv … ions-ipset

Hi, Adze, is the ipset configuration like this? Given I want to have a.com, b.com,...z.com going thru wan2. And a local faster DNS server for them is 1.2.3.4 let's say.

First, I add one line at the end of /etc/dnsmasq.conf i.e. "conf-dir=/etc/dnsmasq.d"; and the second, I create a file so called gowan2.conf under /etc/dnsmasq.conf and edit it as following:

  server=/.a.com/1.2.3.4
  server=/.b.com/1.2.3.4
  ...
  server=/.z.com/1.2.3.4
  ipset=/.a.com/.b.com/.../.z.com/wan2list

And the third, I add one configuration in mwan:
  config rule 'gowan2'
    option sticky '1'
    option ipset 'wan2list'
    option use_policy 'wan2_wan'

Is that correct?

My dnsmasq knowledge only goes so far, but i would say yes, it is correct. However, remove the sticky option as it makes no sense in a fail-over policy.

Adze wrote:

My dnsmasq knowledge only goes so far, but i would say yes, it is correct. However, remove the sticky option as it makes no sense in a fail-over policy.

All right, my fault. sticky thing shall be removed. ..Thanks a lot for your reply. However, then it is the problem coming. When I have 10,000 domain name to put into ipset, the way you supposed to be correct could not work. Was 10,000 too many?

forgot to add these are the messages i got in diagnostics page:

Check IP rules

Missing both of the required interface IP rules

Check routing table

Missing required interface routing table 1
Missing required interface routing table 2

hotplug ifup/ifdown has no effect on connections.
systemlog shows: No MWAN systemlog history found/No detailed status information available

troubleshooting with masked MAC addresses

Software versions : 

OpenWrt - OpenWrt Designated Driver r47551
LuCI - git-15.325.46423-c478101

mwan3 - 2.0-0
mwan3-luci - 1.4-4

Output of "cat /etc/config/mwan3" : 

config interface 'l2tp'
    option enabled '1'
    option reliability '1'
    option count '1'
    option timeout '2'
    option interval '5'
    option down '3'
    option up '3'

config interface 'wwan'
    option enabled '1'
    option reliability '1'
    option count '1'
    option timeout '2'
    option interval '5'
    option down '3'
    option up '3'

config member 'l2tp_member'
    option interface 'l2tp'

config member 'wwan_member'
    option interface 'wwan'

config policy 'l2tp_only'
    list use_member 'l2tp_member'
    option last_resort 'blackhole'

config policy 'wwan_only'
    list use_member 'wwan_member'
    option last_resort 'blackhole'

config rule 'wlan0_1'
    option src_ip '192.168.5.0/24'
    option proto 'all'
    option sticky '0'
    option use_policy 'l2tp_only'

config rule 'wlan0_2'
    option src_ip '192.168.6.0/24'
    option proto 'all'
    option sticky '0'
    option use_policy 'wwan_only'

config rule 'wlan0_3'
    option src_ip '192.168.7.0/24'
    option proto 'all'
    option sticky '0'
    option use_policy 'l2tp_only'

config rule 'lan'
    option src_ip '192.168.4.0/24'
    option proto 'all'
    option sticky '0'
    option use_policy 'l2tp_only'

config rule 'wlan0_4'
    option src_ip '192.168.8.0/24'
    option proto 'all'
    option sticky '0'
    option use_policy 'blackhole'

Output of "cat /etc/config/network" : 

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option force_link '1'
    option macaddr 'xx:xx:xx:xx:xx:xx'
    option proto 'static'
    option netmask '255.255.255.0'
    option delegate '0'
    option _orig_ifname 'eth0.1 wlan0 wlan1'
    option _orig_bridge 'true'
    option ipaddr '192.168.4.1'
    option ifname 'eth0.1'

config interface 'wan'
    option ifname 'eth0.2'
    option force_link '1'
    option macaddr 'xx:xx:xx:xx:xx:xx'
    option proto 'dhcp'
    option delegate '0'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '4 6t'

config interface 'l2tp'
    option proto 'l2tp'
    option delegate '0'
    option metric '10'
    option server '131.12.114.2'
    USERNAME HIDDEN
    PASSWORD HIDDEN
    option auto '1'

config interface 'wlan0_1'
    option proto 'static'
    option ipaddr '192.168.5.1'
    option netmask '255.255.255.0'
    option delegate '0'
    option ifname 'wlan0'

config interface 'wlan0_2'
    option proto 'static'
    option delegate '0'
    option ipaddr '192.168.6.1'
    option netmask '255.255.255.0'
    option ifname 'wlan0-1'

config interface 'wlan0_3'
    option proto 'static'
    option ipaddr '192.168.7.1'
    option netmask '255.255.255.0'
    option delegate '0'
    option ifname 'wlan0-2'

config interface 'wwan'
    option _orig_ifname 'wlan2'
    option _orig_bridge 'false'
    option proto 'static'
    option ipaddr '192.168.0.42'
    option netmask '255.255.254.0'
    option gateway '192.168.0.1'
    option broadcast '192.168.1.255'
    option dns '208.67.222.222 208.67.220.220'
    option delegate '0'
    option metric '20'
    option auto '1'

config interface 'wlan0_4'
    option proto 'static'
    option delegate '0'
    option ipaddr '192.168.8.1'
    option netmask '255.255.255.0'
    option ifname 'wlan0-3'

Output of "ifconfig" : 

eth0      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:61012 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:21024162 (20.0 MiB)
          Interrupt:5 

eth0.1    Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          inet addr:192.168.4.1  Bcast:192.168.4.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0.2    Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:60698 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:20758716 (19.7 MiB)

l2tp-l2tp Link encap:Point-to-Point Protocol  
          inet addr:10.10.1.5  P-t-P:10.10.1.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1410  Metric:1
          RX packets:5314631 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9093226 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:1289292537 (1.2 GiB)  TX bytes:12008116178 (11.1 GiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:66792 errors:0 dropped:0 overruns:0 frame:0
          TX packets:66792 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:7084358 (6.7 MiB)  TX bytes:7084358 (6.7 MiB)

mon0      Link encap:UNSPEC  HWaddr E8-94-F6-2C-1F-A8-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST NOTRAILERS RUNNING PROMISC ALLMULTI  MTU:1500  Metric:1
          RX packets:15777055 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2620510671 (2.4 GiB)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          inet addr:192.168.5.1  Bcast:192.168.5.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:138906320 errors:0 dropped:0 overruns:0 frame:0
          TX packets:73286967 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:193081851392 (179.8 GiB)  TX bytes:9084616580 (8.4 GiB)

wlan0-1   Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          inet addr:192.168.6.1  Bcast:192.168.6.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5851858 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3491339 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8450006455 (7.8 GiB)  TX bytes:723819902 (690.2 MiB)

wlan0-2   Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          inet addr:192.168.7.1  Bcast:192.168.7.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2928178 errors:0 dropped:5868 overruns:0 frame:0
          TX packets:3898468 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:680164281 (648.6 MiB)  TX bytes:4340992467 (4.0 GiB)

wlan0-3   Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          inet addr:192.168.8.1  Bcast:192.168.8.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:360 (360.0 B)

wlan1     Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15134 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13130 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:11970095 (11.4 MiB)  TX bytes:9145190 (8.7 MiB)

wlan1-1   Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan1-2   Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:335 errors:0 dropped:117 overruns:0 frame:0
          TX packets:335 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:37000 (36.1 KiB)  TX bytes:43066 (42.0 KiB)

wlan1-3   Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan2     Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          inet addr:192.168.0.42  Bcast:192.168.1.255  Mask:255.255.254.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8879735 errors:0 dropped:14440 overruns:0 frame:0
          TX packets:14944377 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2239147203 (2.0 GiB)  TX bytes:21318800695 (19.8 GiB)

Output of "route -n" : 

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.10.1.1       0.0.0.0         UG    10     0        0 l2tp-l2tp
0.0.0.0         192.168.0.1     0.0.0.0         UG    20     0        0 wlan2
10.10.1.1       0.0.0.0         255.255.255.255 UH    0      0        0 l2tp-l2tp
131.12.114.2    192.168.0.1     255.255.255.255 UGH   20     0        0 wlan2
192.168.0.0     0.0.0.0         255.255.254.0   U     20     0        0 wlan2
192.168.4.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0.1
192.168.5.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0
192.168.6.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0-1
192.168.7.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0-2
192.168.8.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0-3

Output of "ip rule show" : 

0:    from all lookup 128 
1:    from all lookup local 
32766:    from all lookup main 
32767:    from all lookup default

Output of "ip route list table 1-250" : 

No data found

Firewall default output policy (must be ACCEPT) : 

ACCEPT

Output of "iptables -L -t mangle -v -n" : 

Chain PREROUTING (policy ACCEPT 20M packets, 15G bytes)
 pkts bytes target     prot opt in     out     source               destination         
  20M   15G fwmark     all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain INPUT (policy ACCEPT 5345K packets, 1506M bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain FORWARD (policy ACCEPT 14M packets, 13G bytes)
 pkts bytes target     prot opt in     out     source               destination         
  14M   13G mssfix     all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain OUTPUT (policy ACCEPT 9119K packets, 12G bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain POSTROUTING (policy ACCEPT 23M packets, 26G bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain fwmark (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain mssfix (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 TCPMSS     tcp  --  *      eth0.2  0.0.0.0/0            0.0.0.0/0            tcp flags:0x06/0x02 /* wan (mtu_fix) */ TCPMSS clamp to PMTU
  204  9496 TCPMSS     tcp  --  *      wlan2   0.0.0.0/0            0.0.0.0/0            tcp flags:0x06/0x02 /* wan (mtu_fix) */ TCPMSS clamp to PMTU
 6157  294K TCPMSS     tcp  --  *      l2tp-l2tp  0.0.0.0/0         0.0.0.0/0            tcp flags:0x06/0x02 /* vpn (mtu_fix) */ TCPMSS clamp to PMTU

Hi anarchy99,


You are running the brand new (possibly buggy) v2.0 version. Lets find out whats wrong...

It looks like mwan3 has not even started. There are no rules, no routes and no iptables or whatsoever configered. Could you try the following:

chmod 755 /etc/hotplug.d/iface/15-mwan3
ACTION=ifup DEVICE=wlan2 INTERFACE=wwan /etc/hotplug.d/iface/15-mwan3
echo $?

what number do you get?

(Last edited by Adze on 27 Nov 2015, 16:52)

it returns number 7. does the mwan3 appear in processes list once its started?

As of version 2.0, mwan3 has exit codes. The following errors are known:

1: ACTION is not "ïfup" or "ifdown"
2: INTERFACE not set
3: DEVICE not set
4: ip not found
5: ipset not found
6: iptables not found
7: ip6tables not found
8: logger not found

(Last edited by Adze on 27 Nov 2015, 23:22)

anarchy99 wrote:

it returns number 7. does the mwan3 appear in processes list once its started?

mwan3 process does not remain in process list. It exits after tables and rules are set.

Error 7 means that ip6tables is not found. If you dont use ipv6 that would not be a problem. So consider it a bug. Please comment out line 13 in "/etc/init.d/hotplug.d/iface/15-mwan3. Also comment out line 6 in "/usr/sbin/mwan3". And try again please.

Thnx

(Last edited by Adze on 27 Nov 2015, 23:28)

it works. interfaces are accessible as expected. only ip6 errors remain in log, any way to remove them?

Last 50 MWAN systemlog entries. Newest entries sorted at the top :

Sat Nov 28 03:14:06 2015 daemon.err uhttpd[4893]: /usr/sbin/mwan3: line 1: /usr/sbin/ip6tables: not found
Sat Nov 28 03:14:01 2015 daemon.err uhttpd[4893]: /usr/sbin/mwan3: line 1: /usr/sbin/ip6tables: not found
Sat Nov 28 03:13:56 2015 daemon.err uhttpd[4893]: /usr/sbin/mwan3: line 1: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 1: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 1: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:16 2015 user.notice mwan3: ifup interface wwan (wlan2)
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 1: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 1: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:14 2015 daemon.err uhttpd[4893]: /sbin/hotplug-call: /etc/hotplug.d/iface/15-mwan3: line 45: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:13 2015 user.notice mwan3: ifup interface l2tp (l2tp-l2tp)
Sat Nov 28 03:12:11 2015 daemon.err uhttpd[4893]: /usr/sbin/mwan3: line 174: /usr/sbin/ip6tables: not found
Sat Nov 28 03:12:11 2015 daemon.err uhttpd[4893]: /usr/sbin/mwan3: line 174: /usr/sbin/ip6tables: not found
Sat Nov 28 02:54:40 2015 daemon.err uhttpd[4893]: /usr/sbin/mwan3: line 1: /usr/sbin/ip6tables: not found
Sat Nov 28 02:54:35 2015 daemon.err uhttpd[4893]: /usr/sbin/mwan3: line 1: /usr/sbin/ip6tables: not found
Adze wrote:
muronghan wrote:

However, I found the destination IP configuration seemed to limit the number of IP address to around 300. And there are about over 7000 IP rules (in the format of aa.bb.cc.dd/xx) for domestic so I had to manually separate those 7000 into smaller group (less than 300 for each, so about 26 rules as total) rather than just copy-paste only one big group in the destination IP column. Is there any possible to release this limitation? I ask for this favor because the number of IP segment allocated to countries changes quite frequently. Maintaining 26 rules rather than 1 is always a consumption of time.

Ipset is your friend. You can create rules with ipset instead of destination ip. This way you only need one mwan3 rule per ISP. More information:

http://www.linuxjournal.com/content/adv … ions-ipset

Hi, Adze, I put those thousands of CIDR things into /etc/rc.local as following:

ipset create gotowan2 hash:net hashsize 8192
ipset add gotowan2 1.1.0.0/24
ipset add gotowan2 1.1.2.0/23
ipset add gotowan2 1.1.4.0/22
ipset add gotowan2 1.1.8.0/21
...... (skip 5000+ CIDR)
exit 0

Add one rule with gotowan2 ipset into /etc/config/mwan3. Reboot the router and it works. Is that what you advised? Thanks a lot!

HI ADZE... Just wondering.... Mwan3 is compatible with HNET-FULL is a homenet packages that include babeld....

The last time I test mwan3 with babeld  I like it both, it does some kind of homing it adds bandwidth from the ISPs interfaces. Giving me 20mbps down and 5 mbps up


Then I install hnet-full with babeld without mwan3 but seems no homing, it appears that it uses only one ISP of 3 availables instead of 3 as used to with mwan3 babeld... Giving 7 mbps down 1.5 mbps up

Any experience, comment with Hnet-full?  Why with mwan3 does homing. Thanks

(Last edited by inquba on 30 Nov 2015, 16:54)

Hi

I installed mwan3 with OpenWrt Chaos Calmer 15.05 / LuCI (git-15.248.30277-3836b45) on a TP-LINK WDR3600.

My first problem is that I get the following error messages at the "MWAN Interface Configuration":
There are currently 2 of 250 supported interfaces configured
WARNING: some interfaces have no default route in the main routing table!
WARNING: some interfaces are configured incorrectly or not at all in /etc/config/network!
WARNING: some interfaces have no metric configured in /etc/config/network!

Second, I find it difficult to follow this manual: https://wiki.openwrt.org/doc/howto/mwan3
For example I did not find anything on how to give priority to voip traffic.

Can you recommend a simple guide to setup mwan3?  Preferably from LUCI ?

Hi

About the Warning messages, I did find a related post with a solution here: 
https://forum.openwrt.org/viewtopic.php … 38#p230638

However my setting in the file /etc/config/network are different, so I could not follow the suggested solution:

config interface 'wan'
    option ifname 'eth0.2'
    option _orig_ifname 'eth0.2'
    option _orig_bridge 'false'
    option proto 'pppoe'

config interface 'WAN2'
    option ifname 'eth0.3'
    option _orig_ifname 'eth0.3'
    option _orig_bridge 'false'
    option proto 'pppoe'

(Last edited by bobptz on 10 Dec 2015, 08:20)

bobptz wrote:

Hi

I installed mwan3 with OpenWrt Chaos Calmer 15.05 / LuCI (git-15.248.30277-3836b45) on a TP-LINK WDR3600.

My first problem is that I get the following error messages at the "MWAN Interface Configuration":
There are currently 2 of 250 supported interfaces configured
WARNING: some interfaces have no default route in the main routing table!
WARNING: some interfaces are configured incorrectly or not at all in /etc/config/network!
WARNING: some interfaces have no metric configured in /etc/config/network!

Second, I find it difficult to follow this manual: https://wiki.openwrt.org/doc/howto/mwan3
For example I did not find anything on how to give priority to voip traffic.

Can you recommend a simple guide to setup mwan3?  Preferably from LUCI ?

Could you please post your current network setup and mwan3 setup? Maybe i can help...

As to your question about giving priority to VoIP traffic, that can be done with QoS packages, not with mwan3.

(Last edited by Adze on 10 Dec 2015, 10:42)

Hello Adze

For some reason WAN2 is always OFFLINE.  Funny thing is when I connect the modem to the WAN2 port, I can have internet access.  I set WAN to disabled and when I connect the WAN port to the modem, again I have internet access.  (I setup WAN and WAN2, but I only have ONE modem running right now).

You asked me to post my network and mwan3 setup.  I am not exactly sure what you mean, here is some info I could gather:


This is the MWAN detailed status:

Interface status:
 interface wan is online (tracking active)
 interface wan2 is unknown

Policy balanced:
 wan (100%)

Policy wan2_only:
 unreachable

Policy wan2_wan:
 wan (100%)

Policy wan_only:
 wan (100%)

Policy wan_wan2:
 wan (100%)

Known networks:
 2.85.239.153
 192.168.1.0
 127.0.0.1
 127.0.0.0
 224.0.0.0/3
 127.255.255.255
 80.106.108.74
 127.0.0.0/8
 192.168.1.1
 192.168.1.0/24
 192.168.1.255

Active rules:
    0     0 S youtube  tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            match-set youtube dst multiport sports 0:65535 multiport dports 80,443 
  458 34992 S https  tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport sports 0:65535 multiport dports 443 
  658 43759 - balanced  all  --  *      *       0.0.0.0/0            0.0.0.0/0

This is the "Trouble shooting data":

Software versions : 

OpenWrt - OpenWrt Chaos Calmer 15.05
LuCI - git-15.248.30277-3836b45

mwan3 - 1.6-2
mwan3-luci - 1.4-3

Output of "cat /etc/config/mwan3" : 

config interface 'wan'
    list track_ip '8.8.4.4'
    list track_ip '8.8.8.8'
    list track_ip '208.67.222.222'
    list track_ip '208.67.220.220'
    option reliability '2'
    option count '1'
    option timeout '2'
    option interval '5'
    option down '3'
    option up '8'
    option enabled '1'

config interface 'wan2'
    list track_ip '8.8.8.8'
    list track_ip '208.67.220.220'
    option reliability '1'
    option count '1'
    option timeout '2'
    option interval '5'
    option down '3'
    option up '8'
    option enabled '1'

config member 'wan_m1_w3'
    option interface 'wan'
    option metric '1'
    option weight '3'

config member 'wan_m2_w3'
    option interface 'wan'
    option metric '2'
    option weight '3'

config member 'wan2_m1_w2'
    option interface 'wan2'
    option metric '1'
    option weight '2'

config member 'wan2_m2_w2'
    option interface 'wan2'
    option metric '2'
    option weight '2'

config policy 'wan_only'
    list use_member 'wan_m1_w3'

config policy 'wan2_only'
    list use_member 'wan2_m1_w2'

config policy 'balanced'
    list use_member 'wan_m1_w3'
    list use_member 'wan2_m1_w2'

config policy 'wan_wan2'
    list use_member 'wan_m1_w3'
    list use_member 'wan2_m2_w2'

config policy 'wan2_wan'
    list use_member 'wan_m2_w3'
    list use_member 'wan2_m1_w2'

config rule 'youtube'
    option sticky '1'
    option ipset 'youtube'
    option dest_port '80,443'
    option proto 'tcp'
    option use_policy 'balanced'

config rule 'https'
    option sticky '1'
    option dest_port '443'
    option proto 'tcp'
    option use_policy 'balanced'

config rule 'default_rule'
    option dest_ip '0.0.0.0/0'
    option use_policy 'balanced'

Output of "cat /etc/config/network" : 

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdf7:1a7c:a459::/48'

config interface 'lan'
    option ifname 'eth0.1'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'eth0.2'
    option _orig_ifname 'eth0.2'
    option _orig_bridge 'false'
    option proto 'pppoe'
    USERNAME HIDDEN
    PASSWORD HIDDEN
    option metric '10'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option mirror_source_port '0'
    option mirror_monitor_port '0'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option ports '0t 3 4 5'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '0t 1'
    option vid '2'

config switch_vlan
    option device 'switch0'
    option vlan '3'
    option vid '3'
    option ports '0t 2'

config interface 'WAN2'
    option ifname 'eth0.3'
    option _orig_ifname 'eth0.3'
    option _orig_bridge 'false'
    option proto 'pppoe'
    USERNAME HIDDEN
    PASSWORD HIDDEN
    option metric '20'

Output of "ifconfig" : 

br-lan    Link encap:Ethernet  HWaddr 14:CC:20:BA:5D:2A  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fdf7:1a7c:a459::1/60 Scope:Global
          inet6 addr: fe80::16cc:20ff:feba:5d2a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:21761 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23891 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2709897 (2.5 MiB)  TX bytes:17254312 (16.4 MiB)

eth0      Link encap:Ethernet  HWaddr 14:CC:20:BA:5D:2A  
          inet6 addr: fe80::16cc:20ff:feba:5d2a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:46107 errors:0 dropped:0 overruns:0 frame:0
          TX packets:47671 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:20013318 (19.0 MiB)  TX bytes:20241755 (19.3 MiB)
          Interrupt:4 

eth0.1    Link encap:Ethernet  HWaddr 14:CC:20:BA:5D:2A  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:19728 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22020 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2430301 (2.3 MiB)  TX bytes:16830842 (16.0 MiB)

eth0.2    Link encap:Ethernet  HWaddr 14:CC:20:BA:5D:2A  
          inet6 addr: fe80::16cc:20ff:feba:5d2a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:26379 errors:0 dropped:59 overruns:0 frame:0
          TX packets:23983 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:16753091 (15.9 MiB)  TX bytes:3084867 (2.9 MiB)

eth0.3    Link encap:Ethernet  HWaddr 14:CC:20:BA:5D:2A  
          inet6 addr: fe80::16cc:20ff:feba:5d2a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:786 (786.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:22 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1995 (1.9 KiB)  TX bytes:1995 (1.9 KiB)

pppoe-wan Link encap:Point-to-Point Protocol  
          inet addr:2.85.239.153  P-t-P:80.106.108.74  Mask:255.255.255.255
          inet6 addr: fe80::94d:b15a:64a7:23aa/10 Scope:Link
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:23681 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21342 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:16435318 (15.6 MiB)  TX bytes:2535520 (2.4 MiB)

wlan0     Link encap:Ethernet  HWaddr 14:CC:20:BA:5D:2B  
          inet6 addr: fe80::16cc:20ff:feba:5d2b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2452 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3471 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:359752 (351.3 KiB)  TX bytes:658152 (642.7 KiB)

Output of "route -n" : 

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         80.106.108.74   0.0.0.0         UG    10     0        0 pppoe-wan
80.106.108.74   0.0.0.0         255.255.255.255 UH    0      0        0 pppoe-wan
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan

Output of "ip rule show" : 

0:    from all lookup 128 
1:    from all lookup local 
1001:    from all iif pppoe-wan lookup main 
2001:    from all fwmark 0x100/0xff00 lookup 1 
2253:    from all fwmark 0xfd00/0xff00 blackhole
2254:    from all fwmark 0xfe00/0xff00 unreachable
32766:    from all lookup main 
32767:    from all lookup default

Output of "ip route list table 1-250" : 

1
default via 80.106.108.74 dev pppoe-wan

Firewall default output policy (must be ACCEPT) : 

ACCEPT

Output of "iptables -L -t mangle -v -n" : 

Chain PREROUTING (policy ACCEPT 45030 packets, 19M bytes)
 pkts bytes target     prot opt in     out     source               destination         
45034   19M mwan3_hook  all  --  *      *       0.0.0.0/0            0.0.0.0/0           
45030   19M fwmark     all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain INPUT (policy ACCEPT 6006 packets, 437K bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain FORWARD (policy ACCEPT 38828 packets, 19M bytes)
 pkts bytes target     prot opt in     out     source               destination         
38828   19M mssfix     all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain OUTPUT (policy ACCEPT 5925 packets, 849K bytes)
 pkts bytes target     prot opt in     out     source               destination         
 5929  849K mwan3_hook  all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain POSTROUTING (policy ACCEPT 44753 packets, 19M bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain fwmark (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain mssfix (1 references)
 pkts bytes target     prot opt in     out     source               destination         
  764 45840 TCPMSS     tcp  --  *      pppoe-wan  0.0.0.0/0            0.0.0.0/0            tcp flags:0x06/0x02 /* wan (mtu_fix) */ TCPMSS clamp to PMTU
    0     0 TCPMSS     tcp  --  *      eth0.3  0.0.0.0/0            0.0.0.0/0            tcp flags:0x06/0x02 /* wan (mtu_fix) */ TCPMSS clamp to PMTU

Chain mwan3_connected (2 references)
 pkts bytes target     prot opt in     out     source               destination         
23391   17M MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            match-set mwan3_connected dst MARK or 0xff00

Chain mwan3_hook (2 references)
 pkts bytes target     prot opt in     out     source               destination         
50963   20M CONNMARK   all  --  *      *       0.0.0.0/0            0.0.0.0/0            CONNMARK restore mask 0xff00
 5172  294K mwan3_ifaces  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
 5154  293K mwan3_connected  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
 3537  172K mwan3_track  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
 1609  110K mwan3_rules  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
50963   20M CONNMARK   all  --  *      *       0.0.0.0/0            0.0.0.0/0            CONNMARK save mask 0xff00
41222   19M mwan3_connected  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match ! 0xff00/0xff00

Chain mwan3_iface_wan (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  pppoe-wan *       0.0.0.0/0            0.0.0.0/0            match-set mwan3_connected src mark match 0x0/0xff00 /* default */ MARK or 0xff00
   18  1618 MARK       all  --  pppoe-wan *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wan */ MARK xset 0x100/0xff00

Chain mwan3_ifaces (1 references)
 pkts bytes target     prot opt in     out     source               destination         
 5172  294K mwan3_iface_wan  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00

Chain mwan3_policy_balanced (3 references)
 pkts bytes target     prot opt in     out     source               destination         
 1026 67620 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wan 3 3 */ MARK xset 0x100/0xff00

Chain mwan3_policy_wan2_only (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* unreachable */ MARK xset 0xfe00/0xff00

Chain mwan3_policy_wan2_wan (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wan 3 3 */ MARK xset 0x100/0xff00

Chain mwan3_policy_wan_only (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wan 3 3 */ MARK xset 0x100/0xff00

Chain mwan3_policy_wan_wan2 (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wan 3 3 */ MARK xset 0x100/0xff00

Chain mwan3_rule_https (1 references)
 pkts bytes target     prot opt in     out     source               destination         
  589 42944 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 MARK xset 0x100/0xff00
    6   406 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            ! match-set mwan3_sticky_https src,src MARK and 0xffff00ff
    6   406 mwan3_policy_balanced  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
  589 42944 SET        all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match ! 0xfc00/0xfc00 del-set mwan3_sticky_https src,src
  589 42944 SET        all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match ! 0xfc00/0xfc00 add-set mwan3_sticky_https src,src

Chain mwan3_rule_youtube (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 MARK xset 0x100/0xff00
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            ! match-set mwan3_sticky_youtube src,src MARK and 0xffff00ff
    0     0 mwan3_policy_balanced  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
    0     0 SET        all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match ! 0xfc00/0xfc00 del-set mwan3_sticky_youtube src,src
    0     0 SET        all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match ! 0xfc00/0xfc00 add-set mwan3_sticky_youtube src,src

Chain mwan3_rules (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 mwan3_rule_youtube  tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            match-set youtube dst multiport sports 0:65535 multiport dports 80,443 mark match 0x0/0xff00 /* youtube */
  589 42944 mwan3_rule_https  tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport sports 0:65535 multiport dports 443 mark match 0x0/0xff00 /* https */
 1020 67214 mwan3_policy_balanced  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* default_rule */

Chain mwan3_track (1 references)
 pkts bytes target     prot opt in     out     source               destination         
 1928 61696 MARK       icmp --  *      *       0.0.0.0/0            0.0.0.0/0            match-set mwan3_track_wan dst icmptype 8 length 32 MARK or 0xff00

This is from Network Config:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdf7:1a7c:a459::/48'

config interface 'lan'
    option ifname 'eth0.1'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'eth0.2'
    option _orig_ifname 'eth0.2'
    option _orig_bridge 'false'
    option proto 'pppoe'
    option username 'o9ke4b@otenet.gr'
    option password 'rty8-4l'
    option metric '10'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option mirror_source_port '0'
    option mirror_monitor_port '0'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option ports '0t 3 4 5'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '0t 1'
    option vid '2'

config switch_vlan
    option device 'switch0'
    option vlan '3'
    option vid '3'
    option ports '0t 2'

config interface 'WAN2'
    option ifname 'eth0.3'
    option _orig_ifname 'eth0.3'
    option _orig_bridge 'false'
    option proto 'pppoe'
    option username 'o9ke4b@otenet.gr'
    option password 'rty8-4l'
    option metric '20'

Just in case, here is the IFCONFIG from my pc (I am using ubuntu 14.04):

$ ifconfig
eth2      Link encap:Ethernet  HWaddr d0:50:99:4b:7a:b7  
          inet addr:192.168.1.215  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::d250:99ff:fe4b:7ab7/64 Scope:Link
          inet6 addr: fdf7:1a7c:a459:0:d250:99ff:fe4b:7ab7/64 Scope:Global
          inet6 addr: fdf7:1a7c:a459:0:3560:99c8:bff9:148a/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:116407 errors:0 dropped:0 overruns:0 frame:0
          TX packets:79660 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:146480442 (146.4 MB)  TX bytes:8814148 (8.8 MB)
          Interrupt:20 Memory:f7c00000-f7c20000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3958 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3958 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:406723 (406.7 KB)  TX bytes:406723 (406.7 KB)

Also, this is from main menu -> status -> routes:

Active IPv4-Routes
Network     Target     IPv4-Gateway     Metric     Table
wan     0.0.0.0/0     80.106.108.74     0     1
wan     0.0.0.0/0     80.106.108.74     10     main
wan     80.106.108.74         0     main
lan     192.168.1.0/24         0     main

It certainly does not look right.  How come I do not see WAN2? 

Does this help you?  Please tell me what else you need.

(Last edited by bobptz on 12 Dec 2015, 02:53)

I made a couple of changes in the Firewall settings suggested in a forum.  WAN2 still shows Offline even though I have plugged the modem from WAN to WAN2 and I do have internet working, I can browse pages.

Maybe this diagnostic result helps?
Unable to perform diagnostic tests on wan2. There is no physical or virtual device associated with this interface

Why do I get this?

(Last edited by bobptz on 12 Dec 2015, 23:35)