OpenWrt Forum Archive

Topic: dead after flashing wr703n

The content of this topic has been archived between 14 Feb 2014 and 3 May 2018. Unfortunately there are posts – most likely complete pages – missing.

You can set up wifi.  Check the wiki.  Or you can plug the device into your router--making sure IPs are compatible.

If AA 12.09 has luci, sysupgrade is all you need.

halfdome wrote:

Which one should I use?

my zip is now USELESS because lastest AA 12.09 images from downloads.openwrt will work!

(Last edited by nebbia88 on 26 Apr 2013, 13:40)

Unfortunately I must have flashed a broken file or somehow something in the process messed my device up.

Now I cannot connect to the router via LAN (I even cannot find it with IP scan), also no WLAN.

So I built the serial port following this page
http://forums.openpilot.org/blog/52/ent … fi-router/
Now I can watch the router boot, but the "tpl" command does seem to work for me - that is I don't get the "hornet>" / uboot console mode.


HOWEVER:
I get the regular console "root@(none):" and can enter commands there. So following
http://wiki.openwrt.org/doc/uci/wireless
I was abled to turn WLAN on with the command
"uci set wireless.@wifi-device[0].disabled=0; uci commit wireless; wifi" in /etc/config/wireless.

Then I can access the router with telnet over WLAN. I flashed the new squashfs-factory image (with wget in the console). But after reboot I am back at the beginning of this post. The same happens when flashing the squashfs-sysupgrade file.

Any ideas or suggestions?

Did you try logging in with telnet?  That's necessary after first flashing (except with sysupgrade--unless you didn't set a password the first time).  Then set a password with "passwd".  Then reboot and you should be able to log in with ssh.

Telnet via LAN
-not possible (neither static IP [192.168.1.100] nor DHCP (no IP is handed out, I end up with 169.254.xxx.yyy)

Telnet via WLAN:
-possible, after turning WLAN on via serial console.
-I canged / created passwd
-LuCi login via Browser worked, I uploaded new firmware and unchecked "keep settings"

#update#
I need to correct my previous statement "but after reboot I am back at the beginning: No LAN / WLAN"
This was wrong.

Now after a reboot, the router starts WLAN and acts as access point, login via LuCI (and previous stored password) works.

ONLY the connection via ethernet is still dead.
Any command how to turn it on?

(Last edited by halfdome on 1 May 2013, 20:36)

what image you flashed specifically? what release (r36xxx) you see in cli..

If you have access through the serial console, you should be able to make whatever changes you need to the configuration files using the "vi" editor:  /etc/config/network and /etc/config/wireless

If you have questions, post the contents of those files.

(Last edited by lizby on 1 May 2013, 21:08)

Image used for flashing: http://downloads.openwrt.org/attitude_a … pgrade.bin but before the ...factory was installed
Trunk 9220



But I guess, my previous edit was too fast.
Now the router does not remember to turn WLAN on after power off / power on.
When booting up the serial port says
...
"switching to jffs2"
"- init -"
"Kernel panic - not syncing: Attempted to kill init!"
Then the device is unresponsive (while LED flashes with 2Hz).

If I power down / up again and press the reset button as soon as the LED starts flashing (~after 10s),
I get to the console where it says


"ATTITUDE ADJUSTMENT (12.09-beta, r33312)"

The complete printout (shorted for some scrambled text in the beginning) is below.


When I look for the files in /etc/config, I only find "dhcp dropbear  firewall  luci  system ucitrack uhttpd"
But not the "wireless network" files.
At this point I am clueless about how the files vanished - at least the wireless was there earlier!



##############################
##############################
##############################
#Console readout


½Étó    JIE³+ÉingY+ÉlåÖ¨Û 0ò0ÂÂva²N¦uuX.t´^
ájµIÏÂÅ80²(irqO¢ is X
Éå33X UART

[    0.470000] console [ttyATH0] enabled, bootconsole disabled

[    0.470000] console [ttyATH0] enabled, bootconsole disabled

[    0.480000] m25p80 spi0.0: found en25q32b, expected m25p80

[    0.480000] m25p80 spi0.0: en25q32b (4096 Kbytes)

[    0.490000] 5 tp-link partitions found on MTD device spi0.0

[    0.490000] Creating 5 MTD partitions on "spi0.0":

[    0.500000] 0x000000000000-0x000000020000 : "u-boot"

[    0.510000] 0x000000020000-0x000000108374 : "kernel"

[    0.510000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only

[    0.520000] 0x000000108374-0x0000003f0000 : "rootfs"

[    0.530000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only

[    0.540000] mtd: partation "rootfs" set to be root filesystem

[    0.450000] mtd: partition "rootfs_data" created automatically, ofs=2D0000, len=120000

[    0.550000] 0x0000002d0000-0x0000003f0000 : "rootfs_data"

[    0.560000] 0x0000003f0000-0x000000400000 : "art"

[    0.570000] 0x000000020000-0x0000003f0000 : "firmware"

[    0.590000] ag71xx_mdio: probed

[    0.600000] eth0: Atheros AG71xx at 0xb9000000, irq 4

[    1.150000] ag71xx ag71xx.0: eth0: connected to PHY at ag71xx-mdio.1:04 [uid=004dd041, driver=Generic PHY]

[    1.160000] TCP cubic registered

[    1.160000] NET: Registered protocol family 17

[    1.170000] 8021q: 802.1Q VLAN Support v1.8

PuTTYPuTTYPuTTYPu[    1.170000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.

[    1.180000] Freeing unused kernel memory: 208k freed

- ppeinit -

Press the [f] key and hit [enter] to enter failsafe mode

- failsafe -





BusyBox v1.19.4 (2012-08-26 12:49:54 UTC) built-in shell (ash)

Enter 'help' for a list of built-in commands.



  _______                     ________        __

|       |.-----.-----.-----.|  |  |  |.----.|  |_

|   -   ||  _  |  -__|     ||  |  |  ||   _||   _|

|_______||   __|_____|__|__||________||__|  |____|

          |__| W I R E L E S S   F R E E D O M

-----------------------------------------------------

ATTITUDE ADJUSTMENT (12.09-beta, r33312)

-----------------------------------------------------

  * 1/4 oz Vodka      Pour all ingredients into mixing

  * 1/4 oz Gin        tin with ice, strain into glass.

  * 1/4 oz Amaretto

  * 1/4 oz Triple sec

  * 1/4 oz Peach schnapps

  * 1/4 oz Sour mix

  * 1 splash Cranberry juice

-----------------------------------------------------

root@(none):/# PuTTYPuTTYPuTTYPu

(Last edited by halfdome on 1 May 2013, 22:17)

update to aa rc2 !!!

That probably would have saved me a lot of trouble right from the beginning, unfortunately I am  stuck now:

So at this point I have to figure out, how to get the image on the router, because I can only start it somehow accessible  with the reset button - and without either LAN or WLAN I don't know how to upload the image.

Is there a way to transfer the bin file via serial cable?

(Last edited by halfdome on 1 May 2013, 22:40)

it seems you are getting into failsafe mode.
Try typing: firstboot
This does assume you loaded a squashfs system!

So after restart - push reset button - console - command "firstboot"

I get
"""
[   41.570000] JFFS2 notice: (446) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found."""

This seems to be jffs2 filesystem but I do not recall installing any of the jffs2 images!

no it seems ok!
you should be able to enable wifi, and transfer image with that..

How can I turn on wifi without the "wireless" file in etc/config?

If just this file is needed, can someone provide it for me / send me a link for the file so that I can type the content via serial port?

If the alternative -creating the necessary files for LAN- is easier, I could try this approach also. Which files would I have to create / edit for this?

(Last edited by halfdome on 2 May 2013, 10:44)

wifi detect > /etc/config/wireless

???

i thought that out of failsafe mode the standard config files were there...

no way to enable ethernet afaik...

(Last edited by nebbia88 on 2 May 2013, 18:46)

nebbia88 wrote:

Maybe it's simpler to enable wifi and connect to it...

Just

uci set wireless.@wifi-device[0].disabled=0; uci commit wireless; wifi

Just wanted to throw in my thanks for this.  After getting into the TTY just by holding the TX/RX wires to the pads (no soldering) and pasting this command, I was able to flash the working firmware (http://downloads.openwrt.org/attitude_a … actory.bin) over WiFi with the standard OpenWRT web GUI and both eth0 and wlan0 worked at powerup.

(Last edited by EkriirkE on 1 Jun 2013, 11:41)

great wink

it's even simpler cause you just need gnd and tx to send commands, and gnd could be easilly not needed if you use the same usb hub for both the 703 usb power cable and the usb to ttl adapter wink

so one hand to hold the wire and the other to paste command xD

Hi guys! I just bought a wr703n which has Build 120925 (so v 1.7).
Can you confirm that the latest openwrt AA 12.09 works for this version?
I am, of course, still with the chinese web interface.
Thanks!

Hello,

it seems that I too have the new firmware version of the TL-WR703N.

The sticker says Ver:1.6

The Chinese web-interface says :

3.14.4 Build-121204 Rel.41020n

and U-Boot is also a new version:

root@OpenWrt:~# grep -a U-Boot /dev/mtd0ro | cut -d'I' -f1
U-Boot 1.1.4 (Dec  4 2012 - 11:19:44)

I have just flash the AA factory image and everything seems to work.

regards
Mx

FYI, I also just received a WR703N (bought last month from dx) with a newer firmware revision. I flashed it with the Attitude Adjustment image (RELEASE=12.09, REVISION=r36088) and everything seems to work fine.

My device had the following version numbers:

label on case says 1.6

sticker on enet jack says:
TL-WR703N 1.6
134208

chinese web interface says:
当前软件版本:    3.14.5 Build 130318 Rel.64321n
当前硬件版本:     WR703N v1 00000000

and grepping the U-Boot version from /dev/mtd0ro says:
U-Boot 1.1.4 (Mar 18 2013 - 17:36:29)

FYI, I got a WR703N from DX too, 3three months ago.

Webinterface says:

当前软件版本:   
3.14.4 Build 121204 Rel.41020n
当前硬件版本:    
WR703N v1 00000000

Label on case:
SN 131288072xx Ver.1.6

root@OpenWrt:/#  grep -a U-Boot /dev/mtd0ro | cut -d'I' -f1
U-Boot 1.1.4 (Dec  4 2012 - 11:19:44)

BRICKED with attitude_adjustment/12.09-rc1.
FAILED to recover via serial with attitude_adjustment/12.09.
SUCCESSFUL recoverd via serial with snapshots/trunk, at the moment:  BARRIER BREAKER (Bleeding Edge, r37374)


An other WR703N from the same delivery:

Label on case:
S/N 131288075xx Ver:1.6

Webinterface:
当前软件版本:   
3.14.4 Build 121204 Rel.41020n
当前硬件版本:    
WR703N v1 00000000


SUCESSFUL updated to OpenWrt via webinterface with snapshots/trunk, at the moment:  BARRIER BREAKER (Bleeding Edge, r37374)

Maybe someone searches for this Build number and direct use the right version ;)

regards

really strange that 12.09 final does not work! have you tried a sysupgrade now? you can alwayse recover it if you still have serial console access...

Thanks nebbia88!

After some issues with the new block mount command / extroot, I'm happy that AA after a sysupgrade sucessfuly is running.

for all lazy guys here the cmds to copy and paste:

cd /tmp
root@OpenWrt:/tmp#wget http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/md5sums
root@OpenWrt:/tmp#wget http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-sysupgrade.bin
root@OpenWrt:/tmp# md5sum -c md5sums 2> /dev/null | grep OK
openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-sysupgrade.bin: OK
root@OpenWrt:/tmp# sysupgrade -v  openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-s
ysupgrade.bin 

(wait here, then adjust network config)
root@OpenWrt:/# ping 192.168.2.1
PING 192.168.2.1 (192.168.2.1): 56 data bytes
64 bytes from 192.168.2.1: seq=0 ttl=64 time=1.223 ms
64 bytes from 192.168.2.1: seq=1 ttl=64 time=0.577 ms

I will try to flash another WR703N with the AA via webinterface to recheck my first posting.