OpenWrt Forum Archive

Topic: The TP-Link's New WR703-MR10U

The content of this topic has been archived between 6 Feb 2018 and 5 May 2018. Unfortunately there are posts – most likely complete pages – missing.

usually packages for 3g fits in 4mb flash, are you sure you did not install something else?

Hi!

Thanks to slboat's nice offer on ebay I have a modded mr10u ("mr10n") now.

It came with 16MB flash, 64MB ram, OpenWrt and worked great. And it was in English (have seen some older posts that talked about chinese UI).

It worked until I found that I can't install addtl. packages due to some version mismatch and decided to flash my own OpenWrt build (made with packagebuilder, after modding it for 16MB flash). I wanted usb storage support and to play with some other packages.

(BTW, slboat: I had to modify the URL where it gets the packages from, because the one in there didn't have a Packages file)

But somehow it didn't end well, I now just get a extreme primitive "Failsafe UI" (likely from the bootloader) with a file select and submit button.

It does not even say what one is seeing (like "u.boot vX.X" or so?) nor what exactly one should upload there... (like which image, which file format), but I tried with original firmware file from tplink china, with openwrt factory image, with pepe2k's uboot image, with self-made 16MB openwrt image.

No firmware image worked, it didn't even complete the upload, just hang there with "sending request" forever.

With u-boot (likely due to its much smaller size), it at least completed and told it is flashing/rebooting now, but of course that didn't work either - likely it does not flash the bootloader from that failsafe UI (web), but just the main firmware. But as I said: it leaves the user rather unclear about the possibilities.

I did a trace with wireshark and saw that the upload was going extremely slow. dup and retransmissions on tcp level.

So, my questions:

That bootloader seems a bit unhelpful and the failsafe web UI of it doesn't work for me - what I read about pepe2k's modded u-boot sounded much better. slboat, why didn't you flash that? wink

And what precisely do I have there on this mr10n, is it a unmodified u-boot?

Does it offer anything else than the (non-working) http upload and working with a serial console (that I have to solder first and find a 2.5mm socket for my cable - but this is not really a comfortable nor quick option for non-electronics people)?

Or is there some trick to get http upload working?

From old times with wrt54, I am somehow used to devices that just accept their firmware via tftp at bootloader time (so the only thing one needs is a pc with a tftp client). No soldering necessary...

Other than this little problem, the device seems really nice. Charging takes rather long, but maybe discharging will then also take long. big_smile

Cheers,

Thomas

I solved it, after soldering a serial console cable into the device...

Observations:

It did not boot because:
"Uncompressing Kernel Image ... Too big uncompressed streamLZMA ERROR 1"

I tried again transferring/flashing some images, this time using u-boot's tftpboot command (u-boot modified by slboat).

The tftpboot of this u-boot version had major issues, often it gave up due to too many retries. But after many tries, I succeeded transferring and flashing an image (piratebox iirc) that didn't have these issues and booted successfully.

I also flashed pepe2k's improved u-boot - which has a much nicer UI and there even the web-based flashing works. Seems somehow much more reliable / comfortable than the less modded u-boot. Thanks pepe2k!

I also have issues with slboat's MR10U router.  I just received one last week and tried to perform a terminal upgrade as per the generic sysupgrade instructions for the MR10 page so I can install current packages for OpenVPN and others.  http://wiki.openwrt.org/doc/howto/generic.sysupgrade

The upgrade to CC r42868 appears to run OK but after reboot/cold reboot LuCI is not responding, so no GUI access.  How can I fix this?

MBS wrote:

You need to install LuCI. http://wiki.openwrt.org/doc/howto/luci.essentials


How would I do this with no internet connection through the router?  It was configured with wifi as the WAN interface so now has no uplink.  Can I download the LuCI package locally and transfer it to the router somehow?

Hi guys !

I've just received my new MR10U and proceeded to flash it using the web interface.

After it got to 100%, the page waited until timeout. I then assumed that it was successfuly flashed and i could reboot the router.

The router doesn't show up on regular telnet. It doesn't even has an IP address. But curiously i can still telnet him on failsafe mode.
I tried many times to reinstall the image using the indirect netcat method ( downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-mr10u-v1-squashfs-factory.bin ) without any success, but without loosing failsafe access either.

Are there any other images or checksums i can try, or any ideas of where i may be failing ?

sorry! My bad english.

My mr10u have the same issues,but the previous solution is invalid .

the  issues :"I've got the device, installed OpenWRT (using step by step manual), connected it to my wi-fi, and tried to install luci - and just failed.. "No space left on device" it said.."
-----------------------------------------------------

root@OpenWrt:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
rootfs                     832               208       624   25% /
/dev/root                2048            2048         0  100% /rom
tmpfs                      14464          52     14412    0% /tmp
/dev/mtdblock3       832             208       624   25% /overlay
overlayfs:/overlay   832             208       624   25% /
tmpfs                      512                 0       512    0% /dev

install luci  ,  
Collected errors:
 * wfopen: /usr/lib/lua/luci/i18n/firewall.no.lmo: No space left on device.
 * wfopen: /usr/lib/lua/luci/i18n/firewall.pt-br.lmo: No space left on device.
 * wfopen: /usr/lib/lua/luci/i18n/firewall.ca.lmo: No space left on device.


I did two things:
1. try the openwrt_sysupgrade

root@OpenWrt:~# cd /tmp
root@OpenWrt:/tmp# wget [url]http://downloads.openwrt.org/snapshots/trunk/ar71xx/open[/url]
wrt-ar71xx-generic-tl-mr10u-v1-squashfs-sysupgrade.bin
Connecting to downloads.openwrt.org (78.24.191.177:80)
openwrt-ar71xx-gener 100% |*******************************|  2816k  0:00:00 ETA
root@OpenWrt:/tmp# sysupgrade -n openwrt-ar71xx-generic-tl-mr10u-v1-squashfs-sys
upgrade.bin
killall: watchdog: no process killed
Sending TERM to remaining processes ... ubusd askfirst logd netifd dnsmasq 6relayd ntpd
Sending KILL to remaining processes ... askfirst
Switching to ramdisk...
Performing system upgrade...
Unlocking firmware ...

Writing from <stdin> to firmware ...
Upgrade completed
Rebooting system...

2.fix opkg.conf

root@OpenWrt:/tmp/opkg-lists# cd /etc/
root@OpenWrt:/etc# vi opkg.conf
src/gz attitude_adjustment [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/generic/packages[/url]
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay

root@OpenWrt:/etc# opkg update
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/attitude_adjustment.
root@OpenWrt:/etc# opkg install luci
Installing luci (0.11.1-1) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/luci_0.11.1-1_ar71xx.ipk.
Installing uhttpd (2012-10-30-e57bf6d8bfa465a50eea2c30269acdfe751a46fd) to root.                     ..
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/uhttpd_2012-10-30-e57bf6d8bfa465a50eea2c30269acdfe751a46fd_ar71xx                     .ipk.
Installing luci-mod-admin-full (0.11.1-1) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/luci-mod-admin-full_0.11.1-1_ar71xx.ipk.
Installing luci-mod-admin-core (0.11.1-1) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/luci-mod-admin-core_0.11.1-1_ar71xx.ipk.
Installing luci-lib-web (0.11.1-1) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/luci-lib-web_0.11.1-1_ar71xx.ipk.
Installing luci-lib-core (0.11.1-1) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/luci-lib-core_0.11.1-1_ar71xx.ipk.
Installing lua (5.1.4-8) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/lua_5.1.4-8_ar71xx.ipk.
Installing liblua (5.1.4-8) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/liblua_5.1.4-8_ar71xx.ipk.
Installing libuci-lua (2013-01-04.1-1) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/libuci-lua_2013-01-04.1-1_ar71xx.ipk.
Installing libubus-lua (2013-01-13-bf566871bd6a633e4504c60c6fc55b2a97305a50) to                      root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/libubus-lua_2013-01-13-bf566871bd6a633e4504c60c6fc55b2a97305a50_a                     r71xx.ipk.
Installing luci-lib-sys (0.11.1-1) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/luci-lib-sys_0.11.1-1_ar71xx.ipk.
Installing luci-lib-nixio (0.11.1-1) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/luci-lib-nixio_0.11.1-1_ar71xx.ipk.
Installing luci-sgi-cgi (0.11.1-1) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/luci-sgi-cgi_0.11.1-1_ar71xx.ipk.
Installing luci-proto-core (0.11.1-1) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/luci-proto-core_0.11.1-1_ar71xx.ipk.
Installing luci-i18n-english (0.11.1-1) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/luci-i18n-english_0.11.1-1_ar71xx.ipk.
Installing luci-lib-ipkg (0.11.1-1) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/luci-lib-ipkg_0.11.1-1_ar71xx.ipk.
Installing luci-theme-openwrt (0.11.1-1) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/luci-theme-openwrt_0.11.1-1_ar71xx.ipk.
Installing luci-theme-base (0.11.1-1) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/luci-theme-base_0.11.1-1_ar71xx.ipk.
Installing luci-app-firewall (0.11.1-1) to root...
Downloading [url]http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/ar71xx/ge[/url]                     neric/packages/luci-app-firewall_0.11.1-1_ar71xx.ipk.
Configuring luci-lib-sys.
Configuring liblua.
Configuring libuci-lua.
Configuring lua.
Configuring libubus-lua.
Configuring luci-lib-core.
Configuring luci-lib-nixio.
Configuring luci-sgi-cgi.
Configuring luci-lib-web.
Configuring luci-proto-core.
Configuring luci-i18n-english.
uci: I/O error
Configuring luci-mod-admin-core.
ln: /etc/rc.d/S05luci_fixtime: No space left on device
ln: /etc/rc.d/K95luci_fixtime: No space left on device
ln: /etc/rc.d/S59luci_dhcp_migrate: No space left on device
Configuring luci-theme-base.
Configuring luci-theme-openwrt.
uci: I/O error
Configuring luci-lib-ipkg.
Configuring luci-mod-admin-full.
Configuring uhttpd.
Collected errors:
 * wfopen: /usr/lib/lua/luci/i18n/firewall.no.lmo: No space left on device.
 * wfopen: /usr/lib/lua/luci/i18n/firewall.pt-br.lmo: No space left on device.
 * wfopen: /usr/lib/lua/luci/i18n/firewall.ca.lmo: No space left on device.
 * wfopen: /usr/lib/lua/luci/i18n/firewall.de.lmo: No space left on device.
 * wfopen: /usr/lib/lua/luci/i18n/firewall.ja.lmo: No space left on device.
 * wfopen: /usr/lib/lua/luci/i18n/firewall.el.lmo: No space left on device.

in the and:

root@OpenWrt:/etc# df
Filesystem           1K-blocks      Used Available Use% Mounted on
rootfs                     832       764        68  92% /
/dev/root                 2048      2048         0 100% /rom
tmpfs                    14336       376     13960   3% /tmp
/dev/mtdblock3             832       764        68  92% /overlay
overlayfs:/overlay         832       764        68  92% /
tmpfs                      512         0       512   0% /dev


the same to the beginning

What should I do?
Thank you.

(Last edited by renzhe on 31 Dec 2014, 09:56)

So basically, noone here seems to have an MR-10U router that can be updated, install new packages or works after any sort of system  upgrade.

It would be nice if these routers could actually do anything more than run outdated basic functions.  What was the point of upgrading the hardware if noone can even install current releases of packages and OpenWRT on them?

I've never been able to recover mine, and I now have a second MR-10 router that still works, but I cannot even upgrade the existing packages or install new packages.

The package sources in the LuCI interface were incorrect.  I edited them to the correct ones, but they still cannot even be installed.  I get the same failures with both Openvpn-openssl and openvpn-polarssl.

Installing openvpn-polarssl (2.3.6-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/base/openvpn-polarssl_2.3.6-1_ar71xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for openvpn-polarssl:
 *     kernel (= 3.14.26-1-6ac056ba1e83003f14487d27a703318e) * 
 * opkg_install_cmd: Cannot install package openvpn-polarssl.

What's the point of wasting time and money on this router if you can't even change or update the software it comes with?

If you guys don't need certain bleeding edge parts from trunk, you should stick to stable Barrier Breaker (14.07) for now. That will even come with luci GUI installed.

OpenVPN support is bleeding edge?  Apparently so, because after 3 months posted this bug is still outstanding. 

https://dev.openwrt.org/ticket/18220

The point is, what's the point of this router being upgraded, or installed at all if we can't update firmware, or even packages without it breaking??

You may have missed my point here. Referring to this:

anonym00s3 wrote:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for openvpn-polarssl:
 *     kernel (= 3.14.26-1-6ac056ba1e83003f14487d27a703318e) * 

This is a typical problem when using trunk, it happens when the buildbot has already built another round of packages since you downloaded your firmware image. Your kernel versions are out of sync.
This problem can be avoided by using a stable version (like 14.07).
So, have you encountered problems installing openvpn in 14.07?

Hello All,

In the past I have compiled a custom build for WR703N based on AA 12.09 that contained all needed stuff for 3G, USB storage and serial support + openvpn and some other useful features enabled in busybox - all in the image for the stock 4MB device flash.

I would like to do the same for MR10U. However it is officially supported since BB 14.07 where this setup cannot be build in a 4MB image layout.

Having in mind that MR10U is very similar in HW to MR11U (which is officially supported by AA), can I use MR11U profile in AA buildroot as a base for my image and flash it on MR10U after that.

Any ideas whether it is possible or it is likely to brick the MR10U box.

The discussion might have continued from here.