OpenWrt Forum Archive

Topic: Nexx WT1520 support

The content of this topic has been archived between 31 Mar 2018 and 30 Apr 2018. Unfortunately there are posts – most likely complete pages – missing.

Thank you for the answer, Metai. I already found out about WT3020 and since the price is almost the same as 1520 it's a no-brainer.

I'm also looking into this 3G mobile router. From buyer reports it's also OpenWRT capable and from this particular seller comes with 32MB RAM and 8MB Flash. So should be as good for such purpose.
http://i00.i.aliimg.com/wsphoto/v0/1829126906/WHOSA-Mini-Portable-3G-4G-MiFi-Wireless-N-USB-WiFi-Hotspot-JU-Router-AP-150Mbps-Wlan.jpg

Hello,
I have upgraded my wt1520 with the image downloaded from http://downloads.openwrt.org/snapshots/ … pgrade.bin
After rebooting, the system is up and running doing routing and broadcasting ssid, however I am not able to login as root via SSH, none of the passwords are accepted. Web interface fails to open as well.
Tried root:openwrt , root:password, admin:admin - no luck
Any more suggestions/default passwords to try?

maybe your unit was 4mb and you flashed 8mb image?

hackru wrote:

maybe your unit was 4mb and you flashed 8mb image?

Could be smile
any hope to regain access in this case?

(Last edited by emin on 26 Mar 2015, 13:49)

emin wrote:

I have upgraded my wt1520 with the image downloaded from http://downloads.openwrt.org/snapshots/ … pgrade.bin

First of all: The first OpenWrt firmware you flash should always be the factory variant. sysupgrade is only for upgrading OpenWrt at a later time.

After rebooting, the system is up and running doing routing and broadcasting ssid

That would be a strong indication that OpenWrt has not actually been installed; Wifi is deactivated in OpenWrt by default. You are probably still running the manufacturer firmware.

(Last edited by metai on 26 Mar 2015, 22:20)

I think he can't upgrade 1520 with sysupgrade firmware, because stock interface doesn't allows unencoded firmwares.

hackru wrote:

I think he can't upgrade 1520 with sysupgrade firmware, because stock interface doesn't allows unencoded firmwares.

Apologies for not being clear, I had openwrt already running on the box, and then did the sysupgrade
Upgrade was successful, I saw the message on the console, but can not login with root now

Thanks

Tried telnet?

acfilho wrote:

Tried telnet?

Yes, not enabled

Are you using cable or wireless to connect to the router? Could be the firewall refusing the connection.

acfilho wrote:

Are you using cable or wireless to connect to the router? Could be the firewall refusing the connection.

Nope, ssh opens and asks for login

Upload photo PCB Nexx WT1520 labeled Gpio and 3.3V (except Rx, Tx). thanks

(Last edited by sakatgg on 31 Mar 2015, 18:48)

hackru wrote:

Why you ever did this days?! There's factory image in openwrt trunk, it's much simplier way. Just flash in from original web-interface. Now when you ruined your router, there's only one option for you - connect to serial pads and upgrade firmware from u-boot.

Hi,
Because i don't have any experience with this router, and because there are 3 files in the trunk, which one should i use to flash via the web interface ?

openwrt-ramips-rt305x-wt1520-4M-initramfs-uImage
openwrt-ramips-rt305x-wt1520-4M-squashfs-factory
openwrt-ramips-rt305x-wt1520-4M-squashfs-sysupgrade

Thanks

Hi,
Bravo for the wonderful work !
I ordered a WT1520 and I can't wait to play with it!
Thanks a lot.

to everyone: please do not order 1520, instead order 3020. they priced identically(+-) but 3020 have modern low power consumption chip. 3020 supported in openwrt too.

Ok I try to cancel my order...
Thanks !

hackru wrote:

to everyone: please do not order 1520, instead order 3020. they priced identically(+-) but 3020 have modern low power consumption chip. 3020 supported in openwrt too.

Not to mention the WT3020 (except the first revision) comes with 8 instead of 4 MB flash memory, which helps a LOT in OpenWrt, especially with trunk builds.

That being said, the WT1520 is very stable and works just fine with OpenWrt. I myself am using it exclusively as an "ethernet condom" (essentially just the default firewall/NAT between WAN and LAN) for my notebook whenever I don't particularly trust the wired network I'm connecting to. Aside from it getting a bit warmer to the touch than other devices, I can't say that it draws an excessive amount of power.

(Last edited by metai on 10 Apr 2015, 20:23)

I just got my WT1520H, I saw the post "update Dec 2014 - There's no need to use this instructions now. Just flash openwrt factory image available in trunk via nexx web-interface", so I did the update via stock firmware update page.

ALl is well, once I corrected /etc/opkg.conf from rt305x to generic, but I can't install luci. Is there a way to make that work?

splashd wrote:

I can't install luci. Is there a way to make that work?

The usual when it comes to trunk builds on 4 MB devices: Compile an image (using Image Builder or full-blown Buildroot) and include LuCI, or use extroot. Personally, if you don't have huge plans for the little thing I would recommend getting acquainted with the command line for the few things you want to tweak.

I brick my wt1520.
При прошивке mtd3.bin окирпичел wt1520. Рутер после подачи питания сразу начинает непрерывно светить лампочкой и не отвечает по сети. tcpdump тоже молчит.
Теперь можно восстановить только подпаиванием к TX/RX/GRN и подключением терминалкой? Или есть другие варианты?
Спасибо за внимание.

(Last edited by olegun on 27 Apr 2015, 23:17)

I need a working netem on this router. So I'm trying to compile it myself.
I download the trunk and compile it following README.
While configuring (make menuconfig) I change first 3 items - select the router model.
And set [.] Global build settings ---> Select all packages by default.
Compilation completes successfully.
I upload it(openwrt-ramips-rt305x-wt1520-4M-squashfs-sysupgrade.bin) with wget and sysupgrade.
Previously I uploaded hackru's bin, which works fine.
After reboot I do not see wifi AP. And web-interface does not work through the LAN.
But it is alive: gives IP (192.168.1.x) through LAN. And I can enter using telnet.
OpenWRT and Unix in general is not my habitat.
What am I doing wrong?

I do not know what could happen, but today the router with my empty system behaves another way.
I've done nothing, but it does. Maybe it were night hallucinations, but I'm sure yestarday it behaved like I described in my previous post.
Today it gives me a strange IP(169.254.177.123) through LAN.
I try to connect to 169.254.1.1 / 169.254.177.1 but there are no Telnet or SSH response.
Wifi AP appeares. After connecting to wifi, router gives me IP 192.168.1.11, but there is still no Telnet/SSH response from 192.168.1.1.

I can not enter any way.
I've tried to enter safemode using button, but failed. Using sniffer I've also studied it does not send broadcast udp@4919 datagram.

Has anybody used serial UART way to debrick on this router?

kleverevelk wrote:

Has anybody used serial UART way to debrick on this router?

Just read this thread from beginning.

I've made USB-UART and soldered RX, TX. Now I can get access through UART.
Started TFTP server on my PC.
Try to upload Sys code to RAM via TFTP (menu item 1).
It downloads successfully but looks like the kernal is the same (my emply).
I upload hackru's bin (openwrt-ramips-rt305x-nexx-wt1520-squashfs-sysupgrade.bin).
Maybe it should be another bin image?