OpenWrt Forum Archive

Topic: Nexx WT1520 support

The content of this topic has been archived between 31 Mar 2018 and 30 Apr 2018. Unfortunately there are posts – most likely complete pages – missing.

I'm developing OBDII(all subs) to Ethernet gateway for remote vehicle diagnostics over Internet.
There are a lot of outdoor testing and debuging, so I need HW emulation of WAN.
I'm going to use WT1520 as test bench for the purposes.
Connection scheme:
my_gateway1 - WT1520.Port1~bridge~ WT1520.Port2 - my_gateway2
Bridge between WT1520 ports with traffic shaping using netem.

Roger_ from the NEXX website.

Hi Guys,

I configured wt1520 to use 3G stick (huawei e355) via cdc-ether and now I have extra interface eth1 for WAN over 3G which works perfectly, sharing Internet via LAN and WIFI.

Now I want to use existing WAN port as LAN port (in addition to LAN and WIFI), is there any example/guidance for that?

Also I wonder if I can use router as really dumb "access point/switch" and rely on 3G stick to to the job (DHCP, etc)?



PS to archive this on wt1520 you need:
'opkg install kmod-usb-net-cdc-ether kmod-usb2 usb-modeswitch'

(Last edited by gently on 29 May 2015, 12:37)

Now I want to use existing WAN port as LAN port (in addition to LAN and WIFI), is there any example/guidance for that?

just set in switch configuration needed vlan(1)

Also I wonder if I can use router as really dumb "access point/switch" and rely on 3G stick to to the job (DHCP, etc)?

yes you can. just disable dhcp on nexx and bridge modem interface to br-lan.

thanks hackru!

I simply added into 'lan' interface 'eth0.2' and now WAN seems to act like LAN, perfect!
option ifname 'eth0.1 eth0.2'

as for bridging br-lan with eth1, what would be the process?

Actually you've done it wrong, now chip sees same packets in two vlans, it's not good(same as connecting ethernet cable's both ends to one switch). better do as i told you, switch vlan on wan port to vlan1.

http://images.mysku.ru/uploads/images/01/87/22/2014/06/27/38362b.png

set untagged on vlan1 in all fields, set off on vlan2 in all fields.

then bridge your interfaces as you did with eth0.1 and eth0.2.

install luci, configure vlans, save configs, reflash firmware, install your software and copy configs, what's the difficulty?

okay, i removed eth0.2 as you suggested

here is what i have in /etc/config/network concerning vlans:

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

(Last edited by gently on 21 May 2015, 11:09)

okay, finally it turned out that for wt1520 physical configuration is:
port0 - LAN port
port4 - WAN port

which means that I simply disabled vlan2 and added into vlan1 port '4' (WAN), now config contains:

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4 6t'


seems to work now, thanks!

now the question is how to bridge correctly LAN and eth1 (3G donge with DHCP)

(Last edited by gently on 29 May 2015, 12:43)

hello, I read all the thread and it gave me a lot of informations.
But I have a problem, hope someone can help me. It's my first play with openwrt, router flashing...
I flashed the file from this post :

Maker39 wrote:
colorprint wrote:

Well, it actually works (wifi is disabled after flashing), but I cant install luci for trunk openwrt - not enough space sad

here lecturing compilled with hackru patch with LuCi http://cyber-place.ru/showpost.php?p=18 … stcount=40

It was OK.

Then I wanted to flash the trunk's sysupgrade and it doesn't want to, so I used : mtd -r write /xxx.bin
And here I am, I broke my wt1520.

Then I bought and used a usb2ttl as said in the thread. (with two needles)

I connected the PC to LAN port, launched a tftp server on my pc and put in a bin file.
I choose menu 2

device : 192.168.1.1
pc (tftp server): 192.168.1.2
openwrt.bin (I renamed the bin file. do I need factory or sysupgrade? )


U-Boot 1.1.3 (Sep 13 2012 - 16:39:43)

Board: Ralink APSoC DRAM:  32 MB
relocate_code Pointer at: 81fb4000
spi_wait_nsec: 42
spi device id: ef 40 16 0 0 (40160000)
find flash: W25Q32BV
raspi_read: from:30000 len:1000
.*** Warning - bad CRC, using default environment

============================================
Ralink UBoot Version: 4.0.1.0
--------------------------------------------
ASIC 5350_MP (Port5<->None)
DRAM_CONF_FROM: Boot-Strapping
DRAM_TYPE: SDRAM
DRAM_SIZE: 256 Mbits
DRAM_WIDTH: 16 bits
DRAM_TOTAL_WIDTH: 16 bits
TOTAL_MEMORY_SIZE: 32 MBytes
Flash component: SPI Flash
Date:Sep 13 2012  Time:16:39:43
============================================
icache: sets:256, ways:4, linesz:32 ,total:32768
dcache: sets:128, ways:4, linesz:32 ,total:16384

 ##### The CPU freq = 360 MHZ ####
 estimate memory size =32 Mbytes

Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial.
   9: Load Boot Loader code then write to Flash via TFTP.
 4
You choosed 2

 0
raspi_read: from:40028 len:6
.

2: System Load Linux Kernel then write to Flash via TFTP.
 Warning!! Erase Linux in Flash then burn new one. Are you sure?(Y/N)
 Please Input new ones /or Ctrl-C to discard
        Input device IP (10.10.10.123) ==:192.168.1.1
        Input server IP (10.10.10.3) ==:192.168.1.2
        Input Linux Kernel filename () ==:openwrt.bin

 netboot_common, argc= 3

 NetTxPacket = 0x81FE6440

 KSEG1ADDR(NetTxPacket) = 0xA1FE6440

 NetLoop,call eth_halt !

 NetLoop,call eth_init !
Trying Eth0 (10/100-M)

 Waitting for RX_DMA_BUSY status Start... done


 Header Payload scatter function is Disable !!

 ETH_STATE_ACTIVE!!
Using Eth0 (10/100-M) device
TFTP from server 192.168.1.2; our IP address is 192.168.1.1
Filename 'openwrt.bin'.

 TIMEOUT_COUNT=10,Load address: 0x80100000
Loading: Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REQUEST, return our IP
Got ARP REPLY, set server/gtwy eth addr (bc:ee:7b:71:bd:6a)
Got it
T T T T T T T T
Retry count exceeded; starting again
Trying Eth0 (10/100-M)

 ETH_STATE_ACTIVE!!
T T T T Got ARP REQUEST, return our IP
T T
Retry count exceeded; starting again
Trying Eth0 (10/100-M)

wireshark doesn't show anything

In advance, thanks for your help.

(Last edited by teddy1602 on 10 Jun 2015, 19:32)

Hmmmmm. Looks like I already installed CC on nexx 1520

OpenWrt Chaos Calmer r42757 / LuCI Trunk (svn-r10537)

Another question - how to upgrade to RC2?

yepp, factory image is already in trunk.

Another question - how to upgrade to RC2?

install sysupgrade image from rc2

hackru wrote:

try to replace bootloader via
> 7: Load Boot Loader code then write to Flash via Serial

this one is 115200 with web-interface.
https://app.box.com/s/ijk9powmujyy026614fc#


I replaced the bootloader now I will try to unbrick it.

thank you very much for this step.

AZ82 wrote:

There are plenty of packages in openwrt directory
http://downloads.openwrt.org/chaos_calm … ps/rt305x/
Which one is sysupgrade for nexx 1520?

There are basically two versions of the WT1520 out there, you need to check whether you have the 4MB or the 8MB flash version ("4M" or "8M" in the filename, respectively). Other than that, yes, the "squashfs-sysupgrade" file is the one you want.

(Last edited by metai on 17 Jun 2015, 08:47)

metai wrote:
AZ82 wrote:

There are plenty of packages in openwrt directory
http://downloads.openwrt.org/chaos_calm … ps/rt305x/
Which one is sysupgrade for nexx 1520?

There are basically two versions of the WT1520 out there, you need to check whether you have the 4MB or the 8MB flash version ("4M" or "8M" in the filename, respectively). Other than that, yes, the "squashfs-sysupgrade" file is the one you want.

I got an error

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

Tried both 4M and 8M binaries.

When upgrade from SSH


root@OpenWrt-wt1520:/tmp# sysupgrade -v /tmp/openwrt-15.05-rc2-ramips-rt305x-wt1
520-4M-squashfs-sysupgrade.bin
Sysupgrade is not yet supported on generic.
Image check 'platform_check_image' failed.

use sysupgrade -F

Success upgrade with mtd -r write /tmp/***.bin firmware

LuCi is not installed
when i tried to install LuCi using ssh, got an error No space left on device.

Is it possible that i have 8M nexx-1520? I have wrote 4M image. Can I rewrite 8M image instead?

(Last edited by AZ82 on 18 Jun 2015, 23:26)

Flashed 8M firmware - same error on LuCi install

hackru, can you please share your config to build firmware with embedded LuCi for nexx-1520? I have built my own firmware, but want to check if I made no errors.

Looks like I bricked device - flashed with 8Mb version.
Now I will try to flash device from RPi.