OpenWrt Forum Archive

Topic: Nexx WT1520 support

The content of this topic has been archived between 31 Mar 2018 and 30 Apr 2018. Unfortunately there are posts – most likely complete pages – missing.

I just bought one of these little guys and I've discovered that there are two versions, 4M and 8M and so two OpenWRT images. In case I brick this thing, how do I know which version I've got? Pardon me if someone has already explained, but I couldn't find it anywhere on this thread.

Thanks

(Last edited by jrdld on 11 Jul 2015, 23:15)

I've actually never done this, but it should be possible for you to telnet into the router running stock firmware using user "nexxadmin", password "y1n2inc.com0755" (all without quotation marks of course). Even on a very limited shell, it should give an output to "df -h", and you should immediately see if you've got a device with 4MB or 8MB. (8MB seem to be a lot less common, fwiw.)

Thanks metai, but unfortunately I've now got a more basic problem.

I managed to get on to the web interface (original firmware), and go to the firmware upgrade screen, but then the LAN connection went down before I could do anything. Since then neither ethernet port will come up no matter what switch/computer/cable combination I use, and no matter what USB power supply I use. Power light but no network.

Has anyone else seen this sort of behaviour?

(Last edited by jrdld on 13 Jul 2015, 15:24)

jrdld wrote:

I managed to get on to the web interface (original firmware), and go to the firmware upgrade screen, but then the LAN connection went down before I could do anything.

Even before you uploaded a firmware image?

Exactly. Dodgy hardware it would seem. Trying to get a refund from the ebay seller now.

Hi,
I also wonder how to use it as repeater,
I tried to config the device as the video here suggest
https://www.youtube.com/watch?v=3rbsh2zxPnk
but when enabling the Main AP, I do not see beacons of the WT1520.
Any suggestions?
Also I tried to go back the original version, but without success ( Probably because it encrypted),
Is it possible to go back the the official FW?
Thanks

(Last edited by mudonroad on 25 Jul 2015, 02:46)

I have two of these I've got 15.05-rc3 running on. One problem I seem to have is the space not reporting the 4MB like my other openwrt devices. Here is what I show

Filesystem                Size        Used       Available   Use%     Mounted on
rootfs                     448.0K    296.0K        152.0K      66%      /
/dev/root                  2.3M        2.3M               0       100%      /rom
tmpfs                      14.2M       64.0K          14.1M        0%     /tmp
/dev/mtdblock6      448.0K    296.0K         152.0K      66%     /overlay
overlayfs:/overlay  448.0K    296.0K         152.0K      66%     /
tmpfs                      512.0K           0           512.0K        0%    /dev



From bootlog
[    0.560000] m25p80 spi32766.0: w25q32 (4096 Kbytes)
[    0.570000] 4 ofpart partitions found on MTD device spi32766.0
[    0.580000] Creating 4 MTD partitions on "spi32766.0":
[    0.590000] 0x000000000000-0x000000030000 : "u-boot"
[    0.600000] 0x000000030000-0x000000040000 : "u-boot-env"
[    0.610000] 0x000000040000-0x000000050000 : "factory"
[    0.630000] 0x000000050000-0x000000400000 : "firmware"
[    0.680000] 2 uimage-fw partitions found on MTD device firmware
[    0.690000] 0x000000050000-0x000000166ee8 : "kernel"
[    0.700000] 0x000000166ee8-0x000000400000 : "rootfs"
[    0.710000] mtd: device 5 (rootfs) set to be root filesystem
[    0.720000] 1 squashfs-split partitions found on MTD device rootfs
[    0.740000] 0x000000390000-0x000000400000 : "rootfs_data"


Any thoughts on how to fix this?

vsoutherner wrote:

I have two of these I've got 15.05-rc3 running on. One problem I seem to have is the space not reporting the 4MB like my other openwrt devices. Here is what I show

Filesystem                Size        Used       Available   Use%     Mounted on
rootfs                     448.0K    296.0K        152.0K      66%      /
/dev/root                  2.3M        2.3M               0       100%      /rom

The number next to "rootfs" above only reports the free space, and 448 kB sounds about right for a 4 MB device.

That sucks. Are the 8MB using the same brand of flash just the 8MB version. I don't mind trying to replace it and reflash the software if that's the case

good day! but not for me( my nexx wt1520 malfunction today. from arduino uno as uart bridge using minicom i have received this:

U-Boot 1.1.3 (Sep 13 2012 - 16:39:43)

Board: Ralink APSoC DRAM:  16 MB
relocate_code Pointer at: 80fb4000
spi_wait_nsec: 42 
spi device id: ef 40 16 0 0 (40160000)
find flash: W25Q32BV
raspi_read: from:30000 len:1000 
.*** Warning - bad CRC, using default environment

============================================ 
Ralink UBoot Version: 4.0.1.0
-------------------------------------------- 
ASIC 5350_MP (Port5<->None)
DRAM_CONF_FROM: Boot-Strapping 
DRAM_TYPE: SDRAM 
DRAM_SIZE: 128 Mbits
DRAM_WIDTH: 16 bits
DRAM_TOTAL_WIDTH: 16 bits
TOTAL_MEMORY_SIZE: 16 MBytes
Flash component: SPI Flash|
Date:Sep 13 2012  Time:16:39:43
============================================
icache: sets:256, ways:4, linesz:32 ,total:32768
dcache: sets:128, ways:4, linesz:32 ,total:16384 

 ##### The CPU freq = 360 MHZ #### 
 estimate memory size =16 Mbytes

Please choose the operation: 
   1: Load system code to SDRAM via TFTP. 
   2: Load system code then write to Flash via TFTP. 
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial. 
   9: Load Boot Loader code then write to Flash via TFTP. 
 0 
   
3: System Boot system code via Flash.
## Booting image at bc050000 ...
raspi_read: from:50000 len:40 
.   Image Name:   NEXXWT1520
   Created:      2014-07-23  15:19:24 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1043374 Bytes = 1018.9 kB
   Load Address: 80000000
   Entry Point:  80000000
raspi_read: from:50040 len:febae 
................   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 80000000) ...
## Giving linux memsize in MB, 16

Starting kernel ...

[    0.000000] Linux version 3.10.44 (openwrt@gb-13) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r41360) ) #1 Sat Jun 28 03:10:26 UTC 2014
[    0.000000] SoC Type: Ralink RT5350 id:1 rev:3
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0001964c (MIPS 24KEc)
[    0.000000] MIPS: machine is NEXX WT1520
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x01ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x01ffffff]

after that booting stop and led swich off
and one more thing/ from minicom i can't send any data to router
helpme please bring my nexx to life

DRAM_SIZE: 128 Mbits
TOTAL_MEMORY_SIZE: 16 MBytes

this is your problem - uboot detects incorrect memory size. this probably could happen because of your arduino have ttl level of 5v and nexx has 3.3v. you can try to connect serial console after powering up router, waiting for about second, maybe this could help to detect right memory size. anyway, i recommend to buy usb2ttl with correct voltage.

oh, thank for reply! your advice was right! jast a min, gnd pin broked) soldering it

booting stop after

...   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 80000000) ...
## Giving linux memsize in MB, 32

Starting kernel ...
                                                                                              
[    0.000000] Linux version 3.10.44 (openwrt@gb-13) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r41360) ) #1 Sat Jun 28 03:10:26 UTC 2014
[    0.000000] SoC Type: Ralink RT5350 id:1 rev:3                                             
[    0.000000] bootconsole [early0] enabled                                                   
[    0.000000] CPU revision is: 0001964c (MIPS 24KEc)                                         
[    0.000000] MIPS: machine is NEXX WT1520
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x01ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x01ffffff]
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line: console=ttyS1,57600 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Writing ErrCtl register=000612dd
[    0.000000] Readback ErrCtl register=000612dd
[    0.000000] Memory: 29156k/32768k available (2288k kernel code, 3612k reserved, 569k data, 212k init, 0k highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:256
[    0.000000] CPU Clock: 360MHz
[    0.000000] Calibrating delay loop... 239.61 BogoMIPS (lpj=1198080)
[    0.070000] pid_max: default: 32768 minimum: 301
[    0.070000] Mount-cache hash table entries: 512
[    0.080000] pinctrl core: initialized pinctrl subsystem
[    0.090000] NET: Registered protocol family 16
[    0.140000] bio: create slab <bio-0> at 0
[    0.150000] rt2880_gpio 10000600.gpio: registering 24 gpios
[    0.160000] rt2880_gpio 10000600.gpio: registering 24 irq handlers
[    0.170000] Switching to clocksource MIPS
[    0.180000] NET: Registered protocol family 2
[    0.190000] TCP established hash table entries: 512 (order: 0, 4096 bytes)
[    0.210000] TCP bind hash table entries: 512 (order: -1, 2048 bytes)
[    0.220000] TCP: Hash tables configured (established 512 bind 512)
[    0.230000] TCP: reno registered
[    0.240000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.250000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.260000] NET: Registered protocol family 1
[    0.270000] rt-timer 10000100.timer: maximum frequncy is 7324Hz
[    0.330000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.340000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.360000] msgmni has been set to 56
[    0.370000] io scheduler noop registered
[    0.380000] io scheduler deadline registered (default)
[    0.390000] gpio-export gpio_export.6: 1 gpio(s) exported
[    0.400000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.430000] 10000500.uart: ttyS0 at MMIO 0x10000500 (irq = 13) is a 16550A
[    0.450000] 10000c00.uartlite: ttyS1 at MMIO 0x10000c00 (irq = 20) is a 16550A
[    0.460000] console [ttyS1] enabled, bootconsole disabled
[    0.460000] console [ttyS1] enabled, bootconsole disabled
[    0.490000] m25p80 spi32766.0: found w25q32, expected gd25q64
[    0.500000] m25p80 spi32766.0: w25q32 (4096 Kbytes)
[    0.510000] 4 ofpart partitions found on MTD device spi32766.0
[    0.530000] Creating 4 MTD partitions on "spi32766.0":
[    0.540000] 0x000000000000-0x000000030000 : "u-boot"
[    0.550000] 0x000000030000-0x000000040000 : "u-boot-env"
[    0.560000] 0x000000040000-0x000000050000 : "factory"
[    0.580000] 0x000000050000-0x000000400000 : "firmware"
[    0.590000] 0x00000014ebee-0x000000400000 : "rootfs"
[    0.600000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.630000] mtd: device 4 (rootfs) set to be root filesystem
[    0.640000] mtd: partition "rootfs_data" created automatically, ofs=0x3a0000, len=0x60000
[    0.660000] 0x0000003a0000-0x000000400000 : "rootfs_data"
[    0.680000] eth0: done loading
[    0.690000] rt3xxx-usbphy ubsphy.3: loaded
[    0.700000] rt2880_wdt 10000120.watchdog: Initialized
[    0.710000] TCP: cubic registered
[    0.720000] NET: Registered protocol family 17
[    0.730000] Bridge firewalling registered
[    0.740000] 8021q: 802.1Q VLAN Support v1.8
[    0.770000] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    0.790000] Freeing unused kernel memory: 212K (802cb000 - 80300000)
procd: Console is alive
procd: - watchdog -
[    8.030000] usbcore: registered new interface driver usbfs
[    8.040000] usbcore: registered new interface driver hub
[    8.060000] usbcore: registered new device driver usb
[    8.120000] gpio-keys-polled gpio-keys-polled.4: missing platform data
[    8.130000] gpio-keys-polled: probe of gpio-keys-polled.4 failed with error -22
[    8.160000] SCSI subsystem initialized
[    8.180000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    8.200000] ehci-platform: EHCI generic platform driver
[    8.410000] rt3xxx-usbphy ubsphy.3: remote usb device wakeup disabled
[    8.420000] rt3xxx-usbphy ubsphy.3: UTMI 16bit 30MHz
[    8.430000] ehci-platform 101c0000.ehci: EHCI Host Controller
[    8.440000] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
[    8.460000] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
[    8.490000] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
[    8.500000] hub 1-0:1.0: USB hub found
[    8.510000] hub 1-0:1.0: 1 port detected
[    8.520000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    8.530000] ohci-platform 101c1000.ohci: Generic Platform OHCI Controller
[    8.550000] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
[    8.560000] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
[    8.630000] hub 2-0:1.0: USB hub found
[    8.640000] hub 2-0:1.0: 1 port detected
[    8.660000] dwc_otg: version 2.72a 24-JUN-2008
[    8.670000] leds-gpio gpio-leds.5: pins are not configured from the driver
[    8.690000] usbcore: registered new interface driver usb-storage
procd: - preinit -
[   10.060000] rt305x-esw 10110000.esw: link changed 0x00
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
kmod: ran 1 iterations
[   14.630000] jffs2: notice: (323) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 12 of xr.
block: extroot: no root or overlay mount defined
jffs2 is ready
jffs2 is ready
[   14.920000] jffs2: notice: (320) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 12 of xr.
switching to overlay
procd: - early -
procd: - watchdog -
procd: - ubus -
procd: - init -
Please press Enter to activate this console.
Command failed: Not found
[   19.640000] Loading modules backported from Linux version master-2014-05-22-0-gf2032ea
[   19.660000] Backport generated by backports.git backports-20140320-37-g5c33da0
[   19.720000] nf_conntrack version 0.5.0 (458 buckets, 1832 max)
[   19.800000] usbcore: registered new interface driver usbserial
[   19.820000] usbcore: registered new interface driver usbserial_generic
[   19.840000] usbserial: USB Serial support registered for generic
[   19.910000] xt_time: kernel timezone is -0000
[   19.930000] usbcore: registered new interface driver cdc_ether
[   20.020000] cfg80211: Calling CRDA to update world regulatory domain
[   20.040000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   20.050000] cfg80211: World regulatory domain updated:
[   20.060000] cfg80211:  DFS Master region: unset
[   20.060000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   20.080000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   20.100000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   20.120000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   20.130000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   20.150000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   20.160000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   20.320000] PPP generic driver version 2.4.2
[   20.330000] NET: Registered protocol family 24
[   20.390000] usbcore: registered new interface driver option
[   20.440000] usbserial: USB Serial support registered for GSM modem (1-port)
[   20.510000] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 5350, rev 0500 detected
[   20.520000] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 5350 detected
[   30.920000] device eth0 entered promiscuous mode
[   30.940000] br-ETH0: port 1(eth0) entered forwarding state
[   30.950000] br-ETH0: port 1(eth0) entered forwarding state
[   30.990000] device eth0.1 entered promiscuous mode
[   31.000000] br-ETH0: port 2(eth0.1) entered forwarding state
[   31.010000] br-ETH0: port 2(eth0.1) entered forwarding state
[   31.040000] device eth0.2 entered promiscuous mode
[   31.050000] br-ETH0: port 3(eth0.2) entered forwarding state
[   31.060000] br-ETH0: port 3(eth0.2) entered forwarding state
[   32.950000] br-ETH0: port 1(eth0) entered forwarding state
[   33.010000] br-ETH0: port 2(eth0.1) entered forwarding state
[   33.060000] br-ETH0: port 3(eth0.2) entered forwarding state
procd: - init complete -
[   36.640000] device wlan0 entered promiscuous mode
[   37.660000] br-lan: port 1(wlan0) entered forwarding state
[   37.670000] br-lan: port 1(wlan0) entered forwarding state
[   39.670000] br-lan: port 1(wlan0) entered forwarding state

debug level 4 log (last n str)

procd: q_initd_complete(98): stop /etc/init.d/sysntpd running 
[   44.700000] device wlan0 entered promiscuous mode
procd: service_handle_set(236): Create service dnsmasq
procd: service_instance_update(66): Create instance dnsmasq::instance1
procd: instance_start(194): Started instance dnsmasq::instance1
procd: _rc(132): running /etc/init.d/dnsmasq running
procd: q_initd_run(68): start /etc/init.d/dnsmasq running 
procd: q_initd_complete(98): stop /etc/init.d/dnsmasq running 
procd: watchdog_timeout_cb(37): Ping
[   45.850000] br-lan: port 1(wlan0) entered forwarding state
[   45.860000] br-lan: port 1(wlan0) entered forwarding state
procd: watch_subscribe_cb(48): ubus event ubus.object.add
procd: watch_subscribe_cb(57): ubus path hostapd.wlan0
procd: hotplug_handler_debug(410): {{"ACTION":"add","DEVPATH":"\/devices\/virtual\/net\/br-wan","SUBSYSTEM":"net","DEVTYPE":"bridge","INTERFACE":"br-wan","IFINDEX":"13","SEQNUM":"429"}}
procd: rule_handle_command(361): Command: execprocd: rule_handle_command(363):  /sbin/hotplug-callprocd: rule_handle_command(363):  netprocd: rule_handle_command(364): 
procd: rule_handle_command(366): Message:procd: rule_handle_command(368):  ACTION=addprocd: rule_handle_command(368):  DEVPATH=/devices/virtual/net/br-wanprocd: rule_handle_command(368):  SUBSYSTEM=netprocd:  
procd: queue_next(287): Launched hotplug exec instance, pid=1524
procd: hotplug_handler_debug(410): {{"ACTION":"add","DEVPATH":"\/devices\/virtual\/net\/br-wan\/queues\/tx-0","SUBSYSTEM":"queues","SEQNUM":"430"}}
procd: hotplug_handler_debug(410): {{"ACTION":"remove","DEVPATH":"\/devices\/virtual\/net\/br-wan\/queues\/tx-0","SUBSYSTEM":"queues","SEQNUM":"431"}}
procd: hotplug_handler_debug(410): {{"ACTION":"remove","DEVPATH":"\/devices\/virtual\/net\/br-wan","SUBSYSTEM":"net","DEVTYPE":"bridge","INTERFACE":"br-wan","IFINDEX":"13","SEQNUM":"432"}}
procd: rule_handle_command(361): Command: execprocd: rule_handle_command(363):  /sbin/hotplug-callprocd: rule_handle_command(363):  netprocd: rule_handle_command(364): 
procd: rule_handle_command(366): Message:procd: rule_handle_command(368):  ACTION=removeprocd: rule_handle_command(368):  DEVPATH=/devices/virtual/net/br-wanprocd: rule_handle_command(368):  SUBSYSTEM=netproc 
procd: queue_proc_cb(292): Finished hotplug exec instance, pid=1524
procd: queue_next(287): Launched hotplug exec instance, pid=1535
procd: queue_proc_cb(292): Finished hotplug exec instance, pid=1535
procd: service_handle_set(232): Update service dnsmasq
procd: service_instance_update(58): Update instance dnsmasq::instance1
procd: _rc(132): running /etc/init.d/dnsmasq running
procd: q_initd_run(68): start /etc/init.d/dnsmasq running 
procd: q_initd_complete(98): stop /etc/init.d/dnsmasq running 
[   47.860000] br-lan: port 1(wlan0) entered forwarding state
procd: watchdog_timeout_cb(37): Ping
procd: watchdog_timeout_cb(37): Ping
procd: watchdog_timeout_cb(37): Ping
procd: watchdog_timeout_cb(37): Ping
procd: watchdog_timeout_cb(37): Ping
procd: watchdog_timeout_cb(37): Ping

(Last edited by loderunner84 on 26 Aug 2015, 13:22)

fix it. by usb-uart connect and make firstboot. thanks for this thread!

I can´t find this in ebay but WT1520H and WT1520F look alike, is it posible to install the same openwrt image to any of those?

Take a look at nexx 3020, it is much better.

Hi i think i need a little help...

how i select the option number 2 for write a new fw.

The key number 2 aparently don't work and the device (WT3020) boot always in option number 3.


How i stop this ? It is possible ? I bricked my router before...



============================================
Ralink UBoot Version: 4.1.1.0
--------------------------------------------
ASIC 7620_MP (Port5<->None)
DRAM component: 512 Mbits DDR, width 16
DRAM bus: 16 bit
Total memory: 64 MBytes
Flash component: SPI Flash
Date:Jan  3 2014  Time:09:12:42
============================================
icache: sets:512, ways:4, linesz:32 ,total:65536
dcache: sets:256, ways:4, linesz:32 ,total:32768

##### The CPU freq = 580 MHZ ####
estimate memory size =64 Mbytes

Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial.
   9: Load Boot Loader code then write to Flash via TFTP.
0
   
3: System Boot system code via Flash.
## Booting image at bc050000 ...
raspi_read: from:50000 len:40
Bad Magic Number,33303230

(Last edited by Nasp on 27 Dec 2015, 22:01)

Let me guess, you don't see any countdown on the screen and key number 3 get selected instantly, right?
1) this sounds weird, but let your device to cool down to room temperature and then try
2) connect to rx/tx via 1000ohm resistors
3) power your nexx via usb from your pc
4) try with connected/not connected GND connector

"Bad Magic Number,33303230"
I see you tried to upload some firmware directly(probably using mtd_write) and not using stock web-interface.

hackru wrote:

Let me guess, you don't see any countdown on the screen and key number 3 get selected instantly, right?
1) this sounds weird, but let your device to cool down to room temperature and then try
2) connect to rx/tx via 1000ohm resistors
3) power your nexx via usb from your pc
4) try with connected/not connected GND connector

"Bad Magic Number,33303230"
I see you tried to upload some firmware directly(probably using mtd_write) and not using stock web-interface.


No, i see the countdown but can't select anything... I also tried almost all the options from 1 to 4 (1000ohm resistors not) ant in two diferent PCs with minicom!!

Yes, i bricked my device before, no i have "Bad Magic Numbers.."

Hello,

Yesterday I flashed my new WT 1520 to openwrt using your tutorial on page 3.

I installed using this https://app.box.com/s/jyz599nk2rerma62p4zz

Everything worked fine and I could connect to internet just fine.

Today I try to connect via Wireless to my internet with the WAN port and I'm unable to connect there is no ip-v4 address and I can't connect  to the web interface.
I can connect to the internet but I see a yellow triangle on the network..

However, when I put the internet cable directly to LAN then I can connect to internet just fine but then it's not connected via the WT1520 router..

I tried to reset but the reset button doesn't seem to be working..

what can I do please help!

Hi, people!
Help wanted. Maybe somebody devote me a few minutes. The situation is this ...
After a lot of experimentation with the firmware, I stopped at the Zyxel Keenetic 4G II. Everything worked fine until I got to an alternative Zyxel's firmware, which I filled by using zyxel's menu. As you might imagine the router died.
And it seems that during process of flashing was corrupted u-boot. (I have restored several times before that and saw and used the console via serial port)
I understand that I have one way - unsolder the flash-chip and fill back bootloader. (Or maybe better whole flash at once?) And then, i hope, i can install Open-wrt again!
Question: Can anybody make dump of bootloader or full flash?
Suited all versions 4 or 8MB (If 8MB I'll buy this chip smile )
I will be glad to any advice and suggestions, because I'm a beginner.
Thanks!

(Last edited by front_by_front on 28 Mar 2016, 10:01)

Dear all, I need help, I just flashed the router and I managed to flashed it, however, after I set the root password, I can't login anymore, I do not know where I went wrong. Effectively, I cannot login to the admin page, everything else works like a router.

I tried to get into failsafe but failed. Any idea what I can do?

I have new openwrt user.
I have installed it on my Nexx WT 1520 (4mb), I'd like user it to 1) share usb pen drive data and 2) create small dlna server (if possible).

I have 2 questions:
1. how share usb data? I cannot try settings about usb from web interface.
2. I cannot install samba (there is not free space) and minidlna, is there a solution?
3. If I would can back to original firmware, is there a tutorial?

Thanks

Dear all, Stuck in the thicket ...
I use the WT1520 Nexx basis. Unfortunately, I can not just five GPIO ports used by number of gpio18,19,20,21, the rest I can not get it to work.
I use the "script static" in https://wiki.openwrt.org/doc/hardware/port.gpio, but just found out this 5 port. One of the documents included in the gpio7, 9,10,11,12,13,14. The forums I found dts configurations, but I do not know not understand. The WT1520 like to use simple lines RX.TX port to the console, button, USB, Ethernet and WiFi. I do not need anything, only  other GPIO's. I can use Image build, but i can not use dts.
Can someone dts file and help? what is the GPIO0 and what use?

thx
G