OpenWrt Forum Archive

Topic: Update on Linksys WRT1900AC support

The content of this topic has been archived between 16 Sep 2014 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Question from me for once smile

Stock has a single button to turn off the LEDs (except for the power).

Can this be done in the current CC Trunk builds?

I know about the LED settings screen, but can only see options for "triggers" and wouldn't know how (if possible) to merely just disable (all) the various lights.

netgod wrote:

So how many dBm can the antennas output?

highest setting available in the GUI in mine with my (European) country code is 20 dBm (100 mW) on each radio.

I wonder what the specs are on the chip. CRDA can be hacked to get higher dBm or you can configure your country as Bolivia where dBm is uncapped smile

I know when I change the region to USA, it lets me increase the 5ghz radio to 30db.  Though I don't think its actually doing anything, range is still the same.

rip057 wrote:
Kaloz wrote:
rip057 wrote:

can someone who is doing the current go to build include this patch so the overlay pivot system will work...

https://forum.openwrt.org/viewtopic.php?id=54138

with  Kaloz build there isnt room to install gcc, yet its offered as a package?  i dont get it

im going to try and build, but guaranteeing i am going to have issues...

Well, I have no idea why would you want to compile natively, but I would deboostrap Debian/Ubuntu on an external esata/usb drive and chroot myself there.


i really dont want to compile, im kind of curious why these packages which were prevalent in ar71xx arent in this build... guess it will come or they have been dropped, but i figure with usb3.0, on top of the fact that i have a horde of packages that i want to install... and the pivot overlay would be awesome, but does not work... i have tried many many options to get this to work... and have a good understanding about how it is supposed to work, but the only solution so far is this patch... that being said most of the packages the i would want to natively compile are relatively small... im not trying to compile a kernel on the device, but GAWK is a pretty simple build, im more than sure ngrep is a really simple build, and netsed is also a tiny build with just a simple make and one code file... it is a  lot simpler to just natively build, I would do a build through the openwrt package build but these packages arent offered at all

really i just want the pivot overlay to work and if i am going to go through the process of compiling another img with it patched via the post i cited then i dont really want to mess around with more cross compilation insanity...

all the things i said have been done on ar71xx with no problems


@Kaloz,

I just tried to get pivot overlay to work with no success. It seems the following patch is already in trunk since 12/15/14 and is enabled by default in the .config file

https://dev.openwrt.org/changeset/43717

However, no matter what I put in /etc/config/fstab it doesn't seem to work. Any chance you can troubleshoot this? Thanks.

DavidMcWRT wrote:
lifehacksback wrote:

In an effort to consolidate the images here is a build based on Kaloz's image with:

- Btrfs module built in
- Transmission
- Openvpn
- block-mount
- samba
- ext4
- hd-idle
- qos
- collectd
- graphs (for some reason not working @Kaloz did I not installed a package? maybe opkg will fix this in a jiffy)
- bootstrap luci not openwrt

---------------------------------------------------------\

I made this image to make it as close to Kaloz's images while adding some extra things here and there (especially the btrfs module tho you need to install the btrfs-progs for more support)

one change that was weird but i forgot the change (ill update when i have the time)

Image: https://www.dropbox.com/s/vvo9rcpmd8ig9 … 9.img?dl=0

@lifehacksback

Thanks for your continued releases.

However, could you (also) please put back up your original 3.18.1 build as a "known, good" release?

I'll need to re-edit my OpenWRT flashing guide with the new link!

Thanks.  (Still happily running it BTW smile).


Hi, all

My router is bricked.
Kaloz's -> stock firm -> lifehacksback -> Kaloz's
During last process, my router has been bricked.

After power led is 5 times blink, led is solid. and connected lan led on.
tftp connect not available.

I will buy ttl cable.

Must stock firm -> openwrt.
openwrt -> openwrt method have many risk.

:-)

Abitrary wrote:
DavidMcWRT wrote:
lifehacksback wrote:

In an effort to consolidate the images here is a build based on Kaloz's image with:

- Btrfs module built in
- Transmission
- Openvpn
- block-mount
- samba
- ext4
- hd-idle
- qos
- collectd
- graphs (for some reason not working @Kaloz did I not installed a package? maybe opkg will fix this in a jiffy)
- bootstrap luci not openwrt

---------------------------------------------------------\

I made this image to make it as close to Kaloz's images while adding some extra things here and there (especially the btrfs module tho you need to install the btrfs-progs for more support)

one change that was weird but i forgot the change (ill update when i have the time)

Image: https://www.dropbox.com/s/vvo9rcpmd8ig9 … 9.img?dl=0

@lifehacksback

Thanks for your continued releases.

However, could you (also) please put back up your original 3.18.1 build as a "known, good" release?

I'll need to re-edit my OpenWRT flashing guide with the new link!

Thanks.  (Still happily running it BTW smile).


Hi, all

My router is bricked.
Kaloz's -> stock firm -> lifehacksback -> Kaloz's
During last process, my router has been bricked.

After power led is 5 times blink, led is solid. and connected lan led on.
tftp connect not available.

I will buy ttl cable.

Must stock firm -> openwrt.
openwrt -> openwrt method have many risk.

:-)

Have you tried this?

http://wiki.openwrt.org/toh/linksys/wrt … ware_flash

Also, as a safeguard you should always uncheck "keep settings" if you are jumping between different firmwares built using different configs/revisions.

(Last edited by tusc on 6 Jan 2015, 01:17)

Ok so this is strange I have the CC software loaded and its kind of working. However in the wireless network interfaces it has a password of the router and not my password for the wireless. I can change it but once I save it, it reverts back to the password for the router and won't keep the actual wireless pass. Is there a way to clear this out or clear the configuration files? I have tried several times to reflash and not save settings but still the password does not remove itself

I should clarify just in case, the key for the wireless security won't take

This shows up in the logs over and over for all my wireless connections

an  6 00:02:34 2015 daemon.info hostapd: wlan0: STA e8:ab:fa:02:83:65 IEEE 802.11: deauthenticated due to local deauth request
Tue Jan  6 00:02:35 2015 daemon.info hostapd: wlan0: STA e8:ab:fa:02:83:65 IEEE 802.11: associated (aid 3)
Tue Jan  6 00:02:37 2015 daemon.info hostapd: wlan0: STA e8:ab:fa:0b:42:32 IEEE 802.11: associated (aid 1)
Tue Jan  6 00:02:37 2015 daemon.info hostapd: wlan0: STA 9c:2a:70:06:b8:66 IEEE 802.11: deauthenticated due to local deauth request
Tue Jan  6 00:02:38 2015 daemon.info hostapd: wlan0: STA e8:ab:fa:02:83:65 IEEE 802.11: disassociated
Tue Jan  6 00:02:39 2015 daemon.info hostapd: wlan0: STA e8:ab:fa:0d:eb:3b IEEE 802.11: associated (aid 4)
Tue Jan  6 00:02:39 2015 daemon.info hostapd: wlan0: STA 9c:b6:54:9d:d5:2a IEEE 802.11: deauthenticated due to local deauth request
Tue Jan  6 00:02:41 2015 daemon.info hostapd: wlan0: STA 9c:b6:54:9d:d5:2a IEEE 802.11: associated (aid 2)

(Last edited by dpdurst on 6 Jan 2015, 02:01)

tusc wrote:
Abitrary wrote:
DavidMcWRT wrote:

@lifehacksback

Thanks for your continued releases.

However, could you (also) please put back up your original 3.18.1 build as a "known, good" release?

I'll need to re-edit my OpenWRT flashing guide with the new link!

Thanks.  (Still happily running it BTW smile).


Hi, all

My router is bricked.
Kaloz's -> stock firm -> lifehacksback -> Kaloz's
During last process, my router has been bricked.

After power led is 5 times blink, led is solid. and connected lan led on.
tftp connect not available.

I will buy ttl cable.

Must stock firm -> openwrt.
openwrt -> openwrt method have many risk.

:-)

Have you tried this?

http://wiki.openwrt.org/toh/linksys/wrt … ware_flash

Also, as a safeguard you should always uncheck "keep settings" if you are jumping between different firmwares built using different configs/revisions.


Yes, i did link method.
first step is not available(rest button hold...)
I always update at status of uncheck "keep settings".
I guess that must update stock firmware to openwrt.

Thank you.

dpdurst wrote:

Ok so this is strange I have the CC software loaded and its kind of working. However in the wireless network interfaces it has a password of the router and not my password for the wireless. I can change it but once I save it, it reverts back to the password for the router and won't keep the actual wireless pass. Is there a way to clear this out or clear the configuration files? I have tried several times to reflash and not save settings but still the password does not remove itself

I should clarify just in case, the key for the wireless security won't take

This shows up in the logs over and over for all my wireless connections

an  6 00:02:34 2015 daemon.info hostapd: wlan0: STA e8:ab:fa:02:83:65 IEEE 802.11: deauthenticated due to local deauth request
Tue Jan  6 00:02:35 2015 daemon.info hostapd: wlan0: STA e8:ab:fa:02:83:65 IEEE 802.11: associated (aid 3)
Tue Jan  6 00:02:37 2015 daemon.info hostapd: wlan0: STA e8:ab:fa:0b:42:32 IEEE 802.11: associated (aid 1)
Tue Jan  6 00:02:37 2015 daemon.info hostapd: wlan0: STA 9c:2a:70:06:b8:66 IEEE 802.11: deauthenticated due to local deauth request
Tue Jan  6 00:02:38 2015 daemon.info hostapd: wlan0: STA e8:ab:fa:02:83:65 IEEE 802.11: disassociated
Tue Jan  6 00:02:39 2015 daemon.info hostapd: wlan0: STA e8:ab:fa:0d:eb:3b IEEE 802.11: associated (aid 4)
Tue Jan  6 00:02:39 2015 daemon.info hostapd: wlan0: STA 9c:b6:54:9d:d5:2a IEEE 802.11: deauthenticated due to local deauth request
Tue Jan  6 00:02:41 2015 daemon.info hostapd: wlan0: STA 9c:b6:54:9d:d5:2a IEEE 802.11: associated (aid 2)

SSH into the router and then type "vi /etc/config/wireless"
then hit "i" to edit it change the passphrase to anything you want.

Then hit "ESC" then "ZZ"
Now type "wifi" this will reload the wifi config, enjoy

Abitrary wrote:
tusc wrote:
Abitrary wrote:

Hi, all

My router is bricked.
Kaloz's -> stock firm -> lifehacksback -> Kaloz's
During last process, my router has been bricked.

After power led is 5 times blink, led is solid. and connected lan led on.
tftp connect not available.

I will buy ttl cable.

Must stock firm -> openwrt.
openwrt -> openwrt method have many risk.

:-)

Have you tried this?

http://wiki.openwrt.org/toh/linksys/wrt … ware_flash

Also, as a safeguard you should always uncheck "keep settings" if you are jumping between different firmwares built using different configs/revisions.


Yes, i did link method.
first step is not available(rest button hold...)
I always update at status of uncheck "keep settings".
I guess that must update stock firmware to openwrt.

Thank you.

@Abitrary

I'm having the same exact issue and I have the console cable.
I'll do it tomorrow and update you

--
Aaron

jmschu02 wrote:
dpdurst wrote:

Ok so this is strange I have the CC software loaded and its kind of working. However in the wireless network interfaces it has a password of the router and not my password for the wireless. I can change it but once I save it, it reverts back to the password for the router and won't keep the actual wireless pass. Is there a way to clear this out or clear the configuration files? I have tried several times to reflash and not save settings but still the password does not remove itself

I should clarify just in case, the key for the wireless security won't take

This shows up in the logs over and over for all my wireless connections

an  6 00:02:34 2015 daemon.info hostapd: wlan0: STA e8:ab:fa:02:83:65 IEEE 802.11: deauthenticated due to local deauth request
Tue Jan  6 00:02:35 2015 daemon.info hostapd: wlan0: STA e8:ab:fa:02:83:65 IEEE 802.11: associated (aid 3)
Tue Jan  6 00:02:37 2015 daemon.info hostapd: wlan0: STA e8:ab:fa:0b:42:32 IEEE 802.11: associated (aid 1)
Tue Jan  6 00:02:37 2015 daemon.info hostapd: wlan0: STA 9c:2a:70:06:b8:66 IEEE 802.11: deauthenticated due to local deauth request
Tue Jan  6 00:02:38 2015 daemon.info hostapd: wlan0: STA e8:ab:fa:02:83:65 IEEE 802.11: disassociated
Tue Jan  6 00:02:39 2015 daemon.info hostapd: wlan0: STA e8:ab:fa:0d:eb:3b IEEE 802.11: associated (aid 4)
Tue Jan  6 00:02:39 2015 daemon.info hostapd: wlan0: STA 9c:b6:54:9d:d5:2a IEEE 802.11: deauthenticated due to local deauth request
Tue Jan  6 00:02:41 2015 daemon.info hostapd: wlan0: STA 9c:b6:54:9d:d5:2a IEEE 802.11: associated (aid 2)

SSH into the router and then type "vi /etc/config/wireless"
then hit "i" to edit it change the passphrase to anything you want.

Then hit "ESC" then "ZZ"
Now type "wifi" this will reload the wifi config, enjoy

Well while you were replying I loaded up AA and then reloaded CC with without saving settings the password takes now and the wireless devices are online. Viewing the config file shows the right password, however in Luci she still shows the login password to the router. Something is still not exactly correct. It would be nice to find a way to default all config files to make sure.

I've tried both the latest lifehacksback and kaloz images, and am only offered the bottom 5GHz. channels. Not seeing the top channels that I usually use. Nothing but channels 36-49 (as I recall) have been available in the latest images. I did set the US locale for both wireless radios, so that shouldn't have been the problem.

Anyone else seeing this? Any tricks that I'm missing here?

By the way, thanks to all for your enthusiastic and hard work *smile*! Gives me hope for this WRT1900AC, that there can be useful firmware for it.

RogerSC wrote:

I've tried both the latest lifehacksback and kaloz images, and am only offered the bottom 5GHz. channels. Not seeing the top channels that I usually use. Nothing but channels 36-49 (as I recall) have been available in the latest images. I did set the US locale for both wireless radios, so that shouldn't have been the problem.

Anyone else seeing this? Any tricks that I'm missing here?

By the way, thanks to all for your enthusiastic and hard work *smile*! Gives me hope for this WRT1900AC, that there can be useful firmware for it.

I just left the locale to be World and gain the extra 3DB of power. I get auto and 4 other choices all 40 and above as well. I don't have a problem with this but would think that 5G should show 35-64

dpdurst wrote:

Well while you were replying I loaded up AA and then reloaded CC with without saving settings the password takes now and the wireless devices are online. Viewing the config file shows the right password, however in Luci she still shows the login password to the router. Something is still not exactly correct. It would be nice to find a way to default all config files to make sure.

1. Flash to Stock Firmware
     1.1 uncheck keep settings
2. Flash to OpenWRT

You should be at default settings...but perhaps i'm mistaken

jmschu02 wrote:
dpdurst wrote:

Well while you were replying I loaded up AA and then reloaded CC with without saving settings the password takes now and the wireless devices are online. Viewing the config file shows the right password, however in Luci she still shows the login password to the router. Something is still not exactly correct. It would be nice to find a way to default all config files to make sure.

1. Flash to Stock Firmware
     1.1 uncheck keep settings
2. Flash to OpenWRT

You should be at default settings...but perhaps i'm mistaken


Tried and didn't work either

RogerSC wrote:

I've tried both the latest lifehacksback and kaloz images, and am only offered the bottom 5GHz. channels. Not seeing the top channels that I usually use. Nothing but channels 36-49 (as I recall) have been available in the latest images. I did set the US locale for both wireless radios, so that shouldn't have been the problem.

Anyone else seeing this? Any tricks that I'm missing here?

By the way, thanks to all for your enthusiastic and hard work *smile*! Gives me hope for this WRT1900AC, that there can be useful firmware for it.

Can confirm that (with my European country code set) in lifehacksback's build I only get auto or the four lower 5GHz channels.

Sounds like DFS support isn't present/enabled/working.  Perhaps one of the devs can confirm/investigate.

Not so much of an issue for me though as I'm the only 5GHz AP within range, so I have it all to myself smile

(Last edited by DavidMcWRT on 6 Jan 2015, 03:26)

After some trial and error and messing with the key on the wireless security, which still happens when making a new network. I'm all up and running with all devices (22 total) of ip camera's, laptops, tablets, printers, thermostats, smoke/co2 detectors and a guest network to go with it. Kudos for the software, running very nice!

(Last edited by dpdurst on 6 Jan 2015, 04:13)

DavidMcWRT wrote:

Question from me for once smile

Stock has a single button to turn off the LEDs (except for the power).

Can this be done in the current CC Trunk builds?

I know about the LED settings screen, but can only see options for "triggers" and wouldn't know how (if possible) to merely just disable (all) the various lights.

I don't own this router, following very closely and will hopefully purchase one soon.  To change the state of the LEDs in my AR71xx based router, I do the following:

echo 0 > "/sys/class/leds/netgear:green:power/brightness"
echo 0 > /sys/class/leds/ath9k-phy1/brightness
echo 0 > /sys/class/leds/ath9k-phy0/brightness
/sbin/swconfig dev rtl8366s port 1 set led 0

You can probably figure out the various sysfs files for this device's LEDs.

After I found these, I put the commands in my /etc/rc.local

Hope that helps

dpdurst wrote:
RogerSC wrote:

I've tried both the latest lifehacksback and kaloz images, and am only offered the bottom 5GHz. channels. Not seeing the top channels that I usually use. Nothing but channels 36-48 (as I recall) have been available in the latest images. I did set the US locale for both wireless radios, so that shouldn't have been the problem.

Anyone else seeing this? Any tricks that I'm missing here?

By the way, thanks to all for your enthusiastic and hard work *smile*! Gives me hope for this WRT1900AC, that there can be useful firmware for it.

I just left the locale to be World and gain the extra 3DB of power. I get auto and 4 other choices all 40 and above as well. I don't have a problem with this but would think that 5G should show 35-64

Yes, I'm expecting to see channels 149 and above, and none if those channels are available. I remember clearly that the first lifehacksback cc image that I used the other day (the one that had the kernel version before 3.18.1) did have channel 161, because I used it *smile*. So I expected to see that this time around. I don't expect to see the channels that require DFS yet, like channel 64.

Kind of odd, actually, there's usually at least one 5GHz. upper channel (149 or above) available even for early versions of firmware.

(Last edited by RogerSC on 6 Jan 2015, 04:36)

I'm using Kaloz's build and try to test the usb storage but I'm unable to mount. I tried two different usb thumb drive with one as hfsplus and the other one as exfat formatted.

By running "fdisk -l", here is the output.

Device     Boot Start       End   Sectors   Size Id Type
/dev/sda1  *     8064 246546431 246538368 117.6G  7 HPFS/NTFS/exFAT

By running "sfdisk -l", here is the output.

Disk /dev/sda: 15346 cylinders, 255 heads, 63 sectors/track
Units: cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/sda1   *      0+  15346-  15347- 123269184    7  HPFS/NTFS/exFAT
        start: (c,h,s) expected (0,128,1) found (1023,254,63)
/dev/sda2          0       -       0          0    0  Empty
/dev/sda3          0       -       0          0    0  Empty
/dev/sda4          0       -       0          0    0  Empty


When running dmesg, I can see the device is detected and sda device is created under /dev.

[16171.005105] usb 1-1: new high-speed USB device number 2 using orion-ehci
[16171.187199] usb-storage 1-1:1.0: USB Mass Storage device detected
[16171.193679] scsi host2: usb-storage 1-1:1.0
[16172.195872] scsi 2:0:0:0: Direct-Access              Patriot Memory   PMAP PQ: 0 ANSI: 6
[16172.205564] sd 2:0:0:0: [sda] 246546432 512-byte logical blocks: (126 GB/117 GiB)
[16172.214051] sd 2:0:0:0: [sda] Write Protect is off
[16172.218897] sd 2:0:0:0: [sda] Mode Sense: 2b 00 00 08
[16172.225307] sd 2:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[16172.313454]  sda: sda1
[16172.320053] sd 2:0:0:0: [sda] Attached SCSI removable disk

However, when trying to mount, I got this error and I don't see any error from dmesg output.

mount: mounting /dev/sda1 on /mnt/share failed: Invalid argument

Anyone know what the problem is? Maybe I need to use Lifehack's build.

(Last edited by LogicoZone on 6 Jan 2015, 06:49)

LogicoZone wrote:

I'm using Kaloz's build and try to test the usb storage but I'm unable to mount. I tried two different usb thumb drive with one as hfsplus and the other one as exfat formatted.

By running "fdisk -l", here is the output.

Device     Boot Start       End   Sectors   Size Id Type
/dev/sda1  *     8064 246546431 246538368 117.6G  7 HPFS/NTFS/exFAT

By running "sfdisk -l", here is the output.

Disk /dev/sda: 15346 cylinders, 255 heads, 63 sectors/track
Units: cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/sda1   *      0+  15346-  15347- 123269184    7  HPFS/NTFS/exFAT
        start: (c,h,s) expected (0,128,1) found (1023,254,63)
/dev/sda2          0       -       0          0    0  Empty
/dev/sda3          0       -       0          0    0  Empty
/dev/sda4          0       -       0          0    0  Empty


When running dmesg, I can see the device is detected and sda device is created under /dev.

[16171.005105] usb 1-1: new high-speed USB device number 2 using orion-ehci
[16171.187199] usb-storage 1-1:1.0: USB Mass Storage device detected
[16171.193679] scsi host2: usb-storage 1-1:1.0
[16172.195872] scsi 2:0:0:0: Direct-Access              Patriot Memory   PMAP PQ: 0 ANSI: 6
[16172.205564] sd 2:0:0:0: [sda] 246546432 512-byte logical blocks: (126 GB/117 GiB)
[16172.214051] sd 2:0:0:0: [sda] Write Protect is off
[16172.218897] sd 2:0:0:0: [sda] Mode Sense: 2b 00 00 08
[16172.225307] sd 2:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[16172.313454]  sda: sda1
[16172.320053] sd 2:0:0:0: [sda] Attached SCSI removable disk

However, when trying to mount, I got this error and I don't see any error from dmesg output.

mount: mounting /dev/sda1 on /mnt/share failed: Invalid argument

Anyone know what the problem is? Maybe I need to use Lifehack's build.

Most likely they are not in his build. If you look at this link there are only two file system modules listed, ext4 and vfat (fat32). https://downloads.openwrt.org/people/ka … ages/base/ - search for kmod-fs on the page.

http://wiki.openwrt.org/doc/howto/usb.s … sb_storage

OK, for anyone worried about fan control, here's a patch to enable fan control:
https://drive.google.com/open?id=0BwDQ7 … FhCaWpLM0E
(you can apply the patch with git apply)

The script adds a init script (/etc/init.d/fan_control) which runs a script (/usr/sbin/fan_monitor) to control the fan.

The default behavior turns on the fan more quickly than the Belkin script:

- Fan turns ON full when any of CPU/DDR/WiFi are at or above 85/65/75C
- Fan turns OFF when all of CPU/DDR/WiFi are at or below 80/60/70C

The Belkin defaults are the same, except for WiFi which didn't turn on until 105C. 105C seemed crazy, so I set it to a lower value.

My router never gets hot enough that the fan even runs with this script (I'm at 60C CPU / 50C DDR / 54C WiFi right now) so you may not need this anyway, but it's a bit of extra insurance in case you need it.

I would be happy to work with Kaloz or anyone else to get this into mainline if it makes sense. I work for Google and the easiest process is for Google to hold the copyright and to release it under the GPLv2 (I already have an explicit OK for this patch). I don't believe OpenWRT requires copyright assignment, but if you do it's possible but a bit more involved on my part.

Howdy! i been following this for ages now, im currently running the latest Kaloz build and used to run MCWRT.
Thanks all for the major efforts on getting this running and the constant work on it.

As a quick fix for the fan control in the meantime im running a cron job every minute to check the cpu temp(as the fan seems to be on top of it) and then using awk i make it put 0 or 1 if the temp is higher than 65 or lower than 65 .
sensors | grep cpu | awk {yourscript}


Question now, any reason why the MCS never goes beyond 0?
Also did anyone notice the power adjust does not work?

Cheers and thanks for the effort again, happy to help/test/etc.

bsoft wrote:

The Belkin defaults are the same, except for WiFi which didn't turn on until 105C. 105C seemed crazy, so I set it to a lower value.

For WiFi even 80-90 is on the safe side smile

bsoft wrote:

I would be happy to work with Kaloz or anyone else to get this into mainline if it makes sense. I work for Google and the easiest process is for Google to hold the copyright and to release it under the GPLv2 (I already have an explicit OK for this patch). I don't believe OpenWRT requires copyright assignment, but if you do it's possible but a bit more involved on my part.

We don't need copyright reassignment, but would be nicer to make this implemented in a daemon instead. Anyways, in the meantime I'm happy to take the patch is you send it with a "Signed-off-by" to me and the development list.