OpenWrt Forum Archive

Topic: TP-Link Archer C2 AC750 support

The content of this topic has been archived between 30 Mar 2018 and 5 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Okay, now I really have the C2 here.
I would like to add support for this router to OpenWRT. Where should I start?
It looks like for start supporting I should create a file target/linux/ramips/dts/archer_c2.dts and put there some data.

At the moment I'm reading about adding new device (openwrt does support platform already, right?).

Any tips and hints are really appreciated.

Okay, Here is bootlog:

What can I do next? create a generic image and try to put it into the router?


thanks for trying to support this device. But I am really curious why  already list this device "openwrt-ready" .....: 

Did tp-link sponsored a box of c2 devices to the openwrt community for free? :-) Would be very nice of then, though:-)


Nor Archer C2 neither c20i are supported by OpenWRT. Probably it is just a error in description?
nope, tp-link didn't sponsored it. Unfortunately

Still need some help - just an idea - what to do next.
I'm going to build kernel and initramfs image for mt7620a_mt7610e and upload it to the device via TFTP. Not sure if it will brick the device.

Any help is very appreciated.

I logged into OEM firmware (admin /1234). But I'm not sure what it can give me. There are no /sys/class/gpio (for getting GPIO info).

Is it possible to load a kernel into memory (from bootloader) and try to start it without flashing it into chip?

Today I tried to flash openwrt uimage.bin file with commands

tftp 81000000 uimage.bin
cp.linux 81000000

and now I see only

## Booting image at bc020000 ...
   Uncompressing Kernel Image ... LZMA ERROR 1 - must RESET board to recover

and then the router reboots.

Any ideas what can be wrong here?

Do we have a manual somewhere about creating target/linux/ramips/dts/ files?

Is there progress in the topic? I have the Archer C20i here and stuck at the same point.

No news. At the moment I'm waiting for new C2 router as I killed previous one smile

I would be glad to hear something new from you.

I have tested several images with booting from flash or from memory.
But every time I only got this message:

Uncompressing Kernel Image ... LZMA ERROR 1 - must RESET board to recover

It's the same if I use the MTK SDK. I guess it's a problem with the TP-Link bootloader.

Can someone please post the serial port assignment of the J2 header for the Archer C2 AC750?

I just recieved one of these and hope to get openwrt on it.

Thank you

You should can see it on the board. The square pad is VCC. (You don't need this one.) The next is GND. The both other are RX/TX. Baud rate is 115200.

Thanks bd03E

I see a four pin header without any silk screening on it. I'll go for it.

I have the firmware already compiled for it so this is my next step.

The LZMA Problem is solved. But the Kernel didn't start.

U-Boot 1.1.3 (Jun 23 2014 - 15:14:15)

Board: Ralink APSoC DRAM:  64 MB
relocate_code Pointer at: 83fb0000
enable ephy clock...done. rf reg 29 = 5
SSC disabled.
Archer C20i v1.0.0
spi_wait_nsec: 29
spi device id: ef 40 17 0 0 (40170000)
find flash: W25Q64BV
Ralink UBoot Version:
ASIC 7620_MP (Port5<->None)
DRAM component: 512 Mbits DDR, width 16
DRAM bus: 16 bit
Total memory: 64 MBytes
Flash component: SPI Flash
Date:Jun 23 2014  Time:15:14:15
icache: sets:512, ways:4, linesz:32 ,total:65536
dcache: sets:256, ways:4, linesz:32 ,total:32768

 ##### The CPU freq = 580 MHZ ####
 estimate memory size =64 Mbytes

continue to starting system.                                                                                                                                              0
disableEthForward(1158):disable switch forward...

3: System Boot system code via Flash.(0xbc020000)
do_bootm:argc=2, addr=0xbc020000
## Booting image at bc020000 ...
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 00000000) ...
## Giving linux memsize in MB, 64

Starting kernel ...

yeah I got that LZMA error also.

Need to find out why the no initrd is in there. seems like it is not passing the command line to the kernel

I guess the 'No initrd' does not matter. It's also there with the original TP-Link firmware.

But why u-boot don't get the memory address configures in the image?

## Transferring control to Linux (at address 00000000) ...

have you modified the mktplinkfw to fixup the header for the C2?

I have also set the kernel compress to LZMA in the kernel config still get that LZMA error

The header from the original firmware looks like a version 2 header. But the mktplinkfw2 tool can not read the file...

3: System Boot system code via Flash.(0xbc020000)
do_bootm:argc=2, addr=0xbc020000
## Booting image at bc020000 ...
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 00000000) ...
## Giving linux memsize in MB, 64

Starting kernel ...

Unhandled kernel unaligned access[#1]:
Cpu 0
$ 0   : 00000000 00000000 0000000a b0000c1c
$ 4   : 00000001 83f4ffb0 83f503b0 00000000
$ 8   : 83f4fe90 ffffffff 00000001 00000005
$12   : 00000000 83f4fdc8 00000002 83fcaa70
$16   : 83fe0000 83fe0000 83fc69c0 1fffffff
$20   : 83fe0000 00000000 83fe0000 00000000
$24   : 00000020 00000000                 
$28   : 83fcc8e0 83f4fe70 83fe0000 83fc7290
Hi    : 00000008
Lo    : 00000000
epc   : abbeb184 0xabbeb184
    Not tainted
ra    : 83fc7290 0x83fc7290
Status: 00000002    KERNEL EXL
Cause : 40008014
BadVA : 00007eae
PrId  : 00019650 (MIPS 24Kc)
Modules linked in:
Process swapper (pid: 1, threadinfo=83c18000, task=83c17958, tls=00000000)
*HwTLS: e311cd55
Stack : 00000000 80000000 1fffffff fffffff6 83fcc8e0 83f4fe9c 30387830 30303030
        00003000 83fcd000 00000000 00000000 00000000 00000000 bc020200 bc020000
        00000002 83f4ff50 83fcd03c 00000000 83ffddc4 83fbaa70 83fcd03c 83f4fef0
        00000000 00000000 bc020000 00000000 00000000 00000033 83fcc8e0 83fcd03c
        00000000 00000000 00000032 00000033 ffffffff 83fcd03c 00000102 00000000
Call Trace:

Code: e2ee2e2e  ae0a2f6e  2eaa7f2e <aea27eae> aeef6e6e  bfea6e2e  aeae246e  2aaa2f6e  2aaa2dee
Disabling lock debugging due to kernel taint
Kernel panic - not syncing: Attempted to kill init!

Your further than me I'm stuck at bootup still.

I might rewrite the bootloader for this damn thing.