OpenWrt Forum Archive

Topic: P-2812HNU-FX: getting OpenWrt installed

The content of this topic has been archived between 6 Jun 2015 and 5 May 2018. Unfortunately there are posts – most likely complete pages – missing.

i got my initramfs file from github. I mean 60 B/s.

My TFTP server is my router as it works much better than windows tftpd you mentioned and it transfers at gigabit speeds like 80+MB/s rather than the 8MB/s you got.

Essentially what i want to do is bridge DSL to WAN and connect WAN to my router, and connect LAN to my router also for management and openwrt stuff and perhaps even use the phone ports too. 100% CPU usage is fine as long as it means modem is getting priority but as i have read it seems to be a DHCP issue.

I dont want to use the ISP's included hardware because of security issues.

System Error Message,

'initramfs file from github' doesn't ring a bell for me, could be a version for i86, ARM, linux, anything ...
How sure are you it's build for a ZyXEL P-2812-HNU(L)-F1? Why not try my build first, as it's specially build for an F1 and works! You can always up/downgrade to other F1 versions.

All my TFTP uploads went between 0 and 1 second, even the uImage file 4.6MB
TFTP is your router? Where are the files to be uploaded, i guess NOT locally, as i wrote earlier they SHOULD be. I can understand your long(er) uploads now. I even don't use USB devices to hold my files to be uploaded by TFTP as they are too slow.

'Bridge DSL to WAN and connect WAN to my router' and you don't want to use ISP hardware?
Which 'router' do you mean? Can't make much out of your message regarding router, management, and also connect LAN to the router? (LAN -connect to- LAN won't work with any router!)
A clear picture would tell the story much easier i guess...

Why not ONLY use one F1?                 DSL - F1 - WAN & LAN  & WLAN as LAN ports ?

100% CPU means device looks dead on web interface or DHCP requests, and very slow response on SSH sessions, i think you don't want that.

BTW, the continue of flashing my 4th F1 with all loggings can be found here.
Without the last update -to r48507- it has functionality of DSL (i thought even PTM & ATM, depends on files used).

My router is the mikrotik CCR1036 so ofcourse i would want to use that for routing. It also has a tftp server and less limitations than my PC has for configuring networks. This means i can just attach a router i want to configure to it and i wont even need to change any ip addresses or worry about lack of NICs. I also run a tftp server on it as well and it has a micro SD card to store the files on it.

I first download the files to PC than upload it to my router. The modem i dont want to use is the bt homehub 5 which cant install openwrt at the momeny and has some security vulnerabilities not even addressed. I also have my own wireless AC access points.

From github i specifically used the ones for the p2812fnu fx1.

What i plan to do is plug VDSL into the zyxel modem, bridge it with the WAN port, plug WAN port into my CCR, and plug a LAN port back into zyxel so that i can use it as both a modem and a device to run openwrt things on.

I compared both the bits on the file from PC and on the router and both match so file corruption did not happen on my end and my router has handled much larger images without any issues.

I read your logs and your tutorial about install openwrt. I couldnt find where you got your files unless if they are in the openwrt archive somewhere.

System Error Message,

Explaination about your CCR1036 makes more clear smile
Although i doubt the internal TFTP reaches 80MB upload from micro SD card. But it's no showstopper.

The files i used are from scapi and my own builds on my own server, downloadable from within this post:
https://forum.openwrt.org/viewtopic.php … 99#p329499
You could try the initramfs file from my build, it does work.

Thanks, i'll give it a try soon and let you know how it goes. I will also measure power consumption. If this is lower than 10W it would beat bt homehub 5. Although there are 2 variants of the bt homehub, the lantiq CPU (same one used in this but dual core) uses 10W, the broadcom MIPS uses 15W. Every watt i save counts as it means less heat and less bills for things that stay on all the time.

i tried both the files from scapi and from openwrt download and both gave the same error

Verifying Checksum ... OK
   Uncompressing Kernel Image ... LZMA: uncompress or overwrite error 7 - must RESET b
DGDodo wrote:

BAJansen,
courfazor,

You wrote: 'ZyXEL P-2812HNU-F3 is extremely old',
but still it's a good & nice 1GB switch running OpenWrt! Even with the nice webGUI, -although indeed without DSL functionality- one of my F1's  does it's job now 63d 19h 59m 37s without any issues, with Linux 4.4 already  ...
(and i'm also some inactive here -lately- wink )
So building a 'simple' OpenWrt is not needed, you could just build default with some things extra (i also run Privoxy within my router)

You say that, but I kinda relied on @scapi which got his router fried over power issues to make the images. Something he won't bother with, well I'm happy he even made those 10 months ago thanks wink. The router is fine, no questioning that, but the WAN/LAN makes it hard. I tried compiling my own P-2812HNU-F3 before, and ended up with having the DHCP (dnsmasq) down (more or less not giving me lease) or some errors on the web interface. Not only that, but scapi fixed the WAN by having it put up with what we discussed earlier in a mode where he seperate wan/lan and it could drop the firewall or something and need manual restart, unless a script can do that. Hence why I thought it could be good as a switch.

So, what I can think of is if I use the router and make it on the LAN interface, but that will make the TX ring errors and then lead to horrible Wi-Fi, which is not good enough for this router. I did it before, and the errors were so man untill in the end the whole Wi-Fi went compeltely down. That makes it hard to have any use of it except ethernet-wise, it doesn't help that I am not that good in making images. But that's just my words for it, maybe seperating WAN/LAN solution can work, but since I do not know how to put this in effect when I make an image for my router I have no way of trying it out. I can't be using it with bad Wi-Fi either. DSL port I don't need, DSL is dead here, all fiber now.

(Last edited by courfazor on 9 Jul 2016, 00:09)

DGDodo wrote:

System Error Message,


The files i used are from scapi and my own builds on my own server, downloadable from within this post:
https://forum.openwrt.org/viewtopic.php … 99#p329499
You could try the initramfs file from my build, it does work.

# Nice, to have all the necessery files in one folder.
DGDodo thanks.
a little remark: wrong filename by chapter 8.
step    used program    file
8    WINSCP        openwrt-lantiq-xrx200-P2812HNUF1-ubifs-ubinized.bin

But no problem at all.
greatings Ad.

I'am doing exaclty as DGDodo described with his r45269 files and getting exactly the same outputs, but after running kernel i run into problems.

P-2812HNU-Fx # bootm 0x80800000
## Booting kernel from Legacy Image at 80800000 ...
   Image Name:   MIPS OpenWrt Linux-3.18.10
   Created:      2015-04-04  23:46:13 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    4718520 Bytes = 4.5 MiB
   Load Address: 80002000
   Entry Point:  80002000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK

Starting kernel ...

[    0.000000] Linux version 3.18.10 (sylwek@WRT) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r44945) ) #2 Sun Apr 5 01:45:49 CEST 2015
[    0.000000] SoC: VR9 rev 1.1
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019555 (MIPS 34Kc)
[    0.000000] MIPS: machine is P2812HNUF1 - ZyXEL P-2812HNU-F1
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 08000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x07ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x07ffffff]
[    0.000000] Initmem setup node 0 [mem 0x00000000-0x07ffffff]
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
[    0.000000] Kernel command line: console=ttyLTQ0,115200 init=/etc/preinit
[    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Writing ErrCtl register=00014b20
[    0.000000] Readback ErrCtl register=00014b20
[    0.000000] Memory: 121772K/131072K available (3506K kernel code, 149K rwdata, 1036K rodata, 3160K init, 206K bss, 9300K reserved)
[    0.000000] NR_IRQS:256
[    0.000000] CPU Clock: 500MHz
[    0.000000] Calibrating delay loop... 332.54 BogoMIPS (lpj=665088)
[    0.032000] pid_max: default: 32768 minimum: 301
[    0.036000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.040000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.044000] pinctrl core: initialized pinctrl subsystem
[    0.052000] NET: Registered protocol family 16
[    0.060000] pinctrl-xway 1e100b10.pinmux: Init done
[    0.064000] dma-xway 1e104100.dma: Init done - hw rev: 7, ports: 7, channels: 28
[    0.168000] dcdc-xrx200 1f106a00.dcdc: Core Voltage : 1016 mV
[    0.172000] PCI host bridge /fpi@10000000/pci@E105400 ranges:
[    0.176000]  MEM 0x0000000018000000..0x0000000019ffffff
[    0.180000]   IO 0x000000001ae00000..0x000000001affffff
[    0.192000] gpio-stp-xway 1e100bb0.stp: Init done
[    0.196000] usbcore: registered new interface driver usbfs
[    0.200000] usbcore: registered new interface driver hub
[    0.204000] usbcore: registered new device driver usb
[    0.208000] PCI host bridge to bus 0000:00
[    0.212000] pci_bus 0000:00: root bus resource [mem 0x18000000-0x19ffffff]
[    0.216000] pci_bus 0000:00: root bus resource [io  0xffffffff]
[    0.220000] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.224000] pci 0000:00:0e.0: BAR 0: assigned [mem 0x18000000-0x1800ffff]
[    0.228000] Switched to clocksource MIPS
[    0.232000] NET: Registered protocol family 2
[    0.236000] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.244000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.252000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.256000] TCP: reno registered
[    0.260000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.268000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.272000] NET: Registered protocol family 1
[    5.136000] gptu: totally 6 16-bit timers/counters
[    5.140000] gptu: misc_register on minor 63
[    5.144000] gptu: succeeded to request irq 126
[    5.152000] gptu: succeeded to request irq 127
[    5.156000] gptu: succeeded to request irq 128
[    5.160000] gptu: succeeded to request irq 129
[    5.164000] gptu: succeeded to request irq 130
[    5.168000] gptu: succeeded to request irq 131
[    5.172000] ralink,eeprom ralink_eep: using RT3062.eeprom as eeprom
[    5.180000] phy-xrx200 gphy-xrx200: requesting lantiq/vr9_phy11g_a1x.bin
[    5.188000] phy-xrx200 gphy-xrx200: booting GPHY0 firmware at 6A60000
[    5.192000] phy-xrx200 gphy-xrx200: booting GPHY1 firmware at 6A60000
[    5.300000] futex hash table entries: 256 (order: -1, 3072 bytes)
[    5.308000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    5.312000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    5.324000] msgmni has been set to 237
[    5.328000] io scheduler noop registered
[    5.332000] io scheduler deadline registered (default)
[    5.340000] 1e100c00.serial: ttyLTQ0 at MMIO 0x1e100c00 (irq = 112, base_baud = 0) is a lantiq,asc
[    5.348000] console [ttyLTQ0] enabled
[    5.348000] console [ttyLTQ0] enabled
[    5.356000] bootconsole [early0] disabled
[    5.356000] bootconsole [early0] disabled
[    5.364000] nand: device found, Manufacturer ID: 0xec, Chip ID: 0xf1
[    5.364000] nand: Samsung NAND 128MiB 3,3V 8-bit
[    5.364000] nand: 128MiB, SLC, page size: 2048, OOB size: 64
[    5.380000] Scanning device for bad blocks
[    5.424000] Bad eraseblock 755 at 0x000005e60000
[    5.444000] 4 ofpart partitions found on MTD device 10000000.nand-parts
[    5.448000] Creating 4 MTD partitions on "10000000.nand-parts":
[    5.452000] 0x000000000000-0x000000040000 : "uboot"
[    5.460000] 0x000000040000-0x000000060000 : "uboot-env"
[    5.464000] 0x000000060000-0x000000260000 : "kernel"
[    5.468000] 0x000000260000-0x000008000000 : "ubi"
[    5.576000] libphy: lantiq,xrx200-mdio: probed
[    5.600000] net-xrx200: invalid MAC, using random
[    5.668000] eth0: attached PHY [Lantiq XWAY VR9 GPHY 11G v1.3] (phy_addr=0:00, irq=-1)
[    5.736000] eth0: attached PHY [Lantiq XWAY VR9 GPHY 11G v1.3] (phy_addr=0:01, irq=-1)
[    5.804000] eth0: attached PHY [Lantiq XWAY VR9 GPHY 11G v1.4] (phy_addr=0:11, irq=-1)
[    5.872000] eth0: attached PHY [Lantiq XWAY VR9 GPHY 11G v1.4] (phy_addr=0:13, irq=-1)
[    5.940000] eth0: attached PHY [Lantiq XWAY VR9 GPHY 11G v1.3] (phy_addr=0:05, irq=-1)
[    5.948000] wdt 1f8803f0.watchdog: Init done
[    5.952000] TCP: cubic registered
[    5.956000] NET: Registered protocol family 17
[    5.960000] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[    5.972000] Bridge firewalling registered
[    5.976000] 8021q: 802.1Q VLAN Support v1.8
[    5.984000] UBI error: ubi_auto_attach: no valid UBI magic found i[    5.996000] Freeing unused kernel memory: 3160K (8049a000 - 807b0000)
[    6.020000] init: failed to symlink /tmp -> /var
[    6.020000] init: Console is alive
[    6.028000] init: - watchdog -
[    6.056000] dwc2 1e101000.ifxhcd: requested GPIO 489
[    6.916000] dwc2 1e101000.ifxhcd: DWC OTG Controller
[    6.916000] dwc2 1e101000.ifxhcd: new USB bus registered, assigned bus number 1
[    6.924000] dwc2 1e101000.ifxhcd: irq 62, io mem 0x00000000
[    6.932000] dwc2 1e101000.ifxhcd: Hardware does not support descriptor DMA mode -
[    6.932000] dwc2 1e101000.ifxhcd: falling back to buffer DMA mode.
[    6.944000] hub 1-0:1.0: USB hub found
[    6.948000] hub 1-0:1.0: 1 port detected
[    7.812000] dwc2 1e106000.ifxhcd: DWC OTG Controller
[    7.812000] dwc2 1e106000.ifxhcd: new USB bus registered, assigned bus number 2
[    7.820000] dwc2 1e106000.ifxhcd: irq 91, io mem 0x00000000
[    7.828000] dwc2 1e106000.ifxhcd: Hardware does not support descriptor DMA mode -
[    7.828000] dwc2 1e106000.ifxhcd: falling back to buffer DMA mode.
[    7.840000] hub 2-0:1.0: USB hub found
[    7.844000] hub 2-0:1.0: 1 port detected
[    8.028000] init: - preinit -
[    8.140000] random: procd urandom read with 31 bits of entropy available
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[   11.248000] procd: - early -
[   11.252000] procd: - watchdog -
[   11.816000] procd: - ubus -
[   12.828000] procd: - init -
Please press Enter to activate this console.
[   13.856000] IFXOS, Version 1.5.14 (c) Copyright 2009, Lantiq Deutschland GmbH

[   13.884000] NET: Registered protocol family 10
[   13.892000] NET: Registered protocol family 8
[   13.892000] NET: Registered protocol family 20
[   13.904000] PPP generic driver version 2.4.2
[   13.916000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   13.936000] MEI CPE Driver, Version 1.2.0

[   13.936000] (c) Copyright 2009, Infineon Technologies AG
### MEI CPE - MEI CPE - MEI CPE - MEI CPE ###


Lantiq CPE API Driver version: DSL CPE API V4.11.4
[   13.960000]
[   13.960000] Predefined debug level: 2
[   13.972000] Loading modules backported from Linux version master-2015-03-09-0-g141f155
[   13.976000] Backport generated by backports.git backports-20150129-0-gdd4a670
[   13.988000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   14.000000] Infineon Technologies DEU driver version 2.0.0
[   14.004000] IFX DEU DES initialized (multiblock).
[   14.008000] IFX DEU AES initialized (multiblock).
[   14.012000] IFX DEU ARC4 initialized (multiblock).
[   14.020000] IFX DEU SHA1 initialized.
[   14.020000] IFX DEU MD5 initialized.
[   14.024000] IFX DEU SHA1_HMAC initialized.
[   14.028000] IFX DEU MD5_HMAC initialized.
[   14.040000] nf_conntrack version 0.5.0 (1952 buckets, 7808 max)
[   14.068000] NET: Registered protocol family 24
[   14.092000] xt_time: kernel timezone is -0000
[   14.112000] cfg80211: Calling CRDA to update world regulatory domain
[   14.136000] cfg80211: World regulatory domain updated:
[   14.136000] cfg80211:  DFS Master region: unset
[   14.144000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   14.152000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   14.160000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   14.168000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   14.176000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   14.184000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[   14.192000] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   14.200000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   14.208000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   14.304000] PCI: Enabling device 0000:00:0e.0 (0000 -> 0002)
[   14.308000] rt2800pci 0000:00:0e.0: failed to load eeprom property
[   14.312000] ieee80211 phy0: rt2x00lib_request_eeprom_file: Info - Loading EEPROM data from 'RT3062.eeprom'.

After that it just reboots. Any solution to that?

kurjam:

The first rows are already different then mine log.
    strange too: 5.984000] UBI error: ubi_auto_attach: no valid UBI magic found i[
so my advice is: repeat the hole procedure again, (from When CFG 02 UART Popups in terminal), and watch after each step for strange errors.

ad.ven,
Thanks 4 comments, and is adjusted (step8).

Kurjam,
As ad.ven wrote, do the complete flash again, watch all loggings closely and with no error it will mostly fix any issues.

System Error Message,
You wrote: "i tried both the files from scapi and from openwrt download and both gave the same error"
Did you try my files (yet)? As other ppl say it works like it should be. when you try my files, only use all files within my package, mixing up files with other builds could/will result in any error. It could also be that your device is bricked already, did the router ever worked before as it should be?

So yeah, if you didn't get it already: F3 had some issues with the Wi-Fi driver and the ports being as it is normally. I have no idea what @scapi did to his build to seperate WAN with LAN, which introduced some kind of security concern. But it sure fixed the Wi-Fi. But I guess you could disable Wi-Fi completely to have all the other functionality in tact as it should be. So that kind of solves my problem either way. It can function perfectly as an advanced switch nonetheless smile

(Last edited by courfazor on 22 Jul 2016, 15:43)

jsface wrote:

Things get worse I think, we I power on the only I get is:

ROM VER: 1.0.5
CFG 06
NAND
NAND Read OK

Any help?

ralink 3062 wifi chip dead

DGDodo wrote:

devill_08,

You should go to UART mode: CFG 04, short R15 and R24 located near NAND
And NOT short R15 with R24 wink

Only in CFG 04 mode you're able to rewrite your device, following the steps written in above link.
It's sometimes difficult to even short 1 of those small spots (needed for a F1 device).
If you don't get @ CFG 04, in my opinion, the device is bricked.

I'm having the same issue as devill_08
On F3 no matter what I do I can't get into CFG 04. I can get into CFG 02 if I short R17.
And I can confirm that my router works otherwise, I've just booted it up as it was before.

What can I do? R24 and R15 look different than R17, is there some special way on how to short them?
I've even tried using graphene from pen and what not. I'm trying to short R24 separately and R15 separately.

Here is a picture of my router, it looks a little bit different that what I've seen here, I repeat this is F3.
I've marked what I expected to be shorted, I've also tried to short pin R23 I guess (above first red line) in desperation but to no avail

(just add protocol in front of url, I'm not allowed to post links/images)
s18.postimg.org/hfp5mlo7t/IMG_2874.jpg

some1,

The picture you show, contains a SAMSUNG 234 K9F1G08U0D chip, which ONLY fit's on a F1 device as this is a NAND chip, not a NOR chip which is on a F3 device.

Also the picture https://wiki.openwrt.org/_detail/media/ … 2812hnu-f3
@ the UART specs: https://wiki.openwrt.org/toh/zyxel/p2812hnu-f3
Shows a 'B' version chip, which is on a F3 device.

The picture @ the F1 UART (https://wiki.openwrt.org/_detail/media/ … 2812hnu-f1) shows also a 'D' chip, as on your photo?

Are you really, 100%, really, sure you are using a F3 device ??

In my opinion the board is from a F1 device ...

The model on the case definitely states that it is a F3 device and router looked to me like it wasn't tampered. On the other hand, I got it from openwrt developer so I guess that's definitely an option. I'll try to boot F1 u-boot from ram in CFG 02 and see if that get's me up and running. Thanks!

Yes DGDodo, that was it. I flashed and upgraded to latest version from gcomsys.noip.me/phpbb/viewtopic.php?f=19&t=64#p186
Works as expected, thanks again!

I know it.

F3 has NOR chip on other side of PCB (NAND is where CPU and other stuff is placed), F3 can boot F1 U-boot but will skip NOR init (it is used for U-Boot only).

Hi all,

Not entirely the correct forum perhaps, but because this is the default modem for my provider... Can someone perhaps help me (re)configuring my modem for my provider?
I managed to get OpenWrt running using the wiki and the modifications from this forum, and after some fiddling also VDSL and wifi seem to work.

OpenWrt says:

Status: UP
Line State: showtime_tc_sync [0x801]
Line Speed: 31.804 Mb/s / 3.632 Mb/s
Line Attenuation: 25.3 dB / 0 dB
Noise Margin: 6.2 dB / 5.8 dB

However, there is (of course) no direct mapping from the old firmware names to the new ones. Especially, the VLAN cannot be set.
Old config was: VDSL     Routing     IPoE     VLAN priority 1, VLAN ID 34
I could find no single place where to fill in the VLAN. Some searching on the net led me to know that it's something with 802.1q, however my ADSL knowledge is still a bit in the ADSL-age. I don't know if the VLAN is neccesary, since I don't have IPTV or telephony.
My provider says the settings should be:
    Telfort
    PPPoE
    VLAN: 34
I tried: DHCP (=IPoE??), "Hostname to send when requesting DHCP" => Telfort. This does not seem to work.
I also tried: PPPoE with access concentrator 34, service name Telfort. No username and password, since I'm quite sure they're not needed.
Both do not work... DSL sync is there, but no internet connection.

/etc/config/network is currently:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd9d:ac81:6a94::/48'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ifname 'eth0.1'
        option macaddr '00:01:02:03:04:05'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 4 5 6t'
                                               
config atm-bridge 'atm'                        
        option vpi '0'                         
        option vci '34'                        
        option encaps 'llc'                    
        option payload 'bridged'          
                                          
config interface 'wan'                    
        option ifname 'nas0'              
        option _orig_ifname 'nas0'        
        option _orig_bridge 'false'       
        option proto 'dhcp'               
        option hostname 'Telfort'         
                                          
config interface 'wan6'                   
        option ifname '@wan'       
        option proto 'dhcpv6'      
        option reqaddress 'try'    
        option reqprefix 'auto'    
        option macaddr 'CC:5D:4E:<secret ;-)>'
                                          
config vdsl 'dsl'                         
        option annex 'a'                  
        option firmware '/lib/firmware/vdsl.bin'
        option tone 'av'                        
        option xfer_mode 'ptm'            

I tried stuff with overriding MAC addresses (writing down the one on the bottom), but that didn't seem to help. Does anyone know where to continue?

Luckily I bought a used modem as a backup, so I have all the time to go back and forth between the old and new configs...

BTW, am I correct in that I cannot update the Wiki? I'd like to update it with 'more correct' information. smile

(Last edited by zeekoe on 12 Dec 2016, 23:21)

Finally, after a lot of trial and error and searching...
For future reference for others:

config interface 'loopback'        
        option ifname 'lo'         
        option proto 'static'      
        option ipaddr '127.0.0.1'  
        option netmask '255.0.0.0' 
                                   
config globals 'globals'           
        option ula_prefix 'fdc9:fb7a:d338::/48'
                                
config interface 'lan'          
        option force_link '1'   
        option type 'bridge'    
        option proto 'static'
        option ipaddr '192.168.1.1'             
        option netmask '255.255.255.0'          
        option ip6assign '60'                   
        option ifname 'eth0.1'                  
        option macaddr '00:01:08:03:04:05'      
                                                
config switch                                   
        option name 'switch0'                   
        option reset '1'                        
        option enable_vlan '1'                  
                                                
config switch_vlan            
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 4 5 6t'

config atm-bridge 'atm'                   
        option encaps 'llc'                     
        option payload 'bridged'                
        option vci '34'                         
        option vpi '0'                          
                                                
config interface 'wan'                          
    option proto 'dhcp'                         
    option ifname 'ptm0.34'                     
    option service 'Telfort'                    
    option mtu '1480'                           
                                                
config vdsl 'dsl'                  
        option annex 'a'           
        option firmware '/lib/firmware/vdsl.bin'
        option tone 'av'                        
        option xfer_mode 'ptm'

Not sure if the mtu option is needed.

I have installed CC 15.5.01 on my 2812 F1 router.
After installing I cannot reboot from the CLI. I have to turn the
router off and on with the power switch.

The serial interface gives after the [reboot] command:

ROM VER: 1.0.5
CFG 06
NAND
NAND Read OK

U-Boot SPL 2013.10-openwrt5 (Nov 18 2014 - 19:54:01)
SPL: initializing NAND flash
SPL: checking U-Boot image
SPL: loading U-Boot to RAM
SPL: decompressing U-Boot with LZO
SPL: cannot start U-Boot

I could softboot when I had installed BB.

Any ideas?

Question
Does somewone have wifi working on 2812 F1? When connected using wifi, at the moment I connect LAN, I get these symptoms:

  • in log the infamous "ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2"

  • On the laptop the ping dropping to >100 ms for a few pings until it finally dies.

  • On my phone downlink consitently at ~100 kbps, uplink 0 kbps or tens of seconds.

The last several pages of this thread suggest that people are using the router happily. I tried the following:

  • Mode N, mode Legacy

  • Channels 3 and 6

  • The wifireboot script

  • Loading the module with nohwcrypt option

  • Different LAN ports, even disabling other ports in switch

  • Different firmware files

  • With or without some firmware files

Rebooting many times in between.

I'm using:

root@OpenWrt:~# cat /etc/banner
  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (15.05.1, r48532)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------

with before-posted /etc/config/network and

root@OpenWrt:/lib/firmware# md5sum /lib/firmware/*
20e4d2a890984f149b97120489244fd8  /lib/firmware/RT3062.eeprom
68c703977277e9ac16597d1ca519f7ec  /lib/firmware/rt2860.bin
965315f69fab212fa8d1493401ec4daa  /lib/firmware/rt3062.bin.DISABLED
6feba8f8f939fed82d049ae13bc2cf96  /lib/firmware/vdsl.bin

and also tried

75a1da3caa0b1c95e81dfba207f834c6  rt2860.bin

Problem
All the time, wifi works perfectly, even with multiple devices... until I connect LAN.

Workaround
Finally, I tried separating lan from wlan - which seemed to be suggested earlier in this thread. Since I couldn't find instructions anywhere, here my config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc9:fb7a:d338::/48'

config interface 'lan'
        option force_link '1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option macaddr '00:01:08:03:04:05'
        option _orig_ifname 'eth0.1 radio0.network1'
        option _orig_bridge 'true'
        option ifname 'eth0.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 4 5 6t'
                          
config atm-bridge 'atm'         
        option encaps 'llc'      
        option payload 'bridged'  
        option vci '34'
        option vpi '0'  
                                               
config interface 'wan'         
        option proto 'dhcp'     
        option ifname 'ptm0.34' 
        option service 'Telfort'
        option mtu '1480'          
                                      
config vdsl 'dsl'                               
        option annex 'a'                        
        option firmware '/lib/firmware/vdsl.bin'    
        option tone 'av'          
        option xfer_mode 'ptm'
                             
config interface 'wlan'            
        option proto 'static'         
        option ipaddr '192.168.2.1'   
        option netmask '255.255.255.0'

Afterwards, in Interfaces > WLAN > Firewall Settings, be sure to select the 'LAN' to enable forwarding to wan and you're done!

This works - however you would have your WLAN network separated from your LAN network.
Check DGDodo's answer for a possibly better solution.

(Last edited by zeekoe on 8 Jan 2017, 15:44)

zeekoe,

Assuming you have DSL working as WAN, you can indeed use all other eth ports as LAN within 1 vlan, according your vlan setting. You could try by removing the WAN port (5) from your configuration to try, as hardware technical there is some difference between LAN & WAN ports.

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 4 6t'

I doubt it will remove your strange behavior when connecting a LAN device.

Normally i use always 2 vlan's although they have same function.
You can always 'bridge' them later together (again).
To add the (physically) WAN port on other vlan:

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '5 6t'

Now you also see 2 vlan's in the Luci web-GUI.

Below an example on newer OpenWrt-Lede version, with only vlan2 (LAN) en vlan3 (WAN):
http://dgcomsys.noip.me/DGWP01/wp-content/uploads/2016/11/img_582cee59d4c82.png
(CPU always tagged, untag the ports for WAN / LAN)

You also can override MAC address by using 'lan_dev' (and 'wan_dev') in /etc/config/network instead of option 'macaddr' :

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'aa:bb:cc:dd:ee:ff'

# if using WAN port as WAN input:  
# zeekoe, in your case wan = dsl , i presume :) it can be skipped
config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '11:22:33:44:55:66'

This works fine in OpenWrt-Lede, and i guess this also will work for CC and other versions.

{edit}
I use the following file for wifi (mostly MAC adjusted, as i use more then 1 device):

20e4d2a890984f149b97120489244fd8  /lib/firmware/RT3062.eeprom

But never had the same issue you referring too.

DG.

(Last edited by DGDodo on 27 Dec 2016, 21:07)

wvdakker,

Sounds weird, maybe a reflash would fix this, if the u-boot is also reflashed during this process, which i doubt.
From CLI a reboot should always work.

Your default u-boot seems corrupt, maybe reflash the device (TTL-serially)?
First (6) steps of: https://wiki.openwrt.org/toh/zyxel/p2812hnu-f1
And then i guess you should also change the u-boot settings (step 11), and most probably also the rest of the code.

DG.