OpenWrt Forum Archive

Topic: P-2812HNU-FX: getting OpenWrt installed

The content of this topic has been archived between 6 Jun 2015 and 5 May 2018. Unfortunately there are posts – most likely complete pages – missing.

I see, thanks for sharing your configuration. I'll tinker with it for a bit again.

I'm now getting a DSL connection, but not at the speed I'm expecting. It should be 30/3 mbps. Could that be because of missing vectoring support in the firmware maybe? The strang thing is, I have to configure it as Annex A, but it shows connected as Annex B.

Someone with Telfort as a provider that can help?

https://thumb.ibb.co/fJt5Ja/DSL_openwrt2.png

(Last edited by reynard80 on 8 Sep 2017, 20:50)

reynard80 wrote:

I see, thanks for sharing your configuration. I'll tinker with it for a bit again.

I'm now getting a DSL connection, but not at the speed I'm expecting. It should be 30/3 mbps. Could that be because of missing vectoring support in the firmware maybe? The strang thing is, I have to configure it as Annex A, but it shows connected as Annex B.

Someone with Telfort as a provider that can help?

Do you already have it working?
I've as isp telfort also. I'm on scapi 47026 but get max 10mbit download.

What build are you using? Can you share it with your vdsl.bin included. That would be sweet!

Thanks

JEFFreal wrote:

...
Do you already have it working?
I've as isp telfort also. I'm on scapi 47026 but get max 10mbit download.

What build are you using? Can you share it with your vdsl.bin included. That would be sweet!

Thanks

I'm using LEDE Reboot 17.01.2 r3435-65eec8bd5f now, which seems to work well. I haven't had luck with scapi versions, they wouldn't run properly, but that probably had to do with me being not being patient during installation.

I haven't been able to get the DSL up to full speed though. Should be 30/3 Mbps as said before, but I'm getting up to 22/2 now. I'm using firmware extracted from here. I found a recent Speedlink firmware, and I'm getting up and down vectoring support with it. So it looks good, but still no maximum speed. Not sure if I'm allowed to post the firmware file itself here.

As I posted before, I may have to fiddle with the settings a bit, as I'm getting an Annex B connection, but I've set it to Annex A, which seems a bit strange. Guess I'll have to try a few settings to see if it something improves. But, maybe it's just that Telfort uses a different lantiq firmware .bin

Therefore, I was hoping someone had root access to the original latest Telfort firmware to extract the lantiq firmware and settings.

https://thumb.ibb.co/cnDo8a/dsl.png

config globals 'globals'
    option ula_prefix 'xxxx:xxxx:xxxx::/48'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 4 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '5 6t'

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1'
    option _orig_ifname 'eth0.1 radio0.network1'
    option _orig_bridge 'true'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option _orig_ifname 'wan'
    option _orig_bridge 'false'
    option proto 'dhcp'
    option ifname 'eth0.2'

config interface 'vdsl'
    option ifname 'ptm0.34'
    option proto 'dhcp'
    option service 'Telfort'
    option mtu '1480'
    option macaddr 'xx:xx:xx:xx:xx:xx'

config atm-bridge 'atm'
    option vpi '0'
    option vci '34'
    option encaps 'llc'
    option payload 'routed'

config dsl 'dsl'
    option tone 'av'
    option line_mode 'vdsl'
    option xfer_mode 'ptm'
    option firmware '/lib/firmware/xcpe_579B07_574C02.bin'
    option annex 'a'

(Last edited by reynard80 on 11 Sep 2017, 10:03)

I'm still not able to get maximum speed on my (Dutch Telfort) DSL connection. I'm not getting more than 22/2Mbps whereas I should get up to 30/3Mbps. Some people earlier in the topic apparently managed to get up to 30/3, so I would like to know what firmware they used, as that seems the differentiating factor?

I'm now using 'xcpe_579B07_574C02.bin' from some Speedlink firmware. I have tried extracting firmware from other manufacturers, such as Fritzbox and TP Link, but unsuccesfully.

I would appreciate some help with finding the optimum firmware.

https://thumb.ibb.co/cnDo8a/dsl.png

(Last edited by reynard80 on 12 Sep 2017, 14:53)

reynard80 wrote:

I'm still not able to get maximum speed on my (Dutch Telfort) DSL connection. I'm not getting more than 22/2Mbps whereas I should get up to 30/3Mbps. Some people earlier in the topic apparently managed to get up to 30/3, so I would like to know what firmware they used, as that seems the differentiating factor?

I'm now using 'xcpe_579B07_574C02.bin' from some Speedlink firmware. I have tried extracting firmware from other manufacturers, such as Fritzbox and TP Link, but unsuccesfully.

I would appreciate some help with finding the optimum firmware.

Thanks for your reply, its working with decent speed now smile I guess the scapi build for ISP Telfort is not working (I never had it above 10mbit)
I installed Led Reboot like you did (same build you have) and made use of your network config file.
I downloaded some vdsl firmware from the site you gave earlier.
I now get 50mbit download and 30mbit upload (the same speed i reached with telforts firmware).
Working right now on iptv...

(Last edited by JEFFreal on 13 Sep 2017, 04:32)

You can download the vdsl.bin here dropbox.com/s/bfh72d7bmjv74fg/vdsl.bin?dl=0

config globals 'globals'
    option ula_prefix 'xxxxxxxxxxxxxx::/48'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 4 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '5 6t'

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1'
    option _orig_ifname 'eth0.1 radio0.network1'
    option _orig_bridge 'true'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option _orig_ifname 'wan'
    option _orig_bridge 'false'
    option proto 'dhcp'
    option ifname 'eth0.2'

config interface 'vdsl'
    option ifname 'ptm0.34'
    option proto 'dhcp'
    option service 'Telfort'
    option mtu '1480'
    option macaddr 'xxxxxxxxx:c8'

config atm-bridge 'atm'
    option vpi '0'
    option vci '34'
    option encaps 'llc'
    option payload 'routed'

config dsl 'dsl'
    option tone 'bv'
    option line_mode 'vdsl'
    option xfer_mode 'ptm'
    option firmware '/lib/firmware/vdsl.bin'
    option annex 'b'

cdn.pbrd.co/images/GK4x2je.png

(Last edited by JEFFreal on 13 Sep 2017, 00:15)

reynard80 wrote:
JEFFreal wrote:

...
Do you already have it working?
I've as isp telfort also. I'm on scapi 47026 but get max 10mbit download.

What build are you using? Can you share it with your vdsl.bin included. That would be sweet!

Thanks

I'm using LEDE Reboot 17.01.2 r3435-65eec8bd5f now, which seems to work well. I haven't had luck with scapi versions, they wouldn't run properly, but that probably had to do with me being not being patient during installation.

I haven't been able to get the DSL up to full speed though. Should be 30/3 Mbps as said before, but I'm getting up to 22/2 now. I'm using firmware extracted from . I found a recent Speedlink firmware, and I'm getting up and down vectoring support with it. So it looks good, but still no maximum speed. Not sure if I'm allowed to post the firmware file itself here.

As I posted before, I may have to fiddle with the settings a bit, as I'm getting an Annex B connection, but I've set it to Annex A, which seems a bit strange. Guess I'll have to try a few settings to see if it something improves. But, maybe it's just that Telfort uses a different lantiq firmware .bin

Therefore, I was hoping someone had root access to the original latest Telfort firmware to extract the lantiq firmware and settings.

config globals 'globals'
    option ula_prefix 'xxxx:xxxx:xxxx::/48'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 4 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '5 6t'

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1'
    option _orig_ifname 'eth0.1 radio0.network1'
    option _orig_bridge 'true'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option _orig_ifname 'wan'
    option _orig_bridge 'false'
    option proto 'dhcp'
    option ifname 'eth0.2'

config interface 'vdsl'
    option ifname 'ptm0.34'
    option proto 'dhcp'
    option service 'Telfort'
    option mtu '1480'
    option macaddr 'xx:xx:xx:xx:xx:xx'

config atm-bridge 'atm'
    option vpi '0'
    option vci '34'
    option encaps 'llc'
    option payload 'routed'

config dsl 'dsl'
    option tone 'av'
    option line_mode 'vdsl'
    option xfer_mode 'ptm'
    option firmware '/lib/firmware/xcpe_579B07_574C02.bin'
    option annex 'a'

Do you got the settings for telfort iptv also? Cause i dont get it to work..

I will try your suggested firmware, although I think I tried it before. Also, I'll use some of your settings. Did you use the MAC address on the bottom of the router as the MAC for the DSL connection?

JEFFreal wrote:

Do you got the settings for telfort iptv also? Cause i dont get it to work..

No, sorry, I don't have a Telfort television subscription.

reynard80 wrote:

I will try your suggested firmware, although I think I tried it before. Also, I'll use some of your settings. Did you use the MAC address on the bottom of the router as the MAC for the DSL connection?

JEFFreal wrote:

Do you got the settings for telfort iptv also? Cause i dont get it to work..

No, sorry, I don't have a Telfort television subscription.

Yes, i used the mac adres from the bottom. Try vdsl.bin from the dropbox link i provided.

JEFFreal wrote:

Yes, i used the mac adres from the bottom. Try vdsl.bin from the dropbox link i provided.

Still no maximum speed with that vdsl.bin. You are getting maximum speed on your connection with it?

reynard80 wrote:
JEFFreal wrote:

Yes, i used the mac adres from the bottom. Try vdsl.bin from the dropbox link i provided.

Still no maximum speed with that vdsl.bin. You are getting maximum speed on your connection with it?

Sorry for the late reaction... Yeah i get maximum speed with it. Maybe you should try the new LEDE release...

JEFFreal wrote:

...
Sorry for the late reaction... Yeah i get maximum speed with it. Maybe you should try the new LEDE release...

Maybe a bit offtopic, but the strange thing is that I'm getting a 82.x.x.x IP address with the original modem (30/3Mbps) and an 195.x.x.x IP address with the LEDE project modem (with the lower speed of 20/2Mbps). Apparently there is a difference in the connection.

What IP are you getting on your modems with Telfort ISP?

(Last edited by reynard80 on 20 Oct 2017, 12:25)

reynard80 wrote:
JEFFreal wrote:

...
Sorry for the late reaction... Yeah i get maximum speed with it. Maybe you should try the new LEDE release...

Maybe a bit offtopic, but the strange thing is that I'm getting a 82.x.x.x IP address with the original modem (30/3Mbps) and an 195.x.x.x IP address with the LEDE project modem (with the lower speed of 20/2Mbps). Apparently there is a difference in the connection.

What IP are you getting on your modems with Telfort ISP?

Weird i get the same ip address 86.x.x.x Is your dns the same? Otherwise you can force that in /var/resolv.conf.auto

No, I'm also getting 195.x.x.x DNS IP's. But changing those won't help for the DSL line speed?

reynard80 wrote:

No, I'm also getting 195.x.x.x DNS IP's. But changing those won't help for the DSL line speed?

I dont know exactly where but i think you can force your dns settings somewhere. Maybe /var/resolv.conf but i dont know. Changing that will probably change your speed to normal.

@JEFFreal please use the "Post reply" button instead of the "Quote".
There is no use in duplicating the posting before yours.

The discussion might have continued from here.