OpenWrt Forum Archive

Topic: P-2812HNU-FX: getting OpenWrt installed

The content of this topic has been archived between 6 Jun 2015 and 5 May 2018. Unfortunately there are posts – most likely complete pages – missing.

sad  Except my WAN interface, all seems to work fine.

Wed Dec  3 20:25:56 2014 daemon.notice netifd: wan (2061): udhcpc (v1.22.1) started
Wed Dec  3 20:25:57 2014 daemon.notice netifd: wan (2061): Sending discover...
Wed Dec  3 20:26:00 2014 daemon.notice netifd: wan (2061): Sending discover...
Wed Dec  3 20:26:03 2014 daemon.notice netifd: wan (2061): Sending discover...
Wed Dec  3 20:27:10 2014 daemon.notice netifd: wan (2061): Received SIGTERM
Wed Dec  3 20:27:10 2014 daemon.notice netifd: Interface 'wan' is now down
Wed Dec  3 20:27:10 2014 daemon.notice netifd: Interface 'wan' is disabled
Wed Dec  3 20:27:10 2014 daemon.notice netifd: Interface 'wan' is enabled
Wed Dec  3 20:27:10 2014 daemon.notice netifd: Interface 'wan' is setting up now
Wed Dec  3 20:27:10 2014 daemon.notice netifd: wan (2443): udhcpc (v1.22.1) started
Wed Dec  3 20:27:10 2014 daemon.notice netifd: wan (2443): Sending discover...
Wed Dec  3 20:27:13 2014 daemon.notice netifd: wan (2443): Sending discover...
Wed Dec  3 20:27:16 2014 daemon.notice netifd: wan (2443): Sending discover...
Wed Dec  3 20:27:24 2014 daemon.notice netifd: wan (2443): Received SIGTERM
Wed Dec  3 20:27:24 2014 daemon.notice netifd: Interface 'wan' is now down
Wed Dec  3 20:27:24 2014 daemon.notice netifd: Interface 'wan' is disabled
Wed Dec  3 20:27:24 2014 daemon.notice netifd: Network device 'nas0' link is down
Wed Dec  3 20:27:24 2014 daemon.notice netifd: Interface 'wan' has link connectivity loss

And i need a re-install due to too many bad erasable blocks ...

[    0.436000] Scanning device for bad blocks
[    0.460000] Bad eraseblock 254 at 0x000001fc0000
[    0.464000] Bad eraseblock 255 at 0x000001fe0000
[    0.468000] Bad eraseblock 256 at 0x000002000000
[    0.472000] Bad eraseblock 257 at 0x000002020000
[    0.476000] Bad eraseblock 258 at 0x000002040000
[    0.480000] Bad eraseblock 259 at 0x000002060000
[    0.488000] Bad eraseblock 260 at 0x000002080000
[    0.492000] Bad eraseblock 261 at 0x0000020a0000
[    0.496000] Bad eraseblock 262 at 0x0000020c0000
[    0.500000] Bad eraseblock 263 at 0x0000020e0000
[    0.504000] Bad eraseblock 264 at 0x000002100000
[    0.508000] Bad eraseblock 265 at 0x000002120000
[    0.516000] Bad eraseblock 266 at 0x000002140000
[    0.520000] Bad eraseblock 267 at 0x000002160000
[    0.524000] Bad eraseblock 268 at 0x000002180000
[    0.528000] Bad eraseblock 269 at 0x0000021a0000
[    0.532000] Bad eraseblock 270 at 0x0000021c0000
[    0.536000] Bad eraseblock 271 at 0x0000021e0000
[    0.540000] Bad eraseblock 272 at 0x000002200000
[    0.548000] Bad eraseblock 273 at 0x000002220000
[    0.552000] Bad eraseblock 274 at 0x000002240000
[    0.556000] Bad eraseblock 276 at 0x000002280000
[    0.560000] Bad eraseblock 277 at 0x0000022a0000
[    0.564000] Bad eraseblock 278 at 0x0000022c0000
[    0.568000] Bad eraseblock 279 at 0x0000022e0000
[    0.576000] Bad eraseblock 281 at 0x000002320000
[    0.580000] Bad eraseblock 284 at 0x000002380000
[    0.584000] Bad eraseblock 285 at 0x0000023a0000
[    0.588000] Bad eraseblock 286 at 0x0000023c0000
[    0.592000] Bad eraseblock 288 at 0x000002400000
[    0.596000] Bad eraseblock 290 at 0x000002440000
[    0.600000] Bad eraseblock 291 at 0x000002460000
[    0.608000] Bad eraseblock 292 at 0x000002480000
[    0.612000] Bad eraseblock 293 at 0x0000024a0000
[    0.616000] Bad eraseblock 294 at 0x0000024c0000
[    0.620000] Bad eraseblock 295 at 0x0000024e0000
[    0.624000] Bad eraseblock 296 at 0x000002500000
[    0.628000] Bad eraseblock 297 at 0x000002520000
[    0.636000] Bad eraseblock 298 at 0x000002540000
[    0.640000] Bad eraseblock 299 at 0x000002560000
[    0.644000] Bad eraseblock 300 at 0x000002580000
[    0.648000] Bad eraseblock 301 at 0x0000025a0000
[    0.652000] Bad eraseblock 302 at 0x0000025c0000
[    0.656000] Bad eraseblock 303 at 0x0000025e0000
[    0.660000] Bad eraseblock 304 at 0x000002600000
[    0.668000] Bad eraseblock 305 at 0x000002620000
[    0.672000] Bad eraseblock 306 at 0x000002640000
[    0.676000] Bad eraseblock 307 at 0x000002660000
[    0.680000] Bad eraseblock 308 at 0x000002680000
[    0.684000] Bad eraseblock 309 at 0x0000026a0000
[    0.688000] Bad eraseblock 310 at 0x0000026c0000
[    0.696000] Bad eraseblock 311 at 0x0000026e0000
[    0.700000] Bad eraseblock 312 at 0x000002700000
[    0.704000] Bad eraseblock 313 at 0x000002720000
[    0.708000] Bad eraseblock 314 at 0x000002740000
[    0.712000] Bad eraseblock 315 at 0x000002760000
[    0.716000] Bad eraseblock 316 at 0x000002780000
[    0.720000] Bad eraseblock 317 at 0x0000027a0000
[    0.732000] Bad eraseblock 371 at 0x000002e60000
[    0.732000] Bad eraseblock 372 at 0x000002e80000
[    0.740000] Bad eraseblock 373 at 0x000002ea0000
[    0.744000] Bad eraseblock 374 at 0x000002ec0000
[    0.748000] Bad eraseblock 375 at 0x000002ee0000
[    0.752000] Bad eraseblock 376 at 0x000002f00000
[    0.756000] Bad eraseblock 377 at 0x000002f20000
[    0.760000] Bad eraseblock 378 at 0x000002f40000
[    0.768000] Bad eraseblock 379 at 0x000002f60000
[    0.772000] Bad eraseblock 381 at 0x000002fa0000
[    0.776000] Bad eraseblock 384 at 0x000003000000
[    0.780000] Bad eraseblock 385 at 0x000003020000
[    0.784000] Bad eraseblock 386 at 0x000003040000
[    0.788000] Bad eraseblock 387 at 0x000003060000
[    0.840000] Bad eraseblock 973 at 0x0000079a0000

(Last edited by DGDodo on 16 Dec 2014, 20:49)

Did you change Vlan config ? Still you didn't tell us how do you connect to internet, WAN ETH or WAN ADSL/VDSL.

I need dump of these two:

0x000003ce0000-0x000004760000 : "reserve"
0x000007ec0000-0x000007f00000 : "romd"

If anyone have original firmware.

Made a own tutorial about setup progress and getting ride of most NAND Bad Blocks:
http://dgcomsys.noip.me/phpbb/viewtopic.php?f=19&t=48&p=112#p112

My WAN port is most probably hard defect, but have to investigate.
And still working with the box not connected to internet (yet, maybe by wifi, lol)

I'll try the newest scapi code tomorrow.

@cornelus2009

Strange, in sources u-boot env points to "reserved", but In your dump it is empty, maybe branded F1 has different boot layout or config.

@DGDodo

From your ifconfig I see that you didn't read what I've wrote.

Set Vlans to enable WAN ETH, read wiki how to do that, wan port is "5".

Edit: WiFi and ADSL quite stable, no nand errors, uptime about 4 days:

https://www.dropbox.com/s/b6l3t6l1fw1qsnm/Zrzut%20ekranu%202014-12-18%2021.28.31.png

Updated BB images in my dropbox(NAND fix; cal_data), added possibility to "sysupgrade" without need to enter u-boot (need some tests).

@cornelus2009

How about your tests ? Nand seems to be stable now, at least no errors when installing packages and changing config.

@DGDodo
With WAN connected tftp anything within u-boot and check status of:

P-2812HNU-F1 # tftpboot 0x80800000 openwrt-lantiq-xrx200-P2812HNUF1-uImage-initramfs
ltq_phy: addr 0, link 1, speed 100, duplex 1
ltq_phy: addr 1, link 0, speed 10, duplex 0
ltq_phy: addr 17, link 0, speed 10, duplex 0
ltq_phy: addr 19, link 0, speed 10, duplex 0
ltq_phy: addr 5, link 0, speed 10, duplex 0  <-----

(Last edited by scapi on 18 Dec 2014, 22:56)

scapi, indeed i do not read too much smile
WAN ETH is what i wanna use, WAN ADSL/VDSL could be disabled on my device, as i did with my other F1, still running ZyXEL firmware. (I don't have a ADSL or VDSL line here...)

As you wrote earlier: WAN should be enabled by default, it does NOT work default?
Isn't the default value ADSL/VDSL? Which i don't (can't) use?

So i guess my WAN port is defect, as i do get a link on all LAN ports (4, 2, 1 and 0) but don't get a link on (default) WAN Port 5.

During boot the port is detected:

[    0.744000] eth0: attached PHY [Lantiq XWAY VR9 GPHY 11G v1.3] (phy_addr=0:00, irq=-1)
[    0.812000] eth0: attached PHY [Lantiq XWAY VR9 GPHY 11G v1.3] (phy_addr=0:01, irq=-1)
[    0.880000] eth0: attached PHY [Lantiq XWAY VR9 GPHY 11G v1.4] (phy_addr=0:11, irq=-1)
[    0.948000] eth0: attached PHY [Lantiq XWAY VR9 GPHY 11G v1.4] (phy_addr=0:13, irq=-1)
[    1.016000] eth0: attached PHY [Lantiq XWAY VR9 GPHY 11G v1.3] (phy_addr=0:05, irq=-1)

But further within OS it does not work.
As WDS device (WLAN=WAN, ports 4,2,1,0,WAN=LAN), or as Router (WAN=WAN, ports 4,2,1,0,WLAN=LAN) the WAN port won't get any link. Only errors as described before.

Below my current network config, VLAN1=LAN+WLAN, VLAN2=WAN(ETH):

root@OpenWrt:/# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fddb:2e4d:74ec::/48'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option macaddr '00:01:02:03:04:05'
        option _orig_ifname 'eth0.1 radio0.network1'
        option _orig_bridge 'true'
        option ifname 'eth0.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0 1 2 4 6t'

config interface 'wan'
        option _orig_ifname 'nas0'
        option _orig_bridge 'false'
        option proto 'dhcp'
        option type 'bridge'
        option ifname 'eth0.2 nas0'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '5 6t'

Next try will be tftp the image on the WAN port (but i guess this won't work).
Later today or weekend ..

(Last edited by DGDodo on 19 Dec 2014, 16:51)

@cornelus2009

How about your tests ? Nand seems to be stable now, at least no errors when installing packages and changing config.

Nand seems stable now, worked about 2 days and today get an crash, no acces to lan, internet droped down.
Not saw in log, what crashed.

DGDodo wrote:

config interface 'wan'
        option _orig_ifname 'nas0'
        option _orig_bridge 'false'
        option proto 'dhcp'
        option type 'bridge'
        option ifname 'eth0.2 nas0'

remove nas0.

After plugging WAN cable is there any sign on WAN Led ?

@cornelus2009 are you using adsl/vdsl ?

(Last edited by scapi on 19 Dec 2014, 19:37)

Nop, using ftth high speed, my provider ofers me 200mb/s, with an huawei hg658c, i got 14mb/s down speed over wifi, with p2812hnuf1 and vgv7519 both with openwrt installed on them, max speed is 7mb/s on wifi and wired same.

Dunno why speed is reduced.

If ADSL/VDSL isn't used disable dsl_control in start up, it can cause memory overflow if not physically connected, as for speed it's strange I'm on ADSL Line got max over WiFi about 9-10Mbit/s, sync 10-12Mbit/s. Also post output of "swconfig dev switch0 show" or if You have separated WAN "swconfig dev eth? show".

(Last edited by scapi on 19 Dec 2014, 21:07)

scapi,

Quote: "After plugging WAN cable is there any sign on WAN Led ?"
Nope, also not on the switch i use to connect it to, only port4, 2, 1 and 0...

Seen that 'memory overflow' message ones, i guess? after almost 24h of testing smile or is the jffs2 msgs something else? :

[86116.956000] device eth0.1 entered promiscuous mode
[86116.960000] device eth0 entered promiscuous mode
[86116.972000] br-lan: port 1(eth0.1) entered forwarding state
[86116.976000] br-lan: port 1(eth0.1) entered forwarding state
[86118.968000] br-lan: port 1(eth0.1) entered disabled state
[86119.876000] br-lan: port 1(eth0.1) entered forwarding state
[86119.880000] br-lan: port 1(eth0.1) entered forwarding state
[86121.884000] br-lan: port 1(eth0.1) entered forwarding state
[86279.212000] device nas0 entered promiscuous mode
[86279.216000] br-lan: port 2(nas0) entered forwarding state
[86279.224000] br-lan: port 2(nas0) entered forwarding state
[86281.228000] br-lan: port 2(nas0) entered forwarding state
[86320.300000] device nas0 left promiscuous mode
[86320.304000] br-lan: port 2(nas0) entered disabled state
[86330.256000] jffs2: warning: (23907) jffs2_sum_write_data: Not enough space for summary, padsize = -1293

Anyway i disabled dsl_control & dsl_fs from start-up:
http://dgcomsys.noip.me/DGWP01/wp-content/uploads/2014/12/img_5494b6a5b31f0.png

Removed nas0 from uci webinterface settings (WAN), as it was also not visable on 'ifconfig' on console?
So where or what is now my WAN port? Could/Should i configure it as 'Custom Interface:'?

root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:01:02:03:04:05
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fddb:2e4d:74ec::1/60 Scope:Global
          inet6 addr: fe80::201:2ff:fe03:405/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:55626 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32183 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:10282599 (9.8 MiB)  TX bytes:8567975 (8.1 MiB)

eth0      Link encap:Ethernet  HWaddr 1A:FA:B5:26:9F:4D
          inet6 addr: fe80::18fa:b5ff:fe26:9f4d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:51357 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48632 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:11408642 (10.8 MiB)  TX bytes:13272811 (12.6 MiB)

eth0.1    Link encap:Ethernet  HWaddr 1A:FA:B5:26:9F:4D
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:51350 errors:0 dropped:0 overruns:0 frame:0
          TX packets:36469 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:10072680 (9.6 MiB)  TX bytes:8844111 (8.4 MiB)

eth0.2    Link encap:Ethernet  HWaddr 1A:FA:B5:26:9F:4D
          inet6 addr: fe80::18fa:b5ff:fe26:9f4d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:2106 (2.0 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:745834 errors:0 dropped:0 overruns:0 frame:0
          TX packets:745834 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:50723953 (48.3 MiB)  TX bytes:50723953 (48.3 MiB)

wlan0     Link encap:Ethernet  HWaddr 00:0C:43:30:62:00
          inet6 addr: fe80::20c:43ff:fe30:6200/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:17813 errors:0 dropped:0 overruns:0 frame:0
          TX packets:44213 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1592638 (1.5 MiB)  TX bytes:10375918 (9.8 MiB)

But still WAN stays dead (i guess it  was already dead...)
In this overview, i can never get port 5 other status then 'no link':
http://dgcomsys.noip.me/DGWP01/wp-content/uploads/2014/12/img_548eda3508014.png
i have to try scapi's way: tftp over WAN port, but i guess that won't work either, as there is never a link on port 5...

Although it's also strange that eth0, eth0.1 & eth0.2 have same MAC in ifconfig?
Btw, is there anywhere a setting to disable ipv6 everywhere, as eth0.1 looks have no ipv6, eth0.2 does have ipv6?
i really need to read alot more about this "adapter / interface / bridge / switch / vlan / ipv6"  kinda stuff  ... (ipv4 is know smile )
Tomorrow looking further into this ...

cornelius2009, maybe switch off ADSL/VDSL, as descibed here, if not used? Maybe it improves eth-speeds.

DG.

Something is limiting bandwidth via WiFi from router, but I don't know what:

Client connecting to 192.168.1.1, TCP port 5001
TCP window size: 87.5 KByte (default)
------------------------------------------------------------
[  3] local 192.168.211.130 port 41647 connected with 192.168.1.1 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.1 sec  28.1 MBytes  23.5 Mbits/sec

(100Mbit/s)LAN -> (300Mbit/s) WIFI = 87Mbit/s
(150Mbit/s)WiFi -> (300Mbit/s) WIFI = 23Mbit/s
Don't have Gigabit to test LAN -> LAN

@DGDodo

This is Your WAN

eth0.2    Link encap:Ethernet  HWaddr 1A:FA:B5:26:9F:4D
          inet6 addr: fe80::18fa:b5ff:fe26:9f4d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:2106 (2.0 KiB)

If in U-Boot port 5 still isn't working then maybe something physically happened to it.
You can always use any port as WAN, just change vlan config.

(Last edited by scapi on 20 Dec 2014, 12:07)

Today I installed OpenWRT, it was almost painless. The uploading of the ram u-boot took too much time, so I wrote a little program:

#include <time.h>
#include <stdio.h>

int main( int argc, char **argv, char **envp )
{
    int count=0, kb=0;
    char buf[ 1 ];
    while( 1 == read( 0, buf, 1 ) )
    {
        write( 1, buf, 1 );
        if( 1024 == ++count )
        {
            char buffer[ 64 ];
            write( 2, buffer, sprintf( buffer, "\r%d kB", ++kb ) );
            count = 0;
        }
        usleep( 500 );
    }
    return 0;
}

You can use it this way:

delay <u-boot-file >/dev/ttyUSB0

The usleep( 500 ) adds a delay of 500 microseconds between each byte. I guess it can be shorter, but this way it uploaded at 2kB/sec.

Further there was one small glitch in scapi's instructions. Before being able to ubiformat /dev/mtd3 it first has to be detached:

ubidetach -p /dev/mtd3

Now I have to test. Thanks to all who contributed.

115200 is speed of com port, it can't take more then 1min.

Mijzelf wrote:

Further there was one small glitch in scapi's instructions. Before being able to ubiformat /dev/mtd3 it first has to be detached:

ubidetach -p /dev/mtd3

Now I have to test. Thanks to all who contributed.

Read again Step 9 it was there from the beginning.

Edit: Updated images for F3 in my dropbox
Whole NAND is used for UBI and kernel (NOR only for U-Boot/U-Boot env)
Added Calibration data for F3 WiFi.

For F1/F3 added VDSL annex a/b firmware in dropbox folder, need someone that uses annex B to test if different firmware than one already in image is needed.

Config for VDSL/ptm:

file /etc/config/network

#config atm-bridge 'atm'
# option vpi '0'
# option vci '35'
# option encaps 'llc'
# option payload 'bridged'

config interface 'wan'
        option ifname 'ptm0.35'   <----- use vpi/vci params here example 'ptm8.32'  means vpi=8 vci=32
        option proto 'pppoe'
        option macaddr 'fc:f5:28:17:xx:xx' <----- Your MAC (on my images taken from U-boot env)
        option username 'user' <----- username
        option password 'password' <----- password

config vdsl 'dsl'
        option annex 'a'  <------- change annex here
        option firmware '/lib/firmware/vdsl.bin'
        option tone 'av' <------- probably if annex B is chosen, needs to be changed to 'bv'
        option xfer_mode 'ptm'

For ADSL/VDSL over atm:

config atm-bridge 'atm'
    option vpi '0' <----- use vpi/vci params here
    option vci '35' <----- use vpi/vci params here
    option encaps 'llc'
    option payload 'bridged'

config interface 'wan'
    option ifname 'nas0'
    option proto 'pppoe'
    option ipv6 '1'
        option macaddr 'fc:f5:28:17:xx:xx' <----- Your MAC (on my images taken from U-boot env)
        option username 'user' <----- username
        option password 'password' <----- password

config vdsl 'dsl'
    option annex 'a' <------- change annex here
    option firmware '/lib/firmware/vdsl.bin'
    option tone 'av' <------- probably if annex B is chosen, needs to be changed to 'bv'
    option xfer_mode 'atm'

(Last edited by scapi on 22 Dec 2014, 10:12)

scapi wrote:

115200 is speed of com port, it can't take more then 1min.

When just uploading at 115200 bits/sec, the upload is ignored. (or it  crashes the receiver, don't know). When using Teraterm and delaying each byte 1 msec, I got a whopping 90 bytes/second.


Read again Step 9 it was there from the beginning.

:blush:

The box seems stable, ADSL trains in a bit faster than on my stock P2812HNU-F1.  8.064/1.024  vs +/- 7000/950. The stock box runs fw 3.11TUJ. It is possible that the current speed is the max. I have an 8/1 account.

Now I have problems to get IPv6 running. I think I have boiled it down to the inability to load sit.ko. This is not possible because symbol __secpath_dest  is missing. I found that in linux/net/xfrm/xfrm_input.c. It seems to have something to do with ipsec. Did you disable that?

Mijzelf, i'm using TeraTerm with 115200 serial connection, try 1ms line-delay instead of char-delay? i now flash the u-boot within 2 minutes. Only my 1st try took a long time (i probably had slower serial connection back then).

I sometimes do get the following message after command 'ubidetach -p /dev/mtd3':

root@OpenWrt:/# ubidetach -p /dev/mtd3
ubidetach: error!: cannot detach "/dev/mtd3"
           error 19 (No such device)

But then the next ubiformat command will run fine.

scapi my box won't tftp from WAN ('eth0: attached PHY [Lantiq XWAY VR9 GPHY 11G v1.3] (phy_addr=0:05, irq=-1)') port, altough its recognized initially.
The earlier mentioned eth0.2 was manually created and therefore had the same MAC address.
WAN port is after a clean re-flash ADSL/VDSL (nas0), when i remove nas0 openWRT does not see any WAN port. i have to investigate why. As i don't have ADSL/VDSL line, i disabled that functionality.

I will try to setup my box with WLAN=WAN and eth0.x=LAN (so as an Wireless extended 4x1Gbps switch), and i'm aware that i could setup any eth_port as WAN port.

DG.

@Mijzelf

IPv6 by default is build in, don't know what Your trying to load, give hint and I compile it for You.

I'm trying to get an IPv6 wan address. My providers offers that through a 6to4 tunnel. It works on stock firmware, but on OpenWRT the status of wan6 is 'not connected'.
Then I tried aiccu, but it also fails. AFAIK both need sit.ko, and I found I can't load that, as I wrote.

Hej, thanks a lot for your effort. But I think I need the kernel compiled with this modules enabled, not the modules itself. I uninstalled my iptunnel and sit package, and reinstalled yours instead. But still:

~ # modprobe sit
kmod: 2 modules could not be probed
kmod: - ip_tunnel
kmod: - sit

~ # dmesg
[83389.992000] ip_tunnel: Unknown symbol __secpath_destroy (err 0)

Why are you trying to force load sit module ? Ipv6 is build in and 6to4 is simple script

For me 6to4 fails silently. (Just 'not connected'). But, it is dependent on kmod-sit:

Package: 6to4
Version: 12-1
Depends: libc, kmod-ipv6, kmod-sit

I'm not sure where and how the module should be loaded, the script says:

proto_6to4_setup() {
<snip>

        proto_add_tunnel
        json_add_string mode sit

But anyway, the module can't load, and I think it's the reason for my silent failure. 6to4 creates a tunnel and uses a sit endpoint.
And apparently sit.ko is one of those modules which needs a 'socket' in the kernel, so it can only be loaded in a kernel which had the sit module configured at compile time.

Thanks. I confirm that the router can be updated this way, but the settings are lost. (At least when updating from ubifs to ubifs-squashfs).

The 6to4 tunnel now works.

hi guys. Sorry for maybe stupid question, but, if I unsolder flash from my P-2812HNU-F3 router, put it in programmer, and program BIN file from Zyxel website. Will the router work after this? Before I did this with laptop bios and it worked.

Sorry, posts 76 to 75 are missing from our archive.