OpenWrt Forum Archive

Topic: Support for SagemCom F@ST 2304 (Sky)

The content of this topic has been archived between 28 Apr 2018 and 7 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

daemon123 thanks,

I renamed the patch, deleted it's content & repasted your posted patch. git status shows only that file is changed in the OpenWRT repo.
I cleaned (make dirclean)
I have reset to the default config (make defconfig)
Made a new kernel config (make kernel_menuconfig) it fails, this is the output…

Applying patch platform/950-board_fast2304.patch
patching file arch/mips/bcm63xx/boards/board_bcm963xx.c
Hunk #1 succeeded at 858 with fuzz 2.
Hunk #2 FAILED at 5372.
1 out of 2 hunks FAILED -- rejects in file arch/mips/bcm63xx/boards/board_bcm963xx.c
Patch platform/950-board_fast2304.patch does not apply (enforce with -f)
make[2]: *** [/home/ladmin/buildroot/openwrt-14.07/openwrt/build_dir/target-mips_mips32_uClibc-] Error 1
make[2]: Leaving directory `/home/ladmin/buildroot/openwrt-14.07/openwrt/target/linux/brcm63xx'
make[1]: *** [menuconfig] Error 2
make[1]: Leaving directory `/home/ladmin/buildroot/openwrt-14.07/openwrt/target/linux'
make: *** [kernel_menuconfig] Error 2

When I manually patch the line numbers do not tally correctly, I have to adjust the points where I insert your changes. Do you want compare the source file or git log messages?

git log shows this for me as the last commit - are we on the same version?
commit 878af3117f68c2f8d6b3d6582e50c6cef521f6f7
Author: jow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date:   Thu Feb 26 21:29:57 2015 +0000

    BB: ubox: fix segmentation fault in insmod

(Last edited by das_robot on 8 Mar 2015, 22:22)

One thing that concerns me…

That suggests we need to modify the makefile…

Does git status show your file as modified?

Clearly I don't understand what is going on here.
I have the patch inserted, make does create output for the F@ST-2304-... but I am unable to create a RAM disk that boots…

VFS: Cannot open root device "mtdblock2" or unknown-block(31,2): error -5
Please append a correct "root=" boot option; here are the available partitions:

I'd like to flash the firmware - but since a RAM image fails I suspect my build is wrong. Can anyone help?
I could do with a working .config for buildroot or a hint on how to setup a minimal build for the RAM image (or how to build a correct firmware for this device).

Anyone still trying to get this to work? tongue

darylt wrote:

Anyone still trying to get this to work? tongue

I gave up trying.

How far are you getting?

Not far sad

I research and look then step away when frustrated, but I keep coming back to it like a fool big_smile -- I don't want it to beat me LOL

I have got perfect serial communication to the board with an FTDI TTL-232 cable, but trying to figure out what I need to do to compile the source has got me going in circles.

I'm afraid I also went in circles trying to get it to compile correctly too as you can see from this thread.

If anyone has suggestions I may be able to try again but I erased the Ubuntu system I used for building & would need to get up and running again. I think this router is not well liked so it should be simpler to find one that already is known to work with OpenWRT…

I can help adding support for this router.

das_robot was you able to run my ram firmware?

If you can make a backup of the linux partition then we could extract the original firmware. It may help for analyzing the firmware header. Having a copy of original firmware is a good idea before installing Openwrt.

It's been so long I can't remember how far I got with your firmware danitool, sorry.

I do have this zip, it appears to have the backup of the original 5 partitions and the version I tried from daemon123… …

I think I netcat'ed them from the router before I tried any modifications.

I have used your 'lede-brcm63xx-generic-FAST2304-initramfs.elf' & it has booted OK smile

I may need to review how to flash the firmware to properly test but so far it seems promising, I did this in CFE…

It boots, I think I need to setup an ip & figure how to get the web interface setup, it doesn't seem to be accessible as eth0 has no ip & is down.
This is the log when flashed… … 067011.txt

Let me know if you need debug info or anything from me. in case you need it here is the log where I first loaded the image… … 067011.txt

Thanks for testing. However it seems the b43 driver doesn't support the BCM4313 wifi chip. I will make another firmware with brcmsmac, but probably it isn't well supported

danitool wrote:

Thanks for testing. However it seems the b43 driver doesn't support the BCM4313 wifi chip. I will make another firmware with brcmsmac, but probably it isn't well supported

I think that sounds about right from the reading I did when looking into it first time. I was planning on using this to test segmenting networks & since the Wifi support on this router is out of date I don't think I need it. I guess one possibility is to add an external card via the USB port but that isn't on the board so soldering is required and may be more effort than it is is worth.

Here are the logs for the next version… … fe.bin.txt … fe.bin.txt

ifconfig -a does now show wlan0 & the radio appears to be detected, lsmod has modules loaded too. iw list also shows info for the card smile

Now I cannot connect to the web UI at all. I did revert to the last version & the web UI worked, so I don't think the issue is with my local network setup. I do get a dhcp lease from it on my Mac on the latest version.

Thanks, I suddenly realised luci was missing after posting. The UI now has wifi ready for configuring. I don't have enough time to test at the moment, darylt are you testing this? The patch is in the download if you want to build your own.

I am unable to scan for networks and I cannot see the SSID when it is enabled in 802.11.N or legacy mode.

This is appearing in the serial console as I scan/ enable the network…
[  316.329147] brcmsmac bcma0:1: brcms_ops_bss_info_changed: Beacon enabled: false
[  316.441279] brcmsmac bcma0:1: wl0: wlc_suspend_mac_and_wait: waited 83000 uS and MI_MACSSPNDD is still not on.
[  316.451608] brcmsmac bcma0:1: wl0: psmdebug 0x00ff8706, phydebug 0x00000000, psm_brc 0x0000
[  316.674900] brcmsmac bcma0:1: wl0: wlc_suspend_mac_and_wait: waited 83000 uS and MI_MACSSPNDD is still not on.

Testing wifi is not a priority for me yet, I need to reconfigure it correctly within my current setup.

Is it possible that the wireless mac address config is missing?

(Last edited by francisuk on 27 Apr 2017, 00:25)

The discussion might have continued from here.