OpenWrt Forum Archive

Topic: [MT7621A]WiTi Board is coming. Do you want to hack it?

The content of this topic has been archived between 8 Feb 2018 and 3 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Hi all.
I see that there are already trunk snapshot builds. are they functional?

theundead wrote:

Hi all.
I see that there are already trunk snapshot builds. are they functional?

You get links in the previous post - see for yourself - now I am writing this by WiTi on which it is installed slightly newer version of the same OpenWrt Designated Driver r47894 / LuCI Master (git-15.349.45651-ff2f536) - just install the test and will be clear about and how it works.
I just ... works.
EDIT:
OpenWrt Designated Driver r47894 / LuCI Master (git-15.349.45651-ff2f536)
firmware+rootfs+packages (It contains no active drivers mmc/sdhci for later installation - if someone wanted to find out what is causing the problem in the lack of ability to function entirely - is based on the default profile - image does not, of course, these drivers):
http://hostuje.net/file.php?id=3875fe00 … fbbf4d81e8
- added the latest, stable proftpd-1.3.5a (custom-made quickly based on BB - generally works)
- I removed part of my scripts, also other than those described previously, and now the new programs and improved one script ncm.sh and added her to the /etc/banner - the rest is pure openwrt.
I encourage you to test - image is heavily bloated but also strongly featured.
opkg list_installed - http://wklej.org/id/1878675/
.config - http://wklej.org/id/1878683/
big_smile

(Last edited by build000 on 15 Dec 2015, 19:36)

Is there a current 'getting started' guide, ie how to perform first flash, current recommended OpenWRT image etc?

J1mbo wrote:

Is there a current 'getting started' guide, ie how to perform first flash, current recommended OpenWRT image etc?

How do you get the original image mqmaker without LuCI (eg. Same built from original sources, etc.) - serial console.
How have our original image mqmaker LuCI -  just update the corresponding page LuCI without saving the settings, but you can and the serial console.
That's all.

Important:
1). The first launch wan connection does not work - as you can not enter the LuCI/terminal simply restart your cable/dsl modem - count that every first launch after installation on purely be different MAC address on the WAN/LAN. Subsequent restarts nothing in this area do not change.
2). The first input terminal after ssh (telnet does not exist - talking about trunk) without a password - if it did not set in LuCI.
3). My observation is that if we do not want continuous dropping connections WiFi 5 GHz after each update of the system that mechanism LuCI/terminal (sysupgrade) with a set - you need for each new compilation and a new installation of the image to install the system on a purely (without saving settings).

(Last edited by build000 on 16 Dec 2015, 05:31)

gsustek wrote:

Did anyone try this ?
https://downloads.openwrt.org/snapshots … pgrade.bin

You read the last few posts? Nothing has changed in the driver kmod-mmc since the appearance of Witi profile of mainline openwrt, so if it is in the image of the driver (or rather, since this is the minimum compilation of the default profile) that you're guaranteed suspension system startup with an error.

Has anybody tested Samba performance? I have tried it with OpenWrt built from nitroshift's branch and it is very poor :-(

I did some tests using dd on SAMBA share mounted to my Linux computer. I did it though cable connection using 1GB file.
I got following results:
Reading ~ 65MB/s
Writing ~ 1MB/s

I have tried to understand why write speed is so bad so I tried to test HDD write speed. I have measured ~12-15MB/s that is also bad in my opinion but definitely not a week point for Samba test.

Any ideas?

(Last edited by KejPi on 16 Dec 2015, 22:57)

@KejPi

Please give more details about your test: hard-disk model, partition table, filesystem used, etc.

I am using a 2TB hard-disk with one partition spread across the entire capacity, formatted in ext4 and mapped from my PC. this is my result when copying a ~900MB file from my PC to the share:

http://s15.postimg.org/99q04p85z/samba.jpg

nitroshift

(Last edited by nitroshift on 17 Dec 2015, 06:51)

Is the partition aligned at a multiple of 4096 bytes?

nitroshift wrote:

Please give more details about your test: hard-disk model, partition table, filesystem used, etc.

I am using old 160GB Maxtor Drive formated as ext4 single partition. This drive is shared by Samba with anonymous access (without any user/password). Shared drive is mounted [mount -t cifs .... ] on my Arch Linux machine that is connected to WiTi by cable (no other client is connected). I did the test using DD:

dd if=/tmp/test.bin of=/mnt/share/test.bin bs=4M

Test file is 1024MB, /tmp is in RAM. I have tried several block sizes (bs=1M, bs=2M, bs=4M) with the same result. The writes speed is ~1MB/s.
For read test I used the same approach:

dd if=/mnt/share/test.bin of=/tmp/test.bin bs=4M

This gives around 65MB/s.

I have also observed CPU load during write test and it was very low ~1% and there is nothing in log files. I wanted to test Samba performance with dbench https://dbench.samba.org/ but for some reason it was not working with WiTi samba configuration :-(

Then I have tried local write speed on WiTi. Unfortunately OpenWrt version of DD does not print statistics so I used less precise method:

date && \
dd if=/dev/zero of=/tmp/test.bin bs=4M &&\
date

And then I calculated speed from time before and after. I was roughly 12-15MB/s that is also quite low but still much better than Samba performance.

So from read speed it is clear that network thoughput is not limiting write speed and HDD speed should not be limiting as well.

What is HDD write speed that you can achieve?

https://dev.openwrt.org/changeset/47898

Introduces support for the second WAN port. It's still rudimentary, but it works.

nitroshift

(Last edited by nitroshift on 17 Dec 2015, 16:03)

@KejPi

Try using a different HDD, I am using a 2.5" HDD and I am getting 30MB/s Write, 100MB/s Read.
dd is good enough for testing write speed.

I have tried different HDD and now I have:
write ~28MB/s
read ~60MB/s

This a is performance I am satisfied with :-) Thanks for your hints!

And I have another question - I would like to power down WiTi in the way that it is correctly unmounting HDD and stops all running services. My ideas is to use e.g. WPS button or some GPIO to say to WiTi to shut down and wait for power off while it is flashing some LED. I have tried "poweroff" and "halt" commands but both are ending by reboot.
Any idea or hint?

Thanks!

(Last edited by KejPi on 17 Dec 2015, 21:30)

it doesn't have the standby / poweroff circuitry

Google finds this patch:
http://patchwork.linux-mips.org/patch/9432/
which might be helpful to you maybe.

I suspect you also might be able to get a remote controlled power socket to do what you need it to do.

does anyone have issues with 2.4G wifi (wlan1/phy1)?
mine is dropping about every 30 min and i had to disable it (the client a broadcom phy on win10)

(Last edited by maurer on 18 Dec 2015, 19:10)

Generally radio (WiFi) in the main line openwrt lies and squeals (kmod-mmc, etc. also) - completing the development of drivers, system, etc. It is so far distant history even as this device - except that you do not see that except for the addition of support generally lasted some work on improving what already is added and adapt to what is changed, developed for ramips/mtk7261/etc. The creators and producers of devices do not offer anything for mainline openwrt, in addition to its proprietary version of openwrt based on BB and the proprietary SDK from the manufacturer mtk7621 - or they chose the easier path...
This does not bode too well for the future of this equipment in openwrt.

(Last edited by build000 on 19 Dec 2015, 06:21)

@maurer

Windows 10 handles wireless networks differently than previous versions and I've read that a lot of people had / have issues with broadcom clients. The issue is not with the OpenWRT driver. Maybe updating the broadcom driver can help?

nitroshift

(Last edited by nitroshift on 19 Dec 2015, 10:03)

Owing to getting a bunch of Ubiquiti stuff, I have one of these for sale on EBay (uk) for anyone interested.

For you guys have not purchase witi board.Newifi d1 seems a decent alternative. It based on MT7621AT+MT7603E+MT7612E.
I have successfully ported witi image into it.All ports,switch,5g wifi is ok.
But I don't have MT7603E source codes to get 2.4g wifi working right now.
http://s21.postimg.org/xjr8ybiad/witiboard.jpg

(Last edited by axishero on 20 Dec 2015, 12:22)

about newfi d1, as i know it's without sata and external radio amps so it's not a real alternative for witi (like pandorabox pbr-m1, but pandora also don't have external amps)
also you can check youku flagship device which is very close to d1

(Last edited by stas2z on 20 Dec 2015, 12:13)

Newifi is a different board targeted for different needs.

@axishero

Please refrain from advertising other products in this thread. Thank you.

nitroshift

(Last edited by nitroshift on 21 Dec 2015, 06:53)

Does anyone know how to change default gpio number of reset button in witi-u-boot sdk? https://github.com/mqmaker/witi-uboot

(Last edited by axishero on 24 Dec 2015, 13:28)

shutin wrote:
LTH wrote:

Is there anyone who can give a guide on how to build my own image for nitro's repo?
I would like to add a git server and also add a print server.

Follow this guide from the vendor but use his repo instead.
https://mqmaker.com/doc/make-your-own-image/
You can add packages for those things in make menuconfig or you can do it afterward with opkg

I have just followed the guide above, but used the nitroshift image.

The guide says I should upload the new image with a tftp server.
but do I have to do that?
Can I just use the witiboards webinterface

The first page says "flash operations"

@LTH

You can flash the image by going to Administration / System / Backup - Flash firmware.

nitroshift

Since I don't have a WITI yet.Can any owner tell me that if it has a http failsafe web ui within its U-boot? Can you press the reset key to enter this ui?

Sorry, posts 226 to 225 are missing from our archive.