OpenWrt Forum Archive

Topic: OpenWRT on Asus RT-AC51U

The content of this topic has been archived between 12 Apr 2018 and 2 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello!

I'm currently working on an Asus RT-AC51U. I bought this router because it was not officially supported by OpenWRT and I wanted to work on a router that was not supported by OpenWRT.

So, this router uses a MediaTek MT7620A CPU which is normally supported by OpenWRT (at least, there is a profile for this CPU when building the OpenWRT firmware).
Before talking about my problem, here are some information about this device.

Firstly, I opened the case to look at the serial port. There are 4 cruciform screws on the back, after that, you have to remove the "roof" of the router (which a bit resistant).

When it was opened, I found the serial port and I soldered my serial adapter to it: http://s8.postimg.org/orhtorgdt/IMG_20150927_141424.jpg
The serial configuration is the following: 115200 8N1

After that I started to look at the manufacturer firmware. Their firmware uses a TRX extension but it seems that the firmware header is not a TRX one. After some researches, I was able to reproduce the correct header for the firmware to be accepted by the web upgrade utility (I will put the code on github later).

The original firmware can be cut into 3 parts:
- 48 bytes "TRX" header
- LZMA kernel
- SquashFS filesystem

After I built the OpenWRT firmware for the MT7620A CPU, I created the new TRX firmware with the following files:
- vmlinux.bin.lzma (LZMA kernel)
- root.squashfs (SquashFS filesystem)

Then I started the upgrade process, the firmware file is accepted and successfully wrote then the unit reboots.
When rebooting, OpenWRT seems to start but it indefinitely loops...
For more information, here is the original boot log: http://pastebin.com/461Bimt1.
Here is the one after the flash with the OpenWRT image: http://pastebin.com/gjq6hH8L.

After the OpenWRT kernel is uncompressed, it loops on the following lines:

[    0.000000] Linux version 3.18.21 (vico@Vico-OpenWRT) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r46832) ) #1 Sun Sep 27 12:53:50 CEST 2015
[    0.000000] Board has DDR2
[    0.000000] Analog PMU set to hw control
[    0.000000] Digital PMU set to hw control
[    0.000000] SoC Type: MediaTek MT7620A ver:2 eco:6
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019650 (MIPS 24KEc)

Do you have any ideas why it loops? Is there any fix?

Thanks in advance for your help,
Francis.

Which firmware image file  do you test?

Hi 123serge123,

as I said in my first post, the firmware I test is built using the root.squashfs and vmlinux.bin.lzma files, that I got after building OpenWRT for the MT7620A CPU.

The original Asus firmware is like this:
- 48 bytes TRX header
- LZMA compressed kernel
- SquashFS filesystem

The one I test is like this:
- 48 bytes TRX header (fixed due to CRC checks)
- LZMA compressed kernel given by the compilation of OpenWRT (vmlinux.bin.lzma)
- SquashFS filesystem given by the compilation of OpenWRT (root.squashfs)

Francis.

You use inconfigured kernel. Try vmlinux-mt7620a_mt7610e.bin.lzma instead of vmlinux.bin.lzma

Thank you for your fast answer 123serge123!

Indeed, using  vmlinux-mt7620a_mt7610e.bin.lzma works better but this is not 100% working tongue

Could you explain me what is the difference between the vmlinux.bin.lzma file and the  vmlinux-mt7620a_mt7610e.bin.lzma one?

So now, I get a kernel panic when mounting root fs, here is the full boot log: http://pastebin.com/QJTRfj35.

Another strange thing is that before showing:

[    0.660000] console [ttyS0] enabled

, the serial configuration is 115200 8N1 and after that it switches to 57600 8N1.

Thank you for your help smile
Francis.

Congratulation! We've found mistake in openwrt source. Line

 spi spi32766.0: setup: requested speed is too low 1000000 Hz

show that 1MHz is very low speed for spi. Change 1000000 to 10000000 (1MHz to 10MHz) in the file target/linux/ramips/MT7620a_MT7610e.dts. It must look like

spi-max-frequency = <10000000>;

and rebuild. BTW you may use ready image
bin/ramips/mt7620/openwrt-15.05-ramips-mt7620-mt7620a_mt7610e-squashfs-sysupgrade.bin

File vmlinux-mt7620a_mt7610e.bin.lzma contain hardware config integrated (simply binary version of dts-file which describes board configuration). One of the steps during building filnal firmware image is compilation dts-file (dts-file to dtb-file with dtc program) and putting dbt-file into generic kernel file (vmlinux.bin) at fixed position.

Hi 123serge123,

I modified the dts file which is in target/linux/ramips/dts/MT7620a_MT7610e.dts, and I rebuilt the image.
Then I took the build_dir/target-mipsel_24kec+dsp_musl-1.1.11/linux-ramips_mt7620/openwrt-15.05-ramips-mt7620-mt7620a_mt7610e-squashfs-sysupgrade.bin file and created the firmware by updating the header.

Here is the new boot log, it is better but it still kernel panics: http://pastebin.com/ZgFtXCDf.

It seems that MTD partitions are not the same as the one created by the original Asus firmware, maybe it is the issue?

Thank you for your help,
Francis.

No, no, no. Use ready image in ./bin/ramips. While building final firmware image openwrt writes additional info in the header for flash-driver to correctly split "firmware" partition into "kernel" , "rootfs" and "rootfs_data".

Ok, my bad!

Now, I used the correct file in ./bin/ramips but the boot log seems to be the same: http://pastebin.com/paiQVpbg.

Thanks for your patience!
Francis.

Do you really use bin/ramips/openwrt-15.05-ramips-mt7620-mt7620a_mt7610e-squashfs-sysupgrade.bin?
Log must look like:

Creating 4 MTD partitions on "spi32766.0":
0x000000000000-0x000000030000 : "u-boot"
0x000000030000-0x000000040000 : "u-boot-env"
0x000000040000-0x000000050000 : "factory"
0x000000050000-0x000000800000 : "firmware"
0x0000001479e6-0x000000800000 : "rootfs"
mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
mtd: device 4 (rootfs) set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=0x340000, len=0x4c0000
0x000000340000-0x000000800000 : "rootfs_data"

after splitting instead of:

Creating 4 MTD partitions on "spi32766.0":
0x000000000000-0x000000030000 : "u-boot"
0x000000030000-0x000000040000 : "u-boot-env"
0x000000040000-0x000000050000 : "factory"
0x000000050000-0x000000800000 : "firmware"

So in your case "rootfs" partition is not defined and mounting failed.
Something wrong with buildded image. Show output of:

mkimage -l <your_image_name>
mkimage -l openwrt-15.05-ramips-mt7620-mt7620a_mt7610e-squashfs-sysupgrade.bin

(Last edited by 123serge123 on 29 Sep 2015, 11:29)

Hi 123serge123,

yeah, I used bin/ramips/openwrt-15.05-ramips-mt7620-mt7620a_mt7610e-squashfs-sysupgrade.bin file.

mkimage -l firmware.trx
Image Name:
Created:      Mon Sep 28 19:12:32 2015
Image Type:   MIPS Linux Kernel Image (lzma compressed)
Data Size:    3145690 Bytes = 3071.96 kB = 3.00 MB
Load Address: 80000000
Entry Point:  8000c150
mkimage -l openwrt/bin/ramips/openwrt-15.05-ramips-mt7620-mt7620a_mt7610e-squashfs-sysupgrade.bin
mkimage: ERROR: "openwrt/bin/ramips/openwrt-15.05-ramips-mt7620-mt7620a_mt7610e-squashfs-sysupgrade.bin" has corrupted data!
GP Header: Size 27051956 LoadAddr acbba41

Thank you for your help.
Francis.

(Last edited by Francis on 29 Sep 2015, 13:50)

But you burn into flash your firmware.trx? Try to burn file openwrt-15.05-ramips-mt7620-mt7620a_mt7610e-squashfs-sysupgrade.bin without any modification.

Hi,

I used the file openwrt-15.05-ramips-mt7620-mt7620a_mt7610e-squashfs-sysupgrade.bin and tftp it to the router. I don't understand but it works correctly:

[    0.720000] 4 ofpart partitions found on MTD device spi32766.0
[    0.730000] Creating 4 MTD partitions on "spi32766.0":
[    0.740000] 0x000000000000-0x000000030000 : "u-boot"
[    0.750000] 0x000000030000-0x000000040000 : "u-boot-env"
[    0.760000] 0x000000040000-0x000000050000 : "factory"
[    0.770000] 0x000000050000-0x000000800000 : "firmware"
[    0.840000] 2 uimage-fw partitions found on MTD device firmware
[    0.860000] 0x000000050000-0x00000017b77a : "kernel"
[    0.870000] 0x00000017b77a-0x000000800000 : "rootfs"
[    0.880000] mtd: device 5 (rootfs) set to be root filesystem
[    0.890000] 1 squashfs-split partitions found on MTD device rootfs
[    0.900000] 0x000000350000-0x000000800000 : "rootfs_data"
[    0.920000] gsw: setting port4 to ephy mode
[    0.920000] ralink_soc_eth 10100000.ethernet eth0 (uninitialized): port 1 link up (100Mbps/Full duplex)
[    0.940000] ralink_soc_eth 10100000.ethernet: generated random MAC address 12:41:9e:04:f4:39
[    0.960000] ralink_soc_eth 10100000.ethernet: loaded mt7620 driver
[    0.970000] ralink_soc_eth 10100000.ethernet eth0: ralink at 0xb0100000, irq 5
[    0.990000] rt2880_wdt 10000120.watchdog: Initialized
[    1.000000] TCP: cubic registered
[    1.010000] NET: Registered protocol family 10
[    1.020000] NET: Registered protocol family 17
[    1.030000] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[    1.050000] 8021q: 802.1Q VLAN Support v1.8
[    1.080000] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
[    1.100000] Freeing unused kernel memory: 148K (8035b000 - 80380000)
[    3.860000] init: Console is alive

So I will dig into this router and OpenWRT, first thing, it seems wireless is not working. There is a br-lan interface listed by ifconfig but there is no /etc/config/wireless.

Anyway thank you for your help, I will try to flash the router with this file using the Asus web upgrade utility smile

Francis.

Show full boot log. And output of

hexdump -C /dev/mtd2

And add

        wmac@10180000 {
                ralink,mtd-eeprom = <&factory 0>;
        };

into dts-file to make wifi work.

(Last edited by 123serge123 on 29 Sep 2015, 20:29)

First, here is the boot log: http://pastebin.com/pyB1TRxa. I noticed that the entrypoint is different from the Asus firmware.

Here is the result of the command "hexdump -C /dev/mtd2": http://pastebin.com/Me452v2j.

I'll add the lines you gave me later and recompile the firmware. Big thank to you 123serge123, for your patience and your help!

Francis.

Hi,

So I added the line you gave me 123serge123 and now wifi works, thank you! Anyway, there is only 1 WiFi network but there should be 2 networks (2,4GHz & 5GHz).

Also, LEDs are not set correctly but I'll look into that...

Francis.

To add support for 2-nd wifi you need correct dts-file pci section. This section must look like:

        pcie@10140000 {
                    status = "okay";
    
                    pcie-bridge {
                            mt76@0,0 {
                                    reg = <0x0000 0 0 0 0>;
                                    device_type = "pci";
                                    mediatek,mtd-eeprom = <&factory 0x8000>;
                                    mediatek,2ghz = <0>;
                            };
                    };
            };

and add kmod-mt76 package into your firmware image.

Hi 123serge123,

so for replying so late, I was busy these last days.

So I added what you put in your last post into the dts file but nothing has changed, I still have 1 wireless interface.
Moreover, it seems there is an issue with the WAN interface, I have no internet. I tried to put a static address for this interface (eth0.2) but nothing happens.

Here is the following configuration for your instance:

config interface 'wan'
        option ifname 'eth0.2'
        option force_link '1'
        option macaddr 'a6:7b:54:bd:b2:1b'
        option proto 'static'
        option ipaddr '192.168.1.80'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'

Here is the lan configuration:

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option macaddr 'a6:7b:54:bd:b2:1a'
        option type 'bridge'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

So when I connect using the wireless network, I automatically get an IP address (10.0.0.xxx) distributed by the DHCP server but I can't access the Internet. When pinging a google DNS (8.8.8.8) I got no response, the same goes for 192.168.1.1.

Francis wrote:

So I added what you put in your last post into the dts file but nothing has changed, I still have 1 wireless interface.

Log pls.

Moreover, it seems there is an issue with the WAN interface, I have no internet. I tried to put a static address for this interface (eth0.2) but nothing happens.

And what is your ISP protocol (Static, DHCP, PPPoE)? First check that you use correct switch-port (LAN and WAN ports may be exchanged but can be corrected easy in switch config).

So when I connect using the wireless network, I automatically get an IP address (10.0.0.xxx) distributed by the DHCP server but I can't access the Internet. When pinging a google DNS (8.8.8.8) I got no response, the same goes for 192.168.1.1.

BTW some ISP control client connection with MAC-address. If WAN MAC was changged (with compare to stock firmware) it may be a reason too.

Hi,

Here is the log: http://pastebin.com/aJfLfk1M.

About my network, I have a router given by my ISP which has a DHCP server which serves 192.168.1.xxx IPs.
I modified the configuration of this router and put a static IP address (192.168.1.80) associated to this MAC address (a6:7b:54:bd:b2:1b) which should be the Asus router.

About ports on the Asus router, there are 4 yellow ports (LAN) and 1 blue port (WAN). Here is the full ifconfig answer:

br-lan    Link encap:Ethernet  HWaddr A6:7B:54:BD:B2:1A
          inet addr:10.0.0.1  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::a47b:54ff:febd:b21a/64 Scope:Link
          inet6 addr: fd78:c5af:87f3::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18112 errors:0 dropped:8 overruns:0 frame:0
          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:24510757 (23.3 MiB)  TX bytes:2268 (2.2 KiB)

eth0      Link encap:Ethernet  HWaddr A6:79:16:53:76:3A
          inet6 addr: fe80::a479:16ff:fe53:763a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:145827 errors:0 dropped:0 overruns:0 frame:0
          TX packets:57 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:200402729 (191.1 MiB)  TX bytes:7293 (7.1 KiB)
          Interrupt:5

eth0.1    Link encap:Ethernet  HWaddr A6:79:16:53:76:3A
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:142018 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:192620464 (183.6 MiB)  TX bytes:2400 (2.3 KiB)

eth0.2    Link encap:Ethernet  HWaddr A6:7B:54:BD:B2:1B
          inet addr:192.168.1.80  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::a47b:54ff:febd:b21b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:2192 (2.1 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:97 errors:0 dropped:0 overruns:0 frame:0
          TX packets:97 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:6984 (6.8 KiB)  TX bytes:6984 (6.8 KiB)

wlan0     Link encap:Ethernet  HWaddr 1C:B7:2C:7B:42:70
          inet6 addr: fe80::1eb7:2cff:fe7b:4270/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14828 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:20526191 (19.5 MiB)

Thanks for your help.

EDIT: Ok, I put the ethernet cable on yellow port 4 and I have internet access from the asus router...

I also found a problem with opkg feeds (/etc/opkg/distfeeds.conf), original address is:
http://downloads.openwrt.org/snapshots/ … 0/packages
it should be :
http://downloads.openwrt.org/snapshots/ … s/packages

(Last edited by Francis on 8 Oct 2015, 14:07)

Francis wrote:

Here is the log: http://pastebin.com/aJfLfk1M.

No any message from mt76 kernel module. Check installation of package kmod-mt76.

EDIT: Ok, I put the ethernet cable on yellow port 4 and I have internet access from the asus router...

In file /etc/config/network exchange port 0 and 4 in switch configuration.

There is a problem, in /etc/config/network I don't have a switch configuration. I tried to create one but when doing /etc/init.d/network reload I got this:

Failed to connect to the switch. Use the "list" command to see which switches are available.

I will check for the installation of package kmod-mt76 but I remember that I selected it.

Francis wrote:

There is a problem, in /etc/config/network I don't have a switch configuration. I tried to create one but when doing /etc/init.d/network reload I got this:

Failed to connect to the switch. Use the "list" command to see which switches are available.

Show file /etc/config/network and output of command

swconfig dev switch0 show

I will check for the installation of package kmod-mt76 but I remember that I selected it.

Show

opkg list_installed

It's possible that you build it but not include into image if you mark it as "m" (must be "y" in .config)

Hi,

So I typed "swconfig dev switch0 show"

swconfig dev switch0 show
Global attributes:
        enable_vlan: 1
Port 0:
        pvid: 1
        link: port:0 link:down
Port 1:
        pvid: 1
        link: port:1 link:down
Port 2:
        pvid: 1
        link: port:2 link:down
Port 3:
        pvid: 1
        link: port:3 link:down
Port 4:
        pvid: 2
        link: port:4 link:up speed:100baseT full-duplex
Port 5:
        pvid: 1
        link: port:5 link:down
Port 6:
        pvid: 1
        link: port:6 link:up speed:1000baseT full-duplex
Port 7:
        pvid: 0
        link: port:7 link:down
VLAN 1:
        vid: 1
        ports: 0 1 2 3 5 6t
VLAN 2:
        vid: 2
        ports: 4 6t

Now, the list of installed packages:

opkg list_installed
base-files - 160-r47159
busybox - 1.23.2-3
dmesg - 2.25.2-4
dnsmasq - 2.75-2
dropbear - 2015.68-3
firewall - 2015-07-27
fstools - 2015-09-15-cc63723d886fde2cd364a545b7cb05b70721b83f
grep - 2.21-2
hostapd-common - 2015-03-25-1
ip6tables - 1.4.21-1
iptables - 1.4.21-1
iw - 4.1-1
iwinfo - 2015-10-05-813f61e48b9b1a76cb55f3b4a229bf98d3cd53a9
jshn - 2015-09-15-136a5196266d03d537f822c4e67d2fde2ed59505
jsonfilter - 2014-06-19-cdc760c58077f44fc40adbbe41e1556a67c1b9a9
kernel - 3.18.21-1-bbefbd65218cbef13cc5c578e3e69d78
kmod-cfg80211 - 3.18.21+2015-07-21-1
kmod-eeprom-93cx6 - 3.18.21-1
kmod-gpio-button-hotplug - 3.18.21-1
kmod-ip6tables - 3.18.21-1
kmod-ipt-conntrack - 3.18.21-1
kmod-ipt-core - 3.18.21-1
kmod-ipt-nat - 3.18.21-1
kmod-leds-gpio - 3.18.21-1
kmod-ledtrig-usbdev - 3.18.21-1
kmod-lib-crc-ccitt - 3.18.21-1
kmod-lib-crc-itu-t - 3.18.21-1
kmod-mac80211 - 3.18.21+2015-07-21-1
kmod-mt76 - 3.18.21+2015-10-05-1
kmod-nf-conntrack - 3.18.21-1
kmod-nf-conntrack6 - 3.18.21-1
kmod-nf-ipt - 3.18.21-1
kmod-nf-ipt6 - 3.18.21-1
kmod-nf-nat - 3.18.21-1
kmod-nf-nathelper - 3.18.21-1
kmod-nls-base - 3.18.21-1
kmod-ppp - 3.18.21-1
kmod-pppoe - 3.18.21-1
kmod-pppox - 3.18.21-1
kmod-rt2800-lib - 3.18.21+2015-07-21-1
kmod-rt2800-mmio - 3.18.21+2015-07-21-1
kmod-rt2800-pci - 3.18.21+2015-07-21-1
kmod-rt2800-soc - 3.18.21+2015-07-21-1
kmod-rt2x00-lib - 3.18.21+2015-07-21-1
kmod-rt2x00-mmio - 3.18.21+2015-07-21-1
kmod-rt2x00-pci - 3.18.21+2015-07-21-1
kmod-slhc - 3.18.21-1
kmod-tun - 3.18.21-1
kmod-usb-core - 3.18.21-1
kmod-usb-ohci - 3.18.21-1
kmod-usb2 - 3.18.21-1
libblobmsg-json - 2015-09-15-136a5196266d03d537f822c4e67d2fde2ed59505
libc - 1.1.11-1
libgcc - 4.8-linaro-1
libip4tc - 1.4.21-1
libip6tc - 1.4.21-1
libiwinfo - 2015-10-05-813f61e48b9b1a76cb55f3b4a229bf98d3cd53a9
libiwinfo-lua - 2015-10-05-813f61e48b9b1a76cb55f3b4a229bf98d3cd53a9
libjson-c - 0.12-1
libjson-script - 2015-09-15-136a5196266d03d537f822c4e67d2fde2ed59505
liblua - 5.1.5-1
liblzo - 2.08-1
libnl-tiny - 0.1-5
libopenssl - 1.0.2d-1
libpcre - 8.37-2
libpthread - 1.1.11-1
librt - 1.1.11-1
libubox - 2015-09-15-136a5196266d03d537f822c4e67d2fde2ed59505
libubus - 2015-07-07-7ec9b8dec77b969bfc860995f96fe91fd40ba5e4
libubus-lua - 2015-07-07-7ec9b8dec77b969bfc860995f96fe91fd40ba5e4
libuci - 2015-08-27.1-1
libuci-lua - 2015-08-27.1-1
libxtables - 1.4.21-1
lua - 5.1.5-1
luci - git-15.280.61656-281d2f6-1
luci-app-firewall - git-15.280.61656-281d2f6-1
luci-app-openvpn - git-15.277.57479-56deb7b-1
luci-app-tinyproxy - git-15.277.57479-56deb7b-1
luci-base - git-15.280.61656-281d2f6-1
luci-lib-ip - git-15.280.61656-281d2f6-1
luci-lib-nixio - git-15.280.61656-281d2f6-1
luci-mod-admin-full - git-15.280.61656-281d2f6-1
luci-proto-ipv6 - git-15.280.61656-281d2f6-1
luci-proto-ppp - git-15.280.61656-281d2f6-1
luci-theme-bootstrap - git-15.280.61656-281d2f6-1
mtd - 21
netifd - 2015-09-27-509ffb22475ebdd5291d510a098f996473951344
odhcp6c - 2015-09-04-dc186d6d2b0dd4ad23ca5fc69c00e81f796ff6d9
odhcpd - 2015-09-07-1-cb1842c117030e6779f9556cd5d86b1a0ef145d7
openssl-util - 1.0.2d-1
openvpn-easy-rsa - 2013-01-30-2
openvpn-openssl - 2.3.6-5
opkg - 9c97d5ecd795709c8584e972bfdf3aee3a5b846d-10
ppp - 2.4.7-8
ppp-mod-pppoe - 2.4.7-8
procd - 2015-09-16-b6618ffab8ed4981c57f53929276559698541462
rpcd - 2015-01-10-f00890cd6eb47ad9bb5da0fb6c50aedc8406e7c5
swconfig - 10
tinyproxy - 1.8.3-2
ubox - 2015-07-14-907d046c8929fb74e5a3502a9498198695e62ad8
ubus - 2015-07-07-7ec9b8dec77b969bfc860995f96fe91fd40ba5e4
ubusd - 2015-07-07-7ec9b8dec77b969bfc860995f96fe91fd40ba5e4
uci - 2015-08-27.1-1
uhttpd - 2015-09-07-993cace15114a0f06f720f34a4748ab54b695f0d
uhttpd-mod-ubus - 2015-09-07-993cace15114a0f06f720f34a4748ab54b695f0d
usign - 2015-05-08-cf8dcdb8a4e874c77f3e9a8e9b643e8c17b19131
wpad-mini - 2015-03-25-1
zlib - 1.2.8-1

And yes, I verified the .config file and here is the line:

CONFIG_PACKAGE_kmod-mt76=y

Show file /etc/config/network pls.
BTW which branch do you use? CC or trunk?