OpenWrt Forum Archive

Topic: TP-Link TL-WR841N v11: looking for testers for trunk build

The content of this topic has been archived between 8 Apr 2018 and 7 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Well, that is odd. No, haven't modded.
I had to telnet into it and then 'mount_root' followed by 'mtd -r erase rootfs_data' since firstboot didn't seem to do a lot.

Holds the settings now and shows 'Free space: 58% (296.00 KB)'. Memory shows between 5800 and 8300kB used of 28708kB.

I wonder if it is a prob flashing an upgrade image from the OEM firmware? Thanks for your help.

danng wrote:

Well, that is odd. No, haven't modded.
I had to telnet into it and then 'mount_root' followed by 'mtd -r erase rootfs_data' since firstboot didn't seem to do a lot.

Holds the settings now and shows 'Free space: 58% (296.00 KB)'. Memory shows between 5800 and 8300kB used of 28708kB.

I wonder if it is a prob flashing an upgrade image from the OEM firmware? Thanks for your help.

Just type df -h and print the result. 296KB sounds about right though because I have similar free space after installing from Boromir build.

I still able to install DDNS packages and it only took like 40kb so I have like 245KB left.

Filesystem              Size          Used       Available  Use%     Mounted on
rootfs                       512.0K        216.0K    296.0K      42%      /
/dev/root                    2.3M          2.3M         0           100%      /rom
tmpfs                        14.0M        408.0K      13.6M        3%      /tmp
/dev/mtdblock3         512.0K        216.0K   296.0K       42%     /overlay
overlayfs:/overlay    512.0K        216.0K    296.0K       42%     /
tmpfs                        512.0K             0        512.0K        0%      /dev

So it was using the tmpfs before as that is 14MB. How bizarre! So maybe that explains why the settings didn't hold but don't know how it got to be using it in the first place. Way over my head!

danng wrote:

So it was using the tmpfs before as that is 14MB. How bizarre! So maybe that explains why the settings didn't hold but don't know how it got to be using it in the first place. Way over my head!

overlay is your real free space, tmpfs will not survive a reboot.

Hello,

I did install the v11 firmware and it works normal until I reboot the router. all the firewall port settings I made was gone now. do you have any idea about it???

Hi,

I have already posted in https://forum.openwrt.org/viewtopic.php?id=61309, but maybe this thread is a better place. I am testing the trunk version (r49395) and It seems that client mode doesn't work. I am trying to connect on a network with encryption WPA2 802.1X (CCMP) and It doesn't work. I have installed the wpad package and the supplicant has a configuration that works in a TL-841N version 9 (OpenWrt Attitude Adjustment 12.09). The configuration of the suplicant is:

root@OpenWrt:~# uci show wireless.@wifi-iface[0]
wireless.cfg033579=wifi-iface
wireless.cfg033579.device=radio0
wireless.cfg033579.network=wan
wireless.cfg033579.mode=sta
wireless.cfg033579.ssid=Eduroam
wireless.cfg033579.encryption=wpa
wireless.cfg033579.key=none
wireless.cfg033579.eap_type=ttls
wireless.cfg033579.identity=XXXXXX
wireless.cfg033579.password=XXXXXX
wireless.cfg033579.auth_cache=1

On the other hand, the comand wpa_cli status return always "wpa_state=SCANNING" and wpa_cli in interactive mode is in loop, it prints on the screen the next messages:

..........................................................
..........................................................
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
..................................................
...................................................

Does anyone has tried successfully in client mode?

King regards.

Hello, I've installed OpenWRT 15.05.1 on my WR841N V11.1 and I've trouble with port forwarding; it doesn't work. Can someone else confirm it?

Thanks

(Last edited by romke on 19 Sep 2016, 09:05)

I flashed the bin file from the first post. I can connect to the router with ssh, but not with 192.168.1.1. It gives an error that the device refused the connection, so I guess LaCi was not installed. The problem is that the router is not connected to the internet, so I can't use wget.

I tried connecting using wiki.openwrt. org/doc/uci/network and the Relay between LAN and Wireless Station. I did the first part, but the two others I didn't understand so I didn't change.

Is there a way I can just flash a new bin (again) and get the LaCi?

If I would want to go back to the stock software, do I have to flash the firmware from the tp-link website?


Thanks!

Hi Borromini,

as a feedback for you and maybe reference for other users:

Flashed 15.05.1 from your server [1].
Took file openwrt-ar71xx-generic-tl-wr841-v11-squashfs-factory.bin and flashed via firmware-upgrade option in stock TP-Link webinterface (FW TL-WR841ND_V11_150616).
(Moved/renamed flashfile with short path/filename (e.g. D:\tmp\tplink.bin) before flashing.)

Image seems to run without problems.
Power LED doesn't work as described in [3].

sorry for the fragmented links, for some reason the forum gives me an error when i try to post a url tag.
[1] h ttps:// volatilesystems.org/dl/openwrt/targets/tl-wr841n-v11
[2]  h ttps:// volatilesystems.org/dl/openwrt/targets/tl-wr841n-v11/openwrt-ar71xx-generic-tl-wr841-v11-squashfs-factory.bin
[3] h ttps:// forum.openwrt.org/viewtopic.php?id=61309

Some information from LuCI:

Model    TP-Link TL-WR841N/ND v11
Firmware Version    OpenWrt Chaos Calmer 15.05.1 r49208 / LuCI for-15.05 branch (git-16.090.31416-605d1f1)
Kernel Version    3.18.29

and shell:

login as: root
root@192.168.1.1's password:


BusyBox v1.23.2 (2016-04-21 21:45:37 CEST) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Chaos Calmer, r49208)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:~# free
             total         used         free       shared      buffers
Mem:         28708        20028         8680          304         2068
-/+ buffers:              17960        10748
Swap:            0            0            0
root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                  512.0K    216.0K    296.0K  42% /
/dev/root                 2.3M      2.3M         0 100% /rom
tmpfs                    14.0M    304.0K     13.7M   2% /tmp
/dev/mtdblock3          512.0K    216.0K    296.0K  42% /overlay
overlayfs:/overlay      512.0K    216.0K    296.0K  42% /
tmpfs                   512.0K         0    512.0K   0% /dev
root@OpenWrt:~# cat /tmp/sysinfo/board_name
tl-wr841n-v9
root@OpenWrt:~# cat /tmp/sysinfo/model
TP-Link TL-WR841N/ND v11
root@OpenWrt:~# cat /proc/cpuinfo
system type             : Qualcomm Atheros QCA9533 ver 2 rev 0
machine                 : TP-LINK TL-WR841N/ND v9
processor               : 0
cpu model               : MIPS 24Kc V7.4
BogoMIPS                : 432.53
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 16
extra interrupt vector  : yes
hardware watchpoint     : yes, count: 4, address/irw mask: [0x0ffc, 0x0ffc, 0x0ffb, 0x0ffb]
isa                     : mips1 mips2 mips32r1 mips32r2
ASEs implemented        : mips16
shadow register sets    : 1
kscratch registers      : 0
package                 : 0
core                    : 0
VCED exceptions         : not available
VCEI exceptions         : not available

root@OpenWrt:~#

edit 2107-01-10: just forgot to mention: I've got HW v11.1.

(Last edited by nuv on 10 Jan 2017, 12:06)

Hello!

nuv wrote:

[1] h ttps:// volatilesystems.org/dl/openwrt/targets/tl-wr841n-v11

something wrong with it!

looks well, but if I select in Luci
Network-interfaces or Network-wifi or simple F5
It asks autorization and after autorization it shows the mainpage again...

(Last edited by i.2.b on 13 Feb 2017, 17:53)

I have took lede, it seems looks well h ttps:// forum.openwrt.org/viewtopic.php?id=68809

Hello  boys n girls wink

firstly i apologize for lame questions, but to be thruth im openWRT lame and need your little support. Or maybe not strict support but confirmations.

My router is:
Firmware:    3.16.9 Build 151008 Rel.70008n
Hardware: WR841N v11 00000000

Time for questions wink

1/ Is this version of openwrt correct for that router? -->

filename: openwrt-ar71xx-generic-tl-wr841-v11-squashfs-factory.bin
checksum:272105012

If 1/ == true {

2/ Can I just update this bin with regular TP-Link control panel?
3/ What about that file 'openwrt-ar71xx-generic-tl-wr841-v11-squashfs-sysupgrade'
is it only for users who got already some other soft and can do update via ssh?

}

Hello. After i flash from trunk i cant  get web interface.   Telnet connection refused and ssh ask the pasword. Any solution ?

V_F wrote:

Hello. After i flash from trunk i cant  get web interface.   Telnet connection refused and ssh ask the pasword. Any solution ?

Hi.
Just tried with "openwrt-ar71xx-generic-tl-wr841-v11-squashfs-sysupgrade.bin" and it worked without problems (see below).
You have to use a LAN port.

  • Telnet is available without user/passwd:

=== IMPORTANT ============================
  Use 'passwd' to set your login password
  this will disable telnet and enable SSH
------------------------------------------

  • Webinterface is available too and prompts:

No password set!
There is no password set on this router. Please configure a root password to protect the web interface and enable SSH.
Go to password configuration...

After setting a pass with the 'passwd' command in telnet, restart the router with the 'reboot' command.
This may take a while.

After reboot, telnet will refuse connection.
login via ssh with user 'root' and the pass you set with 'passwd' command.

Maybe take a look here: wiki.openwrt.org/doc/howto/firstlogin

The discussion might have continued from here.