OpenWrt Forum Archive

Topic: TP-Link Archer MR200

The content of this topic has been archived between 11 Apr 2018 and 6 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello guys thanks for your hard work on this device.
I totally don´t have any plan about router firmwares ...
I really need some extra features on this router, because we (4 persons) have only 100 gb traffic (i would manage a fair distribution) and i need a dbm display for set up the external antenna.
Does this features are supported by openwrt ?
Does it exist a openwrt flashable file already (like the official normal updates) ?

Edit1:
Wow i finally made it:
-Download a program "tftpd32" (zip). Download "ArcherC2V1_tp_recovery.bin", copy that file into a ordner.
-Shut off router.
-Connect your device via lan/wan.
-Go to lan adapter settings, edit ipv4 - ip 192.168.0.66 and mask 255.255.0.0
-Open tftpd32 and choose/browse the ordner with the file ArcherC2V1_tp_recovery.bin, check "show Dir" if the right file choosen
-Choose the correct ip (192.168.0.66) for "server interface"
-Press and hold reset button, power on router- keep holding reset button (not hold the power on) until the update symbol on the router appears.
-On the pc there should appear now a window where the file got uploaded.
-Done
I had to try 3 different devices, because it doesn´t work.

My question how to show the ASU / dbm (Signal strength) value ? I have to install a "software/module" ?
And how i can limit the traffic for each person/mac (for example 1gb for each every day) ?

(Last edited by Deam on 9 Dec 2016, 20:11)

We are hoping to get official LEDE support soon. Heinz pull request is still not merged in LEDE. once it does, the process of switching/upgrading the router gets easier. I've been using this router with LEDE for couple of month now. completely reliable and working like charm. there are still some improvements that could be done specially for the leds. signal leds are off all the time and not showing the actual signal strength (Although you can still see the signal in the LTE's WebGUI). 4g led is also not linked to actually using 4g and will not be turned off if switched to 3g.

@Deam
Take a look at here . iirc, i was able to retrieve some info using that.

@Hamy
thanks for answer. The leds aren`t a problem for me, this firmware works very great.

Well, both packages are installed already. But where i can use "comgt reg" and "comgt info" (sorry i totally don´t have any plan) ?

(Last edited by Deam on 11 Dec 2016, 13:00)

@Deam use 3ginfo package to check signall strength: http://eko.one.pl/?p=openwrt-3ginfo

To install use this command:

opkg install http://dl.eko.one.pl/chaos_calmer/ramips/packages/3ginfo-text_20161111_all.ipk
opkg install http://dl.eko.one.pl/chaos_calmer/ramips/packages/3ginfo_20161111_all.ipk
uci set 3ginfo.@3ginfo[0].device=/dev/ttyUSB1
uci commit 3ginfo
/etc/init.d/3ginfo restart

and go to site:
http://192.168.1.1:81
to view information about connection.
You can go to http://192.168.1.1:81/signal.html to view only signal strength bar.

(Last edited by Heinz on 11 Dec 2016, 13:18)

@Heinz
that would be so great if i can see the signal strength, thats the reason i installed this firmware ;D.

Sorry where i have to insert this command. Please tell me and thanks a lot for this great firmware.

(Last edited by Deam on 11 Dec 2016, 13:36)

Hi smile

I have performed the upgrade from the supplied bin (thank you so much) tongue
This is the first time i test openwrt firmware and i would say that i like it.

So i was playing around and close to have all i wanted then i was running into a strange/blocking issue sad
I was playing with a file in  /etc/init.d for privoxy and the change i have made wasn't working so i revert my change and after that privoxy wasn't working anymore and neither tinyproxy (i have tested both and disable tinyproxy)

When privoxy couldn't start, i have enable back tinyproxy and no working too.

So like i have made a backup just my latest change, let's try to restore it -> same issue/same error.
So let's try a factory reset and same error when i have try to install privoxy again.

I have no clue what is happening.

So i would like to flash the firmware again to do a full restoration even if i would like to understand my issue sad

So my question is :

Can i flash again the (ArcherC2V1_tp_recovery.bin) from tftp ? (like i have done fro official firmware to lede)
Can i flash again the (ArcherC2V1_tp_recovery.bin) from the webGUI ? (i suppose yes but i'm not sure related to bootloader etc.)
Do i need to flash (mr200_back_to_stock.bin) first from webGUI because it doesn't contain the bootloader ? (if i have understand correctly and then to must avoid to flash it from tftp)
Then if i flash (mr200_back_to_stock.bin), i suppose that i can flash (ArcherC2V1_tp_recovery.bin) with the tftp method.

I didn't use serial so when i'm talking about tftp, it's about the start modem with reset ON for at least 10 seconds.

Ps : about the issue i have :
I have try also to uninstall privoxy and tinyproxy and install them again -> same issue
Tried also to reboot / turn off (power off) the router -> same issue.

Tinyproxy does nothing
Privoxy give me that error :
Fatal error: can't check configuration file '/var/etc/privoxy.conf': Invalid argument.

Like i said it seems to happen after editing privoxy file in /etc/init.d (or maybe it's something else but right now nothing i can do make it works again sad )

Thanks in advance for your help and really appriciate the work done for porting openwrt on MR200 tongue

Heinz wrote:

@Deam use 3ginfo package to check signal strength:

uci set 3ginfo.@3ginfo[0].device=/dev/ttyUSB1
uci commit 3ginfo
/etc/init.d/3ginfo restart

Works really nicely tongue
I did this too : uci set 3ginfo.@3ginfo[0].language=en

I didn't perform the firmware flash again yet because i'm not sure about the correct way to do it and i don't want to brick it.
Only the proxy package didn't works but no clue why.

Ok found it but no clue why :
In script to start privoxy :

We have this : (in /etc/init.d/privoxy)
/usr/sbin/privoxy --pidfile $PIDFILE --user privoxy.privoxy $CFGFILE

Changing to :

/usr/sbin/privoxy --pidfile $PIDFILE $CFGFILE

And it works smile but why ?? lol

(Last edited by sebastiii on 11 Dec 2016, 20:01)

So smile
It's working now without going to flash the firmware tongue

But if someone can confirm me (if the need to go to full firmware flash) what is the correct way, it would be really appreciate.

Thanks.

@sebastiii
please tell me where you inserted this command lines:

opkg install ..dl.eko.one.pl/chaos_calmer/ramips/packages/3ginfo-text_20161111_all.ipk
opkg install ..dl.eko.one.pl/chaos_calmer/ramips/packages/3ginfo_20161111_all.ipk
uci set 3ginfo.@3ginfo[0].device=/dev/ttyUSB1
uci commit 3ginfo
/etc/init.d/3ginfo restart

(Last edited by Deam on 11 Dec 2016, 23:39)

I have open a putty connection on ssh (port 22) then i have copy past each line smile
And enjoy it

Omg i can´t believe, this works so so so nice, love you guys.
Thanks a lot.

For others which don´t have any plan like me:
chiark.greenend.org.uk/~sgtatham/putty/download.html     (download putty.exe)
Hostname: 192.168.1.1
Port: 22
Connection Typ: SSH
Click default settints and never open window
Login with your datas from 192.168.1.1 ("root" enter "YOUR_PASSWORT" enter and add the command lines)

(Last edited by Deam on 12 Dec 2016, 01:04)

Yeah smile
Thanks to Heinz tongue

Hello.

It is working almost perfectly.

I only think it is a bug: Forwarding a port!!!
I can not reach the routers configuration site. When I type in my browser my open IP then i oallwys fall back on this site:

404 Not Found
The requested URL was not found

and i found out its this local IP: 192.168.225.1what is defined in my LEDE-Settings as USB3Gateway&DNS
???

What do i do wrong?
And another question, how can i change the language there is only englisch and polish

Thamk you guys

@Mr.Utilman
You need to type the full address:

http://192.168.225.1/login.html

there is no automatic redirection to that

@sebastiii
once you have switched to the openwrt/lede , follow the usual generic sysupgrade process and use the built-in sysupgrade routine.

(Last edited by Hamy on 15 Dec 2016, 14:05)

@Hamy: thank you for your backup! My english is bad. What you told me works fine and yes i have understand that. But what i try since 1 week day in day out is this:
For example the original firmware: When i open the port 80 and check the box "allow remote managment" ... then i can reach my router from the outside, and i also reach every device in my lan by define the port and destinations ip.
BUT now i can open all the ports and i can try what i want... i can never reach the LAN from the outside by my open IP. I can never reach any PC or server in Lan.
OpenPortTolls also allways say: all ports are closed!
And when i try my ip from outside: example.com i allways reach a Error Site instead of any port in my Lan. I allways see the same page.
And i habe tryed forwarding, open ports, deacrivating firewalls and so on...
I dont reach lan or LEDE configuration site from the outside...

(Last edited by Mr.Utilman on 15 Dec 2016, 21:32)

@Mr.Utilman try set static IP on WAN interface:
IP 192.168.225.100
mask 255.255.255.0
gateway 192.168.225.1

dns 192.168.225.1

now open port in "Network - Firewall" Port Forwarding

It´s working now perfectly. don´t know why but thanks to heinz, right information..

Hamy wrote:

@sebastiii
once you have switched to the openwrt/lede , follow the usual generic sysupgrade process and use the built-in sysupgrade routine.

Hi smile

I didn't receive notification about new answer lol.
Thanks for you information but if i want to do a full recovery to LEDE ? what should i do smile

For sure there is something wrong (it seems to be related to user right) but still it's works so it's nice (talking about privoxy and other tool).

Hamy wrote:

LEDE support is now available:
https://downloads.lede-project.org/snap … pgrade.bin

Ok, i have try to flash it from Luci Web and check keep setting but it seems to failed somehow sad sad sad sad
I can putty it on 192.168.1.1 (default address IP) but seems something get really wrong, i think i need help on this.
I can't reach 4G card neither web Luci sad

I really hope that we can do something guys.
I'm sad right now.

I have try again this, i have copied the bin to tmp folder with WinSCP then :
cd /tmp
sysupgrade /tmp/lede-ramips-mt7620-ArcherMR200-squashfs-sysupgrade.bin

But lead to the same issue nothing works except the putty connection (so it's possible to do surely something).
So it means that the link from @Hamy does not content all stuff (httpd / adb etc.) and then make MR200 not working anymore.

@sebastiii
you need to provide more info. ssh to the router and issue 'ip add' and copy its output here. also do 'traceroute 8.8.8.8' and see how far it goes. furthermore try opening http://192.168.225.1/login.html in your browser while using your router as the gateway and see if it loads anything.
not being able to load luci web gui is normal. luci is not included in trunk versions. you need to manually install it:
https://wiki.openwrt.org/doc/howto/luci.essentials
Also issue 'adb devices' in the routers ssh terminal and share its output.

(Last edited by Hamy on 24 Dec 2016, 04:48)

@Hamy

Thanks for your answer but it act like an empty router now sad

This is the log :
https://dl.dropboxusercontent.com/u/105 … pgrade.txt
https://dl.dropboxusercontent.com/u/105 … ip_add.txt

Something goes wrong for sure (led on mr200 has only pwr and lan UP all other are OFF) sad

And adb is not present, so the output is : adb not found.

About Luci, i can't do the install :
opkg update
opkg install luci

Because no internet on device and i can't reach also http://192.168.225.1/login.html neither ping it.

(Last edited by sebastiii on 24 Dec 2016, 09:44)