OpenWrt Forum Archive

Topic: TL-WR842N(EU) - openwrt support

The content of this topic has been archived between 7 Apr 2018 and 29 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

immajor52 wrote:

I have OpenWRT installed now. Could you link me a version what you think would be a good version for newbies to flash?  smile

Definitly not trunk (I mean the one at: downloads.openwrt.org/snapshots/trunk/...)

you may use the @opsy release (It works fine, and is the nearest to latest OpenWrt release, 15.05.1) I recommend this if you aren't interested on do some experiments and just want a working and stable WiFi Router.

Then, over @opsy release using telnet apply a password to be able to use ssh and also run (you can run this on telnet or ssh):

# This will install luci web gui and will be able to logon using your web browser:
# (You need working internet connected to wan port)
opkg update
opkg install luci
/etc/init.d/uhttpd start
/etc/init.d/uhttpd enable
#To remove stats scripts:
crontab -r
/etc/init.d/cron restart

or you can try the LEDE too (it is very new, but it sounds promising).
I personally don't know Gargoile but I read sometimes that it lacks some features over OpenWrt.

You can also try DD-WRT (take a look at Google Images first for some screenshots) and keep in mind that is based on OpenWRT but it is completely different, you must check first if is really compatible, and then flash to stock (tp-link branded firmware) before flash again to DDWRT, same, if you want to come back to Openwrt, flash to stock first. Or you will need to use 3v3 serial-ttl to fix boot problems.

Good luck!

(Last edited by braian87b on 8 Jul 2016, 01:13)

@braian87b and @Heinz

Thank you guys, this is a big help. I think I'm getting to understand how things are going with OpenWRT

braian87b
Could you give me a link of this  @opsy? I'm strugling with finding it.

Heinz
And how about the OpenWRT firmware in your post #9? Would that be a good choice?

(Last edited by immajor52 on 8 Jul 2016, 02:51)

immajor52 wrote:

@braian87b and @Heinz

Thank you guys, this is a big help. I think I'm getting to understand how things are going with OpenWRT

braian87b
Could you give me a link of this  @opsy? I'm strugling with finding it.


Yes, here, in Heinz post on this thread: https://forum.openwrt.org/viewtopic.php … 70#p322170

Heinz wrote:

I did via tftp.

Look here: http://tplink-forum.pl/aktualny-firmwar … wr842n-v3/

This is Openwrt CC without GUI.

(Last edited by braian87b on 8 Jul 2016, 02:50)

Heinz wrote:

I did via tftp.

Look here: http://tplink-forum.pl/aktualny-firmwar … wr842n-v3/

This is Openwrt CC without GUI.

Is it possible to make a version with GUI in it? smile If your ISP is not DHCP, it is hard to config it in the command line and then install Luci.

I installed the firmware from http://tplink-forum.pl/aktualny-firmwar … ttach=2521. But adding other packages results in weird errors like this:

root@OpenWrt:~# opkg install kmod-usb-storage-extras
Multiple packages (kmod-usb-storage-extras and kmod-usb-storage-extras) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-usb-storage-extras and kmod-usb-storage-extras) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-usb-storage-extras and kmod-usb-storage-extras) providing same name marked HOLD or PREFER. Using latest.
Installing kmod-usb-storage-extras (3.18.36-1) to root...
Downloading http://dl.eko.one.pl/chaos_calmer/ar71xx/packages/kmod-usb-storage-extras_3.18.36-1_ar71xx.ipk.
Multiple packages (kmod-usb-storage and kmod-usb-storage) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-usb-storage and kmod-usb-storage) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-usb-storage and kmod-usb-storage) providing same name marked HOLD or PREFER. Using latest.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-storage-extras:
 *     kernel (= 3.18.36-1-9ef0b82025f7672e4f62035bf8320bdd) *
 * opkg_install_cmd: Cannot install package kmod-usb-storage-extras.

Any suggestions?

tristank wrote:

I installed the firmware from http://tplink-forum.pl/aktualny-firmwar … ttach=2521. But adding other packages results in weird errors like this:

root@OpenWrt:~# opkg install kmod-usb-storage-extras
Multiple packages (kmod-usb-storage-extras and kmod-usb-storage-extras) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-usb-storage-extras and kmod-usb-storage-extras) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-usb-storage-extras and kmod-usb-storage-extras) providing same name marked HOLD or PREFER. Using latest.
Installing kmod-usb-storage-extras (3.18.36-1) to root...
Downloading http://dl.eko.one.pl/chaos_calmer/ar71xx/packages/kmod-usb-storage-extras_3.18.36-1_ar71xx.ipk.
Multiple packages (kmod-usb-storage and kmod-usb-storage) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-usb-storage and kmod-usb-storage) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-usb-storage and kmod-usb-storage) providing same name marked HOLD or PREFER. Using latest.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-storage-extras:
 *     kernel (= 3.18.36-1-9ef0b82025f7672e4f62035bf8320bdd) *
 * opkg_install_cmd: Cannot install package kmod-usb-storage-extras.

Any suggestions?

Maybe @opsi will know why... try to comment the eko.one.pl repository on /etc/opkg/dist*.conf I think is called distfeeds.conf
and opkg update and try again...

Just install  my new images, CC changed kernel to 3.18.36

obsy wrote:

Just install  my new images, CC changed kernel to 3.18.36

@opsy You mean this?


cd /tmp && wget http://dl.eko.one.pl/chaos_calmer/ar71x … pgrade.bin # OpenWrt Chaos Calmer 15.05.1 (r49398)
cd /tmp && wget http://dl.eko.one.pl/chaos_calmer/ar71xx/md5sums


# Check the checksum of the file:
md5sum -c md5sums 2> /dev/null | grep OK

# Check for config files to be on the bacckup
sysupgrade -l

# Upgrade;
sysupgrade -v -c /tmp/openwrt-*-sysupgrade.bin # Preserve config
sysupgrade -v -n /tmp/openwrt-*-sysupgrade.bin # NO preserve config - Restore Defaults

yes

@obsy Thanks! Is there a way to uninstall the luci statistics package in services?

EDIT: The command is

opkg remove --autoremove luci-app-ekooneplstat

but there is still the menu entry in services.

(Last edited by tristank on 17 Jul 2016, 13:47)

tristank wrote:

@obsy Thanks! Is there a way to uninstall the luci statistics package in services?

try https://www.google.com/search?q=uninsta … statistics
or please open a new thread, to mantain the focus of this one being specific on TL-WR842N(EU) - openwrt support.

@obsy Could you please remove every polish translation packages? Like

luci-i18n-ddns-pl luci-i18n-commands-pl luci-i18n-firewall-pl luci-i18n-hd-idle-pl luci-i18n-p910nd-pl luci-i18n-samba-pl luci-i18n-transmission-pl luci-i18n-wol-pl

Since removing them with

 opkg remove --autoremove

doesnt free up space.

(Last edited by tristank on 17 Jul 2016, 13:45)

tristank wrote:

@obsy Could you please remove every polish translation packages? Like

luci-i18n-ddns-pl luci-i18n-commands-pl luci-i18n-firewall-pl luci-i18n-hd-idle-pl luci-i18n-p910nd-pl luci-i18n-samba-pl luci-i18n-transmission-pl luci-i18n-wol-pl

Since removing them with

 opkg remove --autoremove

doesnt free up space.

will not free up space since that packages are in /rom,  (on the firmware .bin) and not on the squashfs /overlay

you can sysupgrade to smaller bin like http://dl.eko.one.pl/chaos_calmer/ar71x … grade.bin, I think that comes without luci and other packages.
3.6Mb instead of 6.4Mb on http://dl.eko.one.pl/luci/chaos_calmer/ … pgrade.bin

tristank wrote:

@obsy Could you please remove every polish translation packages? Like

luci-i18n-ddns-pl luci-i18n-commands-pl luci-i18n-firewall-pl luci-i18n-hd-idle-pl luci-i18n-p910nd-pl luci-i18n-samba-pl luci-i18n-transmission-pl luci-i18n-wol-pl

Since removing them with

 opkg remove --autoremove

doesnt free up space.

No smile this images is used in Poland...

@braian87b: I will try that.

@obsy: I understand. Maybe you can provide a different image with english language only. I would appreciate that.

hi :-)

at least Heinz seems to be able to use the UART of the wr842n-v3.
does one of you know how?

if i attach to the serial interface nothing happens :-(

kind regards

yogo1212 wrote:

at least Heinz seems to be able to use the UART of the wr842n-v3.
does one of you know how?

Watch the two parts of this video
Part #1 http://youtu.be/t35Pei_eb6o
Part #2 http://youtu.be/wCwBvoueBG4 past half of this part, shows how to confirm the values, in case yours is dif just copy from ssh and paste it
And don't forget connections are inverted
RX from TTL goes to TX
TX connects to RX
GND to GND
VCC never use it

(Last edited by danymarc on 8 Aug 2016, 15:09)

@danymarc
thank you for your reply. sorry, my question was unclear. the troubles i'm having aren't so much about sending commands and such - more about establishing the serial connection.
i've soldered on a pin header and attached my computer but nothing shows up on the console. the same procedure works for pretty much all tp-link routers i have access to (e.g. archer-c5, wdr4300, wdr3600, wr841n, wr842n-v2) but not the wr842n-v3.
my hope was that maybe i need to put a resistor somewhere to make u-boot initialise the UART or so.

all of the five wr842n-v3 don't seem to initialise their UART :-/

To enable serial, short pins on resistor R101 and R105:

http://tplink-forum.pl/uploader/uploads/1470717397.png

@Heinz
thank you very much :-)
very valuable info

obsy wrote:

Bad advice. This entry is required if you want to install some other kernel module - this is my build.

Obsy, please, can you tell me how can I install luci-app-qos or qos-scripts?, it says this:

Multiple packages (kmod-sched-core and kmod-sched-core) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-sched-core and kmod-sched-core) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-sched-core and kmod-sched-core) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-sched-connmark and kmod-sched-connmark) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-sched-connmark and kmod-sched-connmark) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-sched-connmark and kmod-sched-connmark) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-sched-connmark and kmod-sched-connmark) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-sched-connmark and kmod-sched-connmark) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-sched-connmark and kmod-sched-connmark) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-sched-core and kmod-sched-core) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-sched-core and kmod-sched-core) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-sched-core and kmod-sched-core) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ipt-core and kmod-ipt-core) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ipt-core and kmod-ipt-core) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ipt-core and kmod-ipt-core) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ipt-conntrack-extra and kmod-ipt-conntrack-extra) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ipt-conntrack-extra and kmod-ipt-conntrack-extra) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ipt-conntrack-extra and kmod-ipt-conntrack-extra) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ifb and kmod-ifb) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ifb and kmod-ifb) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ifb and kmod-ifb) providing same name marked HOLD or PREFER. Using latest.

This is warning only.

obsy wrote:

This is warning only.

but installs the dependencies packages or not?