OpenWrt Forum Archive

Topic: Kimax BS-U25CWF - MT7620N Travel Router with Wifi / no LAN USB3

The content of this topic has been archived between 27 Apr 2018 and 6 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I bought two of this and the stock firmware was awful and with chinese pages not translated in English !!!

Attention :
The supply voltage which must be sufficient especially with a hard disk -> 5.5 Volts is a good value

The product can be found at aliexpress for some 20 / 25 euros
Chipset is MT7620N 1443-BMAL
the hardware is not bad it really is a shame

-> I think that with a new firmware you really have to be careful because there is only WIFI

Success with openwrt-ramips-mt7620-u25awf-squashfs-sysupgrade.bin ( normal firmware upgrade )
For the file look forum : 
Kimax BS-U25WF - MT7620 Travel Router with Battery and HD  -> by danman post 2017-02-08 … UxFdVVSeWM

I have no WIFI and no possibility to start with LAN because no LAN !!!
I have connected TXD / RXD wires to 2 gold pads to a serial console ( 57600 bits/s )

The two wires are connected to this

I use Putty and this command for start wifi :
uci set wireless.@wifi-device[0].disabled=0; uci commit wireless; wifi

Wifi is started and i can connect

I open in explorer and i have the LUCI web interface OK

I have compiled with success for the KIMAX U25CWD

for compile use this sources
git clone -b lede-17.01 --single-branch

1- files modified as in the arvati release with u25cwf  or Kimax U25CWF names in  :

U35WF.dts renamed after U25CWF.dts

2 - add a file 99_enable_wifi in package/base-files/files/etc/uci-defaults folder
for running wifi to startup

uci set Wireless uci set wireless.@wifi-device[0].disabled=0
uci commit Wireless
exit 0

still a big thank you to our friend arvati


(Last edited by F5BJR on 19 Dec 2017, 19:46)

F5BJR wrote:

Success with openwrt-ramips-mt7620-u25awf-squashfs-sysupgrade.bin ( normal firmware upgrade )

For the file look forum :  Kimax BS-U25WF - MT7620 Travel Router with Battery and HD  -> by danman post 2017-02-08

After i have no WIFI

I have connected a serial console ( 57600 bis/s )

command for start wifi :

uci set wireless.@wifi-device[0].disabled=0; uci commit wireless; wifi in explorer and i have LUCY interface OK


After a little problem : I cannot see my HDD in NTFS ( only FAT32 )

I am not a linux specialist


System > software > update

Then filter > kmod-fs-ntfs

F5BJR wrote:

Cannot satisfy the following dependencies … pendencies

F5BJR wrote:

Also i have not found ntfs-3g package ...

It is there, at least in 15.05.1 for ar71xx. Don't forget to

opkg update

before anything else.

Thanx for your great job!
But does HDD NAS work in your version of owrt firmware?

The reason I decided to "dig internet"  for experienced people (as you are) and their solutions 
is that I can only share HDD files with other home gadgets making them connected to a NEW network initiated by the device. But is there any chance to make the hdd (NAS) a part of my current wifi network (so no need to switch wifi network for this) ?

Anyway, owrt looks thrilling :-)

(Last edited by vadim245 on 24 Oct 2017, 14:12)

For ugrade :

1 - OK with stock firmware ( chinese )

2 - With Openwrt firmware :
Connect wifi
WinSCP ( mode SCP ) root ( + password if exist ) copy new firmware in /tmp/tmp
mtd write newfirmare_name.bin firmware

3 - Also with a HDD ( firmware.bin in this )
mount hdd
mtd write newfirmare_name.bin firmware

After the reboot leaves "some" times for updating (cleaning partitions  ...)

That is very dangerous to reflash with the chinese stock firmware

Only this solution : Use a SPI eeprom programmer as this : … 23568.html … 0.0.wngRDw

Requiert the original full firmware with your NIC MAC address and not a generic
Mac Adress is in 0x40000 and up
Firmware is in 0x50000 and up

For NIC Mac Address find the 40000 and + adress in eeprom updated with Openwrt ( that is the same values )


(Last edited by F5BJR on 19 Dec 2017, 19:47)

I used standard menu to upload OWRT firmware. It worked well and I almost finished dealing with understanding its promising menus. But occasionally turned WiFi off. That was a real mistake - to turn it off and completely loose the operability (as wifi was the only possible connection  method). So I had to find a soldering iron and buy USB to RS232 port. I connected 2 wires to the yellow points fron your pic (RX/TX) and also a black GND.

Could you be so kind to make some moments a bit clearer:
1. You told you "connected 2 wires to this" (USB-to-RS232-TTL-Serial-port), but in the picture there was GND shown (black colour) as well. Did you also connect it to the port?
2.What voltage should I set (using the bridge connection) 3 or 5 volts?
3. Do I have to power on the Sata chips (main plate) also? Of course "Yes" - or otherwise Linux wont't be loaded. But do I have to attach a SATA HDD?
5. Does OWRT Linux load by default when powerd on or should I long-press the rear button to initiate startup?
6. What Putty settings should be changed from defaults (except com port number)?

1 For black wire , yes because that is the GND  ( i have 3 wires )

2 - For the box tension that is only 5 volts

3 - not only 5 volts and run with or without HDD

5 - OWRT start ( you can verify in Putty console ) after press power button a short time

6 - Putty : When you a have flash OpenWrt with  stock Kimax firmware the COMx parameters are 57600

If Wifi not start use in Putty console  : uci set Wireless uci set wireless.@wifi-device[0].disabled=0

Question : Which firmawre version did you use ?

(Last edited by F5BJR on 30 Oct 2017, 20:30)


Currently "lede-17.01-snapshot-r3290-be18a8af98-ramips-mt7620-u25cwf-squashfs-factory.bin"  is inside the device :-)
What I currently managed to achieve in Putty terminal is something like a garbage mix of Latin and "japanese" symbols  when typing :-)  Will go on learning next night.

With Putty the speed is 57600 ( others parameters are default )

Yesss! I have connected to linux. The problem last night was in bad soldering (too rough in one of the points).
Now I could complete the command as shown by you, but it did nothing. I mean no errors. Just command prompt aftet command input.

So I decided to investigate. I regenerated wifi configuration:

rm -f /etc/config/wireless
wifi config

and decided to watch the wifi config

root@LEDE:/etc# cd /etc/config/
root@LEDE:/etc/config# cat wireless

and in the next coming lines noticed the device name

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'LEDE'
        option encryption 'none'

That was "radio0" and it should be used in the sample command that you have given before.
I have done this way:

root@LEDE:/etc/config# uci set wireless.radio0.disabled=0; uci commit wireless; wifi

And IT WORKED! It works fine after reboot! What a good experience!
Thank you for your tips and support
So next night will try to update OWRT firmware from your most recent post.

(Last edited by vadim245 on 1 Nov 2017, 05:29)

This night I got stuck:
- trying to share HDD that is inside Kimax device (making it available from the network); probably this will never be as easy as automount (could not even mount it manually)
- trying to connect Kimax ( to my home router (

Hope when these 2 steps are done, I will have Kimax as a NAS HDD server in my home network. available as 192.168.10.Х

Plenty of Lunux Mans to be read :-)

Hi! An idea:
Is it possible to include to the next firmware version  (if any is supposed to be done) a working Reset button, which would restore owrt firmwate do defaults. Of course it is still possible to use USB2RS232 to connect directly to linux and do something like this:

root@OpenWrt:~# rm -rf /overlay/*
root@OpenWrt:~# sync 
root@OpenWrt:~# reboot

But welding and case disassambling and wire connection takes time and requires carefullness (to avoid any short circuit).

Probably it is possible to make the Reset button a trigger for the above commands?
Why could this be useful? This is a very quick reset method in case of wrong network setup.
In my practice I have lost connection to the device several times due to my errors in network configuration (wifi was no longer available; the PC could not acquire IP address from the router; other troubles)

Is it possible to hack Kimax to always start wifi (Owrt in fact), in case it is used as home NAS and there was a power failure and there is nobody at home to kick the button?

Why does the system  refuse installing extra packages.
I tried to install


But it says

Upgrading kmod-nls-utf8 on root from 4.4.52-1 to 4.4.93-1...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-nls-utf8:
 *     kernel (= 4.4.93-1-e19b9950ed08c60448d97dc11fbd6537) * 
 * opkg_install_cmd: Cannot install package kmod-nls-utf8.

Any other charset packet (for Russian folder names in samba) has the same trouble. If this is because of an old kernel, is it possible to meke it install the older packet (from the kernel we have here)?

(Last edited by vadim245 on 15 Nov 2017, 18:34)

Will lede-ramips-mt7620-u25awf-h1-squashfs-sysupgrade.bin work for our device (except of cource wifi not up by default)?

I mean taking it from … ps/mt7620/

(Last edited by vadim245 on 16 Nov 2017, 11:45)

We have different abilities: I never succeeded in any compiling :-( just do not know how to (and I am neither a programmer nor a Linux developer) So each time I have to look for another way to overcome obstacles. Here is what I have done:

I downloaded a firmware that was for a bit different model of Kimax (the link from my previous post). it is only 3Mb, 3 times less than the one you shared with us. But this one looked more fresh. Than updated to it using web interface from your firmware. Fortunately it successfully started, without a WiFi. I connected to com port using your method and started WiFi. I used WinSCP to copy all my config files from the previous working system (from one of backup files that I preserved (done with web GUI)). This step was necessary to avoid manual configuration steps. After reboot I had network configured (up and running) and could just download and install LEDE web interface.

From this point everything goes well right from GUI (no conflicts or dependencies trouble. All packets are installable,. Including samba and cidepages like utf8/koi)

F5BJR wrote:

I recompiled the thing " branch master " but I get like you the same kind of error:

Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod ...
*     kernel (= 4.9.58-1-1d53d9e99e27853d247084136e00a484) *  kernel (= 4.9.58-1-1d53d9e99e27853d247084136e00a4l (= 4.9.58-1-1d53d9e99e27853d247084136e00a484) *

Do you have an idea on how to make it work?

It looks like each time you have a kernel hash that is considered to be different (the installing packets consider you have a different kernel from another version), the last 3 or 4 letters are not as in original hash. Maybe kernel subversion is changed each time you do compilation. But packets want the original one. Perhaps there is a compilation option to give the kernel just the same name as the original one has.

How fast is the transfer rate between enclosed HDD and any external device over wifi?
Please mention file system used as well.

(Last edited by vadim245 on 3 Dec 2017, 18:06)

tested with a large avi file : some 3.5 MB/s

Cool, I have 1.2 Mb at most: for NTFS, fat, ext4 and even to internal Linux temp folder to exclude hdd filesystem. :-+

(Last edited by vadim245 on 4 Dec 2017, 03:11)

F5BJR wrote:

tested with a large avi file : some 3.5 MB/s

whichencryption type (wep/wpa/wpa2....) is currently being used while testing?

whichencryption type (wep/wpa/wpa2....) is currently being used while testing?

no encryption !!!

I have a strange device behaviour after reflash to fix bugs:
1. It has both features - HDD available to PC and OWRT running at the same time (previously when pressing a side button. linux started to initiate an access point and this instantly made HDD unavailable to windows)
2. It is absolutely impossible to mount HDD in linux as /dev/sda* is totally missing (why?)

I tried to do all imaginable things these days:
- flashed to new/old firmware from this forum thread (rev2.lede-ramips-mt7620-u25awf-h1-squashfs-sysupgrade.bin; lede-ramips-mt7620-u25cwf-squashfs-sysupgrade.bin) as well as from here … ps/mt7620/
- I did "firstboot" and "rm -rf /overlay/*" ...  etc

Any idea ?

P.S. I even tried to reformat HDD as ext4/fat/ntfs in a primary and logical partitions as well as switched to MBR and GPT. It is always available in windows (ext4 via extra driver)  but no more  in OWRT :-(

(Last edited by vadim245 on 19 Dec 2017, 18:50)