OpenWrt Forum Archive

Topic: Asus WL600g

The content of this topic has been archived between 19 Sep 2015 and 3 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Dear list,

I plan to use a usb soundcard with wL600g.

For this I think, I would need to compile usb sound and soundcore for the router.

Has anybody made experience with this or could tell me, how to do this?

Cheers

mindcruz wrote:

Hi guys,

I'm sorry for posting this offtopic question in your discussion. But there's just so little information to find on the WL 600g and doing some extra stuff with it.

I just ordered the 600g and a usb 250Gb harddrive. What I would like to know is: am I able to somehow run SABnzbd (that's a linux newsreader) on it and to send nzb download url's to it from outside. I read the device runs on linux so I figured this might work. The thing is I know nothing about linux or the WL 600g yet and I have no idea how it compares to the WL 500g. Could you please give me some directions to were to start reading/learning about these modifications.

I've been playing around with the wl600g and have had limited success in getting new software running on it - I now have a torrent client (transmission) running on the router, but unfortunately it's not too stable and has a habit of crashing the entire router sad

The wl600g doesn't seem to be binary compatible with the 500g series, so unfortunately the package repos for the 500g routers aren't able to run - I'd love to be proved wrong on this, though.

To get the newsreader running on it, you'll definitely need to know your way around the linux build tools, and you'll need to get the newsreader to cross-compile to the mips chip that the router uses instead instead of using the normal build tools for your linux distribution.

To start with, make sure you can rebuild the kernel from source, as described in the posts above. If you can get that sorted, you'll be on your way. Then you'll need to rewrite (or create from scratch) the makefile for the newsreader so it uses the mips tools used to build the firmware image.

Once you've done that and have managed to sort out all the errors, you'll have a binary which can either be packaged into the firmware and flashed, or ftp'd to the harddisk and run from there, which is my preference.

Found a great article at http://daniel.fiser.cz/?wl-600g regarding running samba on the wl600g. There's a good howto on compiling the kernel there as well.

HolyMoly wrote:

Found a great article at http://daniel.fiser.cz/?wl-600g regarding running samba on the wl600g. There's a good howto on compiling the kernel there as well.

I've actually had contact with Daniel about his page. Unfortunately he doesn't have the built image anymore (that would have been nice smile) but I am definitely going to try and get the samba server running the way he did. That would be a great start. Also what you said about building the original firmware myself will be something I am going to focus on first.

I asked Daniel some questions, I'll post them here as well:

> * Why are you using samba and not openwrt?

OpenWRT is not reported as running on WL-600g. I did not want to screw
my box without knowing how to fix it (see above). And I only wanted to
share some data on LAN.


> * You used the EXT2 filesystem, why not EXT3? And wouldn't it be
> possible to use the NTFS filesystem on it WITH WRITE abbility when
> compiling your own firmware?

I don't think it's a good idea to use ext3 on a relatively small USB
flash memory. And I do not need journaling there.


> * How fast are you able to use the harddrive over your network
> compared to a normal drive accessed through the network?

I did not run any benchkmark. It is slower then using the USB flash disk
locally. Data throughput is not my top priority.


> * Do you think it's possible to run a service like SABnzbd (which is
> a linux newsreader) on it?

As far as I know SABnzdb is a bunch of Python scripts... Python is not
included in the firmware, so you would have to provide it yourself.
Maybe it's part of OpenWRT and you would be lucky with running it on
WL-600g. Of course, you can "simply" compile Python and run it from
memory stick...

By the way, I now know for a fact (unless the hardware just doesnt support it) that it's possible to run this newsreader service on the 600g. A guy on another forum wrote this:

Problem compiling programs requiring libstdc++

--------------------------------------------------------------------------------

Hi all,

I am currently trying to create my first ipkg package, one that would install the "par2cmdline" application (used by SABnzbd, a server based usenet downloader that I have running on my WL-500g). It is a C++ application and requires stdlibc++.

Now it's not very clear to me how to compile applications using libstdc++ for the WL-500g. In the forum there are a number of threads from different dates saying different things. I know hwoever that other packages that work depend on it (e.g. nmap) so there should be a way... Now I managed to get the application compiled using the cross-compile environment as explained on the Unslung homepage (had to include a "make libstdc++-staging" in the Makefile) and it packages correctly, it installs OK on my WL-500g but when I run it I get the message "cannot find libstdc++.so.5" (I have both the libstdc++ wrapper package and uclibc package installed). Could someone provide me with a short overview on the best way to compile programs requiring libstdc++ based on the current Unslung state?

Thanks,

Peter.

Has anyone succeeded in flashing a jffs2 image on this router?
I successfully compiled a jffs2 image but when I tftp it to the router, the router just hangs.
I haven't opened the router but as far I can see on the fcc images the router has no serial connector so I can't see what went wrong.

What about DSL and Wifi? No sources for them?

Hello,


I try to install the tools to compile the source. However i get errors while run consumer_install:
error: Failed dependencies:
        /bin/sh is needed by uclibc-crosstools-common-3.4.2-10.i386
        ld-linux.so.2 is needed by uclibc-crosstools-common-3.4.2-10.i386
        libc.so.6 is needed by uclibc-crosstools-common-3.4.2-10.i386
        libc.so.6(GLIBC_2.0) is needed by uclibc-crosstools-common-3.4.2-10.i386
        ld-linux.so.2 is needed by uclibc-crosstools-mips-3.4.2-10.i386
        libc.so.6 is needed by uclibc-crosstools-mips-3.4.2-10.i386
        libdl.so.2 is needed by uclibc-crosstools-mips-3.4.2-10.i386
        libm.so.6 is needed by uclibc-crosstools-mips-3.4.2-10.i386
        libncurses.so.5 is needed by uclibc-crosstools-mips-3.4.2-10.i386
        libnsl.so.1 is needed by uclibc-crosstools-mips-3.4.2-10.i386
        /bin/sh is needed by uclibc-crosstools-mips-3.4.2-10.i386
        libc.so.6(GLIBC_2.0) is needed by uclibc-crosstools-mips-3.4.2-10.i386
        libc.so.6(GLIBC_2.1) is needed by uclibc-crosstools-mips-3.4.2-10.i386
        libc.so.6(GLIBC_2.1.3) is needed by uclibc-crosstools-mips-3.4.2-10.i386
        libc.so.6(GLIBC_2.2) is needed by uclibc-crosstools-mips-3.4.2-10.i386
        libc.so.6(GLIBC_2.2.3) is needed by uclibc-crosstools-mips-3.4.2-10.i386
        libdl.so.2(GLIBC_2.0) is needed by uclibc-crosstools-mips-3.4.2-10.i386
        libdl.so.2(GLIBC_2.1) is needed by uclibc-crosstools-mips-3.4.2-10.i386
        libm.so.6(GLIBC_2.0) is needed by uclibc-crosstools-mips-3.4.2-10.i386


I have this files in /lib. However i get these errors!
I'm using Ubuntu Linux 7.04.
Maybe the problen is the Linux distribution????

Another question:
With the original firmware, it is possile to use one HP LaserJet 1000 ? The router detects it, but i can print sad With a OfficeJet 5615, it prints ok smile

Thanks in advance
Best regards

Quite a few people have asked me recently to make available my samba binaries for Asus WL-600g (see http://daniel.fiser.cz/?wl-600g for step-by-step HOWTO and configuration options).

So I provide them as-is. That means no warranty, no support, no liability. Use at your own risk.

http://daniel.fiser.cz/IT/asus_WL-600g/ … .df.tar.gz

Be aware that the link might disappear without prior notice.

(Last edited by daniel.fiser on 8 Jun 2007, 10:28)

I've just got one of these boxes, and will be trying to run various things on it, eg wake-on-lan, mt-daapd server, cron, bit-torrent, nfs, usb->serial etc etc

Daniel, I will try out your Samba, thanks for providing this.

My next thought was - it's just a wl-500 derivative of some sort with some extra bits, right? Well if it has roughly the same architecture, would binaries from wl-500 run on it? Has anyone tried this? There must be some pre-compiled binaries for this hw/kernel/lib combo.

Also, memory is low, any ideas about which processes I can kill? Or maybe mounting a swap partition on the USB disk?

Let's get some discussion going to help everyone!

migmog

Hi all,

I'm considering buying the WL-600g and just wanted to confirm something with everyone here.  I have cable internet at home and would like to use that as my WAN link instead of an ADSL connection.  Is this possible?

From what I have read, it should just be as easy as removing a port from the software bridge to make it a 'WAN' port (routed), run DHCP on that interface, et voila. Is that more or less possible?  I'd just like to confirm before I fork out the cash ...

My alternative is to just get the WL-500gP, but its the same price so I'd rather get a free ADSL2 modem thrown in if possible :-)

thanks,
dunc

Hi all,

are there any news regarding the  and OpenWRT?

I bought an Asus WL-WL600g wireless ADSL2+ router a couple of days ago, and now I am a bit unhappy with the original firmware. First I thought that even DynDNS is not supported, but it seems that I just missed to find it on the configuration website. But when choosing this product I hoped that it would be supported by OpenWRT soon, because I like the idea of having a fully configurable router very much.

So, has anyone had success installing OpenWRT on this device recently, with support for ADSL2+ and WiFi of course? The device is still listed as "untested" on the OpenWRT website. How could I help you to get it working? The GPL source code of the router was on a CDROM (also an older version is on the Asus website), therefore it should be possible to include the needed stuff in OpenWRT. I don't know anything about the binary module stuff though. Maybe I can help you with my programming skill, if the tasks are not to complex.

Best regards,
Eike

if you want you can just start try to bring adsl2+ support to openwrt wink
Or simpler go another way and just add some custom binaries. I you want you can try my custom fw
(dropbear, ext2, usbsound, swap) to play with this device in root shell (basicly nothing else)

: starting dropbear on port 10  -> ssh admin@router -p 10
: starting portbind on port 1234  -> nc router 1234
: execute script after boot located on external flash (/var/harddisk/startup.sh)

also mini_fo its here but something wrong with this better not to use

i was not able to remove the ssh interface it is all runned via cfm application (binary only)

passwd is the same like you set for admin via webui

All the information are provided without any warranty.
Make sure you know what you are doing before commiting any changes to your ASUS WL-600g.

compiled image and diff to broadcoms fw sources (GPL_WL600g_1.0.2.9.B.tar.gz) are at

http://frix.fri.utc.sk/~metyl/wl600g/

ow and if you fuckup something with flashing. there is always option to reflash with tftp

1.) switch off the power
2.) while reset button is pushed switch power on
3.) power LED should start blinking slowly
4.) run tftp -m binary 192.168.1.1 -c put somegoodfirmware.file
5.) wait a while or better wait a longer while. i was not able to determine when it was completed but it takes few minutes.
6.) restart, if you fuck something in between or just repeat from 1 and wait more smile

i've flashed about 20 custom firmwares and some of them break my router but this recovery always worked.

of course and you must suplly correct fw ...

(Last edited by metyl on 5 Oct 2008, 13:42)

Hello!

2metyl you have 1.0.2.9 source?

2metyl
Big thanks, but also need A version, have it?

sorry but on the CD only B version is included. I think this is because the version if for european countries

Hello!

I have a questions!

The OpenWrt firmware for this router is in Development?  I dont´t see many people interested in Development firmwares for this router!

Is possible add a torrent client in OpenWrt for this router?

Sorry for my english

Thanks

openwrt image is ready to flash (https://dev.openwrt.org/wiki/brcm63xx-2.6).
only basic and most important detail is that openwrt cannot support propietary binary drivers for

network drivers for the on-boards DSL, Ethernet and USB

So one possibility is to use ASUS tarball and crosscompile programs you need. Main problem is that i've got problems
runing RW filesystem overlay with mini_fo.ko, but USB storage works well as storage.

To use openwrt enviroment with those stupid binary drivers, new target must be created with same kernel and gcc
(Linux version 2.6.8.1 (root@localhost) (gcc version 3.4.2) #3 Wed Aug 22 21:25:06 CEST 2007)
because current target works with latest (2.6.22.4). But then there will be problem configuring ASUS propietary stuff

ASUS GPL tarball does not have libstdc++ so it must be ported prior porting ctorrent or rtorrent.

another problem is that device has only 16

MB ram, so runing torrent is not so good idea. This is how my image looks like after killing all asus
config stuff (cfm, telnetd) and also lpd, httpd and others which are not needed for ADSL to work

# free
Using fallback suid method
              total         used         free       shared      buffers
  Mem:        13800        11984         1816            0          736
 Swap:            0            0            0
Total:        13800        11984         1816
# cat /proc/meminfo
Using fallback suid method
MemTotal:        13800 kB
MemFree:          1808 kB
Buffers:           736 kB
Cached:           5124 kB
SwapCached:          0 kB
Active:           3444 kB
Inactive:         3500 kB
HighTotal:           0 kB
HighFree:            0 kB
LowTotal:        13800 kB
LowFree:          1808 kB
SwapTotal:           0 kB
SwapFree:            0 kB
Dirty:               0 kB
Writeback:           0 kB
Mapped:           2532 kB
Slab:             2912 kB
Committed_AS:     3832 kB
PageTables:        260 kB
VmallocTotal:  1048560 kB
VmallocUsed:      1576 kB
VmallocChunk:  1046796 kB
#



# cat /proc/cpuinfo
Using fallback suid method
system type             : 96348GW-10
processor               : 0
cpu model               : BCM6348 V0.7
BogoMIPS                : 254.77
wait instruction        : no
microsecond timers      : yes
tlb_entries             : 32
extra interrupt vector  : yes
hardware watchpoint     : no
VCED exceptions         : not available
VCEI exceptions         : not available

processes

# ps axu
Using fallback suid method
  PID  Uid     VmSize Stat Command
    1 admin       304 S   init
    2 admin           SWN [ksoftirqd/0]
    3 admin           SW< [events/0]
    4 admin           SW< [khelper]
    5 admin           SW< [kblockd/0]
    6 admin           SW  [khubd]
   22 admin           SW  [pdflush]
   23 admin           SW  [pdflush]
   24 admin           SW  [kswapd0]
   25 admin           SW< [aio/0]
   30 admin           SW  [mtdblockd]
   39 admin       272 S   /sbin/dropbear -p 10
   42 admin       364 S   -sh
   43 admin       140 S   /sbin/portbind
  226 admin       200 S   pvc2684d
  315 admin       236 S   dhcpd
  368 admin       316 S   syslogd -R 192.168.1.2:514 -r 7
  372 admin       256 S   klogd
  378 admin       868 S   sshd
  531 admin       408 S   pppd -c 1.32.1 -r inet -i nas_1_32 -u wnoisekiller@freedrivers -p ******** -f 0 -m 01432ab4XXXX/1243
  590 admin       208 S   /bin/dnsprobe
  602 admin       264 S   reaim -e 91.X.X.X
  859 admin       244 S   ddnsd /var/ddnsd.cfg /var/ddnsd.cache
 2018 admin       532 R   /sbin/dropbear -p 10
 2019 admin       424 S   -sh
 2051 admin       292 R   ps axu

look at all modules loaded

## cat /proc/modules
Using fallback suid method
usb_storage 49728 0 - Live 0xc014b000
sd_mod 15744 0 - Live 0xc0141000
scsi_mod 91168 2 usb_storage,sd_mod, Live 0xc01a1000
pwc 44480 0 - Live 0xc015d000
ov511 68528 0 - Live 0xc0169000
ip_nat_rtsp 4816 0 - Live 0xc00d0000
ip_conntrack_pptp 2416 0 - Live 0xc0041000
usblp 12656 0 - Live 0xc0146000
ehci_hcd 25776 0 - Live 0xc00d5000
ip_nat_pptp 1824 0 - Live 0xc00d3000
uhci_hcd 27152 0 - Live 0xc00dd000
ip_conntrack_h323 2256 0 - Live 0xc00ce000
ipt_state 544 2 - Live 0xc00cc000
ipt_MASQUERADE 1504 1 - Live 0xc00b7000
ipt_LOG 4064 2 - Live 0xc0043000
ip_conntrack_rtsp 73024 1 ip_nat_rtsp, Live 0xc00b9000
ip_nat_tftp 1888 0 - Live 0xc00b2000
ipt_MARK 704 0 - Live 0xc00b0000
ipt_TCPMSS 2240 2 - Live 0xc00ae000
ipt_mark 416 0 - Live 0xc00ac000
ipt_REDIRECT 768 2 - Live 0xc00aa000
ip_nat_irc 2304 0 - Live 0xc00a8000
ip_conntrack_gre 1968 2 ip_conntrack_pptp,ip_nat_pptp, Live 0xc009b000
ip_conntrack_tftp 1824 0 - Live 0xc0099000
ip_nat_h323 2112 0 - Live 0xc0097000
ip_conntrack_ftp 20576 0 - Live 0xc00a1000
ipt_layer7 9360 0 - Live 0xc009d000
ip_conntrack_irc 68864 1 ip_nat_irc, Live 0xc0085000
ip_nat_gre 1408 0 - Live 0xc0051000
ipt_FTOS 992 0 - Live 0xc004f000
ipt_limit 896 2 - Live 0xc004d000
ipt_length 448 0 - Live 0xc004b000
ip_nat_ipsec 44816 0 - Live 0xc0079000
ip_conntrack_ipsec 30672 0 - Live 0xc0070000
iptable_mangle 960 0 - Live 0xc000a000
iptable_nat 15184 10 ip_nat_rtsp,ip_nat_pptp,ipt_MASQUERADE,ip_nat_tftp,ipt_REDIRECT,ip_nat_irc,ip_nat_h323,ip_nat_gre,ip_nat_ipsec, Live 0xc0046000
ip_conntrack 24736 19 ip_nat_rtsp,ip_conntrack_pptp,ip_nat_pptp,ip_conntrack_h323,ipt_state,ipt_MASQUERADE,ip_conntrack_rtsp,ip_nat_tftp,ipt_REDIRECT,ip_nat_irc,ip_conntrack_gre,ip_conntrack_tftp,ip_nat_h323,ip_conntrack_ftp,ipt_layer7,ip_conntrack_irc,ip_nat_ipsec,ip_conntrack_ipsec,iptable_nat, Live 0xc0015000
iptable_filter 928 1 - Live 0xc0013000
ip_tables 13984 14 ipt_state,ipt_MASQUERADE,ipt_LOG,ipt_MARK,ipt_TCPMSS,ipt_mark,ipt_REDIRECT,ipt_layer7,ipt_FTOS,ipt_limit,ipt_length,iptable_mangle,iptable_nat,iptable_filter, Live 0xc0036000
wl 360064 0 - Live 0xc00e6000
bcm_usb 15792 0 - Live 0xc0031000
bcm_enet 17680 0 - Live 0xc002b000
bcmprocfs 12288 0 - Live 0xc000f000
adsldd 114432 0 - Live 0xc0053000
blaadd 5808 0 - Live 0xc000c000
atmapi 48176 2 adsldd,blaadd, Live 0xc001e000
# cat /proc/filesystems
Using fallback suid method
nodev   sysfs
nodev   rootfs
nodev   bdev
nodev   proc
nodev   sockfs
nodev   usbfs
nodev   usbdevfs
nodev   tmpfs
nodev   pipefs
        ext2
        squashfs
nodev   ramfs
        msdos
        vfat
nodev   devfs
        ntfs
#

# cat /proc/cmdline
Using fallback suid method
root=31:0 ro noinitrd

Hi
I flashed the device with my own custom build.     Unfortunately the build broke my device. Now i have a problem with puting oryginal firmware (or any other firmware) on the device. After the device starts the power led is red and the device dosent respond (i have ping but the tftp server always returns a timeout error when i try to flash it). I'v tried to hold the reset button while turning the power on but the device behaves the same.
I'v been trying to find a solution for this problem for nearly two days so any suggestions are welcome.

To metyl:

thanks for startup script and sleep 60.
How did you complie dropbear? Seems I need to install new version of libc.

with your dropbear binary I get this errors:

Dec 3 20:43:01    authpriv    info    dropbear[2301]: exited before userauth: bad packet size 

and even can't auth.

With vesion 5 of dropbear I get this:

Dec 3 21:23:51    authpriv    warn    dropbear[2568]: failed to open any /dev/pty?? devices
Dec 3 21:23:51    authpriv    warn    dropbear[2568]: no pty was allocated, couldn't execute
Dec 3 21:23:51    authpriv    info    dropbear[2568]: exit after auth (admin): Exited normally

ideas?

Sorry, posts 76 to 75 are missing from our archive.