OpenWrt Forum Archive

Topic: Linksys E2100L is here, has anybody tried it out.

The content of this topic has been archived between 19 Apr 2018 and 4 May 2018. Unfortunately there are posts – most likely complete pages – missing.

I would suggest to refrain from using the orignal linksys image, as openwrt is better for most cases of inquisitive fiddling, stability etc.
at least for my usage

I'd like to try openwrt. But I didn't see any support for E2100L. Right now I am using dd-wrt but really don't like wireless/wired speed between router and other devices. I got much faster speed on original firmware that is why I was interesting to get telnet/ssh connection to original firmware.
If openwrt will be fine with this, I definitely use it, but I haven't try it, as didn't see build for E2100L.

Will share my build if you would like to try..

I used v.90's factory bin posted back in November. It updated through the Linksys web interface. I'm not going to be using the device as a router, so I'm not sure about some of the other issues mentioned, but for my purposes it is working fine.

One note. Although the /etc/openwrt_release says it's 10.03, since v.90 build this off of svn, it's using the kernel from 10.03.1-rc4. You'll need to change your opkg.conf to using 10.03.1-rc4 packages to get working kernel modules.

Glad to know the firmware I posted was useful for you. I'm sorry I haven't done more with it.

I had stability issues, my wireless clients would lose their internet connection (or at least the ability to ping through the device to my first hop) even though the wired clients were stable.

I went back to stock Linksys 1.02.005 firmware, and see that they posted 1.04.007 on 01/12/2011. I submitted a GPL request and will post that link to the wiki once they get back to me.

Hmm. Maybe this will light a fire under me to take another crack at this!

(edit: more stability issues have brought me back to using openwrt, as noted below)

(Last edited by v.90 on 30 May 2011, 07:28)

Interesting, in my case my version of OpenWRT just works fine on 2100L I used it for quite some time.

What revision did you end up using?

I used this code..
http://sourceforge.net/projects/dslite-6rd/
I will try to get the exact versions for you.

currently I am using the below tree of course I have some custom modifications in it. But I don't think It should effect anything.

URL: svn://svn.openwrt.org/openwrt/branches/backfire
Repository Root: svn://svn.openwrt.org/openwrt
Repository UUID: 3c298f89-4303-0410-b956-a3cf2f4a3e73
Revision: 25829
Node Kind: directory
Schedule: normal
Last Changed Author: jow
Last Changed Rev: 25816
Last Changed Date: 2011-03-01 23:38:46 +0530 (Tue, 01 Mar 2011)


On another note, how do you submit changes to OpenWRT by email ? I mean my custom goodies and new hardware platform support..

Oh, interesting. That project is actually the reason I got this hardware platform. I don't know why I never noticed your username was in both places (slaps forehead).


As for getting commits done, I have no idea. Maybe shoot an e-mail to the devel list or ask in IRC?

smile sorry I just try to keep my head low..

thanks for advise  and I really like this community, and would try to give my free time for the betterment.
I will try IRC sometime today/tomorrow..

Part of my problem is that I ran out of disk space for my build environment VM, and ended up moving it off to attached storage that is rarely attached. I'd like to mock something up using Amazon EC2, but haven't put forth the effort.

That said, here is Cisco's response to my GPL request for those who are interested:
http://www.filehosting.org/file/details … 216.tar.gz

I used the steps provided by v.90 to get backfire (10.03, r26359) running on my e2100l via a serial cable.  I was able to flash it many times and everything was going really well with the image I was using, until at one point I just issued a simple reboot.  Upon coming back up I only get gibberish from the serial link and no ability to ping.  Any thoughts on what may cause such a situation?  The behavior makes me think the boot code has been corrupted, but I'm not sure what could have happened during otherwise normal operation for that to occur.  Is there any hope to restoring a router in such a state?

(Last edited by lerhaupt on 11 Apr 2011, 09:08)

Is your serial cable soldered ? or loosely connected..
because if its loosely connected then it can be thats the cause of garbage on serial console.

did you check if see if the boot-loader is alive.. looking for packets wire shark and continuous ping test ?

@v.90 the wiki doesn't help you with JTAG?   http://wiki.openwrt.org/doc/hardware/port.jtag

@nikolaik: we don't support original firmware. Help with compiling belongs into the wiki. Maybe there already is help available for the 160 and it would help you and your problem is already solved?

@Orca: Thanks for the link. JTAG is not so much my thing but if I ever have to go there (I hope not) I'll know where to look!

@lerhaupt: I am apt to agree mohnkhan here. Are you sure your connection to the serial headers isn't shorted in some way? I used bare wire that was looped around the pins until I got fed up with them and acquired a set of these (Link). In my case I needed M-F wires but they also sell M-M and F-F. They were worth it tho as they made the connection much less delicate and precarious to set up.

(Last edited by v.90 on 11 Apr 2011, 16:15)

Thanks for the replies.  The cable is indeed loosely connected to the router.  I removed it and still get the unending blinking blue light of failure.  I installed wireshark and wasn't able to see any traffic over eth0.  Admittedly, I've never used wireshark before, but tcpdump -i eth0 doesn't show anything either.  Continuous pings also result in no reply.   I'm going to invest in some of those solderless cables, but in the meantime do you think its possible that something somehow shorted and fried the boot code?

Hard to say. With RX and TX right next to each other, in theory if they shorted during the u-boot process, the device would see its output from TX thrown back to it on RX, resulting in who knows what.

The one time I shorted my leads resulted in simple terminal garbage. During this reboot, do you remember observing any garbage on the terminal? Or any sort of clear and discernible u-boot text?

Agree to v.90....
In my experience.. I have bricked a router without doing anything that can write to boot loader. Nothing definitely/seriously can explain what happens sometimes. You can only speculate.

about wireshark test thingie.. I would say you try avoiding windows XP PC, because its LAN bring up time is lower.
you power on the router and check for activity from the lan side on the only connected pc. Linux is preferred.

to detect this packets of life from bootloader from openwrt sometime in some stubborn router you need to try around 10 times
one time  = power cycle + view on wireshark for packets.

if you don't see anything again power cycle.

if there is  boot loader intact, then you can sure recover it 99% of times.

JTAG is just not possible on Linksys I never really  succeed. And I have lacked that patience to try out different JTAG cables/kits and play around.


For this you can follow any de-bricking guide, all tend to explain the same basic idea.

Thanks for the advice.  I am running linux locally and have tried a number of times now to capture any packets from the device on bootup.  Since the problems started, there was never anything other than garbage shown during the boot process.  I've since bought a new router and given up on the old one.  I'm using the same image that the other router used when it died.  So far all is well.

Sorry to hear that...
I didn't bother to do a second read/review of whatever I typed (grammar).
Just one more thing to remember if you have serial cable always connected. make sure you don't use the wrong voltage ones. It can slowly kill the router too.

This thing of sudden death used to happen on 54GL more than any other models.

Greetings all. I am back on OpenWRT on my E2100L. The Linksys firmware had become really unstable, presumably due to the level of wireless noise (due to channel saturation) in my apartment building and the device being connected to 'the internet'. The problems I was seeing were more than enough motivation to finally do something with this project.

I finally figured out how to compile this on Amazon EC2. It was well worth the effort. I'm working up the time/motivation to post a how-to or something to the wiki. TBQH the process is very simple and for someone like me who isn't willing to give up their main CPU for compiling I think a few cents per hour to use EC2 is worthwhile.

That said, my next phase is to build trunk instead of backfire and see how it runs. smile

Just out of curiosity what are you guys running for your wireless transmit power?

Using trunk, mine gets set to 27 dBm (501 mW) which seems unlikely, shouldn't it be quite lower?
Using backfire (10.3.1-rc5) the config is blank and iwconfig says 27 dBm.

In all of my terminal logs I never bothered to look at /etc/config/wireless or iwconfig so I'm wondering if this has always been the case. And more importantly, what is the actual max of this radio. smile

(Last edited by v.90 on 6 Jun 2011, 06:00)

v.90 wrote:

Just out of curiosity what are you guys running for your wireless transmit power?

Using trunk, mine gets set to 27 dBm (501 mW) which seems unlikely, shouldn't it be quite lower?
Using backfire (10.3.1-rc5) the config is blank and iwconfig says 27 dBm.

In all of my terminal logs I never bothered to look at /etc/config/wireless or iwconfig so I'm wondering if this has always been the case. And more importantly, what is the actual max of this radio. smile

Could you please share your firmware so others can try it?
I have an E2100L and am trying it... Really need to use VPNC and DD-WRT doesn't includes it in their E2100L release and I can't find a compiled E2100L version I can try.

Thanks

I posted a proof-of-concept build earlier in this thread here and just now fixed the download link, which became inactive over time. I used filehosting.org because they are the same service provider that Linksys/Cisco uses when fulfilling GPL source requests.

Good luck and please have a serial console handy.




On a separate note, a bug for WRT160NL also affects us. Sysupgrade will fail if you attempt to preserve config files.
Thread
Ticket #8960

This one hit me when I attempted to upgrade to trunk from backfire-10.03.1-rc4. I had to break out a screwdriver and a console cable and reflash from TFTP to fix it.

(Last edited by v.90 on 8 Jun 2011, 23:57)

mohnkhan, could you please share your build? Is it working properly? I bricked my router and now I'm bringing it back to life, but I can't trust my build again.

Thanks!