OpenWrt Forum Archive

Topic: Linksys E2100L is here, has anybody tried it out.

The content of this topic has been archived between 19 Apr 2018 and 4 May 2018. Unfortunately there are posts – most likely complete pages – missing.

hmm... I've never used this cable but with other PL2303 devices I've used I was able to set the rate, I'd think you'd be able to do it either on the COM port itself or in PuTTY. This is of course based on a foggy memory heh.

I just got it working on another E2100L
Got the source using this:

svn co svn://

I needed to fix some missing packages on my Ubuntu laptop to get compiling working but it worked.
Did this as mentioned earlier on this post:

All I did was change "NL16" to "NL1X" in these two files:

I got one error regarding the compiling ran it again with VT=99 and ran it again and it compiled succesfully. Upgrading via DD-WRT didn worked so I had to get a MAX232 kit working and recovered it via serial/bootloader using the TFTPD method.

Now is running fine:
U-Boot 1.1.7 (Jan  8 2010 - 14:26:25)

DRAM:  ar7100_ddr_initial_config(237) enter!
ar7100_ddr_initial_config(269) exit!

U-Boot 1.1.7 (Jan  8 2010 - 14:26:25)

AP81 (ar7100) U-boot
64 MB
WRT160NL u-boot version: 1.0.0
Top of RAM usable for U-Boot at: 84000000
Reserving 279k for U-Boot at: 83fb8000
Reserving 192k for malloc() at: 83f88000
Reserving 44 Bytes for Board Info at: 83f87fd4
Reserving 36 Bytes for Global Data at: 83f87fb0
Reserving 128k for boot params() at: 83f67fb0
Stack Pointer at: 83f67f98
Now running in RAM - U-Boot at: 83fb8000
id read 0x100000ff
flash size 8MB, sector count = 128
Flash:  8 MB
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag7100_enet_initialize...
ag7100 get ethaddr for device eth0
Fetching MAC Address from 0x83feb2b0

--------***** Get the RTL8306SD Manufactory ID=386c *****-------
Reg6: speed=0 nway=1 duplex=1
Reg5: speed=0 nway=0 duplex=0
Reg1: a1=7fd9 a2=3210 a3=16d4 a4=3210 a5=0
Reg1: a1=7fd9 a2=3210 a3=16d4 a4=3210
Reg1: a1=7fd9 a2=3210 a3=16d4 a4=3210
Reg1: a1=7fd9 a2=3210 a3=16d4 a4=3210
Reg1: a1=7fd9 a2=3210 a3=16d4 a4=3210
eth0: 98:fc:11:3f:ad:34
eth0 up
### main_loop entered: bootdelay=1

Hit any key to stop autoboot:  0
## Booting WRT160NL ...
Code pattern OK: NL1X  Expect: NL1X
Application code length 0x0000ffe0
## Booting image at bf04003c ...
   Image Name:   MIPS OpenWrt Linux-
   Created:      2012-01-24  19:02:05 UTC
   Image Type:   MIPS Linux Kernel Image (gzip compressed)
   Data Size:    1199562 Bytes =  1.1 MB
   Load Address: 80060000
   Entry Point:  80060000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
kernel: org len = 1199562, new len = 1245184
No initrd
## Transferring control to Linux (at address 80060000) ...

.... And after a few seconds:

BusyBox v1.15.3 (2012-01-24 12:17:11 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
|       |.-----.-----.-----.|  |  |  |.----.|  |_
|   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
|_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
Backfire (10.03.1, r29859) ------------------------
  * 1/3 shot Kahlua    In a shot glass, layer Kahlua
  * 1/3 shot Bailey's  on the bottom, then Bailey's,
  * 1/3 shot Vodka     then Vodka.

Now I have to get everything else running.
This thread was quite helpful.

Hi, I have a e2100l and would like to try installing backfire on it. Does anyone have more detail instructions on build and installation? I don't have JTAG or serial connections to the router.. so would be nice if the instructions are reliable.


I have been following what is going on here and i would like to get this to work on my router, but i am net to source building router FW and i also see a serial tag is recommended.
so many questions
but first
I have backfire and trunk downloaded
i have my configuration set to wrt160nl and i have changed the two files, it will not compile.
i have had my whole system crash on a compile even with "ionice -c 3 nice -n 20 make -j 2" i have a quadcore
what would be a good serial tag for this?
what should i report back for compile issues (i want rndis enabled as well for my phone)
i dont mind setting up a build bot, i got the extra HW here at home

Doesn't seem to be a lot of activity for the Linksys E2100L but thought I would throw in my success story.  I'm currently using Firmware Version OpenWrt Attitude Adjustment r33174 / LuCI Trunk (trunk+svn8893) that I compiled a little over two weeks ago.  Its currently going on a little over 9 days up time with no noted problems.  I installed ntfs-3g to enable read/write to 2TB NTFS drive.  Also have MiniDLNA installed and partially running.  I say partially because it won't index or show files with the MPG extension.  It did index all of the AVI files (a little over 300) and the few I tested streamed flawlessly.  Since I already have a good streaming system running PS3 Media Server on an older Dell Optiplex with WinXP I dropped the MiniDLNA idea and disabled it on the router.  Disk write performance was slow, about 1Mb/s compared to over 11Mb/s when writing to the same disk attached to the Optiplex.  Not sure if the problem is the USB piece SAMBA, or the ntfs-g3 module.  My best guess is the ntfs-g3 module.  I compiled the firmware on Ubuntu 12.04 running in a VirtualBox on a Vista64 PC.  I compiled using the instructions found in the Wiki and the two changes found in this thread (NL16 to NL1X).  After compiling and running on the router I was able to change the Router Model to Linksys E2100L as displayed on the status page.  I didn't reboot the router after doing so but I'm pretty sure it will stick.  Just got tired of seeing WRT160NL displayed.  I did that by changing /tmp/sysinfo/model.  I've done a few more updated compiles but am reluctant to update the firmware since everything is working so good as is.  I have already soft bricked the router 3 times and was able to recover without the use of a JTAG or serial cable.  Don't want to push my luck!  I actually ordered a serial cable the last time it bricked because I thought I wasn't going to recover.  Within a hour after placing the order I was able to recover again using the failsafe boot.  I'm nowhere near being a Linux guru but by following the instructions carefully was able to successfully compile, install and configure the E2100L to the point where I want it.  I do wish I had a second one just so I could play and experiment more.  I'll just have to keep checking the garage sales!

Any chance you could upload your build somewhere for those of us afraid to build our own?


I just finished a new build this afternoon that I plan to test this evening (r33311).  The build I'm using now doesn't include some of the extra's I mentioned previously.  I added them later using the package installer in Luci.  The new build has everything included.  If it loads successfully and seems OK I'll find a place to put them for download.  As a side note, changing the /tmp/sysinfo/model to E2100L is not permanent.  I guess the fact that it is in the tmp directory should have been a clue.  Still trying to figure out where to change it in the source so it gets compiled in the right place.  The problem, for me anyway, is that even the stock firmware for the E2100L contains lots of references to the WRT160NL.  I don't want to change something that causes a catastrophic failure!

Jim  smile

Edit:  Sorry to say I did it, bricked my router big time.  The good news is the Nokia CA-42 cable I bought before and needed now worked and I was able to recover.  So I'm back at it again.  If I come up with something that seems like a safe install I let you now.

(Last edited by jimfree on 1 Sep 2012, 05:52)

Thanks very much!

I dont have the cable yet (ordered it already) so I am not willing to try anything with the router unless its safe.

I'm still at it, it seems like every time I add minidlna then the compile bombs on me with an error saying that a resulting file is too big.  Yet I can compile without it and add it though the web interface afterwards, at least I did once before.  I just thought it would be nice to have everything in the package!  I have a good package compiled with the latest trunk, Attitude Adjustment r33311.  If all else fails and I decide to give up on including minidlna I'll put that one up if you are interested.  Now that I have a working serial cable I have no fear!

This is the error I'm getting -- fread failure or file "/home/jimfree/openwrt/trunk/build_dir/linux-ar71xx_generic/root.squashfs-64k" too large

(Last edited by jimfree on 3 Sep 2012, 06:51)

For wintoon or anyone else who is interested I have shared my build of OpenWrt Attitude Adjustment r33174/LuCI Trunk (trunk+svn8893) at  I was trying to build an all inclusive bin that would include minidlna but for whatever reason, no matter what I did, it came out too large.  With this build I was able to install ntfs-3g, minidlna and luci-app-minidlna using the luci interface and still have room left over.  For the life of me I cannot figure out why I couldn't to a complete compile with the later trunk versions.  You don't need the ntfs-3g if you don't plan on writing to a NTFS drive plugged into the USB port.  Likewise, you don't need to install minidlna unles you want to try it out.

It has been stable on my router.  It was up and running for over a week until I started trying recompile and install new trunk releases to include minidlna.  I've installed it from the stock firmware update web interface and from the luci web interface with no problems.  With all the experimental builds I've become pretty adept at using the serial console to recover from bricked situations smile.


I forgot to mention a couple of things.

1.   The share drive doesn't seem to work right from the Luci interface.  It sets up the mount point OK but the share didn't work.  I had to SSH in and set it up using the mount command.

2.  If you want your router to display the proper model number you can use Luci  to make an entry in Local Startup file, "sed -i 's/WRT160NL/E2100L/g' /tmp/sysinfo/model", quotes not needed.  You'll find it on the SYSTEM|STARTUP tab using Luci.


Thanks very much for the build!

I am still waiting for my cable so I dont want to try and build anything yet, but I will try yours right away.

Thanks again!

Let me know how it goes.  I'm still trying to compile with the latest trunk changes but keep having problems.  I just deleted everything and downloaded fresh source code.  The first compile takes quite a while, waiting to see how it turns out.

Ok, I've got it where I like it using OpenWrt Attitude Adjustment r33324/LuCI Trunk (trunk+svn9236).  the bin is pretty much the same as the r33174 that I posted earlier.  SAMBA and NTFS read/write are included in this build.  I still could not include MiniDLNA in the build as it kept getting too big.  It can be easily installed using the Luci package installer if desired.  After installing MiniDLNA Luci still shows Free space: 17% (416.00 KB).  It has only been running for about 12 hours so does not have the one week plus burn in but I'm pretty confident at this point.      Setting up the mount point and share seems to work as advertised with this release.  I didn't have to SSH in and mount the NTSF drive from the command line.  After a year of trying dd-wrt builds that I would have to reboot 2 or 3 times a week to keep the wireless going I'm wondering why I didn't try building openwrt sooner.  Of course, time will tell!  I probably still won't use MiniDLNA even though its installed as it still won't index/steam mpg files.  I tested the install of this bin from the stock web and it upgraded to openwrt with no problem.  Also tested installing from the r33174 build and that went Ok too.  If you do upgrade from the previous openwrt be sure to  uncheck the Keep Settings box.  One of the times I bricked was trying to keep the settings and using the sysupgrade bin.  I'm not sure if it was the build or that I tried to keep the settings.  I did however backup the settings from r33174 and apply them to r33324 with no issues.  As near as I can tell this build should be the same as the recent beta release.

Here's the link to the bin:


You can enable indexing of mpg files by installing the full variant of libffmpeg I believe.

I thought that to be the case but the bin was too large when I tried to include it and not enough room to install via package installer.  I wasn't willing to give up other features to make room.  It is more of a personal challenge that a need.  In any case I appreciate the work of all the developers and I'm happy with the build I have!

hey jimfree thanks for the work on this. i am trying to go from dd-wrt to your build. and well nothing happens, i just get a badflash. any suggestions? i can recover with tftp with the dd-wrt build.
any suggestions?

also i tried to build my self awhile back and my desktop would just crash, i used ionice and only 2 of 4 threads so i wasent even cooking the cpu at the time.

@rocker2344  I hadn't tried loading from dd-wrt so not sure what your problem may be from there.  If you can flash back to dd-wrt via tftp you should be able to do the same with my build of openwrt.  Have you tried flashing via tftp yet?  If you haven't done so with dd-wrt it would probably be a good idea to reset to factory settings before loading the firmware.  You could also reload the stock firmware from the dd-wrt web gui and then load the openwrt from there.  I know that works as I've done it several times.  I do know that every time I tried to load firmware from openwrt to openwrt and I forgot to uncheck the keep settings box I would get bricked and have to use the serial console to recover, even when using the sysupgrade bin.  There could be a similar issue going from dd-wrt.

I'm actually been running a version a few releases later and have gone almost 2 weeks without touching the router other than checking the statistics.  It looks like the wifi has slowly dropped connection speed over that time but I have not experienced any troubles with video streaming during that time.  Until today that is, but I couldn't confirm which end the problem was.  I reset the access point (Trendnet TEW-640MB) to the PS3 that does the streaming and just hit the wireless save settings button on the E2100L.  That fixed the problem.  I should have checked after doing the access point but didn't think about it at the time.


(Last edited by jimfree on 26 Sep 2012, 04:03)

Yes i tried tftp. it sent nothing idk why
i did a 30-30-30 and installed from dd-wrt webui
i did a 30-30-30 and installed from linksys webui
i did a 30-30-30 and tftp again

Also i think my wireless radio is burnt but i dont care because i mainly use it as a switch with extra powers (how do i know ssh sees ath0 but i cant put it up and dd-wrt reports the mac as 00:00:00:00:00:00)
it has been destroyed for a while just thought i might mention that because it might be holding it back.

@rocker2344  You just reminded me of one of the reasons I gave up on dd-wrt, I was also getting the wireless mac address of 00:00:00:00:00:00.  I don't remember the dd-wrt version that started though.  I'm guessing everything was working OK when the linksys firmware was installed? Curious to know if the mac address showed up while the linksys was installed, if you checked for that.  I can't think of a single reason why either of the openwrt bins I posted wouldn't work as they both had several days of burn in and were working fine on my E2100L.  I haven't received any feedback other than yours.  I was hoping to hear from wintoon to see if it worked for him.  I currently running r33362 which was supposed to fix some issues with mount and unmount usb drives.  I discovered later that the issues are still there.  I thought they were fixed but I still have to use ssh to mount the drive.  Luci shows the mount point correctly in the webui but it doesn't mount the drive.  Oh well.  If you want to try r33362 let me know and I'll put it out there too.


Because this great book: … 143988109X
(this textbook uses a Linksys E2100L router as a backend)

I also want to try the Linksys E2100L,but it's some expensive for me.
So i will try to port the Xinu to wr703n,it's more cheap,so many guys can try it.

it works now. and wow openwrt has a lot of settings it will take a while to get it back to switch mode because this is like a maze for me >_< WIKI HERE I COME!

EDIT: now it stoped....

(Last edited by rocker2344 on 26 Sep 2012, 23:08)

Sounds like you might have some sort of underlying hardware problem.  My current uptime is 13d 16h 49m 36s.

Edit:  Just thought of something, were you in the process or finished making any configuration changes when it stopped working?  It's possible that a bug is in there that didn't show up in the way I configured mine.  I didn't touch any of the switch configurations for example.  Were you able to reboot back to OpenWrt after it stopped?

(Last edited by jimfree on 27 Sep 2012, 01:05)

havent gotten back in. tftp is giving apport responces but the lights light up correctly
as in i enable eth0 on laptop and the corrsopnding lan light turns on

Are you getting any ping responses from the router?  SSH or Telnet both not working either?  TFTP service doesn't run all the time, you need to catch it during the bootup process, not the easiest thing to do as the window of opportunity is very short.  Are you using the command prompt window to tftp?  I found it easier to use a gui version that automatically tries the tftp every second or so while booting the router.  Makes it easier to hit that short window of opportunity.  I think I downloaded it somewhere off of the dd-wrt site.  Don't remember for sure.