OpenWrt Forum Archive

Topic: Tp-link Tl-wr703n

The content of this topic has been archived between 18 Mar 2015 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

noob123 wrote:

I tried to change IP address of my 703n. After changing it I made a mistake in syntax, I wrote something like this:

'192.168.1.1

I forgot to close ', and I disconnected it.

Now I can't access anymore.

What can I do?

Thanks!

use "failsafe" mode

johan666 wrote:
twinclouds wrote:

Looks you are having fun.  It is really pretty simple.
I agree with all your said.  The compiled version using squashfs is compressed and uses less flash memory than jffs.  (I am not sure but guess the ram usage will be the same.)  The first time compilation needs more time than second time around from my experience.  If you only add some packages or make some minor changes, it usually only take 10-20 minutes even with single core.

Compare with compile linux kernel, it is too easier.
just that today's workstation linux doesn't need compile anymore, unless you need fine tune or fine customization.

I find that multi-core doesn't really speedup compilation time, even I have also enabled parallelized.
Do I need to use "distclear" after some period of time to start all over again ?
Or it is fine just add the changes ?

I've just saw trunk code r31541 is out, kernel is 3.3.4

I don't do distclear normally, if all I want to do is to add or delete a few packages in the compiled image.  If you want to recompile a new distribution or you modified the source code, it may be safer to do that.

twinclouds wrote:

I don't do distclear normally, if all I want to do is to add or delete a few packages in the compiled image.  If you want to recompile a new distribution or you modified the source code, it may be safer to do that.

Another problem is I'm not able to compile all packages.
Now I have disabled many things, such as dlna samba appweb sound video etc....
Then I can successfully compile all targets and 3xx packages.
I have tried select everything, but still fail to complete the whole compilation.  Just that over 6xx packages has been built, but stop somewhere..
So how can buildserver build all that packages ?

johan666 wrote:

......
Another problem is I'm not able to compile all packages.
Now I have disabled many things, such as dlna samba appweb sound video etc....
Then I can successfully compile all targets and 3xx packages.
I have tried select everything, but still fail to complete the whole compilation.  Just that over 6xx packages has been built, but stop somewhere..
So how can buildserver build all that packages ?

I only build the packages that I need.  I had problems with some packages before due to compatibility issues but these are solved later on.  If you can identify which one you cannot build by building only that one and some other basic packages, you can let the Openwrt people know by opening a ticket.  There is a site for this purpose.  It is also possible due to resources availability of your computer.  As for me, I don't see why I need to build everything all at once.

johan666 wrote:

So how can buildserver build all that packages ?

make V=99 IGNORE_ERRORS=m
jow wrote:
johan666 wrote:

So how can buildserver build all that packages ?

make V=99 IGNORE_ERRORS=m

I have tried, but still got "exit world"
With "ignore errors", I built 6xx packages.
Some packages got errors then skip....., but then, some serious error cause exit world.

For example,
I saw "appweb" build fail and skip,
after built some more packages, fail in building "b.a.t.m.a.n" thing, then exit.
Also tried w/o -j, but really slow...

I don't use everything, just wanna know what wrong in my system.


I've just finished building trunk r31646, it use linux kernel 3.3.5
Cool!

(Last edited by johan666 on 8 May 2012, 01:28)

The only failing stuff breaking the build despite IGNORE_ERRORS=m is failing host builds, which are usually directly related to the compiling system.

jow wrote:

The only failing stuff breaking the build despite IGNORE_ERRORS=m is failing host builds, which are usually directly related to the compiling system.

All packages selected and compile with "IGNORE_ERRORS=m", I've got something like that.
Look like something is missing.

make[2]: Leaving directory `/home/joh/openwrt/trunk/feeds/packages/lang/4th'
make[2]: Leaving directory `/home/joh/openwrt/trunk/feeds/packages/ipv6/6scripts'
make[2]: Leaving directory `/home/joh/openwrt/trunk/feeds/packages/ipv6/6tunnel'
make[2]: Entering directory `/home/joh/openwrt/trunk/feeds/packages/libs/aalib'
make[2]: Entering directory `/home/joh/openwrt/trunk/feeds/packages/net/aircrack-ptw'
make[2]: Entering directory `/home/joh/openwrt/trunk/feeds/packages/libs/pcre'
make[2]: Leaving directory `/home/joh/openwrt/trunk/feeds/packages/libs/aalib'
make[2]: Entering directory `/home/joh/openwrt/trunk/feeds/packages/libs/libcrypto++'
make[2]: Leaving directory `/home/joh/openwrt/trunk/feeds/packages/net/aircrack-ptw'
mkdir -p /home/joh/openwrt/trunk/bin/ar71xx/packages /home/joh/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33/pcre-8.11/ipkg-ar71xx/libpcrecpp/CONTROL
install -d -m0755 /home/joh/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33/pcre-8.11/ipkg-ar71xx/libpcrecpp/usr/lib
cp -fpR /home/joh/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33/pcre-8.11/ipkg-install/usr/lib/libpcrecpp.so.* /home/joh/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33/pcre-8.11/ipkg-ar71xx/libpcrecpp/usr/lib/
cp: cannot stat `/home/joh/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33/pcre-8.11/ipkg-install/usr/lib/libpcrecpp.so.*': No such file or directory
make[2]: *** [/home/joh/openwrt/trunk/bin/ar71xx/packages/libpcrecpp_8.11-2_ar71xx.ipk] Error 1
make[2]: Leaving directory `/home/joh/openwrt/trunk/feeds/packages/libs/pcre'
make[1]: *** [package/feeds/packages/pcre/compile] Error 2
make[1]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/home/joh/openwrt/trunk/feeds/packages/libs/libcrypto++'
make[2]: Entering directory `/home/joh/openwrt/trunk/feeds/packages/libs/libamsel'
make[2]: Entering directory `/home/joh/openwrt/trunk/feeds/packages/libs/expat'
make[2]: Leaving directory `/home/joh/openwrt/trunk/feeds/packages/libs/libamsel'
make[2]: Leaving directory `/home/joh/openwrt/trunk/feeds/packages/libs/expat'
make[1]: Leaving directory `/home/joh/openwrt/trunk'
make: *** [package/compile] Error 2

real    0m12.127s
user    0m6.424s
sys    0m5.076s

Do I need to separate those compile tasks rather than just use "make" ?

make defconfig
make prereq
make IGNORE_ERRORS=m V=99 BUILD_LOG=1 tools/install #tools build
make IGNORE_ERRORS=m V=99 BUILD_LOG=1 toolchain/install #toolchain build
make IGNORE_ERRORS=m V=99 BUILD_LOG=1 target/compile #kernel compile
make IGNORE_ERRORS=m V=99 BUILD_LOG=1 package/cleanup #package cleanup
make IGNORE_ERRORS=m V=99 BUILD_LOG=1 package/compile #package compile
make IGNORE_ERRORS=m V=99 BUILD_LOG=1 package/install #package install
make IGNORE_ERRORS=m V=99 BUILD_LOG=1 package/rootfs-prepare #rootfs preparation
make IGNORE_ERRORS=m V=99 BUILD_LOG=1 package/index #package index
make IGNORE_ERRORS=m V=99 BUILD_LOG=1 target/install #image generation

(Last edited by johan666 on 8 May 2012, 12:56)

Warning it looks like the firmware dated 5/29 will brick your 703N.
It loads OK but the eth0 network interface doesn't work.  Failsafe mode doesn't fix eth0.

Kevin

sewnbacktogetherwrong wrote:

Warning it looks like the firmware dated 5/29 will brick your 703N.
It loads OK but the eth0 network interface doesn't work.  Failsafe mode doesn't fix eth0.

Kevin

I think the same goes for the 5/29 firmware for the TL-MR3020 too! I installed it on two separate devices simultaneously and both failed on eth0 (I soldered a serial cable to one)

sgt_smith wrote:
sewnbacktogetherwrong wrote:

Warning it looks like the firmware dated 5/29 will brick your 703N.
It loads OK but the eth0 network interface doesn't work.  Failsafe mode doesn't fix eth0.

Kevin

I think the same goes for the 5/29 firmware for the TL-MR3020 too! I installed it on two separate devices simultaneously and both failed on eth0 (I soldered a serial cable to one)

I can confirm this-- I bought a TL-MR3020 two weeks ago, got everything up and running, but killed it with a bad power supply, so I bought a replacement today. Same model, same shelf in the store, same version number (v1.6) on the sticker that's on the ethernet port if you open the case. Installed latest firmware and I can't connect via ethernet. The lights do the same thing as described by sgt_smith over here: https://forum.openwrt.org/viewtopic.php?pid=168465#p168465

I will try connecting via serial tomorrow and upload the older firmware (downloaded it on May 11th). Hopefully that will get things working again...

I've updated the page on the wiki to warn about this: http://wiki.openwrt.org/toh/tp-link/tl-mr3020?s[]=mr&s[]=3020 and provided a link to the working firmware: http://www.4shared.com/file/7rCKwhZF/openwrt-ar71xx-generic-tl-mr30.html?

(Last edited by kronick on 30 May 2012, 09:25)

@ kronick  @ sewnbacktogetherwrong

do you remember which build (r?????) has problem ?

For me, after r31956, ethernet still ok
but wifi cannot start automatically after bootup.

Exactly the same 5/29 firmware problem here. It bricks both of my WR703N sad

I have added a * WARNING * in the wiki page to prevent people getting the firmware to brick the device
http://wiki.openwrt.org/toh/tp-link/tl-wr703n#flashing

* I do not have alternative link for working image. If anyone has one, perhaps it is good to include it in the wiki.

** Besides, could the wiki include some "tested" release, or at least known good release for people to flash? I was confused by the wordings and not expect the squashfs.bin is actually a *Risky* snapshot release... sad

(Last edited by samcwy on 31 May 2012, 06:12)

@Kronick
thanks for the heads up, just got mine and was about to flash

alternative link would be nice, that 4chard wants signup and its broken.

I GOT MY FUCKIN ROUTER BRICKED bcos someone comitted junk code without even testing it.
Coding with your both hands in your pants is okay, but test it or don't fuckin commit !!
Yeah, i'm so fuckin pissed off !! I had to go in a chineese lab to fix it with the serial port like a homeless drunk men.
Common guys, rolling release is cool, but if you can't keep it (kernel modules always broken, ...) just don't do it.
Richard Stallman wouldn't be proud of you guys...

We don't do rolling releases, you're confusing unattended trunk builds with something tested, that is not the case.

I had the same ethernet malfunction problem with the latest firmware update. Though, I updated using the web interface with the "keep settings" option, and the router was still reachable after the update, through wifi.

From there I (mistakenly) thought I could reflash the firmware to go back to first login mode, using that command:

mtd -r write /tmp/openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-sysupgrade.bin firmware

And now, not only the router doesn't answer to the telnet login, but the blue LED goes to lit (non flashing) state after having flashed for about 10 seconds.

@johan666 What works on my MR3020 is Attitude Adjustment Bleeding Edge r31650. I didn't look at the release number on the broken firmware but it is the build from 29-May-2012 09:10 in trunk.

PM me if you want the r31650 firmware for MR3020 and that link isn't working for you.

@vict0r I felt like a total badass soldering in a serial port header for mine. It's all a matter of perspective... I'm just thankful for a project with a community where when there is a problem like this, I can search on the forums and find several other folks going through the same thing and solve it together. rms would love that!

I don't have r31650.
I have r31541 r31779 r31790 r31792......
My latest working build is r31956
I have just built r32007.  But seems that the problem persist.

johan666, did you clean your kernel tree after svn up / git pull ? Since the ag71xx driver is shipped as full source file (not patch), it won't get rebuild if you simply issue "make" without at least "make target/linux/clean" before.

jow wrote:

johan666, did you clean your kernel tree after svn up / git pull ? Since the ag71xx driver is shipped as full source file (not patch), it won't get rebuild if you simply issue "make" without at least "make target/linux/clean" before.

I actually tried delete the whole ~/openwrt and start all over again.
svn co svn://svn.openwrt.org/openwrt/trunk/
feeds update -a
feeds install -a
make defconfig
make prereq
make menuconfig
make
* only selected ar71xx target, all packages remain default.

But the problem remain the same in system log:
user.info sysinit: Configuration file: /var/run/hostapd-phy0.conf user.info sysinit: nl80211: Failed to add interface wlan0 into bridge lo: Operation not supported

I don't know why there is "nl80211", and loopback "lo" become not support,
as a result wifi won't come up after bootup.
However re-issue "wifi" manually will bring wifi up again.
I have post this in ticket system.
And also tried remove /etc/config/wireless then reboot, then re-enable default SSID - openwrt,
wifi still can't bring up after bootup, same error in system log.

I believe you guys didn't tweak the driver, somehow it is unnecessary.
One thing I didn't do is wipe my settings, but my setting is already simple enough.
Pls help to check ....

(Last edited by johan666 on 30 May 2012, 23:51)

An update: All of the current kmod-* packages in trunk refused to install on the older firmware build because of an outdated kernel. So I couldn't get USB storage working :-( I re-flashed to the current trunk build and am SSHing over Wifi for the time being. This is for a PirateBox-like device, so I don't need ethernet, but do need USB.

Since I don't have ethernet on the router, I downloaded all the packages to my laptop, put them on a local web server, and changed opkg to pull packages from the local network. This router may never see the Internet and that's ok!

Seems the latest trunk doesn't work on WR703N (WAN can't connect to Internet)
Does anyone noticed this issue ?

5/29/2012-build bricks mine, too!
How to fix it? only through ttl?