OpenWrt Forum Archive

Topic: Tp-link Tl-wr703n

The content of this topic has been archived between 18 Mar 2015 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

maurer wrote:

hi all,
I discovered with that both 3g usb modems K3520 -Z and -H (made by huawei and zte) don't get enough electrical power do dial or to maintain a connection.
tried in different sites  - so the 3g signal was ok and with 2 different carrier sims inserted.
also tried it with 2 different 703n - so it's a general issue affecting all the v1.2.

strange, the black ZTE modem from rcs-rds works fine, both powered and providing network..
i'm playing with v1.2 too smile

i've successfully attached a hard disk to 703n without external power supply. so maybe insufficient power supply is not at fault if a USB dongle doesn't work? sorry if i misunderstood! by the way, has anyone tried using a cellular modem to connect Openwrt to the internet? i want to connect my old Samsung Symbian-based phone to the router and use its built-in 3G cellular modem to connect to the internet. Under Ubuntu, i can do that without any configuration. is it possibe on Openwrt?Thanks

sin wrote:

Under Ubuntu, i can do that without any configuration. is it possibe on Openwrt?Thanks

give us the output of "lsusb" and "lsmod" to try figuring out ..

aind wrote:
maurer wrote:

hi all,
I discovered with that both 3g usb modems K3520 -Z and -H (made by huawei and zte) don't get enough electrical power do dial or to maintain a connection.
tried in different sites  - so the 3g signal was ok and with 2 different carrier sims inserted.
also tried it with 2 different 703n - so it's a general issue affecting all the v1.2.

strange, the black ZTE modem from rcs-rds works fine, both powered and providing network..
i'm playing with v1.2 too smile

yes - the black modem from RCS-RDS works vey well - if you get signal smile - but that's a MF110 - different model/ HW id
@ sin - you need the kmod-usb-acm module for mobile phones + normal 3g modules like usb-serial etc...

(Last edited by maurer on 1 Nov 2011, 11:10)

I need some help. Of course! smile

I flashed my new TL-WR703N today. Things were working fine until I made a mistake in /etc/config/network. I assigned 192.168.1.1 to "wan" interface and "dhcp" to "lan". Now I can only ping 192.168.1.1, but cannot telnet or ssh into it. I tried booting in failsafe, but it looks like it did not go to failsafe.

I am currently traveling and only have my laptop and ethernet cable. What can I do to login to the router?

All help will be appreciated.

Thanks

aind wrote:
sin wrote:

Under Ubuntu, i can do that without any configuration. is it possibe on Openwrt?Thanks

give us the output of "lsusb" and "lsmod" to try figuring out ..

hello, here is the output of dmesg when i boot the router with phone plugged into the USB port:

usbcore: registered new interface driver usbserial
USB Serial support registered for generic
usbcore: registered new interface driver usbserial_generic
usbserial: USB Serial Driver core
USB Serial support registered for GSM modem (1-port)
usbcore: registered new interface driver option
option: v0.7.2:USB Driver for GSM modems
device wlan0 entered promiscuous mode
br-lan: port 2(wlan0) entering forwarding state
br-lan: port 2(wlan0) entering forwarding state
device wlan0 left promiscuous mode
br-lan: port 2(wlan0) entering forwarding state
device wlan0 entered promiscuous mode
br-lan: port 2(wlan0) entering forwarding state
br-lan: port 2(wlan0) entering forwarding state
ar71xx-wdt: enabling watchdog timer
ar71xx-wdt: timeout=60 secs

when i tried to issue 'ifup wan' to connect, the output of 'logread' is
ing state
Jan  1 00:06:07 OpenWrt kern.info kernel: device wlan0 entered promiscuous mode
Jan  1 00:06:07 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 00:06:07 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 00:06:09 OpenWrt daemon.notice pppd[2202]: pppd 2.4.5 started by root, uid 0
Jan  1 00:06:10 OpenWrt daemon.err pppd[2202]: Connect script failed
Jan  1 00:06:14 OpenWrt daemon.info hostapd: wlan0: STA 00:22:fa:77:5b:7c IEEE 802.11: authenticated
Jan  1 00:06:14 OpenWrt daemon.info hostapd: wlan0: STA 00:22:fa:77:5b:7c IEEE 802.11: associated (aid 1)
Jan  1 00:06:14 OpenWrt daemon.info hostapd: wlan0: STA 00:22:fa:77:5b:7c WPA: pairwise key handshake completed (RSN)

any advice?

AV wrote:

I need some help. Of course! smile

I flashed my new TL-WR703N today. Things were working fine until I made a mistake in /etc/config/network. I assigned 192.168.1.1 to "wan" interface and "dhcp" to "lan". Now I can only ping 192.168.1.1, but cannot telnet or ssh into it. I tried booting in failsafe, but it looks like it did not go to failsafe.

I am currently traveling and only have my laptop and ethernet cable. What can I do to login to the router?

All help will be appreciated.

Thanks

hit the reset button in quick succession as soon as it boots up! means you have to hit it repetitively and quickly. after that, you should be in failsafe mode. i also had messed up the configuration several times but failsafe mode never fails me!

it works! it wasn't working because i didn't set the correct PIN code!

dyq helped me with this. His instructions were much clearer than OpenWrt wiki

To enter failsafe mode:

1. Reboot (Power Down and then UP) the router
2. When the blue LED starts flashing, press the RESET (inside the tiny hole next to the mini-usb)
3. Stop pressing the RESET when the blue LED starts flashing quickly

At this time the router is in failsafe mode.

4. telnet 192.168.1.1. It will take you to the root prompt.
5. Enter "firstboot" at the prompt to reset the router to default
6. Reboot.

Entering "reboot" at the prompt did not work for me, so I had to power cycle. And I was in business.

Thank you.

hi all,
i want to build a 3g router and i have thought to buy a tl-wr703 plus a huawei e173, that works fine under linux, but i have some questions:

1) this openwrt image: http://downloads.openwrt.org/snapshots/ … actory.bin   already contains USB support?
otherwise which is a image that contains usb support for 3g dongle?

2) if i want to install the webgui simply run opkg install luci ?

3)i have read that someone has some problems with some 3g dongle, is an hw power problem or a dongle problem?

Tomorrow i'm buying a tl-wr703 so i can try to do some tests with a mf627 (zte) and a onda mh600hs, both already set in modem-mode so i needn't to usb_modeswitch.

Thanks a lot
ps. excuse me for my bad english

(Last edited by tangoristo on 4 Nov 2011, 23:12)

1) no usb drivers in snapshots - here is a build by me with luci and usb and 3g modules: http://ubuntuone.com/6ojc2uAmCOVR43Utw2q5pZ
2)if you manage to connect the router to internet through command line - ssh/telnet , yes just run:            opkg install luci
3) yes - i have problem with vodafone dongles k3520 both revisions -Z from ZTE and -H from Huawei.
I don't have confirmation that is a hardware issue.

good luck with your tests and post back!

(Last edited by maurer on 5 Nov 2011, 08:53)

john.smith.meiru wrote:

Does anyone have problem with the wr703n connecting as a wireless client. Mine keeps repeating below in dmsg

wlan0: authenticate with 00:22:b0:d3:a1:b0 (try 1)
wlan0: authenticate with 00:22:b0:d3:a1:b0 (try 2)
wlan0: authenticate with 00:22:b0:d3:a1:b0 (try 3)
wlan0: authentication with 00:22:b0:d3:a1:b0 timed out
ath: Failed to stop TX DMA, queues=0x001!
ath: Failed to stop TX DMA, queues=0x001!
ath: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00026e00
ath: Could not stop RX, we could be confusing the DMA engine when we start RX up
ath: Failed to stop TX DMA, queues=0x001!
ath: Failed to stop TX DMA, queues=0x001!
ath: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00006400
ath: Could not stop RX, we could be confusing the DMA engine when we start RX up

@john.smith.meiru

Same here. It looks like problem with the WR703n when acting as a wifi client. It can take ages for it to get associated but as soon as its associated those message will stop appearing. I have created a ticket here https://dev.openwrt.org/ticket/10349. You can put your dmesg in that ticket if you want.

Hope developers can fix it very soon. That's the only noticeable bug I have found with openwrt on wr703n. It otherwise runs perfectly fine.

for me, repeater just works as it should on 703n.
root@OpenWrt:/mnt# Sending discover...
Sending select for 192.168.43.107...
Lease of 192.168.43.107 obtained, lease time 3600
udhcpc: ifconfig wlan1 192.168.43.107 netmask 255.255.255.0 broadcast 192.168.43.255
udhcpc: setting default routers: 192.168.43.1
udhcpc: setting dns servers: 192.168.43.1

root@OpenWrt:/mnt# opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
Inflating http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/snapshots.

sin wrote:

for me, repeater just works as it should on 703n.
root@OpenWrt:/mnt# Sending discover...
Sending select for 192.168.43.107...
Lease of 192.168.43.107 obtained, lease time 3600
udhcpc: ifconfig wlan1 192.168.43.107 netmask 255.255.255.0 broadcast 192.168.43.255
udhcpc: setting default routers: 192.168.43.1
udhcpc: setting dns servers: 192.168.43.1

root@OpenWrt:/mnt# opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
Inflating http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/snapshots.

Sin,

Could you post the version of openwrt you are running? Also please post your /etc/config/wireless file as well?

I have been struggling get the client mode working on my 703n.

sin wrote:

for me, repeater just works as it should on 703n.
root@OpenWrt:/mnt# Sending discover...
Sending select for 192.168.43.107...
Lease of 192.168.43.107 obtained, lease time 3600
udhcpc: ifconfig wlan1 192.168.43.107 netmask 255.255.255.0 broadcast 192.168.43.255
udhcpc: setting default routers: 192.168.43.1
udhcpc: setting dns servers: 192.168.43.1

root@OpenWrt:/mnt# opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
Inflating http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/snapshots.

@Sin

You are really helpful. It looks like a regression on MAC80211 package. I revert it back from r28772 to r28294 and the client mode works instant.

Good evening, I need help, anyone can change the language setting to English or other languages??? Thank you for your attention.

s7mx1 wrote:
sin wrote:

for me, repeater just works as it should on 703n.
root@OpenWrt:/mnt# Sending discover...
Sending select for 192.168.43.107...
Lease of 192.168.43.107 obtained, lease time 3600
udhcpc: ifconfig wlan1 192.168.43.107 netmask 255.255.255.0 broadcast 192.168.43.255
udhcpc: setting default routers: 192.168.43.1
udhcpc: setting dns servers: 192.168.43.1

root@OpenWrt:/mnt# opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
Inflating http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/snapshots.

Sin,

Could you post the version of openwrt you are running? Also please post your /etc/config/wireless file as well?

I have been struggling get the client mode working on my 703n.

i've just installed the latest precompiled version from the trunk http://downloads.openwrt.org/snapshots/trunk/ar71xx/.i forgot the version.

mq109 wrote:

Good evening, I need help, anyone can change the language setting to English or other languages??? Thank you for your attention.

default TP-link chinese firmware - NO - NOT possible yet!
openwrt luci - has english by default - just install luci

mq109 - To elaborate on maurer's reply, here's a brief guide to get going with OpenWrt on the WR703N with an English language web interface:

1. Connect your PC to the WR703N and configure it with a static IP of 192.168.1.2
2. Visit http://192.168.1.1/userRpm/SoftwareUpgradeRpm.htm
3. Upload the latest OpenWrt snapshot for the TL-WR703N (http://downloads.openwrt.org/snapshots/ … actory.bin)
4. Wait 4-5 minutes for the firmware to upload and the device to reboot. The blue LED will be lit solid when it's finished.
5. You should be able to telnet to the device on 192.168.1.1 and receive an OpenWrt prompt (no password required)
6. Set a password on the device (use the "passwd" command). Note: once you've done this you will need to SSH to the device, telnet will be disabled.
7. Configure /etc/config/network with an IP address, gateway and DNS servers that allow the device to access the Internet. Either reboot the device or run "/etc/init.d/network restart" to apply the settings.
8. Run "opkg update" and "opkg install luci" to install the web interface

Hope this helps,

Sam

Thanks buddy, but I am a layman in the field, I know use windows, linux I know nothing. I tried to understand your hint, but it is a lot to me. Anyway thank you for your prompt help.

I have a problem with WR703N. After bad firmware I have a this messages in a Terminal (connected by Nokia cable COMtoUSB):
U-Boot 1.1.4 (Aug 27 2011 - 10:39:39)

AP121-2MB (ar9330) U-boot

DRAM:  32 MB
led turning on for 1s...
id read 0x100000ff
flash size 4194304, sector count = 64
Flash:  4 MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag7240_enet_initialize...
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
: cfg1 0x5 cfg2 0x7114
eth0: 00:03:7f:09:0b:ad
ag7240_phy_setup
eth0 up
: cfg1 0xf cfg2 0x7214
eth1: 00:03:7f:09:0b:ad
athrs26_reg_init_lan
ATHRS26: resetting s26
ATHRS26: s26 reset done
ag7240_phy_setup
eth1 up
eth0, eth1
Autobooting in 1 seconds

Then I type "tpl" and can insert commands in CLI.
I entered this commands:
erase 0xbf020000 +34004 (size of firmware from this forum in HEX)

Then I see this error that 34003 not in flash...
I can`t erase bad firmware and upload new to it. What`s wrong with it?

AlexSpb wrote:

Then I type "tpl" and can insert commands in CLI.
I entered this commands:
erase 0xbf020000 +34004 (size of firmware from this forum in HEX)

Then I see this error that 34003 not in flash...
I can`t erase bad firmware and upload new to it. What`s wrong with it?

Are you suppose to use something like

erase 0xbf020000 +0x34004

I believe you need to put 0x before the hex address.

erase 0xbf020000 +0x34004

I believe you need to put 0x before the hex address.

Hi s7mx1
Not working for me..
CLI says:

hornet> erase 0xbf020000 +0x34004
Error: end address (0xbf054003) not in flash!
Bad address format

What are we doing now?

(Last edited by AlexSpb on 10 Nov 2011, 13:45)

AlexSpb wrote:
erase 0xbf020000 +0x34004

I believe you need to put 0x before the hex address.

Hi s7mx1
Not working for me..
CLI says:

hornet> erase 0xbf020000 +0x34004
Error: end address (0xbf054003) not in flash!
Bad address format

What are we doing now?

@AlexSpb

If you have not modified the uboot and/or the hardware (flash chip) and according to openwrt wiki the image always starts at address 0x9f020000 on the flash. The size of the firmware image should always be 0x3c0000 (taken from WR841nd wiki page but they are essential the same in regarding the flash size).

Therefore you should always do

erase 0x9f020000 +0x3c0000
cp.b 0x80000000 0x9f020000 0x3c0000
bootm 0x9f020000

Assume you loaded the image via tftp to address 0x80000000.

If it still failed check the size of the flash.

Thanks for reply!
I did this:

hornet> erase 0x9f020000 +0x3c0000

First 0x2 last 0x3d sector size 0x10000
  61
Erased 60 sectors

Erasing is ok. Then I load image via tftp:

hornet> tftpboot 0x80000000 openwrt2.bin
eth1 link down
Using eth0 device
TFTP from server 192.168.1.100; our IP address is 192.168.1.111
Filename 'openwrt2.bin'.
Load address: 0x80000000
Loading: #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         ######################################################
done
Bytes transferred = 3932160 (3c0000 hex)

It`s ok too.
Then I try to copy image:

hornet> cp 0x80000000 0x9f020000 0x3c0000
Copy to Flash... Outside available Flash

What I did wrong?