OpenWrt Forum Archive

Topic: TP-Link TL-MR3020 Support

The content of this topic has been archived between 16 Jun 2013 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

okay it works big_smile  thx u very much... im already making this documentation on my blog while doing this stuff.... also if needed i also can write to the wiki.
but i dunno how wiki works...(i havent write any single post to the wiki in my entire live ) im afraid my english is not good enough and make the documentation in wiki become messy.




i already install luci on my usb flashdisk... then activated it. when usb plug i can connect to the luci....

but if i unplug then reboot,  the system changed to default.... (no overlay as i check in df )

after i plug usb again then reboot, well... luci works like a charm....  (there is this /overlay/ mounted on /)


but im still wondering what is the different between pivot /overlay to usb and pivot entire / to the usb as desribed in
http://wiki.openwrt.org/doc/howto/extro … oot.theory

if we pivot entire / to the usb means the system cant boot if there is no flash plug in it?

Hi danwang,

danwang wrote:

and got an empty terminal. When I type in screen, the RX LED lights up on the serial adapter, but nothing shows up. I've also tried minicom with similar results. Has anyone else had this or a similar problem?

I've the same problem.

I'm using the Spakfun's FTDI Basic Breakout 3.3V according to the WIKI (http://wiki.openwrt.org/toh/tp-link/tl-mr3020): http://bit.ly/TcANfw. When i plug it to my laptop USB all LED turn on. After 1 second only led power stays on.

I see the device on Windows and MacOX operating systems.

But when i tried on Putty (Windows) or Screen command (MAC OS X) i got an empty terminal.

Do you fix your problem ?

Mickael

danwang,

I fixed my problem.

You can remove the 3.3V cable. If it doesn't not working you can also switch TX&RX. I used this web site (http://forum.daviddarts.com/read.php?2,4459) to solve my problem.

Mickael

johan666 wrote:

For your information, the latest is r33074
but the whole r330xx has wlan bug.
If you just use AP function, you won't see the bug.

I use r33276, is there still a wlan bug?

I try to get my mr3020 as a client (routed client mode) in my existing wlan-network. but how do I have to configure network and wireless?

thanks a lot
j

managed to configure mr3020 as client (with static ip > I can access it in existing wlan network) and as additional access point with internet access

/etc/config/network:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.201.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option proto 'static'
    option ipaddr 192.168.1.201
    option netmask 255.255.255.0
    option gateway 192.168.1.1
    option dns 192.168.1.1

/etc/config/wireless:

config wifi-device  radio0
    option type     mac80211
    option channel  11
    option macaddr    90:f6:52:d6:d2:d8
    option hwmode    11ng
    option htmode    HT20
    list ht_capab    SHORT-GI-20
    list ht_capab    SHORT-GI-40
    list ht_capab    RX-STBC1
    list ht_capab    DSSS_CCK-40
    # REMOVE THIS LINE TO ENABLE WIFI:
    option disabled 0

config wifi-iface
    option device   radio0
    option network  wan
    option mode     sta
    option ssid     z60_2.4
    option encryption psk2
    option key    SECRET

config wifi-iface
    option device    radio0
    option network    lan
    option mode    ap
    option ssid    radio
    option encryption psk2
    option key    SECRET

/etc/config/firewall:

...
config zone
    option name        wan
    option network        'wan'
    option input        ACCEPT
    option output        ACCEPT
    option forward        REJECT
    option masq        1
    option mtu_fix        1
...
T_Ro wrote:

im already making this documentation on my blog while doing this stuff.... also if needed i also can write to the wiki.

Could you give me a link to your blog ? Or post in the WIKI.

I'm having the same problems.

Thanks !

Hi, I got my MR3020 (v1.7) since a days ago and got the serial console working and playing with bootloader getting files from tftp server and looking into firmware files and playing with it. But I have not load OpenWRT firmware into the router yet.

I have some questions about this router and OpenWRT

I want to boot from ram as described in "5. install a ramdisk-image into main memory" from http://wiki.openwrt.org/doc/howto/generic.flashing
I made all, except step 6 for header fixing, because I think that is only neccesary for the wndr3700.
My steps on router are:

setenv ipaddr 10.1.0.10
setenv serverip 10.1.0.103
setenv bootargs 'board=TL-MR3020'
tftpboot 0x80000000 openwrt-ar71xx-generic-uImage-initramfs-lzma.bin
bootm


But I got an error when booting:  Uncompressing Kernel Image ... Too big uncompressed streamLZMA ERROR 1 - must RESET

Compiling OpenWRT with defaults, Setting target system to: Atheros AR7xxx/AR9xxx, Subtarget: Generic, Target Profile: TP-LINK TL-MR3020
and in Target Images mark ramdisk as noted in the wiki, using the last trunk (33311) and updated packages.

The files generated are called:

openwrt-ar71xx-generic-tl-mr3020-v1-initramfs-uImage.bin
openwrt-ar71xx-generic-tl-mr3020-v1-jffs2-factory.bin
openwrt-ar71xx-generic-tl-mr3020-v1-jffs2-sysupgrade.bin
openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin
openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-sysupgrade.bin
openwrt-ar71xx-generic-uImage-gzip.bin
openwrt-ar71xx-generic-uImage-initramfs-gzip.bin
openwrt-ar71xx-generic-uImage-initramfs-lzma.bin
openwrt-ar71xx-generic-uImage-lzma.bin
openwrt-ar71xx-generic-vmlinux.bin
openwrt-ar71xx-generic-vmlinux-initramfs.bin

And I´m using the file:  openwrt-ar71xx-generic-uImage-initramfs-lzma.bin  to test ramloading, but with no luck.
I noticed that is a GENERIC and not an mr3020, but these are the generated files, I don´t know how to get a initramfs-lzma for 3020.
I want to use the ramdisk aproach, because I need to learn a lot of OpenWRT and I don´t want to flash everytime I need to test something, so

It´s possible? Can somebody help me or give me a tip?


Another question or comment:
I try to unsquash the original rootFs with no luck on my debian box, all the modes that I´ve tried return errors: Some sources with error about version 4 of squashfs and some others with:

Parallel unsquashfs: Using 1 processor
lzma uncompress failed with error code 9
read_block: failed to read block @0x281da1
read_fragment_table: failed to read fragment table index
FATAL ERROR aborting: failed to read fragment table

I really apreciate if somebody can help me with the ramdisk approach!!!
Sorry for my english.

(Last edited by LuisR on 3 Sep 2012, 03:36)

I have the same problem! I couldn't install OpenWrt using the web interface, so I installed with serial console + tftp. I've followed the steps without error, but after reboot, I got a "loop" with the following error message appearing over and over again:


U-Boot 1.1.4 (Nov 28 2011 - 09:34:00)

AP121 (ar9330) U-boot

DRAM:  32 MB
led turning on for 1s...
id read 0x100000ff
flash size 4194304, sector count = 64
Flash:  4 MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag7240_enet_initialize...
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
: cfg1 0x5 cfg2 0x7114
eth0: 00:03:7f:09:0b:ad
ag7240_phy_setup
eth0 up
: cfg1 0xf cfg2 0x7214
eth1: 00:03:7f:09:0b:ad
athrs26_reg_init_lan
ATHRS26: resetting s26
ATHRS26: s26 reset done
ag7240_phy_setup
eth1 up
eth0, eth1
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... ERROR: LzmaDecode.c, 543

Decoding error = 1
LZMA ERROR 1 - must RESET

I'm using the build downloaded from OpenWrt. What can I try?

Thanks in advance!

I made the ram load, just change the address to 0x81000000 and use the file openwrt-ar71xx-generic-tl-mr3020-v1-initramfs-uImage.bin
At first, It boot, now I will play with OpenWRT, modules, usb and so on.

Maybe a memory map will be usefull, I just know that the flash start at 0x9f000000 with 0x3effff bytes, with some don´t touch areas like: 0x9f000000  0x9f3e0000   0x9f3f0000 for uboot, config and art data.

And I think the RAM starts at 0x80000000, but maybe uboot needs some space at the beginning for temp usage???????

If you can clarify my thougs, welcome.

Hey hgdeoro, it´s not the same problem, you want to flash the device and I just want to load OpenWRT on ram and play with it for a while, I don´t want to flash right now.

Thanks
Luis


LuisR wrote:

Hi, I got my MR3020 (v1.7) since a days ago and got the serial console working and playing with bootloader getting files from tftp server and looking into firmware files and playing with it. But I have not load OpenWRT firmware into the router yet.

I have some questions about this router and OpenWRT

I want to boot from ram as described in "5. install a ramdisk-image into main memory" from http://wiki.openwrt.org/doc/howto/generic.flashing
I made all, except step 6 for header fixing, because I think that is only neccesary for the wndr3700.
My steps on router are:

setenv ipaddr 10.1.0.10
setenv serverip 10.1.0.103
setenv bootargs 'board=TL-MR3020'
tftpboot 0x80000000 openwrt-ar71xx-generic-uImage-initramfs-lzma.bin
bootm


But I got an error when booting:  Uncompressing Kernel Image ... Too big uncompressed streamLZMA ERROR 1 - must RESET

Compiling OpenWRT with defaults, Setting target system to: Atheros AR7xxx/AR9xxx, Subtarget: Generic, Target Profile: TP-LINK TL-MR3020
and in Target Images mark ramdisk as noted in the wiki, using the last trunk (33311) and updated packages.

The files generated are called:

openwrt-ar71xx-generic-tl-mr3020-v1-initramfs-uImage.bin
openwrt-ar71xx-generic-tl-mr3020-v1-jffs2-factory.bin
openwrt-ar71xx-generic-tl-mr3020-v1-jffs2-sysupgrade.bin
openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin
openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-sysupgrade.bin
openwrt-ar71xx-generic-uImage-gzip.bin
openwrt-ar71xx-generic-uImage-initramfs-gzip.bin
openwrt-ar71xx-generic-uImage-initramfs-lzma.bin
openwrt-ar71xx-generic-uImage-lzma.bin
openwrt-ar71xx-generic-vmlinux.bin
openwrt-ar71xx-generic-vmlinux-initramfs.bin

And I´m using the file:  openwrt-ar71xx-generic-uImage-initramfs-lzma.bin  to test ramloading, but with no luck.
I noticed that is a GENERIC and not an mr3020, but these are the generated files, I don´t know how to get a initramfs-lzma for 3020.
I want to use the ramdisk aproach, because I need to learn a lot of OpenWRT and I don´t want to flash everytime I need to test something, so

It´s possible? Can somebody help me or give me a tip?


Another question or comment:
I try to unsquash the original rootFs with no luck on my debian box, all the modes that I´ve tried return errors: Some sources with error about version 4 of squashfs and some others with:

Parallel unsquashfs: Using 1 processor
lzma uncompress failed with error code 9
read_block: failed to read block @0x281da1
read_fragment_table: failed to read fragment table index
FATAL ERROR aborting: failed to read fragment table

I really apreciate if somebody can help me with the ramdisk approach!!!
Sorry for my english.

(Last edited by LuisR on 4 Sep 2012, 19:41)

Thank you LuisR for your response! Before trying what you said, I repeated the documented process, and now it boots OK! I downloaded the firmware again, and the one I've downloaded today is larger than the used yesterday... maybe yesterday haven't uploaded the right firmware...

Anyway, I what to report that before the upload using TFTP, I tryied the web interface without success, with the following error message:

Error code: 18005
Upgrade unsuccessfully because the version of the upgraded file was incorrect. Please check the file name.

I've renamed the firmware to the same name as the "official" firmware, without success. An Arduino UNO save the day... I'm using it as a "serial console adapter" :-D

Hello

I have v1 version with firmware wrom wiki
http://downloads.openwrt.org/snapshots/ … actory.bin

I was trying to setup it as a routed client from docu page, I also tried exact same config that dddesign pasted above, with different only my SSID and password.
It works as AP, but never as a client.

Allways have same error after wifi command when trying to setup as a client
command failed: Device or resource busy (-16)
Successfully initialized wpa_supplicant

Is it possible that device is faulty, since it works as AP and scan also works ?

Hi,

I have a small problem. I set Rootfs on External Storage (extroot), following the instructions. USB flash drive connected via usb hub.
If the device reboots after "Reboot", then everything is OK. But if you power off the device reboots, the USB flash drive is not and partitions are not mounted. But, if the stick on without Usb hub, then no such problems. In what could be the reason?

d1dd1 wrote:
T_Ro wrote:

im already making this documentation on my blog while doing this stuff.... also if needed i also can write to the wiki.

Could you give me a link to your blog ? Or post in the WIKI.

I'm having the same problems.

Thanks !

sorry take so long to reply.... got many assignment at college....  here is the link. http://tplinkmr3020.blogspot.com  but still on process. i will update if i got any free time.

bonagel wrote:

I am struggeling with the installation of squeezeslave. There is are two builds of this tool: "OpenWrt ar71xx OSS Package - Built for Backfire" and "OpenWrt ar71xx ALSA Package - Built for Backfire". In both cases I get an error "bus error" when trying to run squeezeslave.

Hi Bonagel,

Backfire binaries probably won't work on the MR3020, as that platform requires a trunk build, i.e. Attitude Adjustment.

If you go back and check the Squeezeslave page at code.google.com, you'll find binaries that work with Attitude Adjustment:

http://squeezeslave.googlecode.com/file … ar71xx.ipk

I just got squeezeslave-oss working on my MR3020 running r33395.  Don't bother with squeezeslave-alsa, it just segfaults despite my MR3020 having alsa-lib.

cougar281 wrote:

hub 1-0:1.0: unable to enumerate USB device on port 1
or
hub 1-0:1.0: connect-debounce failed, port 1 disabled

if I connect a mouse I get this too. someone mentioned this is because it's not an usb2 hub. but mr3020 should have usb2
anyone any tip?

@cougar281: did you solve this problem?

thanks j

gsenna wrote:

It relies on delaying by counting so basically it is highly unreliable, but I dont know other way of producing a delay.

"sleep S" where S means # of seconds ?

nebbia88 wrote:

"sleep S" where S means # of seconds ?

No, I mean another method for delaying that isn't counting. It is actually more accurate to use seq rather than sleep I think.

nebbia88 wrote:

"sleep S" where S means # of seconds ?

No, I mean another method for delaying that isn't counting. It is actually more accurate to use seq rather than sleep I think.

I've found that if we export the gpio pins as it is said in the wiki, there could be a daemon controlling the state of the slide switch. The only thing is that because of how gpio pins change their state, there could be a single second of delay from the moment you push the slide up to the moment the desired action starts running. However, with this method it is now accurate.

Slap me if this has been brought up before:

MR703/MR3040 built from trunk two weeks ago - usb does not support a usb hub. I see varous references to this when I search using Google and it was supposedly fixed 6 months ago. Any hints on how to fix this?

Miniupnpd. I want to change the xml data it sends out. Looking at the source code there is a command line option 'friendly_name' but this doesn't exist on the openwrt build. My assuption is that the name 'OpenWRT' is set in the make file. I've tried to get miniupnpd to build on my system by doing the following:

./scripts/feeds update

./scripts/feeds install miniupnpd

make clean
make menuconfig - but I can't find where to enable it to build!

someone take pity on me as I only have half an idea!

Hi all,

Has anybody tried to do the 64 MB modification, like on the TL-WR703N (http://wiki.openwrt.org/toh/tp-link/tl- … mb.ram.mod)?

I'm buying a TL-MR3020 and would like to avoid the effort if it's already known to fail.

Thanks
pragtich

pragtich wrote:

Hi all,

Has anybody tried to do the 64 MB modification, like on the TL-WR703N (http://wiki.openwrt.org/toh/tp-link/tl- … mb.ram.mod)?

Yes:

root@OpenWrt:/# cat /proc/meminfo | grep Total
MemTotal:          61648 kB
SwapTotal:             0 kB
VmallocTotal:    1048372 kB
root@OpenWrt:/# cat /etc/openwrt_release
DISTRIB_ID="OpenWrt"
DISTRIB_RELEASE="Bleeding Edge"
DISTRIB_REVISION="r33288"
DISTRIB_CODENAME="attitude_adjustment"
DISTRIB_TARGET="ar71xx/generic"
DISTRIB_DESCRIPTION="OpenWrt Attitude Adjustment r33288"

This is the same DDR1 chips, which i used to upgrade Asus WL-500G Premium v1 up to 128Mb.

Hello,
I need some advice how to set up lan on TP-lin mr 3020 with Open-wrt.
Just installed 3g dongle and have internet connection on the router, but cant get it on the pc.. please help me how to configure /etc/config/network file:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.11'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        list dns '192.168.1.1'
        list dns '8.8.8.8'




config interface 'wan'
        option ifname 'ppp0'
        option device '/dev/ttyUSB0'
        option apn banga
        option service umts
        option proto 3g


config interface 'wifi'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

network interfaces:

root@OpenWrt:/etc/config# ifconfig
3g-wan    Link encap:Point-to-Point Protocol
          inet addr:10.13.32.87  P-t-P:10.64.64.64  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:99 errors:0 dropped:0 overruns:0 frame:0
          TX packets:105 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:8874 (8.6 KiB)  TX bytes:8780 (8.5 KiB)

br-lan    Link encap:Ethernet  HWaddr 90:F6:52:7F:5C:28
          inet addr:192.168.1.11  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:778 errors:0 dropped:265 overruns:0 frame:0
          TX packets:301 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:94681 (92.4 KiB)  TX bytes:77392 (75.5 KiB)

eth0      Link encap:Ethernet  HWaddr 90:F6:52:7F:5C:28
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:901 errors:0 dropped:6 overruns:0 frame:0
          TX packets:306 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:137707 (134.4 KiB)  TX bytes:77622 (75.8 KiB)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:46 errors:0 dropped:0 overruns:0 frame:0
          TX packets:46 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4159 (4.0 KiB)  TX bytes:4159 (4.0 KiB)


As you can see wan-3g interface is working, I can get and receive packets, only problem is redirecting it to lan port.
I hope someone can help me.

Thanks in advance.

Why did you set 1.1 as gateway and dns in lan section?

nebbia88 wrote:

Why did you set 1.1 as gateway and dns in lan section?

Normally not needed!!

Sorry, posts 251 to 250 are missing from our archive.