OpenWrt Forum Archive

Topic: Howto enable channel 12 and 13 on TP-Link WR-1043ND?

The content of this topic has been archived between 24 Mar 2018 and 30 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

j8soot wrote:

I changed the wireless channel from 13 to 1 in and wlan now works automatically at boot...

Hi, I use another model, but I think that process is similar and regulatory is changed twice. To get channel 13 with regulatory domain updated, I think an easy way is put "/sbin/wifi" on rc.local and test if it work then. Regards.

If wireless doesn’t come up, try to isolate the issue and file a bug.

I built trunk for the same device yesterday and it comes up fine on channel 13.

(Last edited by towolf on 2 Apr 2012, 18:33)

My build was r31152 and with ATH_USER_REGD but maybe it is something else causing the problem.

It is difficult to isolate the issue when not too familiar with OpenWRT. I did try debugging, I checked the /etc/init.d/network script was working properly and it is, /sbin/wifi is executed on boot but for channel 13 it doesn't work until sometime after boot completes which I guess is a hint about the issue. I even created S99wifi and made it do /sbin/wifi like in S40network and it ran it on boot as expected but again with channel 13 the wlan0 wasn't up.

So it seems the wireless configuration isn't broken it's just after a reboot channel 13 won't come up until boot completes so we need to ssh and run wifi command and it comes up fine.

I am fine using channel 1 until I know more to debug such issues.

almursi wrote:
j8soot wrote:

I changed the wireless channel from 13 to 1 in and wlan now works automatically at boot...

Hi, I use another model, but I think that process is similar and regulatory is changed twice. To get channel 13 with regulatory domain updated, I think an easy way is put "/sbin/wifi" on rc.local and test if it work then. Regards.

I didn't think to use rc.local but I might be able to check it later.

I think it can't be too hard for someone who knows OpenWRT to find the cause and fix it and I am learning quickly so hopefully I will be able to solve it with more knowledge. I can make do with channel 1 for now as I have other learning taking up my time.

try to insert a "sleep 10" right before the "/sbin/wifi is called in /etc/init.d/network...

towolf wrote:

If wireless doesn’t come up, try to isolate the issue and file a bug.

I built trunk for the same device yesterday and it comes up fine on channel 13.

Did you compiled OpenVPN and luci within? Than I would like to download your trunk!

I also enabled the REGD...-thing in the .config.

How did you enable channel 13 on the device?

nebbia88 wrote:

try to insert a "sleep 10" right before the "/sbin/wifi is called in /etc/init.d/network...

Hi, yes smile that was the idea, but the simplest is to try first on rc.local.

DerUltrazauberer wrote:

[I also enabled the REGD...-thing in the .config.
How did you enable channel 13 on the device?

Sorry, I do not remember if it has been commented here, but a common mistake is forgetting to install kmod-wprobe (happened to me more than once), although in the wiki I've seen it quite well explained. Regards.

almursi wrote:

Hi, yes smile that was the idea, but the simplest is to try first on rc.local.

is it EXACTLY the same thing?

have you tried?

because that trick solved me a "no wifi at boot" problem with a zd1211rw usb wifi adapter on my x86 box..

Today I compiled again the latest trunk with kmod-wprobe enabled. But nothing changed, wlan won't start when router is powered on. That's really annoying!

@towolf

Can you post your .config file here? So I can build another firmware with the same options like yours!

DerUltrazauberer wrote:

Today I compiled again the latest trunk with kmod-wprobe enabled. But nothing changed, wlan won't start when router is powered on. That's really annoying!

@towolf

Can you post your .config file here? So I can build another firmware with the same options like yours!

I don't think you want my config. I stripped out everything not needed when using the box as a dumb, switched AP.
I also run uncrypted wireless. But other than that I use the defaults (don't forget make defconfig).

Could you, first of all, post full logread and full dmesg immediately after startup?

Also post /etc/config/wireless

Redact at will.


EDIT: Here's mine:

root@plink:~# cat /etc/config/wireless 
config wifi-device  radio0
        option type     mac80211
        option macaddr  f8:d1:11:xx:xx:xx
        option hwmode   11ng
        option htmode   HT20
        option 'noscan' '1'
        option short_preamble '1'
        option 'country' 'DE'
        list ht_capab   SHORT-GI-40
        list ht_capab   DSSS_CCK-40
        option channel  4
        option disabled 0

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     someap
        option encryption none

(Last edited by towolf on 4 Apr 2012, 20:52)

nebbia88 wrote:

is it EXACTLY the same thing?

have you tried?

Hi, your tip is simply pefect (but rc.local it's easy to edit using luci web page smile, to test). Regards.

towolf wrote:
DerUltrazauberer wrote:

Today I compiled again the latest trunk with kmod-wprobe enabled. But nothing changed, wlan won't start when router is powered on. That's really annoying!

@towolf

Can you post your .config file here? So I can build another firmware with the same options like yours!

I don't think you want my config. I stripped out everything not needed when using the box as a dumb, switched AP.
I also run uncrypted wireless. But other than that I use the defaults (don't forget make defconfig).

Could you, first of all, post full logread and full dmesg immediately after startup?

Also post /etc/config/wireless

Redact at will.


EDIT: Here's mine:

root@plink:~# cat /etc/config/wireless 
config wifi-device  radio0
        option type     mac80211
        option macaddr  f8:d1:11:xx:xx:xx
        option hwmode   11ng
        option htmode   HT20
        option 'noscan' '1'
        option short_preamble '1'
        option 'country' 'DE'
        list ht_capab   SHORT-GI-40
        list ht_capab   DSSS_CCK-40
        option channel  4
        option disabled 0

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     someap
        option encryption none

Ok, let's start with dmesg:

root@OpenWrt:~# dmesg
[    0.000000] Linux version 3.2.13 (ultrazauberer@ubuntu) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #1 Wed Apr 4 15:35:53 CEST 2012
[    0.000000] MyLoader: sysp=49020000, boardp=04a21122, parts=002a0188
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR9132 rev 2
[    0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:5.000MHz
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone PFN ranges:
[    0.000000]   Normal   0x00000000 -> 0x00002000
[    0.000000] Movable zone start PFN for each node
[    0.000000] early_node_map[1] active PFN ranges
[    0.000000]     0: 0x00000000 -> 0x00002000
[    0.000000] On node 0 totalpages: 8192
[    0.000000] free_area_init_node: node 0, pgdat 802d19e0, node_mem_map 81000000
[    0.000000]   Normal zone: 64 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 8128 pages, LIFO batch:0
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line:  board=TL-WR1043ND console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 29256k/32768k available (2112k kernel code, 3512k reserved, 391k data, 196k init, 0k highmem)
[    0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:48
[    0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[    0.080000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.090000] NET: Registered protocol family 16
[    0.090000] MIPS: machine is TP-LINK TL-WR1043ND
[    0.350000] bio: create slab <bio-0> at 0
[    0.360000] Switching to clocksource MIPS
[    0.370000] NET: Registered protocol family 2
[    0.370000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.370000] TCP established hash table entries: 1024 (order: 1, 8192 bytes)
[    0.380000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.380000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.390000] TCP reno registered
[    0.390000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.400000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.410000] NET: Registered protocol family 1
[    0.410000] PCI: CLS 0 bytes, default 32
[    0.430000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.430000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.450000] msgmni has been set to 57
[    0.450000] io scheduler noop registered
[    0.450000] io scheduler deadline registered (default)
[    0.460000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[    0.490000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
[    0.490000] console [ttyS0] enabled, bootconsole disabled
[    0.510000] m25p80 spi0.0: found s25sl064a, expected m25p80
[    0.510000] m25p80 spi0.0: s25sl064a (8192 Kbytes)
[    0.520000] 5 tp-link partitions found on MTD device spi0.0
[    0.520000] Creating 5 MTD partitions on "spi0.0":
[    0.530000] 0x000000000000-0x000000020000 : "u-boot"
[    0.540000] 0x000000020000-0x000000101800 : "kernel"
[    0.540000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.560000] 0x000000101800-0x0000007f0000 : "rootfs"
[    0.560000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.580000] mtd: partition "rootfs" set to be root filesystem
[    0.580000] mtd: partition "rootfs_data" created automatically, ofs=4E0000, len=310000
[    0.590000] 0x0000004e0000-0x0000007f0000 : "rootfs_data"
[    0.600000] 0x0000007f0000-0x000000800000 : "art"
[    0.600000] 0x000000020000-0x0000007f0000 : "firmware"
[    0.610000] Realtek RTL8366RB ethernet switch driver version 0.2.3
[    0.620000] rtl8366rb rtl8366rb: using GPIO pins 18 (SDA) and 19 (SCK)
[    0.630000] rtl8366rb rtl8366rb: RTL5937 ver. 3 chip found
[    0.670000] rtl8366rb: probed
[    0.680000] eth0: Atheros AG71xx at 0xb9000000, irq 4
[    0.980000] TCP westwood registered
[    0.990000] NET: Registered protocol family 17
[    0.990000] 8021q: 802.1Q VLAN Support v1.8
[    1.000000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    1.010000] Freeing unused kernel memory: 196k freed
[    3.190000] ar71xx: pll_reg 0xb8050014: 0x1a000000
[    3.190000] eth0: link up (1000Mbps/Full duplex)
[    3.350000] Registered led device: tp-link:green:usb
[    3.350000] Registered led device: tp-link:green:system
[    3.350000] Registered led device: tp-link:green:qss
[    3.360000] Registered led device: tp-link:green:wlan
[    6.640000] JFFS2 notice: (406) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 11 of xref (0 dead, 0 orphan) found.
[    6.830000] eth0: link down
[    9.010000] deflate: Unknown symbol zlib_inflateReset (err 0)
[    9.020000] deflate: Unknown symbol zlib_inflateInit2 (err 0)
[    9.020000] deflate: Unknown symbol zlib_inflate (err 0)
[    9.030000] deflate: Unknown symbol zlib_inflate_workspacesize (err 0)
[    9.030000] deflate: Unknown symbol zlib_inflateEnd (err 0)
[    9.920000] Compat-wireless backport release: compat-wireless-2012-02-27-1-r31182
[    9.930000] Backport based on wireless-testing.git master-2012-02-27
[    9.960000] cfg80211: Calling CRDA to update world regulatory domain
[   10.350000] NET: Registered protocol family 10
[   10.580000] cfg80211: World regulatory domain updated:
[   10.580000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   10.590000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   10.600000] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   10.610000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   10.610000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   10.620000] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   10.860000] SCSI subsystem initialized
[   11.040000] usbcore: registered new interface driver usbfs
[   11.040000] usbcore: registered new interface driver hub
[   11.050000] usbcore: registered new device driver usb
[   11.660000] ath: EEPROM regdomain: 0x0
[   11.660000] ath: EEPROM indicates default country code should be used
[   11.660000] ath: doing EEPROM country->regdmn map search
[   11.660000] ath: country maps to regdmn code: 0x3a
[   11.660000] ath: Country alpha2 being used: US
[   11.660000] ath: Regpair used: 0x3a
[   11.670000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   11.670000] ieee80211 phy0: Atheros AR9100 MAC/BB Rev:7 AR2133 RF Rev:a2 mem=0xb80c0000, irq=2
[   11.690000] cfg80211: Calling CRDA for country: US
[   11.830000] cfg80211: Regulatory domain changed to country: US
[   11.840000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   11.850000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[   11.860000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[   11.860000] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   11.870000] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   11.880000] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   11.890000] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[   12.490000] NET: Registered protocol family 15
[   12.530000] Initializing XFRM netlink socket
[   12.730000] PPP generic driver version 2.4.2
[   12.770000] tun: Universal TUN/TAP device driver, 1.6
[   12.770000] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[   12.940000] IPv4 over IPv4 tunneling driver
[   13.910000] L2TP core driver, V2.0
[   13.930000] L2TP netlink interface
[   13.950000] L2TP ethernet pseudowire support (L2TPv3)
[   13.970000] L2TP IP encapsulation support (L2TPv3)
[   14.020000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   14.230000] NET: Registered protocol family 24
[   14.500000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[   14.500000] ath79-ehci ar913x-ehci: Atheros built-in EHCI controller
[   14.510000] ath79-ehci ar913x-ehci: new USB bus registered, assigned bus number 1
[   14.550000] ath79-ehci ar913x-ehci: irq 3, io mem 0x1b000000
[   14.570000] ath79-ehci ar913x-ehci: USB 2.0 started, EHCI 1.00
[   14.570000] hub 1-0:1.0: USB hub found
[   14.580000] hub 1-0:1.0: 1 port detected
[   14.610000] nf_conntrack version 0.5.0 (460 buckets, 1840 max)
[   15.250000] uhci_hcd: USB Universal Host Controller Interface driver
[   15.610000] usbcore: registered new interface driver usblp
[   15.740000] Initializing USB Mass Storage driver...
[   15.750000] usbcore: registered new interface driver usb-storage
[   15.750000] USB Mass Storage support registered.
[   15.880000] usbcore: registered new interface driver ums-alauda
[   15.900000] usbcore: registered new interface driver ums-cypress
[   15.920000] usbcore: registered new interface driver ums-datafab
[   15.940000] usbcore: registered new interface driver ums-freecom
[   15.960000] usbcore: registered new interface driver ums-isd200
[   15.980000] usbcore: registered new interface driver ums-jumpshot
[   16.010000] usbcore: registered new interface driver ums-karma
[   16.030000] usbcore: registered new interface driver ums-sddr09
[   16.050000] usbcore: registered new interface driver ums-sddr55
[   16.070000] usbcore: registered new interface driver ums-usbat
[   16.320000] usbcore: registered new interface driver usbhid
[   16.320000] usbhid: USB HID core driver
[   16.340000] usbip_core: USB/IP Core v1.0.0
[   20.980000] ar71xx: pll_reg 0xb8050014: 0x1a000000
[   21.280000] eth0: link up (1000Mbps/Full duplex)
[   23.740000] device eth0.1 entered promiscuous mode
[   23.740000] device eth0 entered promiscuous mode
[   23.790000] br-lan: port 1(eth0.1) entering forwarding state
[   23.800000] br-lan: port 1(eth0.1) entering forwarding state
root@OpenWrt:~#

Then the /etc/config/wireless: (MAC and PW faked)

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option macaddr 'aa:bb:cc:dd:ee:ff'
        option hwmode '11ng'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'DSSS_CCK-40'
        option disabled '1'
        option channel '13'
        option txpower '20'
        option country 'DE'
        option htmode 'HT40-'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2+ccmp'
        option key 'myPW'

root@OpenWrt:~#

And after all the command iwconfig:

root@OpenWrt:~# iwconfig
eth0.1    no wireless extensions.

lo        no wireless extensions.

tunl0     no wireless extensions.

eth0      no wireless extensions.

ip6tnl0   no wireless extensions.

br-lan    no wireless extensions.

eth0.2    no wireless extensions.

root@OpenWrt:~#

I have no idea how to autostart channel 13. After WLAN is working I can start with the configuration of the router (vlans, ...).

DerUltrazauberer wrote:
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        ...
        option disabled '1'
        ...

I have no idea how to autostart channel 13. After WLAN is working I can start with the configuration of the router (vlans, ...).

Hi, maybe because you'd disabled wifi-device, change to 0 (or delete) option 'disabled' '1'.  (with only a wifi-iface disabled regulatory domain is update on boot, at least on my router, but in your case all under wifi-devide seems to be ignored). Regards.

Thanks for the hint. I edited the file and changed the number to zero. After a reboot I also can't the the OpenWRT ESSID.

iwconfig shows me following:

root@OpenWrt:~# iwconfig
eth0.1    no wireless extensions.

lo        no wireless extensions.

tunl0     no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on

eth0      no wireless extensions.

ip6tnl0   no wireless extensions.

br-lan    no wireless extensions.

eth0.2    no wireless extensions.

root@OpenWrt:~#

So I wonder why my wlan isn't configured? I also wonder why the wlan won't start because I configured all in luci and saved&applied the settings.

EDIT: The wlan LED won't go on. In the webinterface the wlan seems still be deactivated:

http://www.abload.de/img/wlan02aucr.png

http://www.abload.de/img/wlan1y0urn.png

If I start the wlan manually over luci it works fine and the config is loaded.

(Last edited by DerUltrazauberer on 5 Apr 2012, 17:35)

Hi, I get same problem:

Apr  5 18:49:07 OpenWrt kern.info kernel: [   43.930000] cfg80211: Calling CRDA for country: ES
Apr  5 18:49:10 OpenWrt kern.info kernel: [   46.240000] device wlan0 entered promiscuous mode
Apr  5 18:49:10 OpenWrt daemon.warn hostapd: wlan0: IEEE 802.11 Configured channel (13) not found from the channel list of current mode (1) IEEE 802.11g
Apr  5 18:49:10 OpenWrt daemon.warn hostapd: wlan0: IEEE 802.11 Hardware does not support configured channel
Apr  5 18:49:10 OpenWrt user.info sysinit: rmdir[ctrl_interface]: No such file or directory
Apr  5 18:49:10 OpenWrt kern.info kernel: [   46.250000] device wlan0 left promiscuous mode
Apr  5 18:49:10 OpenWrt kern.info kernel: [   46.260000] br-lan: port 1(wlan0) entering disabled state
Apr  5 18:49:10 OpenWrt user.info sysinit: Configuration file: /var/run/hostapd-phy0.conf
Apr  5 18:49:10 OpenWrt user.info sysinit: channel [12] (13) is disabled for use in AP mode, flags: 0x1
Apr  5 18:49:10 OpenWrt user.info sysinit: wlan0: IEEE 802.11 Configured channel (13) not found from the channel list of current mode (1) IEEE 802.11g
Apr  5 18:49:10 OpenWrt user.info sysinit: wlan0: IEEE 802.11 Hardware does not support configured channel
Apr  5 18:49:10 OpenWrt user.info sysinit: Could not select hw_mode and channel. (-4)
Apr  5 18:49:10 OpenWrt user.info sysinit: wlan0: Unable to setup interface.
Apr  5 18:49:10 OpenWrt user.info sysinit: Failed to start hostapd for phy0

Apr  5 18:49:26 OpenWrt kern.info kernel: [   62.920000] cfg80211: Regulatory domain changed to country: ES
Apr  5 18:49:26 OpenWrt kern.info kernel: [   62.920000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Apr  5 18:49:26 OpenWrt kern.info kernel: [   62.930000] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Apr  5 18:49:26 OpenWrt kern.info kernel: [   62.940000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Apr  5 18:49:26 OpenWrt kern.info kernel: [   62.950000] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Apr  5 18:49:26 OpenWrt kern.info kernel: [   62.950000] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)

I put sleep 10 on /etc/init.d/network, but I think that it need more delay.

Edited: I can fix it with a simple sleep 10 and /sbin/wifi on rc.local (delay on init.d seems no work, and country is updated near call of rc.local)

it is on luci -> system -> startup -> local startup

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.
sleep 10
/sbin/wifi
exit 0

Regards.

(Last edited by almursi on 5 Apr 2012, 20:04)

dir2cas wrote:

Here are some useful links concerning the topic:
http://smorgasbord.gavagai.nl/2010/09/w … to-fix-it/
http://forum.aircrack-ng.org/index.php?;topic=6822.0
http://forum.aircrack-ng.org/index.php?topic=7826.0

I have included a customized regulatory.bin in my latest openwrt image and it works as expected.

BR

I successfully compiled a modded regulatory.bin. I compiled this file into the firmware and deactivated the ATH_USER_REGD in the .config. Now I can set a much higher tx power, but I can't activate channel 13 in the luci webif. When I manually set the channel to 13 the wlan won't start. I will compile another new firmware with ATH_USER_REGD activated. I will hope the wlan will come on after a reboot. Otherwise I will add the script.

almursi wrote:

it is on luci -> system -> startup -> local startup

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.
sleep 10
/sbin/wifi
exit 0

Regards.

Thanks! This worked, but's just a temporarily solution. I will hope this problem will be fixed in the future.

Does anyone tried to enable vlans? I added the entries for vlan id 7 and id 8 in the /etc/config/network and luci isn't showing the ids. I need tagged vlan ids for internet and iptv. Someone has this constellation working?

DerUltrazauberer wrote:

Does anyone tried to enable vlans? I added the entries for vlan id 7 and id 8 in the /etc/config/network and luci isn't showing the ids. I need tagged vlan ids for internet and iptv. Someone has this constellation working?

I was about to ask the same thing. I will order vdsl with entertain in a couple of weeks. I don't want one of those stupid router which I have to configure with the gui etc. Is there any router that is working with vdsl50+entertain and openwrt?

Kind regards,
fame

fame wrote:
DerUltrazauberer wrote:

Does anyone tried to enable vlans? I added the entries for vlan id 7 and id 8 in the /etc/config/network and luci isn't showing the ids. I need tagged vlan ids for internet and iptv. Someone has this constellation working?

I was about to ask the same thing. I will order vdsl with entertain in a couple of weeks. I don't want one of those stupid router which I have to configure with the gui etc. Is there any router that is working with vdsl50+entertain and openwrt?

Kind regards,
fame

Sorry, I can't test it now. But I think the 1043ND will working with Entertain. I can check it at the beginnung of may. But I also ordered a Netgeat WNDR3800 a week ago, which should have no problems with vlans and it is powerfull enough to route with more than 50mbps.

Now I'm confused smile You asked the question about the vlan tagging. Isn't that something you need to get working before you can use it with entertain (vdsl, iptv, etc...)?

Of course you need VLAN tagging on the WAN port. VLAN id7 should be the normal internet traffic and VLAN id8 is the multicast stream for iptv. So you have to configure these two tags to the wan port and then it should running.

Or what do you mean?

Sorry for the confusion. I thought this would be a problem with openwrt. But it seems to be no problem at all. Would you mind to write a REALLY short tutorial what one have to do to configure the router for the usage with vdsl + entertain? Or is it simple enough that one doesn't need any help?

Thanks for your help so far!

(Last edited by fame on 18 Apr 2012, 20:59)

The router is configured like here: http://www.computerhilfen.de/hilfen-22-389919-0.html

But this is just the basic. The problem is, that you have to configure the tagged vlans first. When I have tested the router, I can post my config and what I have done. But this can lasts 2 weeks.