OpenWrt Forum Archive

Topic: Howto enable channel 12 and 13 on TP-Link WR-1043ND?

The content of this topic has been archived between 24 Mar 2018 and 30 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

This isn't a problem at all, because I have to wait 6 weeks for my vdsl (moving to a new city in june).

Would it be less work for you if you do it in german? I will send you my e-mail address via PM, so it's up to you to device wether you post it here in english or send it to me in german. Thanks again!

Here are some information about the vlan trunking which could be useful:

https://forum.openwrt.org/viewtopic.php … 48#p132148

(Last edited by fame on 18 Apr 2012, 21:56)

I tested the TP-Link with my VDSL2 connection and I get the normal internet working, but not the IPTV. So on next sunday I will test another config. My IPTV receiver won't receive any pictures. Very strange...

The best und easy way, it works for me:

cd /usr/lib/crda/
rm regulatory.bin
wget http://datatomb.de/mirror/stuff/regulatory.bin
reboot

iw reg set $YOURCOUNTRYCODE
iwlist wlan0 channel

(Taken from http://smorgasbord.gavagai.nl/2010/09/w … to-fix-it)
Thanks goes to Cejvik

Best regards,
Jürgen

Due to:
https://dev.openwrt.org/changeset/31954/
tweaking the regulatory.bin is not an option anymore.

So a vanilla build of OpenWrt will not let you match your non-US regulatory requirements, because the chip vendor insists on enforcing the EEPROM setting, while not insisting on having the setting properly set up in end products... Oh the irony.
Does not make me feel any better about building my own firmware to work around this. Just to use channel 13 which I am allowed to do where I reside.
Any chance Atheros can be talked back into allowing ATH_USER_REGD in the vanilla build?

(Last edited by yamada-kun on 5 Aug 2012, 04:17)

yamada-kun wrote:

Due to:
https://dev.openwrt.org/changeset/31954/
tweaking the regulatory.bin is not an option anymore.

So a vanilla build of OpenWrt will not let you match your non-US regulatory requirements, because the chip vendor insists on enforcing the EEPROM setting, while not insisting on having the setting properly set up in end products... Oh the irony.
Does not make me feel any better about building my own firmware to work around this. Just to use channel 13 which I am allowed to do where I reside.
Any chance Atheros can be talked back into allowing ATH_USER_REGD in the vanilla build?

Ditto. Any new workaround without compiling? Would like to use channel 13.

I'm compiling the latest trunk.
I will build the firmware for ALL Atheros devices, with the default settings but with the country select enabled, so all non USA users can use its country regulations. I was facing the same problem in Spain, where the channels 12 and 13 are legal.
http://img266.imageshack.us/img266/5245/13chan.jpg
Will upload to my public dropbox folder, or similar.
Check the HOWTO forum, will post it today or tomorrow!

(Last edited by dabyd64 on 8 Sep 2012, 18:16)

from modinfo cfg80211

parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)

It doesn't work as it should, but at least it unlocks power levels (and starts spamming in dmesg)

(Last edited by swiftgeek on 22 Oct 2012, 04:32)

I found this thread when I try to solve problem on different HW but also Atheros (in my case Atheros 5413)

It is possible change regulatory domain on EEPROM.
package kmod-madwifi contain nice tool ath_info :-)

How would I get the address of the card on a PCI-less router for use with the ath_info?

In retrospective it should have been obvious how to get the address of the device. It appears in kernel log when the driver loads. It seems that it is 0xb80c0000. Unfortunately, ath_info can't seem to read the data.

Everything should be in mtd4 art partition … just what bits we have to change?
Is 1043ND with working 12&13 channels even available? (I have bought one in local shop and it's locked to USA hmm ).  If yes then we maybe could find sth by just diffing those partition images

ath_info works only with ath5k

(Last edited by swiftgeek on 16 Dec 2012, 16:36)

Did anyone check the German version of 1043? Since they seem to have made a special version for that market, it would be reasonable to expect it to have correct regulatory data in the EEPROM. Still we can never be sure until we check.

AndrejaKo wrote:

Did anyone check the German version of 1043? Since they seem to have made a special version for that market, it would be reasonable to expect it to have correct regulatory data in the EEPROM. Still we can never be sure until we check.

Not different to the international ones, I tested a "TL-WR1043ND(DE) Ver:1.1", same behavior for ch12+13.
TP-Link does not seem to care about this, without patching the regdb yourself there is no way to get these channels activated.

So how would that work on Attitude Adjustment?  Since changes in the way regulatory database is used, the older regulatory.bin hack doesn't work.


There is a way to enable this using the kernel option, but that would require someone to host unofficial image, since from what I've seen OpenWRT team doesn't want to distribute images with that option enabled.

Also those two channels were working for me on some versions of DD-WRT (but I forgot which ones). Maybe we should take a look at how they solved the problem.


Also did anyone check how things work in the official TP-LINK image? I've heard reports from people that on stock firmware those channels work, but I didn't check that out yet myself. EDIT: They do work.

(Last edited by AndrejaKo on 21 Dec 2012, 21:32)

AndrejaKo wrote:

So how would that work on Attitude Adjustment?  Since changes in the way regulatory database is used, the older regulatory.bin hack doesn't work.
...
Also those two channels were working for me on some versions of DD-WRT (but I forgot which ones). Maybe we should take a look at how they solved the problem.

The limits seem to be applied incrementally - if you have a country "00" or "US" which does not allow ch12+13 but 500mW, in whole europe you would be able to legally use ch1-13 but no more than 100mW - setting the country to "DE", you will end up with ch1-11 and 100mW.

I needed ch13 in one 1043nd, for this one I had to completely open country 00 and US, created a country "UX" which matches the US regulations. This way I can set country "DE" and get the correct limits (ch1-13, 100mW). To match the original US limits I need to set the country to "UX".

This is of course no solution for openwrt, if TP-Link fails to set the country code in their products.

AndrejaKo wrote:

Also did anyone check how things work in the official TP-LINK image? I've heard reports from people that on stock firmware those channels work, but I didn't check that out yet myself.

Yes, you can enable any channel in the stock firmware, so the openwrt image is by far more FCC-Compliant than the original firmware.

I dont know the reasons for the switch to the "internal regdb" in openwrt, because the images distributed before also followed those FCC rules if the user of the firmware did not break them intentionally. But i am not a lawyer - and for whatever reason this has been done, I am quite sure it was *not* done to spoon-feed the users. If anyone could come up with a solution to modify the flash to set the right local country code this would be nice. Unfortunately this is beyond my knowledge.

Otherwise you only have the one option to compile your own image in order to overcome the channel-limit.

So this does work with OpenWrt Barrier Breaker r34761?

jow wrote:

Use http://luci.subsignal.org/~jow/reghack/ to enable channel 12 and 13.

Thanks a lot Jow. Tried this on attitude_adjustment beta2 and it is working great.  Was looking for something like this for few days as i am not comfortable building kernel from source.

Thanks again

Try it and let us know!

Also if you don't want to experiment, you can go back to page 2 and get the hacked regulatory.bin file which will definitely work there.