OpenWrt Forum Archive

Topic: Howto enable channel 12 and 13 on TP-Link WR-1043ND?

The content of this topic has been archived between 24 Mar 2018 and 30 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

The utility now also supports lifiting the 5GHz restrictions on ath9k.

just compile your own kernel.

Works for me. But I still have low txpower on some tp-link models. It removes the openwrt US reg domain hardcoded restrictions in the ath9k driver, but i'm not sure if it ignores the txpower restrictions in the eeprom fully.

I have a Buffallo WZR-HP-AG300H on r36054 and used jow's utility to hack the driver. It does indeed enable channel 12 and 13, but now I'm unable to change the TX power.

It does report that it is changed, but looking at the received signal strength on another wifi card, the TX power of the router is unchanged. Setting 30 dBm, 20 dBm, 10 dBm or 0 dBm doesn't make any difference.

I tried both using Luci and iw like this:

iw dev wlan0 set txpower fixed 20mBm

Any ideas?

(Last edited by mastabog on 14 Jul 2013, 18:25)

mastabog wrote:

I have a Buffallo WZR-HP-AG300H on r36054 and used jow's utility to hack the driver. It does indeed enable channel 12 and 13, but now I'm unable to change the TX power.

It does report that it is changed, but looking at the received signal strength on another wifi card, the TX power of the router is unchanged. Setting 30 dBm, 20 dBm, 10 dBm or 0 dBm doesn't make any difference.

I tried both using Luci and iw like this:

iw dev wlan0 set txpower fixed 20mBm

Any ideas?

I don't think you should post that here. Either look for a thread on your router specific, post a new thread, or find Jow in the irc channel or something

towolf wrote:

Either you compile the firmware with ATH_USER_REGD on (the official compiles don’t enable it because Atheros asks for this) so the driver chooses the country you want and overrides the EEPROM.

Or, 2, you get a ‹ regulatory.bin › that maps the regulatory settings that your Behörde allows to the country that the EEPROM wants (e.g. US with DE limits). This option just requires you to find this hacked file and to drop it in the right place on the boxes file system. No building necessary. But it’s a bit ugly. The wiki has more.

What does « iw reg get » say? When you look at dmesg you can see that EEPROM has the final say and « iw reg set DE » doesn’t have an effect.

Hi,is there a tx/rx power loss if compile the firmware with ATH-USER-REGD turned on?

AndrejaKo wrote:

.......


Also did anyone check how things work in the official TP-LINK image? I've heard reports from people that on stock firmware those channels work, but I didn't check that out yet myself. EDIT: They do work.

Yes, it worked on the stock firmware, and it even appeared on the official product spec and Ads.

While after flashing the openwrt AA 12.09, these 2 channels 12,13 disappear, whatever country code you set.

It should be open as "openwrt", I am not breaking any reg. law 'cause it's legal to here to use the 2 channels, and TP-Link's stock firmware is doing it too.

on trunk breaks 5ghz (wdr3600)

Thanks for the patch.
It's working for me on 1043ND in HU.

Somebody can distribute how to compile own firmware - without Atheros restriction of course -  just in case this tool won't work in the future?

I compliled my own kernel with forcing Atheros to respect my settings in etc/config/wireless but I still cannot activate channel 14 with JP country.

In iw list Channel 14 is not disabled anymore but wireless just doesn't come up after wifi command.

Is there something else should be done ?

xcom169 wrote:

I compliled my own kernel with forcing Atheros to respect my settings in etc/config/wireless but I still cannot activate channel 14 with JP country.

In iw list Channel 14 is not disabled anymore but wireless just doesn't come up after wifi command.

Is there something else should be done ?

https://en.wikipedia.org/wiki/List_of_WLAN_channels :
channel 14 in Japan: for 11b only

I'm pretty sure you are trying to use it for 11g or 11n...

el_goretto wrote:
xcom169 wrote:

I compliled my own kernel with forcing Atheros to respect my settings in etc/config/wireless but I still cannot activate channel 14 with JP country.

In iw list Channel 14 is not disabled anymore but wireless just doesn't come up after wifi command.

Is there something else should be done ?

https://en.wikipedia.org/wiki/List_of_WLAN_channels :
channel 14 in Japan: for 11b only

I'm pretty sure you are trying to use it for 11g or 11n...

Yes I tried for 11n but it's the same 2,4 Ghz, right?
Is there any debug mode where I can see why wifi command failed?

Hi,

I have bought 2 TPLink T-WR741ND v4.25
On both of them I installed OpenWrt Chaos Calmer 15.05.1

After that, I followed the instructions on this link luci.subsignal.org/~jow/reghack/ to enable channel 12 and 13, the only difference is that Ididn't used wget to get the reghack.mips.elf file, I download it on my computer and uploaded it to the router via WinSCP.

Well, after executing the commands, the result on the console is like that:

root@OpenWrt:/tmp# ./reghack.mips.elf /lib/modules/*/ath.ko
mmap(): Invalid argument
Memory mapping failed (missing fs support?), retrying from tmpfs
Patching @ 0x00000308: ath_is_radar_freq() MIPS opcode in ath/regd.o
Patching @ 0x00000414: ath_is_radar_freq() MIPS opcode in ath/regd.o
Patching @ 0x000034cc: ath world regdomain with 5 rules in ath/regd.o
Patching @ 0x0000356c: ath world regdomain with 4 rules in ath/regd.o
Patching @ 0x000035f0: ath world regdomain with 4 rules in ath/regd.o
Patching @ 0x00003674: ath world regdomain with 5 rules in ath/regd.o
root@OpenWrt:/tmp# ./reghack.mips.elf /lib/modules/*/cfg80211.ko
mmap(): Invalid argument
Memory mapping failed (missing fs support?), retrying from tmpfs
Patching @ 0x0002f0e8: embedded 00 regdomain in cfg80211/regdb.o

The same output in both routers. The thing is, on the first router I did it some weaks ago, and it is working normaly with chanel 12 and 13 enabled, this second one, that I installed OpenWrt yesterday and applied the hack, does not, still limited to channel 11. I reflashed OpenWrt and hack like 5 times now, and still it is limited to channel 11.

I don't remember if I had to to something else on the first router to enable those channels, but if I did, I can't remember what.

Is there something I'm leaving behind?

The discussion might have continued from here.