OpenWrt Forum Archive

Topic: Pictures/details of TL-WR720N 3G Chinese version

The content of this topic has been archived between 8 Feb 2018 and 8 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

loyukfai wrote:

Someone friendly gave me these builds to try out (built on/around 14-Aug), trialed okay on a test device:

http://goo.gl/NmN5bX

Disclaimer/Warning: There are always risks of possibly bricking the device or of any other unexpected harm that may do to your device.

Cheers.



Hey, just a little curious, i've bought the device and used the build from the post above, works like a charm, thanks!

Altough, when installing additional packages, i cant seem to install, i get errors

Is there a newer build maybe?

(Last edited by mtotheathe on 22 Dec 2014, 14:36)

I bought the tl-wr720n v4 chinese version and found this chinese tutorial.
It might be useful for someone, so I post what I did...

Tutorial:
http://bbs.mydigit.cn/simple/?t991342.html

At baidu you can download the needed files
http://pan.baidu.com/s/1hqJzuXe (pass u2e9)

Step 1 is to enable uboot-flashing:

When you are at the stock-firmware, download
wr720nv4/wr720nv4解锁ubootopenwrt固件.bin (3.8M 20141030 11:09 MD5sum 321248fc3d9121b261ffc6f35b60bbde)
and flash it with the original web interface (192.168.1.253)

You can find the firmware update in the webinterface the following way:
System is the entry under the readable (***DNS***) on the left side pane.
Then the third entry is firmware update. If in doubt, use google translate.

Afterwards a bb openwrt-image with write enabled mtd is flashed.

Step 2 is to get the pepe2k uboot:

download the files in the wr720nv4***uboot folder
copy them to the wr720nv4
$ scp flash.sh wr720n-v4-uboot-pepe.bin  root@192.168.1.1:/tmp

root@OpenWrt:/tmp# sh flash.sh wr720n-v4-uboot-pepe.bin 9acf3d80cdcf70375618d900
ab355cdc
wr720n-v4-uboot-pepe.bin md5sum : 9acf3d80cdcf70375618d900ab355cdc
wr720n-v4-uboot-pepe.bin md5sum check pass
0+1 records in
0+1 records out
64512+0 records in
64512+0 records out
Backuping to uboot_backup.bin
Backup some config first,just like MAC address ...
1024+0 records in
1024+0 records out
Flashing
Sync Finished

power it down, power it up and immediatly after powering up, press the reset button until the led flashed three times. you should be able to access the uboot webinterface at 192.168.1.1

Now you have a proper fallback to try different firmware images. The chinese image seems fine and has luci.
There is a overclock uboot for the v4. I didn't try itNow you have a proper fallback to try different firmware images. The chinese image seems fine and has luci..

If you want to build a new one with openvpn and luci (or don't trust the chinese guy). Just get the Imagebuilder:

OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64$ nice -n 19 make image PROFILE=TLWR720 PACKAGES="openvpn-polarssl luci  -ip6tables -kmod-ip6tables -kmod-ipv6 -ppp -ppp-mod-pppoe -odhcp6c -luci-proto-ipv6 -luci-proto-ppp" 
OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64$ scp bin/ar71xx/openwrt-ar71xx-generic-tl-wr720n-v3-squashfs-sysupgrade.bin root@192.168.1.1:/tmp/

The ImageBuilder builds for the v3 but still the image works fine.

root@OpenWrt:~# sysupgrade -v /tmp/openwrt-ar71xx-generic-tl-wr720n-v3-squashfs-sysupgrade.bin 
Invalid image, hardware ID mismatch, hw:07200104 image:07200103.
Image check 'platform_check_image' failed.
root@OpenWrt:~# sysupgrade -F -v /tmp/openwrt-ar71xx-generic-tl-wr720n-v3-squashfs-sysupgrade.bin 
Invalid image, hardware ID mismatch, hw:07200104 image:07200103.
Image check 'platform_check_image' failed but --force given - will update anyway!
....
Performing system upgrade...
Unlocking firmware ...

Writing from <stdin> to firmware ...     
Appending jffs2 data from /tmp/sysupgrade.tgz to firmware...TRX header not found
Error fixing up TRX header
    
Upgrade completed
Rebooting system...

Seems to run fine.

Even though the following isn't wr720n specific, I figured, that many will buy this device to use it as a openvpn-gateway due to its two ethernet ports.

To do so, just drop your openvpn.conf in /etc/openvpn/ and modify the /etc/config/openvpn

option enabled 1
option config /etc/openvpn/yourconf.ovpn

Add a vpn-device to /etc/config/network

config interface 'vpn'
    option proto 'none'
    option ifname 'tun0'
    option delegate '0'

And finally set your firewall up: /etc/config/firewall

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option network 'lan'

config zone
    option name 'wan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option network 'wan'

config zone
    option name 'vpn'
    option input 'REJECT'
    option forward 'REJECT'
    option output 'ACCEPT'
    option network 'vpn'
    option masq '1'
    option mtu_fix '1'


config forwarding
    option src 'lan'
    option dest 'vpn'

Reboot and you're ready to go. Plug the wan-port in any dhcp-enabled network and you will have on lan (and wifi if configured) the openvpn'ed network.

(Last edited by malfi on 7 Feb 2015, 13:26)

Maybe you could upstream the patch so there will be official builds for v4?

Cheers.

mtotheathe wrote:

Hey, just a little curious, i've bought the device and used the build from the post above, works like a charm, thanks!

Altough, when installing additional packages, i cant seem to install, i get errors

Is there a newer build maybe?

Best would be to have the v4 patch upstreamed and let the buildbots do its job.

As a temporary alternative, you may try flashing v3 onto it?

Cheers.

Hello, is v1.1 not supported by OpenWRT?

According to the wiki, v1 only has 2MB flash, so presumably, no, it's not supported.

https://wiki.openwrt.org/toh/tp-link/tl-wr720n

In general, OpenWrt/LEDE only supports devices with min. 4MB flash.

Cheers.

The discussion might have continued from here.