OpenWrt Forum Archive

Topic: Update on Linksys WRT1900AC support

The content of this topic has been archived between 16 Sep 2014 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

@feathersanddown If @kirkgbr is right, you should be able to set a firewall rule to discard dns queries for clients connecting.  I'm not familiar with transmission, so the firewall rule may need to be set manually via the firewall.user script.

@thelakesclub

The mwlwifi recent commits are 100% related to new functions in the 88W8964.bin firmware.  Nothing new for existing hardware.

I don't know, but comments like this would lead me to believe otherwise.

Look at the code.  I didn't say it wouldn't break anything -- in the diffs I see only changes related to adding support for the new firmware blob.  No reason to upgrade unless you have a Rango, imo.

I didn't say it would break anything either, my reference was to the blob, not the wrapper. I was not sure if it was the same blob or not, but in checking I think the FW version appears to be the same as previous, I think:

[   16.191722] ieee80211 phy0: firmware version: 0x702091a
[   16.215469] ieee80211 phy0: firmware region code: 0
[   17.287549] ieee80211 phy1: firmware version: 0x702091a
[   17.311303] ieee80211 phy1: firmware region code: 0

but I do not have the previous FW version at hand.

I think it is the same for the previous driver:

[    9.260798] <<Marvell 802.11ac Wireless Network Driver version 10.3.0.18-20160823-1>>

and

[   10.287765] ieee80211 phy0: firmware version: 0x702091a
[   10.311520] ieee80211 phy0: firmware region code: 0

Cheers

P.S. I am on 4.4.24 @ r1814, and have experienced the wifi drops...  seems to recover after 20 to 30 seconds

I installed DESIGNATED DRIVER (Bleeding Edge, r49388) today and wonder where the php* packages are, last time upgrading was start september and php packages was available?

(Last edited by hd2659 on 14 Oct 2016, 20:33)

This is gonna sound like a stupid question but here goes...

Shouldn't I be able to plug the wan port of my spare wrt1200ac into one of the switch ports on main router lan side and get a DHCP address on that wan interface?

kirkgbr wrote:

This is gonna sound like a stupid question but here goes...

Shouldn't I be able to plug the wan port of my spare wrt1200ac into one of the switch ports on main router lan side and get a DHCP address on that wan interface?

Works fine for me?

Edit: fyi if you are routing (or not as the case may be) to the same range/subnet it won't work. Change it on the lan interface of either router

(Last edited by listerwrt on 14 Oct 2016, 21:21)

listerwrt wrote:
kirkgbr wrote:

This is gonna sound like a stupid question but here goes...

Shouldn't I be able to plug the wan port of my spare wrt1200ac into one of the switch ports on main router lan side and get a DHCP address on that wan interface?

Works fine for me?

Edit: fyi if you are routing (or not as the case may be) to the same range/subnet it won't work. Change it on the lan interface of either router

not sure I understand what you mean by "change it".

kirkgbr wrote:

not sure I understand what you mean by "change it".

Can't you just turn off DHCP on the WRT1200AC and have it work as an AP? or do you want the 1200 to route packages as a second network?

(Last edited by lifehacksback on 14 Oct 2016, 22:31)

kirkgbr wrote:
listerwrt wrote:
kirkgbr wrote:

This is gonna sound like a stupid question but here goes...

Shouldn't I be able to plug the wan port of my spare wrt1200ac into one of the switch ports on main router lan side and get a DHCP address on that wan interface?

Works fine for me?

Edit: fyi if you are routing (or not as the case may be) to the same range/subnet it won't work. Change it on the lan interface of either router

not sure I understand what you mean by "change it".

Change range/subnet on the lan interface. e.g. 10.0.0.1/255.0.0.0 on one side and 192.168.1.1/255.255.255.0 on the other. Otherwise you have two DHCP servers on the same network and the firewall is doing nothing(?). At least that's my understanding. Someone else will know more I'm sure but that should get it working

Edit: or what lifehacksback said would work too. Depends what you are doing. Personally I don't want things on one side (easily) visible to the other

(Last edited by listerwrt on 14 Oct 2016, 22:47)

hd2659 wrote:

I installed DESIGNATED DRIVER (Bleeding Edge, r49388) today and wonder where the php* packages are, last time upgrading was start september and php packages was available?

IMHO


openwrt is not maintained anymore and dead (all major openwrt maintainers left and founded lede). lede is the following up project based on the latest openwrt source, but way more ahead now

kirkgbr wrote:

This is gonna sound like a stupid question but here goes...

Shouldn't I be able to plug the wan port of my spare wrt1200ac into one of the switch ports on main router lan side and get a DHCP address on that wan interface?

Which will  be the dhcp server?  Unless you need two subnets, simply use the spare WRT1200AC as a smart switch on the same subnet, bridging eth0 & eth1 (even if you'd like two subnets, you can still use it as a smart switch [see bottom of network below])


First, make a backup copy of the following files: /etc/config/ dhcp firewall network

cd /etc/config ; cp dhcp dhcp.WAN ; cp firewall firewall.WAN ; cp network network.WAN

Next, make the following edits:

dhcp

     
##########################
   WAN [public] config
##########################

config dnsmasq
    option  domain                  OpenWrt
    option  local                   '/lan/'
    option  leasefile               /tmp/dhcp.leases
    option  resolvfile              /tmp/resolv.conf.auto
    option  localise_queries        1
    option  readethers              1
    option  localservice            1
    option  logquerries             1
    option  domainneeded            1
    option  authoritative           1
    option  rebind_protection       1
    option  rebind_localhost        1
    option  sequential_ip           1

config dhcp 'lan'
    option  interface               lan
    option  leasetime               24h
    option  dhcpv6                  server
    option  ra                      server
    option  ra_management           1
    option  force                   1
    option  start                   40
    option  limit                   10


################################
   LAN [smart switch] config
################################

--- w/o Separate Subnet ---

config dnsmasq
    option  domain                  OpenWrt
    option  local                   '/lan/'
    option  leasefile               /tmp/dhcp.leases
    option  resolvfile              /tmp/resolv.conf.auto
    option  localise_queries        1
    option  readethers              1
    option  localservice            1
    option  logquerries             1
    option  domainneeded            1
    option  authoritative           1
    option  rebind_protection       0
    option  sequential_ip           1


--- w/ Separate Subnet ---

config dnsmasq
    option  domain                  OpenWrt
    option  local                   '/lan/'
    option  leasefile               /tmp/dhcp.leases
    option  resolvfile              /tmp/resolv.conf.auto
    option  localise_queries        1
    option  readethers              1
    option  localservice            1
    option  logquerries             1
    option  domainneeded            1
    option  authoritative           1
    option  rebind_protection       0
    option  sequential_ip           1

config dhcp 'lan'
    option  interface               lan
    option  leasetime               24h
    option  dhcpv6                  server
    option  ra                      server
    option  ra_management           1
    option  force                   1
      

firewall

     
##########################
   WAN [public] config
##########################

config defaults
    option  input           ACCEPT
    option  output          ACCEPT
    option  forward         REJECT
    option  syn_flood       1
    option  drop_invalid    1

config zone
    option  name            lan
    option  network         lan
    option  input           ACCEPT
    option  output          ACCEPT
    option  forward         ACCEPT

config zone
    option  name            wan
    option  network         'wan wan6'
    option  input           REJECT
    option  output          ACCEPT
    option  forward         REJECT
    option  mtu_fix         1
    option  masq            1

config forwarding
    option  dest            wan
    option  src             lan


################################
   LAN [smart switch] config
################################

config defaults
    option  input           ACCEPT
    option  output          ACCEPT
    option  forward         ACCEPT
    option  syn_flood       0
    option  drop_invalid    0

config zone
    option  name            lan
    option  network         lan
    option  input           ACCEPT
    option  output          ACCEPT
    option  forward         ACCEPT
    option  conntrack       1
    option  log             1
     

network

     
##########################
   WAN [public] config
##########################

config interface 'lan'
    option  ifname          eth1
    option  force_link      1
    option  type            bridge
    option  proto           static
    option  ip6assign       60
    option  ipaddr          192.168.1.62
    option  netmask         255.255.255.192
    option  dns             '208.67.222.222 208.67.220.220 8.8.8.8 8.8.4.4'

config interface 'wan'
    option  ifname          eth0
    option  proto           dhcp

config interface 'wan6'
    option  ifname          eth0
    option  proto           dhcpv6


################################
   LAN [smart switch] config
################################

config interface 'lan'
    option  force_link      1
    option  type            bridge
    option  _orig_bridge    true
    option  ifname          'eth0 eth1'
    option  _orig_ifname    eth1
    option  proto           static
    option  ip6assign       60
    option  ipaddr          192.168.1.62
    option  netmask         255.255.255.192
    option  broadcast       192.168.1.63
    option  dns             192.168.1.1
    option  gateway         192.168.1.1

--- OR ---

  - While I'd recommend a static IP to maintain a
    consistent route to LuCI, NetData, DLNA, or
    UPnP [if installed], if you don't want that:

config interface 'lan'
    option  type            bridge
    option  _orig_bridge    true
    option  ifname          'eth0 eth1'
    option  _orig_ifname    eth1
    option  proto           dhcp


--- w/ Separate Subnet ---

  - gateway & dns will be IP of main router

config interface 'lan'
    option  force_link      1
    option  type            bridge
    option  _orig_bridge    true
    option  ifname          'eth0 eth1'
    option  _orig_ifname    eth1
    option  proto           static
    option  ip6assign       60
    option  ipaddr          192.168.1.65
    option  netmask         255.255.255.192
    option  broadcast       192.168.1.126
    option  dns             192.168.1.1
    option  gateway         192.168.1.1
          

Finally, make a backup copy of the smart switch config files:

cd /etc/config ; cp dhcp dhcp.LAN ; cp firewall firewall.LAN ; cp network network.LAN

(Last edited by JW0914 on 15 Oct 2016, 15:46)

Thanks all, I am working something out.  I will report back later.

gufus wrote:
hd2659 wrote:

I installed DESIGNATED DRIVER (Bleeding Edge, r49388) today and wonder where the php* packages are, last time upgrading was start september and php packages was available?

IMHO


openwrt is not maintained anymore and dead (all major openwrt maintainers left and founded lede). lede is the following up project based on the latest openwrt source, but way more ahead now

Which is not even half the truth and if this is the most relevant bit for you use Chadsters McDebian, which indeed qualifies for way ahead.

Eitherway the proper answer is that this is the nature of snapshots, one day it's there, one day it's not. Snapshots are the worst of all choices for regular use. The only value they have is for quick testing. Use something that at least resembles a release or build from source for anything else.

anyone here that is pretty good with openvpn?
I've changed my port to tcp 443, to work around firewalls blocking udp traffic in some of the hotels i stay.

puzzle is now that the local router firewall is thinking the vpn connection is causing a syn-flood.

[73441.805363] TCP: request_sock_TCP: Possible SYN flooding on port 443. Sending cookies.  Check SNMP counters

anyone has any idea what i can tweak to prevent this? (except disabling synflood-protection ofcourse)

U could use port 53 OpenVPN smile

@JohnnySL  Isn't SYN[chronize] TCP only?  OpenVPN should be ran as UDP only, except under the following two conditions: troubleshooting or if receiving high packet loss via udp.  The reason for this is TCP cannot efficiently encapsulate itself.

Please post your server and client configs [sanitize of sensitive info] within code brackets.

I finally managed to get a working trunk firmware for v1 (Mamba) based on kernel 4.4.24 with all offload modules in it, however it's not using the upstreamed mvneta driver but Marvell's own driver. It did require a lot of work and heavy kernel modifications but it serves as a starting point for porting the code.

nitroshift

What additional offload modules have you now got?

gufus wrote:
hd2659 wrote:

I installed DESIGNATED DRIVER (Bleeding Edge, r49388) today and wonder where the php* packages are, last time upgrading was start september and php packages was available?

IMHO


openwrt is not maintained anymore and dead (all major openwrt maintainers left and founded lede). lede is the following up project based on the latest openwrt source, but way more ahead now

IMHO this is FUD and BS wink

Kaloz wrote:

FUD

I hope so. smile

(Last edited by gufus on 16 Oct 2016, 02:25)

IMHO


openwrt is not maintained anymore and dead (all major openwrt maintainers left and founded lede). lede is the following up project based on the latest openwrt source, but way more ahead now

IMHO this is FUD and BS wink

The comment closely resembles this one...

BrainSlayer - "the scan output is identical with a qca9984 client which is working here in that test case. hard to say what the issue is. consider that i developed the vht160 support for ath10k. so if you find a issue there, which i havent seen yet, i'm likelly able to fix it. for testing you may use lede-staging tree from nbd since openwrt is not maintained anymore and dead (all major openwrt maintainers left and founded lede). lede is the following up project based on the latest openwrt source, but way more ahead now git://git.lede-project.org/lede/nbd/staging.git this latest staging tree does contain the latest mac80211 which is also used in dd-wrt"

https://github.com/kaloz/mwlwifi/issues/111

Maybe they missed this https://github.com/openwrt/openwrt (?)

Lantis wrote:

What additional offload modules have you now got?

Hardware Forwarding (HwF), Parser and Classifier (PnC) with Tcam (1024 entries), Packet Modification Table (PMT) and Marvell's own implementation of the Buffer Manager (BM). Routing at gigabit speed now dropped the CPU load from 99% to ~20%. Funny enough, the driver is called mvneta too.

nitroshift

Sorry, posts 13526 to 13525 are missing from our archive.