OpenWrt Forum Archive

Topic: Installing OpenWrt in Xiaomi Wifi Mini

The content of this topic has been archived between 8 Feb 2018 and 5 May 2018. Unfortunately there are posts – most likely complete pages – missing.

anarchy99 wrote:

ok, how do you flash it from telnet? write your procedure please

Why don't you read the tutorial irwan6179 linked to a few posts above?

https://forum.lowyat.net/topic/3828356/all

(Last edited by famewolf on 27 Mar 2016, 18:57)

ok read about it. still it requires changing bootloader or using usb drive. and copying from usb drive becomes a problem when your router is in another room/floor. that's why i've posted how to enable ssh.

I start a bounty (USD 250) for this bug, so this way we can get full Openwrt working over Xiaomi Mini: https://www.bountysource.com/issues/323 … an-in-2-4g

If any can help (with more money or solving this issue) I would appreciate.

sharkys wrote:
gazambuja wrote:

Someone can confirm this bug: https://dev.openwrt.org/ticket/22086 ?
I have 3 differents Xiaomi with the same bug (same firmware build)

This was the reason I switched to Padavan FW from PandoraBox, wasn't using Openwrt however due to the weak signal bug - https://dev.openwrt.org/ticket/20369

gazambuja wrote:

I start a bounty (USD 250) for this bug, so this way we can get full Openwrt working over Xiaomi Mini: https://www.bountysource.com/issues/323 … an-in-2-4g

If any can help (with more money or solving this issue) I would appreciate.

I've been mucking around with the firmware for this, and working on a simple-to-use WebUI for it too, could do with that fixed so I'll chuck $50 at getting the WiFi fixed also.

Will start a new thread for feedback on the firmware / UI though smile

Thanks Chilling_Silence. Very good your project (https://forum.openwrt.org/viewtopic.php?id=63836).
Now, any one can help with the problem over 2.4G? more test to do?

Chilling_Silence wrote:
gazambuja wrote:

I start a bounty (USD 250) for this bug, so this way we can get full Openwrt working over Xiaomi Mini: https://www.bountysource.com/issues/323 … an-in-2-4g

If any can help (with more money or solving this issue) I would appreciate.

I've been mucking around with the firmware for this, and working on a simple-to-use WebUI for it too, could do with that fixed so I'll chuck $50 at getting the WiFi fixed also.

Will start a new thread for feedback on the firmware / UI though smile

can you try latest trunk with modified MIWIFI-MINI.dts file?

replace this part of code:

        wmac@10180000 {
                ralink,mtd-eeprom = <&factory 0>;
        };

        pcie@10140000 {
                status = "okay";

                pcie-bridge {
                        mt76@0,0 {
                                reg = <0x0000 0 0 0 0>;
                                device_type = "pci";
                                mediatek,mtd-eeprom = <&factory 0x8000>;
                                mediatek,2ghz = <0>;
                        };
                };
        };

with

        wmac@10180000 {
                local-mac-address = [00 0a 35 00 00 00];
        };

        pcie@10140000 {
                status = "okay";

                pcie-bridge {
                        mt76@0,0 {
                                reg = <0x0000 0 0 0 0>;
                                device_type = "pci";
                                local-mac-address = [00 0a 36 00 00 00];
                                mediatek,2ghz = <0>;
                        };
                };
        };

where 00 0a 35 00 00 00 is your 2.4GHz wlan mac address and 00 0a 36 00 00 00 is your 5GHz mac address

try to see if the wireless will come up on any of the two intefaces

Ok, I will try this to night. But remember, the 2.4GHz work fine.... until they dont, and need restart hostapd to work again.




anarchy99 wrote:

can you try latest trunk with modified MIWIFI-MINI.dts file?

replace this part of code:

        wmac@10180000 {
                ralink,mtd-eeprom = <&factory 0>;
        };

        pcie@10140000 {
                status = "okay";

                pcie-bridge {
                        mt76@0,0 {
                                reg = <0x0000 0 0 0 0>;
                                device_type = "pci";
                                mediatek,mtd-eeprom = <&factory 0x8000>;
                                mediatek,2ghz = <0>;
                        };
                };
        };

with

        wmac@10180000 {
                local-mac-address = [00 0a 35 00 00 00];
        };

        pcie@10140000 {
                status = "okay";

                pcie-bridge {
                        mt76@0,0 {
                                reg = <0x0000 0 0 0 0>;
                                device_type = "pci";
                                local-mac-address = [00 0a 36 00 00 00];
                                mediatek,2ghz = <0>;
                        };
                };
        };

where 00 0a 35 00 00 00 is your 2.4GHz wlan mac address and 00 0a 36 00 00 00 is your 5GHz mac address

try to see if the wireless will come up on any of the two intefaces

when 2.4 work fine please run this command and post output here

iw dev wlan1 station dump

@anarchy99, here you have differents sta in two scenarios.


When all work fine:

$ iw dev wlan1 station dump
Station a4:77:33:71:74:cc (on wlan1)
    inactive time:    380 ms
    rx bytes:    1076074
    rx packets:    10715
    tx bytes:    11942403
    tx packets:    10490
    tx retries:    1381
    tx failed:    37
    signal:      -81 dBm
    signal avg:    -80 dBm
    tx bitrate:    72.2 MBit/s MCS 7 short GI
    rx bitrate:    72.2 MBit/s MCS 7 short GI
    expected throughput:    34.57Mbps
    authorized:    yes
    authenticated:    yes
    preamble:    short
    WMM/WME:    yes
    MFP:        no
    TDLS peer:    no
    connected time:    1252 seconds
Station 00:73:e0:75:79:a6 (on wlan1)
    inactive time:    29470 ms
    rx bytes:    555881
    rx packets:    1444
    tx bytes:    221251
    tx packets:    740
    tx retries:    234
    tx failed:    10
    signal:      -97 dBm
    signal avg:    -99 dBm
    tx bitrate:    11.0 MBit/s
    rx bitrate:    5.5 MBit/s
    expected throughput:    5.583Mbps
    authorized:    yes
    authenticated:    yes
    preamble:    short
    WMM/WME:    yes
    MFP:        no
    TDLS peer:    no
    connected time:    1196 seconds
Station 2c:8a:72:b4:23:1f (on wlan1)
    inactive time:    4090 ms
    rx bytes:    379142
    rx packets:    2562
    tx bytes:    723692
    tx packets:    1813
    tx retries:    172
    tx failed:    8
    signal:      -95 dBm
    signal avg:    -95 dBm
    tx bitrate:    65.0 MBit/s MCS 7
    rx bitrate:    6.0 MBit/s
    expected throughput:    23.986Mbps
    authorized:    yes
    authenticated:    yes
    preamble:    short
    WMM/WME:    yes
    MFP:        no
    TDLS peer:    no
    connected time:    401 seconds
Station 94:65:9c:9f:a1:00 (on wlan1)
    inactive time:    0 ms
    rx bytes:    1003080
    rx packets:    5800
    tx bytes:    4438783
    tx packets:    5303
    tx retries:    1002
    tx failed:    141
    signal:      -87 dBm
    signal avg:    -85 dBm
    tx bitrate:    72.2 MBit/s MCS 7 short GI
    rx bitrate:    240.0 MBit/s MCS 13 40MHz short GI
    expected throughput:    34.57Mbps
    authorized:    yes
    authenticated:    yes
    preamble:    short
    WMM/WME:    yes
    MFP:        no
    TDLS peer:    no
    connected time:    319 seconds

And when is not working (this connected STA cant connect to this router, for example, not working ssh, not response to ping, etc):

$ iw dev wlan1 station dump
Station 2c:8a:72:b4:23:1f (on wlan1)
        inactive time:  160 ms
        rx bytes:       7067
        rx packets:     79
        tx bytes:       741
        tx packets:     4
        tx retries:     0
        tx failed:      0
        signal:         -79 dBm
        signal avg:     -79 dBm
        tx bitrate:     6.5 MBit/s MCS 0
        rx bitrate:     72.2 MBit/s MCS 7 short GI
        expected throughput:    5.126Mbps
        authorized:     yes
        authenticated:  yes
        preamble:       short
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        connected time: 69 seconds
Station 64:b8:53:da:eb:95 (on wlan1)
        inactive time:  700 ms
        rx bytes:       4105078
        rx packets:     56863
        tx bytes:       40572982
        tx packets:     30789
        tx retries:     2911
        tx failed:      89
        signal:         -91 dBm
        signal avg:     -92 dBm
        tx bitrate:     1.0 MBit/s
        rx bitrate:     24.0 MBit/s
        expected throughput:    28.564Mbps
        authorized:     yes
        authenticated:  yes
        preamble:       short
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        connected time: 41370 seconds
Station 00:73:e0:75:79:a6 (on wlan1)
        inactive time:  7870 ms
        rx bytes:       418366
        rx packets:     11496
        tx bytes:       15570
        tx packets:     88
        tx retries:     4
        tx failed:      4
        signal:         -101 dBm
        signal avg:     -100 dBm
        tx bitrate:     1.0 MBit/s
        rx bitrate:     1.0 MBit/s
        expected throughput:    5.126Mbps
        authorized:     yes
        authenticated:  yes
        preamble:       short
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        connected time: 6934 seconds

PS: to this try I have to wait 24h to reapear the issue, this first 24h all interfaces work fine. Now I reboot the router (wifi restart not work) and all work fine again.
PS2: only to remember, the 5GHz interface always work fine, I connect to wlan0 and can use internet and ssh access without problem.

when it happens again, try issuing /etc/init.d/network restart to see if it will come up.

how about modified .dts test, did you try it?

and if you could run iw dev wlan0 station dump + iwconfig on your linux machine it would help too. someone on the dev ticket claims 110% signal strength on 5GHz.

(Last edited by anarchy99 on 5 Apr 2016, 14:27)

Happend again... I cast some local video to my chromecast and after few seconds internet stop working.
Now:
- in my smartphone connected to wlan0 (5GHz) and run SSH client.
- my Linux laptop connected to wlan1 (2.4GHz) without ping, ssh, etc...

On my Laptop:

$ iwconfig 
wlan0     IEEE 802.11abgn  ESSID:"Azambuja"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: F0:B4:29:55:9F:46   
          Bit Rate=300 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=65/70  Signal level=-45 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1   Missed beacon:0

After /etc/init.d/network restart, nothing change, still has not connection on 2.4 and 5GHz work just fine.

Some more about this, on my laptop (connected to 2.4 and without any connection), have this:

$ arp -n
Address                  HWtype  HWaddress           Flags Mask            Iface
192.168.10.1                     (incomplete)                              wlan0

If Im connect to 5G, this is the response:

$ arp -n
Address                  HWtype  HWaddress           Flags Mask            Iface
192.168.10.1             ether   f0:b4:29:55:9f:46   C                     wlan0

PS I did not have time to try dst file, give me until tomorrow night.

ok, take your time.

when it happens again on 2.4 try adding static arp entry and ping router afterwards.

but iwconfig and iw dev wlan0 station dump output needed when your laptop is connected to 5G

for 2.4 reception is known to be weak at the moment, my suspicion is that the same happens on 5G too.

ok @anarchy99, here you go info about 5G:

Laptop connected to wlan0 (5GHz):

$ iwconfig 
wlan0     IEEE 802.11abgn  ESSID:"Azambuja 5GHz"  
          Mode:Managed  Frequency:5.18 GHz  Access Point: F0:B4:29:55:9F:47   
          Bit Rate=650 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=57/70  Signal level=-53 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:37   Missed beacon:0

And from openwrt router:

# iw dev wlan0 station dump
Station 94:65:9c:9f:a1:00 (on wlan0)
    inactive time:    0 ms
    rx bytes:    1415755
    rx packets:    7969
    tx bytes:    9467643
    tx packets:    9925
    tx retries:    525
    tx failed:    1
    signal:      -60 [-60, -65] dBm
    signal avg:    -59 [-59, -64] dBm
    tx bitrate:    650.0 MBit/s VHT-MCS 7 80MHz short GI VHT-NSS 2
    rx bitrate:    18.0 MBit/s
    expected throughput:    66.833Mbps
    authorized:    yes
    authenticated:    yes
    preamble:    long
    WMM/WME:    yes
    MFP:        no
    TDLS peer:    no
    connected time:    137 seconds

I'm 5mts (16 feets) from the router without any obstacle in middle, in a zone with few interferences.

PS: One more thing: I'm doing some more testing, but the 2.4GHz issue appear to be some issue when this interface have some traffic adove some line... For example:

- One phone using youtube: no problem.
- Two phones using youtube: no problem.
- One phone sharing screen to the TV (android -> chromecast): wlan1 crash.
- More testing to come

(Last edited by gazambuja on 6 Apr 2016, 16:50)

I put some traffic over 2.4GHz (copy some big file and start to download torrents...) and some minutes after that, interface stop working, here you have the logread from the last seconds of wlan1 working:

Wed Apr  6 01:24:25 2016 daemon.debug hostapd: wlan1: WPA rekeying GTK
Wed Apr  6 01:24:25 2016 daemon.debug hostapd: wlan1: STA 2c:8a:72:b4:23:1f WPA: sending 1/2 msg of Group Key Handshake
Wed Apr  6 01:24:25 2016 daemon.debug hostapd: wlan1: STA 94:65:9c:9f:a1:00 WPA: sending 1/2 msg of Group Key Handshake
Wed Apr  6 01:24:25 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: sending 1/2 msg of Group Key Handshake
Wed Apr  6 01:24:25 2016 daemon.debug hostapd: wlan1: STA 0c:41:3e:4a:f5:44 WPA: sending 1/2 msg of Group Key Handshake
Wed Apr  6 01:24:25 2016 daemon.debug hostapd: wlan1: STA a4:77:33:71:74:cc WPA: sending 1/2 msg of Group Key Handshake
Wed Apr  6 01:24:25 2016 daemon.debug hostapd: wlan1: STA 2c:8a:72:b4:23:1f WPA: received EAPOL-Key frame (2/2 Group)
Wed Apr  6 01:24:25 2016 daemon.info hostapd: wlan1: STA 2c:8a:72:b4:23:1f WPA: group key handshake completed (RSN)
Wed Apr  6 01:24:25 2016 daemon.debug hostapd: wlan1: STA 94:65:9c:9f:a1:00 WPA: received EAPOL-Key frame (2/2 Group)
Wed Apr  6 01:24:25 2016 daemon.info hostapd: wlan1: STA 94:65:9c:9f:a1:00 WPA: group key handshake completed (RSN)
Wed Apr  6 01:24:25 2016 daemon.debug hostapd: wlan1: STA a4:77:33:71:74:cc WPA: received EAPOL-Key frame (2/2 Group)
Wed Apr  6 01:24:25 2016 daemon.info hostapd: wlan1: STA a4:77:33:71:74:cc WPA: group key handshake completed (RSN)
Wed Apr  6 01:24:25 2016 daemon.debug hostapd: wlan1: STA 0c:41:3e:4a:f5:44 WPA: received EAPOL-Key frame (2/2 Group)
Wed Apr  6 01:24:25 2016 daemon.info hostapd: wlan1: STA 0c:41:3e:4a:f5:44 WPA: group key handshake completed (RSN)
Wed Apr  6 01:24:25 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: EAPOL-Key timeout
Wed Apr  6 01:24:25 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: sending 1/2 msg of Group Key Handshake
Wed Apr  6 01:24:26 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: EAPOL-Key timeout
Wed Apr  6 01:24:26 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: sending 1/2 msg of Group Key Handshake
Wed Apr  6 01:24:27 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: EAPOL-Key timeout
Wed Apr  6 01:24:27 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: sending 1/2 msg of Group Key Handshake
Wed Apr  6 01:24:28 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: EAPOL-Key timeout
Wed Apr  6 01:24:28 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: WPA_PTK: sm->Disconnect
Wed Apr  6 01:24:28 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: event 3 notification
Wed Apr  6 01:24:28 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 IEEE 802.1X: unauthorizing port
Wed Apr  6 01:24:30 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 MLME: MLME-DEAUTHENTICATE.indication(00:73:e0:75:79:a6, 2)
Wed Apr  6 01:24:30 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 MLME: MLME-DELETEKEYS.request(00:73:e0:75:79:a6)
Wed Apr  6 01:24:33 2016 daemon.info hostapd: wlan1: STA 00:73:e0:75:79:a6 IEEE 802.11: deauthenticated due to local deauth request
Wed Apr  6 01:24:38 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 IEEE 802.11: authentication OK (open system)
Wed Apr  6 01:24:38 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 MLME: MLME-AUTHENTICATE.indication(00:73:e0:75:79:a6, OPEN_SYSTEM)
Wed Apr  6 01:24:38 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 MLME: MLME-DELETEKEYS.request(00:73:e0:75:79:a6)
Wed Apr  6 01:24:38 2016 daemon.info hostapd: wlan1: STA 00:73:e0:75:79:a6 IEEE 802.11: authenticated
Wed Apr  6 01:24:38 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 IEEE 802.11: association OK (aid 1)
Wed Apr  6 01:24:38 2016 daemon.info hostapd: wlan1: STA 00:73:e0:75:79:a6 IEEE 802.11: associated (aid 1)
Wed Apr  6 01:24:38 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 MLME: MLME-ASSOCIATE.indication(00:73:e0:75:79:a6)
Wed Apr  6 01:24:38 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 MLME: MLME-DELETEKEYS.request(00:73:e0:75:79:a6)
Wed Apr  6 01:24:38 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 IEEE 802.11: binding station to interface 'wlan1'
Wed Apr  6 01:24:38 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: event 1 notification
Wed Apr  6 01:24:38 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: start authentication
Wed Apr  6 01:24:38 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 IEEE 802.1X: unauthorizing port
Wed Apr  6 01:24:38 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: sending 1/4 msg of 4-Way Handshake
Wed Apr  6 01:24:38 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: received EAPOL-Key frame (2/4 Pairwise)
Wed Apr  6 01:24:38 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: sending 3/4 msg of 4-Way Handshake
Wed Apr  6 01:24:38 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: received EAPOL-Key frame (4/4 Pairwise)
Wed Apr  6 01:24:38 2016 daemon.debug hostapd: wlan1: STA 00:73:e0:75:79:a6 IEEE 802.1X: authorizing port
Wed Apr  6 01:24:38 2016 daemon.info hostapd: wlan1: STA 00:73:e0:75:79:a6 WPA: pairwise key handshake completed (RSN)
Wed Apr  6 01:24:40 2016 daemon.info dnsmasq-dhcp[3176]: DHCPREQUEST(br-lan) 192.168.10.230 00:73:e0:75:79:a6 
Wed Apr  6 01:24:40 2016 daemon.info dnsmasq-dhcp[3176]: DHCPACK(br-lan) 192.168.10.230 00:73:e0:75:79:a6 android-34402507ce1e26da
Wed Apr  6 01:25:31 2016 daemon.debug hostapd: wlan1: STA 0c:41:3e:4a:f5:44 IEEE 802.11: hostapd_public_action - action=0
Wed Apr  6 01:25:31 2016 daemon.debug hostapd: wlan1: STA 0c:41:3e:4a:f5:44 IEEE 802.11: handle_action - unknown action category 4 or invalid frame

# 20 seconds after this, wlan1 stop working

ok i've put my laptop at 5m distance without any obstacles:

iwconfig: -50
rssi on router: -62

difference about 12db and 5G is not at full power yet, when 5G would be at 100% the difference would go beyond 20db.

even at 1m distance rx rate wasn't at 300 or even close, max at 180Mbps (no AC card here to test only 300M)

possible scenarios:

1. 5G LNA not working
2. hw design error or wrong calibration (due to test result with xiaomi fw)
3. malfunction of my device

i'm really curious about your .dts test and can you run the iwconfig 5G test on xiaomi fw with router in the same place (ch 36)

use some older fw version somewhere between 0.5 and 0.7.20 since i've noticed signal drop after trying one of the latest xiaomi fw and pandorabox. it is possible one of the two did something wrong to 5G radio.

as for 2.4 check dev ticket

(Last edited by anarchy99 on 6 Apr 2016, 20:52)

I try change DTS file today with the last trunk, the result was 2.4G not working at all, and 5G work fine (with a random MAC), here you get the logread init:

# wifi restart; logread |grep radio1
Thu Apr  7 02:07:42 2016 daemon.notice netifd: radio1 (874): Could not find PHY for device 'radio1'
Thu Apr  7 02:07:43 2016 daemon.notice netifd: radio1 (934): WARNING: Variable 'data' does not exist or is not an array/object

Full log:

Thu Apr  7 02:07:37 2016 kern.info kernel: [    0.986140] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
Thu Apr  7 02:07:37 2016 kern.info kernel: [    0.994479] Freeing unused kernel memory: 196K (8039f000 - 803d0000)
Thu Apr  7 02:07:37 2016 user.info kernel: [    3.012299] init: Console is alive
Thu Apr  7 02:07:37 2016 user.info kernel: [    3.015986] init: - watchdog -
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.818469] usbcore: registered new interface driver usbfs
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.824171] usbcore: registered new interface driver hub
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.829758] usbcore: registered new device driver usb
Thu Apr  7 02:07:37 2016 kern.debug kernel: [    4.837725] rt2880-pinmux pinctrl: request pin 30 (io30) for pio:30
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.840775] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.849072] ehci-platform: EHCI generic platform driver
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.864773] phy phy-usbphy.0: remote usb device wakeup disabled
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.870831] phy phy-usbphy.0: UTMI 16bit 30MHz
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.875398] ehci-platform 101c0000.ehci: EHCI Host Controller
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.881308] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.889525] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.897379] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
Thu Apr  7 02:07:37 2016 kern.debug kernel: [    4.904424] usb usb1: no of_node; not parsing pinctrl DT
Thu Apr  7 02:07:37 2016 kern.debug kernel: [    4.904871] hub 1-0:1.0: no of_node; not parsing pinctrl DT
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.904924] hub 1-0:1.0: USB hub found
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.909238] hub 1-0:1.0: 1 port detected
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.916346] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.924236] ohci-platform: OHCI generic platform driver
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.929936] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.936917] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.945119] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
Thu Apr  7 02:07:37 2016 kern.debug kernel: [    4.962253] usb usb2: no of_node; not parsing pinctrl DT
Thu Apr  7 02:07:37 2016 kern.debug kernel: [    4.962776] hub 2-0:1.0: no of_node; not parsing pinctrl DT
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.962830] hub 2-0:1.0: USB hub found
Thu Apr  7 02:07:37 2016 kern.info kernel: [    4.967014] hub 2-0:1.0: 1 port detected
Thu Apr  7 02:07:37 2016 kern.debug kernel: [    4.978084] rt2880-pinmux pinctrl: request pin 24 (io24) for pio:24
Thu Apr  7 02:07:37 2016 kern.debug kernel: [    4.978269] rt2880-pinmux pinctrl: request pin 26 (io26) for pio:26
Thu Apr  7 02:07:37 2016 kern.debug kernel: [    4.978407] rt2880-pinmux pinctrl: request pin 29 (io29) for pio:29
Thu Apr  7 02:07:37 2016 user.info kernel: [    4.980593] init: - preinit -
Thu Apr  7 02:07:37 2016 kern.info kernel: [    5.973657] 8021q: adding VLAN 0 to HW filter on device eth0
Thu Apr  7 02:07:37 2016 kern.notice kernel: [    6.123583] random: procd urandom read with 10 bits of entropy available
Thu Apr  7 02:07:37 2016 kern.notice kernel: [    6.890267] jffs2: notice: (354) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
Thu Apr  7 02:07:37 2016 user.info kernel: [    6.908960] mount_root: switching to jffs2 overlay
Thu Apr  7 02:07:37 2016 user.info kernel: [    6.946739] procd: - early -
Thu Apr  7 02:07:37 2016 user.info kernel: [    6.949801] procd: - watchdog -
Thu Apr  7 02:07:37 2016 user.info kernel: [    7.264792] procd: - ubus -
Thu Apr  7 02:07:37 2016 user.info kernel: [    7.378344] procd: - init -
Thu Apr  7 02:07:37 2016 kern.info kernel: [    8.043552] ip6_tables: (C) 2000-2006 Netfilter Core Team
Thu Apr  7 02:07:37 2016 kern.info kernel: [    8.060885] Loading modules backported from Linux version v4.4-rc5-1913-gc8fdf68
Thu Apr  7 02:07:37 2016 kern.info kernel: [    8.068442] Backport generated by backports.git backports-20151218-0-g2f58d9d
Thu Apr  7 02:07:37 2016 kern.info kernel: [    8.122341] mt76x2e 0000:01:00.0: ASIC revision: 76120044
Thu Apr  7 02:07:37 2016 kern.info kernel: [    8.129245] mt76x2e 0000:01:00.0: Invalid MAC address, using random address 6a:5f:ed:10:0d:6f
Thu Apr  7 02:07:37 2016 kern.warn kernel: [    8.141066] ROM patch already applied
Thu Apr  7 02:07:37 2016 kern.warn kernel: [    8.474175] Firmware Version: 0.0.00
Thu Apr  7 02:07:37 2016 kern.warn kernel: [    8.477836] Build: 1
Thu Apr  7 02:07:37 2016 kern.warn kernel: [    8.480093] Build Time: 201507311614____
Thu Apr  7 02:07:37 2016 kern.warn kernel: [    8.488763] Firmware running!
Thu Apr  7 02:07:37 2016 kern.debug kernel: [    8.492687] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Thu Apr  7 02:07:37 2016 kern.info kernel: [    8.628359] ip_tables: (C) 2000-2006 Netfilter Core Team
Thu Apr  7 02:07:37 2016 kern.info kernel: [    8.645635] nf_conntrack version 0.5.0 (1967 buckets, 7868 max)
Thu Apr  7 02:07:37 2016 kern.info kernel: [    8.702153] xt_time: kernel timezone is -0000
Thu Apr  7 02:07:37 2016 kern.info kernel: [    8.720103] PPP generic driver version 2.4.2
Thu Apr  7 02:07:37 2016 kern.info kernel: [    8.727515] NET: Registered protocol family 24
Thu Apr  7 02:07:37 2016 kern.err kernel: [    8.749669] rt2800_wmac 10180000.wmac: failed to load mtd phandle
Thu Apr  7 02:07:37 2016 kern.info kernel: [    8.755910] ieee80211 phy1: rt2x00lib_request_eeprom_file: Info - Loading EEPROM data from 'soc_wmac.eeprom'.
Thu Apr  7 02:07:37 2016 kern.warn kernel: [    8.766227] rt2800_wmac 10180000.wmac: Direct firmware load for soc_wmac.eeprom failed with error -2
Thu Apr  7 02:07:37 2016 kern.warn kernel: [    8.775571] rt2800_wmac 10180000.wmac: Falling back to user helper
Thu Apr  7 02:07:37 2016 kern.err kernel: [    8.819298] firmware soc_wmac.eeprom: firmware_loading_store: map pages failed
Thu Apr  7 02:07:37 2016 kern.err kernel: [    8.826864] ieee80211 phy1: rt2x00lib_request_eeprom_file: Error - Failed to request EEPROM.
Thu Apr  7 02:07:37 2016 kern.warn kernel: [    8.835591] rt2800_wmac: probe of 10180000.wmac failed with error -11
Thu Apr  7 02:07:40 2016 authpriv.info dropbear[803]: Not backgrounding
Thu Apr  7 02:07:40 2016 user.notice : setting up led power
Thu Apr  7 02:07:41 2016 daemon.info procd: - init complete -
Thu Apr  7 02:07:42 2016 kern.info kernel: [   15.105068] 8021q: adding VLAN 0 to HW filter on device eth0
Thu Apr  7 02:07:42 2016 kern.info kernel: [   15.119192] device eth0.1 entered promiscuous mode
Thu Apr  7 02:07:42 2016 kern.info kernel: [   15.124100] device eth0 entered promiscuous mode
Thu Apr  7 02:07:42 2016 kern.info kernel: [   15.141238] br-lan: port 1(eth0.1) entered forwarding state
Thu Apr  7 02:07:42 2016 kern.info kernel: [   15.147043] br-lan: port 1(eth0.1) entered forwarding state
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Interface 'lan' is enabled
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Interface 'lan' is setting up now
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Interface 'lan' is now up
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Interface 'loopback' is enabled
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Interface 'loopback' is setting up now
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Interface 'loopback' is now up
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Interface 'wan' is enabled
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Interface 'wan6' is enabled
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Bridge 'br-lan' link is up
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Interface 'lan' has link connectivity 
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Network device 'eth0' link is up
Thu Apr  7 02:07:42 2016 daemon.notice netifd: VLAN 'eth0.1' link is up
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Network device 'lo' link is up
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Interface 'loopback' has link connectivity 
Thu Apr  7 02:07:42 2016 daemon.notice netifd: VLAN 'eth0.2' link is up
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Interface 'wan' has link connectivity 
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Interface 'wan' is setting up now
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Interface 'wan6' has link connectivity 
Thu Apr  7 02:07:42 2016 daemon.notice netifd: Interface 'wan6' is setting up now
Thu Apr  7 02:07:42 2016 daemon.notice netifd: wan (920): udhcpc (v1.24.1) started
Thu Apr  7 02:07:42 2016 daemon.notice netifd: radio1 (874): Could not find PHY for device 'radio1'
Thu Apr  7 02:07:42 2016 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Thu Apr  7 02:07:43 2016 daemon.notice netifd: wan (920): Sending discover...
Thu Apr  7 02:07:43 2016 daemon.notice netifd: wan (920): Sending select for 192.168.1.9...
Thu Apr  7 02:07:43 2016 daemon.notice netifd: wan (920): Lease of 192.168.1.9 obtained, lease time 259200
Thu Apr  7 02:07:43 2016 daemon.notice netifd: radio1 (934): WARNING: Variable 'data' does not exist or is not an array/object
Thu Apr  7 02:07:43 2016 daemon.notice netifd: Interface 'wan' is now up
Thu Apr  7 02:07:44 2016 kern.info kernel: [   17.144472] br-lan: port 1(eth0.1) entered forwarding state
Thu Apr  7 02:07:44 2016 daemon.notice netifd: radio0 (873): Configuration file: /var/run/hostapd-phy0.conf
Thu Apr  7 02:07:45 2016 kern.info kernel: [   18.086884] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Thu Apr  7 02:07:45 2016 kern.info kernel: [   18.097514] device wlan0 entered promiscuous mode
Thu Apr  7 02:07:45 2016 daemon.notice netifd: radio0 (873): wlan0: interface state UNINITIALIZED->HT_SCAN
Thu Apr  7 02:07:45 2016 daemon.notice netifd: radio0 (873): Using interface wlan0 with hwaddr 68:5f:ed:10:0d:6f and ssid "OpenWrt"
Thu Apr  7 02:07:46 2016 kern.info kernel: [   18.175519] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Thu Apr  7 02:07:46 2016 kern.info kernel: [   18.182291] br-lan: port 2(wlan0) entered forwarding state
Thu Apr  7 02:07:46 2016 kern.info kernel: [   18.187957] br-lan: port 2(wlan0) entered forwarding state
Thu Apr  7 02:07:46 2016 daemon.notice netifd: radio0 (873): wlan0: interface state HT_SCAN->ENABLED
Thu Apr  7 02:07:46 2016 daemon.notice netifd: radio0 (873): wlan0: AP-ENABLED 
Thu Apr  7 02:07:46 2016 daemon.notice netifd: Network device 'wlan0' link is up

DTS file (line 93):

        wmac@10180000 {
                ralink,mtd-eeprom = [00 0a 35 00 00 00];
        };

        pcie@10140000 {
                status = "okay";

                pcie-bridge {
                        mt76@0,0 {
                                reg = <0x0000 0 0 0 0>;
                                device_type = "pci";
                                mediatek,mtd-eeprom = [00 0a 36 00 00 00];
                                mediatek,2ghz = <0>;
                        };
                };
        };

thanks in advanced, @anarchy99, if you want contact me directly to make advanced test and put less noise here, send me a email to azambuja at protonmail dot ch. I have at least 5 xiaomi devices and the time to make test.

anarchy99 wrote:

can you try latest trunk with modified MIWIFI-MINI.dts file?

replace this part of code:

        wmac@10180000 {
                ralink,mtd-eeprom = <&factory 0>;
        };

        pcie@10140000 {
                status = "okay";

                pcie-bridge {
                        mt76@0,0 {
                                reg = <0x0000 0 0 0 0>;
                                device_type = "pci";
                                mediatek,mtd-eeprom = <&factory 0x8000>;
                                mediatek,2ghz = <0>;
                        };
                };
        };

with

        wmac@10180000 {
                local-mac-address = [00 0a 35 00 00 00];
        };

        pcie@10140000 {
                status = "okay";

                pcie-bridge {
                        mt76@0,0 {
                                reg = <0x0000 0 0 0 0>;
                                device_type = "pci";
                                local-mac-address = [00 0a 36 00 00 00];
                                mediatek,2ghz = <0>;
                        };
                };
        };

where 00 0a 35 00 00 00 is your 2.4GHz wlan mac address and 00 0a 36 00 00 00 is your 5GHz mac address

try to see if the wireless will come up on any of the two intefaces

(Last edited by gazambuja on 7 Apr 2016, 05:30)

I test put the entry on arp and not work sad

# Connected to 2.4G when is not working.
# DHCP give a IP to my laptop without problem:

$ ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 94:65:9c:9f:a1:00  
          inet addr:192.168.10.200  Bcast:192.168.10.255  Mask:255.255.255.0
          ...


$ arp -n
Address                  HWtype  HWaddress           Flags Mask            Iface
192.168.10.1                     (incomplete)                              wlan0

$ sudo arp -i wlan0 -s 192.168.10.1 f0:b4:29:55:9f:46 # IP and MAC of my Xiaomi

$ arp -n
Address                  HWtype  HWaddress           Flags Mask            Iface
192.168.10.1             ether   f0:b4:29:55:9f:46   CM                    wlan0

$ ping 192.168.10.1
PING 192.168.10.1 (192.168.10.1) 56(84) bytes of data.
--- 192.168.10.1 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2000ms

anarchy99 wrote:

ok, take your time.

when it happens again on 2.4 try adding static arp entry and ping router afterwards.

but iwconfig and iw dev wlan0 station dump output needed when your laptop is connected to 5G

for 2.4 reception is known to be weak at the moment, my suspicion is that the same happens on 5G too.

Hi All,
I have two Xiaomi Wifi Mini, and also found the 2.4G connection issue.
I did some research.
There are two project related to MT7621 and MT7612E
WITI : https://github.com/mqmaker/witi-openwrt/
Firefly : https://github.com/FireWRT/FireWRT-Open … ireWRT-SDK

and Mediatek driver for openwrt download
http://www.openwrtdl.com/wordpress/mt76 … B%E8%BD%BD
I believe these driver are released by MediaTek.

I got the mt7620 drivers and patches from these project, and try to merge them into OpenWRT CC.

I folk from openwrt github CC branch and use the mt7620 and mt76x2e driver, also patch luci wireless pages for wifi settings.
https://github.com/changeway/openwrt_CC … i_Mini.git

This is the image I use now
https://changeway.github.io/openwrt/ope … pgrade.bin

There are still issues for using this driver and default configure, but much better than openwrt rt2800 driver using on mt7620.
Any suggestion is welcome.

there is a bug on the pandorabox version.

MT7620 supports VLAN from 0 to 4096., but for me isn't working vlan 20.

I have been testing last weekend on my isp VLAN 20 and didn't work with same configuration compared to another openwrt.

I have test on my lan network with two openwrt(one xiaomi) at vlan 18 and doesn't work , if I replace xiaomi with another , it works well.

Xiaomi at vlan 1,5 is working ok, that is the problem?

(Last edited by alecuba16 on 11 Apr 2016, 18:56)

I back to stock rom. When I installed OpenWrt -  Chaos Calmer 15.05.1 / LuCI 15.05-149-g0d8bbd2 Release (git-15.363.78009-956be55) My 2.4Ghz wifi is very weak just -87dBm on this firmware, two rooms away (7-8 meters the straight line) Orginal xiaomi firmware gave me -60-65dbm. I didn't try 5G because I don't have such a network adapter so I don't know How it works. Maybe in the future someone fix it.

(Last edited by Copeks on 12 Apr 2016, 02:29)

@changeway I test your image and others, here the result:

Distance 1mt/3 feets enviroment with a lot of wifi signals.
Use Wifi Analyzer app over HTC M8 Android 6 to measure.

Format of test:
freq -> best signal / worst signal detected (in 60 seconds of monitoring)

Stock firmware from Xiaomi
2.4 --> -35 / -38
5   --> -39 / -42

Stable version - CC 15.05.01
2.4 --> -57 / -61
5   --> -55 / -58

Trunk - some commit with kernel 4.3 - http://git.openwrt.org/openwrt.git?p=op … ce6ea6df9c
2.4 --> -39 / -56
5   --> -47 / -54

Trunk r49161 (from few days ago... unstable on 2.4G)
2.4 --> -36 / -41
5   --> -48 / -51

Fork of changeway - https://github.com/changeway/openwrt_CC_for_MiWifi_Mini
2.4 --> -34 / -36
5   --> -45 / -47





changeway wrote:

Hi All,
I have two Xiaomi Wifi Mini, and also found the 2.4G connection issue.
I did some research.
There are two project related to MT7621 and MT7612E
WITI : https://github.com/mqmaker/witi-openwrt/
Firefly : https://github.com/FireWRT/FireWRT-Open … ireWRT-SDK

and Mediatek driver for openwrt download
http://www.openwrtdl.com/wordpress/mt76 … B%E8%BD%BD
I believe these driver are released by MediaTek.

I got the mt7620 drivers and patches from these project, and try to merge them into OpenWRT CC.

I folk from openwrt github CC branch and use the mt7620 and mt76x2e driver, also patch luci wireless pages for wifi settings.
https://github.com/changeway/openwrt_CC … i_Mini.git

This is the image I use now
https://changeway.github.io/openwrt/ope … pgrade.bin

There are still issues for using this driver and default configure, but much better than openwrt rt2800 driver using on mt7620.
Any suggestion is welcome.

(Last edited by gazambuja on 13 Apr 2016, 20:52)

Hello guys,

I'm trying to get OpenWRT on my xiaomi, but tried two times and get the same issues

I followed the wiki guide https://wiki.openwrt.org/toh/xiaomi/mini installed default firmware, activated ssh and get root password.

Already tried the following firmwares: http://downloads.openwrt.org/chaos_calm … pgrade.bin (get it from the wiki) and

XMWiFiMini-OpenWrt-PandoraBox-14.09r1696-StrangeOrange-Optimal-U4.bin (someone give this on the thread)

Both tries i went to ssh and after the mtd write my xiaomi reboot and doesnt work anymore

It starts blinking the led and after some times it stops blinking (no lights on led)

Hi,

I have a question for PandoraBox users. My setup is as fallows:

- Main router (not openwrt) which hosts the wifi on SSID1 (and gives addresses in 192.168.0.X range)
- Mi Wifi Mini with PandoraBox in routed client setup (using wifi in 'sta' mode as a client)
- Mi Wifi has only ethernet clients
- Mi Wifi gives addresses in 192.168.1.X range

Right now everything works fine, but when I wanted to add a second wifi network (SSID2) in 'ap' mode, router and it's clients can no longer access Internet. What is strange is I still can ping the main router from both Mi Wifi and from it's clients (both wired clients and wireless clients) so the connection to the main router is still intact.

My configuration is below (I'm adding the second wifi by uncommenting the section from /etc/config/wireless)

cat /etc/config/wireless

config wifi-device 'rai0'
        option type 'mt7612'
        option hwmode '11a'
        option channel 'auto'
        option txpower '100'
        option htmode 'VHT80'
        option country 'CN'

config wifi-iface
        option device 'rai0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt-5GHz'
        option key 'pass'
        option encryption 'psk2'
        option disabled '1'

config wifi-device 'ra0'
        option type 'rt2860v2'
        option hwmode '11g'
        option txpower '100'
        option htmode 'HT40'
        option country 'CN'
        option channel '11'

config wifi-iface
        option network 'wwan'
        option ssid '<SSID1>'
        option encryption 'psk2'
        option device 'ra0'
        option mode 'sta'
        option bssid '8C:04:FF:7C:15:39'
        option key '<pass1>'

#config wifi-iface
#       option device 'ra0'
#       option mode 'ap'
#       option ssid '<SSID2>'
#       option network 'lan'
#       option encryption 'psk2'
#       option key '<pass2>'

cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'auto'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option gateway '192.168.0.1'
        option ip6assign '60'
        option macaddr 'f0:b4:29:52:86:f5'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option macaddr 'f0:b4:29:52:86:f6'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'mt762x'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'mt762x'
        option vlan '1'
        option ports '0 1 2 3 5 6t 7t'

config switch_vlan
        option device 'mt762x'
        option vlan '2'
        option ports '4 6t 7t'

config interface 'wwan'
        option proto 'static'
        option ipaddr '192.168.0.10'
        option netmask '255.255.255.0'
        option gateway '192.168.0.1'
        option dns '8.8.8.8'

cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config dhcp 'wwan'
        option interface 'wwan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

I wanted to ask if anyone had any success with such configuration with mediatek's drivers? Or maybe on other distributions?

Also you can look at https://bitbucket.org/padavan/rt-n56u . This is semiofficial alternative firmware for asus devices and have proprietary mediatek drivers. This firmware (and bootloader) can be builded for xiaomi devices but due to various (licencing) reasons repository with code and configs for xiaomi devices distributing in script ( http://prometheus.freize.net/script/start-99.sh ).

changeway wrote:

Hi All,
I have two Xiaomi Wifi Mini, and also found the 2.4G connection issue.
I did some research.
There are two project related to MT7621 and MT7612E
WITI : https://github.com/mqmaker/witi-openwrt/
Firefly : https://github.com/FireWRT/FireWRT-Open … ireWRT-SDK

and Mediatek driver for openwrt download
http://www.openwrtdl.com/wordpress/mt76 … B%E8%BD%BD
I believe these driver are released by MediaTek.

I got the mt7620 drivers and patches from these project, and try to merge them into OpenWRT CC.

I folk from openwrt github CC branch and use the mt7620 and mt76x2e driver, also patch luci wireless pages for wifi settings.
https://github.com/changeway/openwrt_CC … i_Mini.git

This is the image I use now
https://changeway.github.io/openwrt/ope … pgrade.bin

There are still issues for using this driver and default configure, but much better than openwrt rt2800 driver using on mt7620.
Any suggestion is welcome.

(Last edited by Althathwe on 15 Apr 2016, 12:01)