OpenWrt Forum Archive

Topic: Kimax BS-U25WF - MT7620 Travel Router with Battery and HD

The content of this topic has been archived between 30 Apr 2018 and 6 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

BS-U25WF:It will charge from a laptop usb, but then the router function will not work, the external hdd function with usb will work though... According me it is a bad point.

I agree, I usually do not carry a wall charger with my kit.  I do frequently carry an external battery (RavPower 2.4 Amp, 7800 mah) for my phone.  Have you tried using something similar?

I just got this one thinking I was ordering a U25AWF.  The listing on aliexpress said model:U25AWF but the photos were of the U25WF.  However with this one there is a metal box over all the chips.  Some sort of heat sink I guess.  So I can't confirm it's a MT7620.  Is there a way I can do it through a terminal on a pc connected up to the device.  It's been a long time since I compiled firmware for a router and replaced it.  The last time was a router I put DD-WRT on.  So I'm hoping someone compiled openwrt with good features built in already and could post a link to the firmware.  I'll use imagebuilder if I know the patch is in there.

Mine should be the MT7620 because it has the 2nd antenna running down the side of the hdd compartment, not like the one on the russian link.

I ended up flashing the U25AWF firmware from PhuongLM with hdd spindown and some other goodies.  I figured since it has the same processor and had the same interface as the U25AWF it would work.  It did.  I haven't tested everything but I got the wifi/lan to work and connected to it and can get the Luci interface.  I'm just so new to OpenWRT that the interface is a little confusing.  I'm trying to setup a torrent client that I can use in luci and getting a wifi repeater setup.  I've seen lots of guides.  Still confused.  I'll figure it out.  This will hold me off until I figure out how to compile my own. 

Honestly the interface that Blueendless had on it was version 1.3.3  it wasn't bad.  No samba though and I wanted samba.  All it has was FTP.  It did have a torrent client already, wifi repeater that worked well.  The English on it was awful and the torrent client was in Chinese but using google translate I could figure it out. 

Eventually I'm sure I'll get OpenWRT to have all those features and more........ It's just a nice learning curve with OpenWRT. 

Just an update for anyone with this unit.  I've been able to run it though it with the firmware mentioned.  So far everything works.  USB works with a flash drive and shared the usb with Samba.  So apparently the U25WF and U25AWF are pretty much identical as long as it has the same SOC.  I've not found anything that doesn't work.  Now I just need to figure out how to compile it so I can get all the features I want.

(Last edited by prisoner1969 on 6 Jul 2016, 17:52)

Sorry, how could I return to factory version 1.3.3, now I have open wrt and so i can`t connect my hdd. Thanx.

aleksandr.mironov wrote:

Sorry, how could I return to factory version 1.3.3, now I have open wrt and so i can`t connect my hdd. Thanx.

Flash the rom that's located here.  It's the one I used and it worked perfectly.  That's if you have the one with the MT7620 chipset on it.

https://drive.google.com/open?id=0B-HTw … G5zdERZWUk

At first boot only LAN port is working, the WIFI is disabled by default, please plug device to PC login to 192.168.1.1 setup and enable wifi interface.

You may need to set up the network shares on it.  It uses Samba.  Once I set that up I was able to access the hard drive and usb port with a flash drive in it.

It did work perfectly before that as well if I connected it with the USB cable as an external HDD.

I've not been able to find an original firmware image for this device.  I looked for one in case I was unsatisfied with OpenWRT.  Once I figured out OpenWRT though I became very happy with it.  I even setup my Luci Rtorrent interface and it's working perfectly.  I had to reduce the connections and transfer rates so it wouldn't over heat and reboot.  Which it was doing with default settings.  I'm falling in love with OpenWRT that's for sure......  I even figured out how to set it up as a wireless repeater.

The only thing I'd like to figure out is how to have it setup for multiple host networks.  I have to keep resetting the wireless settings if I move it from home to work to whatever other wireless networks I have to use.  I'm sure there's some way to do it but I haven't found that yet.

(Last edited by prisoner1969 on 27 Jul 2016, 23:23)

Did you install "Kimax U25AWF Patch" from Kh_Shad? How I could install this, and how you get access to hdd?

Patch is already applied in the build that's on the link.  I didn't compile it.  If you look at the previous post it was compiled by PhuongLM.  Access the drive by usb3 cable that came with the unit.  Once you set up the network share in the menu, you can access the drive by samba.  Browse your network in whatever operating system you are using and you should see the share.  That's after you connect either by WIFI or ethernet.  You must connect by ethernet cable first to enable the wifi.  Wifi by default is turned off.  You can also install an ftp server on the unit using the Luci interface and access it by FTP if you'd like.  I prefer samba.

Of course you have to format the drive before being able to use it.  I did that while connected via the usb3 cable.

I'm not proficient to compile my own version yet.  I'm getting a second unit as a backup.  Once I get a working knowledge of compiling my own firmware I'll test it on my backup so as to keep my main unit working.  My new one is a U25AWF with the nice heatsink.  So I'll probably make that one my main working unit and use the U25WF as my firmware testing unit.  Since they are identical in almost every way the firmware works on both.

(Last edited by prisoner1969 on 27 Jul 2016, 23:09)

Ok, thanx for you answer, could you explane me, what should I do with 3 additional files from your link: fdisk, confiq, dmesg, sorry for nooby questions...

aleksandr.mironov wrote:

Ok, thanx for you answer, could you explane me, what should I do with 3 additional files from your link: fdisk, confiq, dmesg, sorry for nooby questions...

nothing unless you are compiling your own firmware I believe.  I just flashed the firmware and it was fine.  I'm a nooby too.  So I don't mind.  I wish some of the more experienced ones with this device would pipe in more often.

(Last edited by prisoner1969 on 28 Jul 2016, 22:54)

Good day, sorry. I installed OpenWrt from your link, but Luci does not see my internal sata disk with NTFS, disk is fulled, and what should I do for recognize disk of samba, changed file system to ext3? Strongly?

Hi,

this sounds like a very interesting openwrt target. I would very much like to get hold of such a router/hdd combo. Any news on the progress? Is there still somebody working on this? Will / can it be included as an official target soon?

Any news are appreciated.

Cheers
andbroe

all works. upload firmware from this topic, without patch. configure mount and samba. also have original file from spi flash. and seller send me .bin with original 1.3.5 firmware.

Great,

but I would like to be able to generate my own image and even do some programming on the device. For this we need a proper build tree.

Regards
andbroe

CosX112 wrote:

all works. upload firmware from this topic, without patch. configure mount and samba. also have original file from spi flash. and seller send me .bin with original 1.3.5 firmware.

Could you post a link to this file: "original 1.3.5 firmware", please?

CosX112 wrote:

http://rgho.st/66jMhTBGy "original 1.3.5 firmware"

Thank you for link, but, can you upload it on another resource (gdrive, dropbox, onedrive, etc)? Chrome mark rghost as fishing site.

(Last edited by gr1ef on 10 Aug 2016, 15:33)

Thanks for the link.

Applied the patch to my Ubuntu 16.04 machine, but am still not able to select the new target in "menuconfig".
What went wrong? Any idea?

Thanks in advance

CosX112 wrote:

http://rgho.st/66jMhTBGy "original 1.3.5 firmware"

Thank you very match, all works, I returned factory firmware from UART, I`m happy,)

I compile an image with things I want. It has transmission-web and it is using 15.05.1 now.

drive.google.com/drive/folders/0B0iF4l2rag1dZm9IWTVJbWkyQkE

I just change the name to u35wf that is the device I have.

(Last edited by RinaGute on 28 Sep 2016, 18:16)

Thanks, RinaGute!

Hi everyone,

locked my hdd, I find myself without web interface, no ssh, ftp ace in short nothing.
Can you tell me the way to follow to unlock it?
I know Arduino programming from uart.

A very big thank you for your help !

I pull original image from spi. You can try flash this image. "original-full-flash-25l12835.bin" on dropbox.

Thank you for your answer.

i have this model, where can i connect spi ?
And with what software can i push "original-full-flash-25l12835.bin" ?

h**p://hpics.li/ea1f6a8
h**p://hpics.li/e5a7554
h**p://hpics.li/5927e87

Please, replace "*" by "t"...

Thank you

(Last edited by bartouz on 11 Sep 2016, 18:59)

Hi,

I progress

i get this from UART

U-Boot 1.1.3 (Jan  7 2013 - 11:32:07)


Board: Ralink APSoC DRAM:  64 MB

relocate_code Pointer at: 83fb4000

enable ephy clock...done. rf reg 29 = 5

SSC disabled.

spi_wait_nsec: 29 

spi device id: c2 20 18 c2 20 (2018c220)

find flash: MX25L12805D

raspi_read: from:30000 len:1000 

raspi_read: from:30000 len:1000 

============================================ 

Ralink UBoot Version: 4.1.0.0

-------------------------------------------- 

ASIC 7620_MP (Port5<->None)

DRAM component: 512 Mbits DDR, width 16

DRAM bus: 16 bit

Total memory: 64 MBytes

Flash component: SPI Flash

Date:Jan  7 2013  Time:11:32:07

============================================ 

icache: sets:512, ways:4, linesz:32 ,total:65536

dcache: sets:256, ways:4, linesz:32 ,total:32768 


 ##### The CPU freq = 580 MHZ #### 

 estimate memory size =64 Mbytes


Please choose the operation: 

   1: Load system code to SDRAM via TFTP. 

   2: Load system code then write to Flash via TFTP. 

   3: Boot system code via Flash (default).

   4: Entr boot command line interface.

   7: Load Boot Loader code then write to Flash via Serial. 

   9: Load Boot Loader code then write to Flash via TFTP. 

 4  3  2  1  0 

   

3: System Boot system code via Flash.

## Booting image at bc050000 ...

raspi_read: from:50000 len:40 

   Image Name:   MIPS OpenWrt Linux-3.14.18

   Image Type:   MIPS Linux Kernel Image (lzma compressed)

   Data Size:    1042922 Bytes = 1018.5 kB

   Load Address: 80000000

   Entry Point:  80000000

raspi_read: from:50040 len:fe9ea 

   Verifying Checksum ... OK

   Uncompressing Kernel Image ... 

can you say me what must i do ?

thank you !

(Last edited by bartouz on 11 Sep 2016, 19:59)