OpenWrt Forum Archive

Topic: RouterStation Pro?

The content of this topic has been archived between 27 Apr 2018 and 6 May 2018. Unfortunately there are posts – most likely complete pages – missing.

so why am i getting 3 interfaces?

wlan0     IEEE 802.11abgn  Mode:Managed  Access Point: Not-Associated
          Tx-Power=0 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

wlan1     IEEE 802.11abgn  Mode:Managed  Access Point: Not-Associated
          Tx-Power=0 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

hwsim0    no wireless extensions.

showing 1 wifi device = radio0 in luci

stel,

I don't think you need the hw-sim module, that is probably why you have the extra wireless interface. If you start by selecting ath9k in menuconfig all dependencies will be satisfied--you don't have to select mac80211 or anything else for wireless.

i didn't compile a .bin. i installed packages that i described so i'm talking about opkg dependency mgmt. i didn't have any interfaces until i installed hw-sim. i guessed that hw-sim was a hardware simulation modules so i avoided installing it. makes sense it would show up as an interface. i'll remove it and see what happens. can someone else send me their iwconfig output? i installed hostap also because i wasn't seeing the essid broadcast and i get more interfaces. check it out.

root@OpenWrt:~# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

wlan0     IEEE 802.11abgn  Mode:Managed  Access Point: Not-Associated
          Tx-Power=0 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

wlan1     IEEE 802.11abgn  Mode:Managed  Access Point: Not-Associated
          Tx-Power=0 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

hwsim0    no wireless extensions.

br-lan    no wireless extensions.

wlan2     IEEE 802.11abgn  Mode:Master  Frequency:2.432 GHz  Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Power Management:off

mon.wlan2  IEEE 802.11abgn  Mode:Monitor  Frequency:2.432 GHz  Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Power Management:off

wlan3     IEEE 802.11abgn  Mode:Master  Frequency:2.432 GHz  Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Power Management:off

I was reading in some posts that support for the gigabit in the RS-Pro isn't supported yet.
Does anyone know if this is still the case or is the gigabit switch now supported.

well i can tell you that i sync up to the gb ports at 1gb (ethtool reports) but i think i screwed up the network config so i can't run a speed test for you let alone get into the damn thing. plus the serial port is male so i need a null modem cable to get on console which i don't have. sux. i was trying to get 2 SSIDs going so i have a public one that doesn't hit my LAN. i was very careful and i didn't mess with the WAN settings so i can always get into the box from there but no go. i find it on the network (hte IP on the WAN port) but ssh and http don't respond. one of the SSIDs show up though i can't associate with it even with static IP settings. what to do?

actually an nmap scan gives me this.

All 100 scanned ports on 192.168.2.189 are filtered

nevermind. i flashed it with a fresh jffs.bin. there was a newer one anyway and i monkeyed with it enough to start from scratch. note that 'option overlay_root /jffs' in /etc/opkg.conf should be commented out with this version for some reason. there's no /jffs partition mounted so i think without this option packages get installed on root. could be a difference between the squashfs and jffs2 binaries. anywa i've got a few issues but it's too let to get into them now.

(Last edited by stel on 4 Jan 2010, 10:10)

ByerRA wrote:

I was reading in some posts that support for the gigabit in the RS-Pro isn't supported yet.
Does anyone know if this is still the case or is the gigabit switch now supported.

I think what you read was that support for the switch isn't there yet. Meaning you can't do things like VLAN config, etc. But in terms of it operating at 1 Gb, yes it can.

cyrus_mc wrote:
ByerRA wrote:

I was reading in some posts that support for the gigabit in the RS-Pro isn't supported yet.
Does anyone know if this is still the case or is the gigabit switch now supported.

I think what you read was that support for the switch isn't there yet. Meaning you can't do things like VLAN config, etc. But in terms of it operating at 1 Gb, yes it can.

Ahh..

Well, hopefully support for the switch will appear soon as VLAN config would be nice on this box.

cyrus_mc wrote:

I think what you read was that support for the switch isn't there yet. Meaning you can't do things like VLAN config, etc. But in terms of it operating at 1 Gb, yes it can.

FWIW, This thread https://forum.openwrt.org/viewtopic.php … 117#p99117 has some status on the progress of getting the Atheros AR8316 switch chip supported.

I haven't seen anything that indicates Ubiquiti is doing anything to get this moving.  If you buy RouterStations Pros, I'd suggest poking Ubiquiti to get them to help in anyway they can.

rct wrote:
cyrus_mc wrote:

I think what you read was that support for the switch isn't there yet. Meaning you can't do things like VLAN config, etc. But in terms of it operating at 1 Gb, yes it can.

FWIW, This thread https://forum.openwrt.org/viewtopic.php … 117#p99117 has some status on the progress of getting the Atheros AR8316 switch chip supported.

I haven't seen anything that indicates Ubiquiti is doing anything to get this moving.  If you buy RouterStations Pros, I'd suggest poking Ubiquiti to get them to help in anyway they can.

I've been poking Ubiquiti about it with no real luck.
(maybe I need to sharpen the stick a bit smile )

I'll just wait until something falls out of the mess.

i've got it all installed again. weird that i could configure the radio with luci but it showed no BSSID though the scan function in luci worked so i know the radio was working and drivers were all there. but i could not see the SSID from my laptop (kubuntu). so i installed hostap, hostap-utils, hostapd, hostapd-utils and then i see the SSID from my laptop but i cannot associate with it (get error cannot associate with AP - from wicd) and also the scan function from within luci stopped working. weirdness. am i missing some package still? you'd think the default openwrt binary was set up for an access point already.

ByerRA wrote:

I've been poking Ubiquiti about it with no real luck.
(maybe I need to sharpen the stick a bit smile )

Are you posting on their forums?  If so, post links here, I can help bug them.  wink

arrgghh i just cannot get the RSPro with R52N card to broadcast 2 SSIDs. what the hell am i doing wrong? check out my configs. i think it has something to do with the insistence that a wlan1 interface is created when i create the second wireless entry (publicwifi). i've tried assigning the network public to eth1, eth1.1, wlan0, wlan1 all with the same effect. note that ifconfig never shows wlan1 but ifconfig -a does. well after an ifconfig wlan1 up it shows but still no ssid broadcast. btw it works right away on my nanostation2 with not-so-latest kamikazee. i'll upgrade it and see if it breaks.

wireless

config 'wifi-device' 'radio0'
        option 'type' 'mac80211'
        option 'channel' '5'
        option 'macaddr' '00:0c:42:3a:ff:06'
        option 'hwmode' '11ng'
        list 'ht_capab' 'HT40-'
        list 'ht_capab' 'SHORT-GI-40'
        list 'ht_capab' 'DSSS_CCK-40'
        option 'txpower' '25'
        option 'disabled' '0'

config 'wifi-iface'
        option 'device' 'radio0'
        option 'ssid' 'stel-test'
        option 'network' 'lan'
        option 'mode' 'ap'
        option 'encryption' 'none'

config 'wifi-iface'
        option 'device' 'radio0'
        option 'ssid' 'publicwifi'
        option 'mode' 'ap'
        option 'encryption' 'none'
        option 'network' 'public'

network

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'proto' 'static'
        option 'netmask' '255.255.255.0'
        option 'defaultroute' '0'
        option 'peerdns' '0'
        option 'dns' '192.168.2.1'
        option 'ipaddr' '192.168.3.1'
        option 'gateway' '192.168.2.106'
        option 'ifname' 'eth1.0'
        option 'type' 'bridge'

config 'interface' 'wan'
        option 'ifname' 'eth0'
        option 'proto' 'dhcp'

config 'interface' 'public'
        option 'proto' 'static'
        option 'ipaddr' '192.168.4.1'
        option 'netmask' '255.255.255.0'
        option 'defaultroute' '0'
        option 'peerdns' '0'
        option 'dns' '192.168.2.1'
        option 'gateway' '192.168.2.106'
        option 'ifname' 'wlan1'

config 'switch'
        option 'vlan0' '1 2 3 4'
        option 'vlan1' '1 2 3 4'

root@router:~# ifconfig -a
br-lan    Link encap:Ethernet  HWaddr 00:0C:42:3A:FF:06 
          inet addr:192.168.3.1  Bcast:192.168.3.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1           
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0           
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0         
          collisions:0 txqueuelen:0                                     
          RX bytes:0 (0.0 B)  TX bytes:402 (402.0 B)                   

br-public Link encap:Ethernet  HWaddr 00:00:00:00:00:00 
          BROADCAST MULTICAST  MTU:1500  Metric:1       
          RX packets:13827 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13520 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0                               
          RX bytes:697769 (681.4 KiB)  TX bytes:1092230 (1.0 MiB)

eth0      Link encap:Ethernet  HWaddr 00:15:6D:C1:3F:14 
          inet addr:192.168.2.106  Bcast:192.168.2.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1             
          RX packets:54418 errors:0 dropped:0 overruns:0 frame:0         
          TX packets:40535 errors:0 dropped:0 overruns:0 carrier:0       
          collisions:0 txqueuelen:1000                                   
          RX bytes:6471304 (6.1 MiB)  TX bytes:5935002 (5.6 MiB)         
          Interrupt:4                                                     

eth1      Link encap:Ethernet  HWaddr 00:15:6D:C1:3F:15 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:50337 errors:0 dropped:0 overruns:0 frame:0
          TX packets:50437 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000                           
          RX bytes:3480570 (3.3 MiB)  TX bytes:4250045 (4.0 MiB) 
          Interrupt:5                                             

eth1.0    Link encap:Ethernet  HWaddr 00:15:6D:C1:3F:15 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:3248 (3.1 KiB)

eth1.1    Link encap:Ethernet  HWaddr 00:15:6D:C1:3F:15
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:812 (812.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1448 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1448 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:99786 (97.4 KiB)  TX bytes:99786 (97.4 KiB)

mon.wlan0 Link encap:UNSPEC  HWaddr 00-0C-42-3A-FF-06-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:52 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3169 (3.0 KiB)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:0C:42:3A:FF:06
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:420 (420.0 B)

wlan1     Link encap:Ethernet  HWaddr 06:0C:42:3A:FF:06
          inet addr:192.168.4.1  Bcast:192.168.4.255  Mask:255.255.255.0
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@router:~# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

eth1.0    no wireless extensions.

br-lan    no wireless extensions.

wlan0     IEEE 802.11abgn  Mode:Master  Frequency:2.432 GHz  Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Power Management:off

mon.wlan0  IEEE 802.11abgn  Mode:Monitor  Frequency:2.432 GHz  Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Power Management:off

wlan1     IEEE 802.11abgn  Mode:Managed  Access Point: Not-Associated
          Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

(Last edited by stel on 7 Jan 2010, 08:37)

looking at http://wireless.kernel.org/en/users/Documentation/iw made me notice that while my wireless config file sets both stel-teest a public SSIDs to mode = ap, the wlan1 interface still gets created as mode=managed (wlan0 mode = AP). i even tried to force it with

iw wlan1 set type ap

but i get this error

See http://wireless.kernel.org/RTFM-AP

which doesn't say much about why i can't set AP mode. my guess is that there can only be one AP mode (master) per hardware. note that i don't have iw installed on my nanostation2 and it shows both ath0 and ath1 as mode = master. maybe i should remove iw from my RSPro?

I am thinking about buying a rspro. I didn't understand if the first openwrt flash must be done via failsafe-tftp-factory or can be done also via preloaded web interface and sysupgrade.bin file.
Thanks in advance

pegasus wrote:

I am thinking about buying a rspro. I didn't understand if the first openwrt flash must be done via failsafe-tftp-factory or can be done also via preloaded web interface and sysupgrade.bin file.
Thanks in advance

Do, you will need to tftp the new image.

yes, the system installed has the gui broken (you can fix by installing a couple of luci packages - see posts on this forum) but i don't think the system on there is upgradeable via the gui anyway. for one the opkg.conf file has an error. anyway tftp methos is easy and adequately documented in this forum.

Hi thank you for answers! Could you please suggest me a mini-pci wireless card to by for rs-pro?Possibly an atheros /n compatible card.Thanks in advance

i've got the microtik R52n ($32 at streakwave.com then /www.titanwirelessonline.com for antennas and pigtails) and the specs are pretty rockin, 2.4Ghz and 5.3/5.8Ghz, 25db, latest atheros chipset. but i'm having a few problems i'm right now guessing are because of an immature ath9k/mac80211 driver. i can't get multiple SSIDs going. i have a nanostation2 as well (uses madwifi for it's atheros radio) and it does multiple SSIDs no sweat. then i can't get it to go into N mode. just started looking into it but damn this stuff should just work. also "auto" for channel select won't work nor will scanning.

(Last edited by stel on 11 Jan 2010, 06:17)

I like the Sparklan WMIA-198N and 199N cards for $55 and $50 each. The 198 is the high powered version and both are Atheros based. The 199N is a 3x3 MIMO card and the 198 is 2x2. I got mine from Oxfordtech.com.

robrob wrote:

I got mine from Oxfordtech.com.

1) FYI that's oxfordtec.com -- without an h).   It looks like the 198 is the higher power 100mW card for $55, and the 199 is the lower powered (?) card for $60 though it doesn't say what the power output is.

I've have to look into them.  I've been away from it, first I have to resolve some issues getting the r52n (2T2R) working. 

On an separate note, anyone try the 8.09.2 release?   How usable is it?

Hey,
I just got the power supply for my RSP and it seems to not like the packages from the repo, so I decided to build a fresh image, but I seem to be missing something as I don't see an option in the menuconfig for RSP or Ubiquiti images.  Is it still supported or am I just not seeing something?
Edit: I just did a "make world" and the images show up but that's a lot of computing for just those images. Any chance that there's a target name for just the rsp images?

(Last edited by haxwithaxe on 16 Jan 2010, 06:55)

haxwithaxe wrote:

Hey,
I just got the power supply for my RSP and it seems to not like the packages from the repo, so I decided to build a fresh image, but I seem to be missing something as I don't see an option in the menuconfig for RSP or Ubiquiti images.  Is it still supported or am I just not seeing something?

You need to select "Atheros AR71xx/AR7240/AR913x" as the target, then "Ubiquiti RouterStation Pro" as the profile.  Make sure you've checked out trunk, as it's not in the 8.09 branch yet.

:facepalm: I went right passed it and didn't even notice it somehow. Thank you.

JimWright wrote:
ByerRA wrote:

I've been poking Ubiquiti about it with no real luck.
(maybe I need to sharpen the stick a bit smile )

Are you posting on their forums?  If so, post links here, I can help bug them.  wink

Ok Jim, please bug them:

Here's a thread in the Ubiquiti Forum that has gone unanswered regarding the lack of an AR8316 switch configuration utility.

http://www.ubnt.com/forum/showthread.php?t=13708