OpenWrt Forum Archive

Topic: TP-Link TL-MR3020 Support

The content of this topic has been archived between 16 Jun 2013 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

written_direcon wrote:

try again, it's not difficult at all to build a working image by yourself :-)

not for me
i tried for 10 days know

I have a MR3020 v1.8 running openwrt 12.09.
I'm trying to use it with e169 3G dongle but any time I enable the wifi (AP mode) to share the connection the 3G link drops every few secs. Thinks a slightly better with external powered USB Hub but still not stable as 3G+Ether only.
Any hints on how to solve the issue?

I wanted to revert to stock firmware but apparently I can't, is it true?
I also tried changing to dd-wrt using the web interface with the file tl-MR3020-webflash.bin ... but it didn't fly.
Any suggestions?

I have a bricked 3020.  At one point I had trunk installed on it and then attempted to put the default firmware back onto it.  Anyway, it boots up now and the WPS and power light stay on and nothing else.

Holding down the WPS button I can boot it into the TP-Link safety mode, whereby it looks for a TFTP server at  I setup a TFTP server on my machine running OS X and opened Wireshark to make sure everything was going as planned.  The 3020 begins downloading the (factory) firmware from the TFTP server and all seems well; however, it restarts and goes back into the same state as before (power and WPS light on, nothing else).

Anyone have any idea where I might go from here that doesn't involve a serial terminal? I've since bought another 3020 but I'd like to resurrect this one and give it to a friend.

what firmware are you using specifically?

have you trimmed the uboot?

anyway glad to hear that also 3020 has that recovery mode..

(Last edited by nebbia88 on 6 Jan 2014, 10:39)

I have to be honest and tell you I have no idea which firmware is on it at this point (I assume none since it's in this state).  I bricked it a few weeks ago and immediately went out and bought a new one because it's fairly critical for my work.  I didn't get a chance to look at it until a couple days ago, and by now the files I used to flash it and my memory of what exactly happened are gone.

I'm not sure what trimming the uboot means. The firmware I'm trying to load onto it is "mr3020nv1_en_3_17_1_up_boot(130929).bin" (renamed to "mr3020v1_tp_recovery.bin").  The main reason I was looking into OpenWRT was because the stock firmware has no QOS, and on a lackluster 3G connection that is shared that REALLY would be helpful.  Unfortunately, OpenWRT didn't seem to like my modem.

I quite like these devices.  I have a third one running a Piratebox.

The same thing happened.  The upload appears to have gone fine.  Here is a link to the Wireshark dump (TFTP only).  Ignore the first couple lines.  Those were before I fixed the file's permissions.  Maybe I should try it on a different OS? …

it happened with (i don't know what model...) that for recovery mode to works you have to find the very same firmware you had before openwrt (bootloader have some check??)

i post here the other firmwares i see for mr3020, both with bootloader trimmed (note that their size is smaller than when you download the same files from

remember to rename them.

let me know if something works... … 130326.bin … 130929.bin

(Last edited by nebbia88 on 9 Jan 2014, 22:33)

No, none of them worked.  mr3020nv1_en_3_17_1_up_boot(130929).bin was what was on it before it was flashed.  Maybe it needs the firmware it shipped with?

i made some tests with my wr703n.

once flashed with the last mr3020 fimrware (130929), i got the tftp recovery mode in uboot.

unfortunately, after several tests, i understood that before flashing, it does a "hardware id check", that compares what's in the flash, with what it got with tftp, and if not equal it will not flash it.

for example, i was able to recover it with 3020 firmware, if i already have a 3020 firmware (both openwrt or tplink), BUT refuses to flash any firmwmare after i erased firmware partition with mtd (I suppose the same happens if you flash a corrupt image).

the 3020 uboot tftp recovery works with other versions (tried wr703n and mr3040), but always checks what's in the flash before writing the new firmware.

does anyone know what else to try to solve this?

(Last edited by nebbia88 on 9 Jan 2014, 16:10)

Im new on openwrt. I just bought an 3020 and i wish i could build an airplay device to listen music on my car. i tryed to build a firmware with attitude adjustment with shairport and usb audio drivers but it didnt worked. i could only acess my router in safe boot throught telnet. i must be doing something wrong. can someone give me a step by step tutorial. i have manage to recover it and i am back on stock attitude adjustment firmware.
thanks for your help guys.

PS: i followed the tutorial below but instead of using trunk i used attitude adjustment because i read it was a stable version, but it didnt worked. sad … eiver.html

(Last edited by CoolFX on 15 Jan 2014, 01:55)

i have a problem with my mr3020
i cannot install kmod-usb-storage.
can u guys help me solved this problem???
thank you

i have a problem with openwrt with my mr3020
i cannot install kmod-usb-storage
can u guys help me solved this problem??
thank you

what error do you get?


Not sure whether it helps @nebbia88 or the others that are trying to revert back to the factory firmware, but maybe you can try the ROOter firmware:

I have a MR 3020 v1.9 (the only that seems to be in the market nowadays - you can still find 1.8 here and there but no 1.7) and I'm quite unclear whether, after flashing to OpenWRT, can one move back to the factory firmware (using any of the binaries available on the internet including the one above).

Hi folks,

I have a very basic question:
My router box says v1.8, but the label in the actual router has a FCC-ID ending with ...v1.

How can I know for sure the correct version?
How I get the correct image (12.09-rc1) if it is v1.8?

If I cannot check the correct version, what should be a conservative way to go use the older revision for v.1.1 ? Or use the newer 12.09-rc1?

Thanks for your patience

Versions suported

(Last edited by rafareino on 31 Jan 2014, 17:43)

Just to avoid crossposting,

Cheap Internet Radio (<50€) with TL-MR 3020 + small usb numeric keypad to control stations and volume. … 08#p225608

(Last edited by pilovis on 18 Feb 2014, 00:09)

What would be the correct  position of the switch? AP mode (Access point) or are the switches taken out of the OpenWRT functionality?

My new 3020 works perfect when directly connected to the WAN or a NULL cable to my PC. when connected as an output of another modem (WAN/LAN mixing?) all seems to work fine but  I'm lost in finding admin access somewhere.I assumed that the range from the 3020 offered would have one IP address assigned to this. Any pointers how this can be found?


(Last edited by peterv999 on 15 Mar 2014, 16:43)

Hi peterv999 your post misses some critical information.

let us know some background information about your environment:
-What's your ISP addressing method and connection/authentication? (DHCP/Fixed IP, DSL/PPPoE/etc)
-what are the detected address/gateway/dns in your machine? (runs ipconfig/ifconfig)
-what's your prefered OS (to provide the right commands to tests)?

By the way, your router should be acessible by, but prior to that you need to manually configure it to stay on address with the mask, thisshould get you directly to Luci interface.

Let us hear back from you.


i've a problem with my mr3020 and want to know if the only solution s using serial console.
After restoring the original firmware with mtd command he has rebooted but now only the power led is on and i can't access it

Ok, first things first.

Please stay calm and tell us what steps you had, use your ssh client history to help you to remember (it will only tell you what steps you had mede outside the box, but should have some glue), then, have you tryed this … safe.mode?

We can have a much more important message from … .port.4919 instead, can you try it? If you use windows this tool ( could help you to use some linux commands.

Good look and tell us back.


well first of all it was on openwrt attitude.
i wanted to return it to tp-link firmware so i've connected it on my computer launch a ssh connection then typed the following command
wget …
unzip TL-MR3020*.zip
mtd -r write mr3020*up*.bin firmware
after that he has rebooted and instead of getting lan led with activity and power led, i just have power led on.
i've tried to ping it with ip since he must be on tp-link configuration but responce from it i've reconfigured my computer ip to ping it on and but still no response.
I've try the failsafe mode of openwrt no sign of activity same for reset of tplink.

here the result of "tcpdump -Ani eth0 port 4919 and udp" on and by the way result after 10mn on both

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes
0 packets captured
0 packets received by filter
0 packets dropped by kernel

i think that i've flashed the bad firmware TL-MR3020_V1_120320 on my mr3020 that hw v1.8 (opened it after the flash operation) or may be because i don't have switched to wisp prior to flash it.

so i just wanted to know if the only way to save it is with serial console because if not, it's useless that i buy a usb ttl.

Well if you are sure you have configured IP/MASK correctly, and you cannot get even the broadcast messages out of the router, then you'll need to appel to the serial console.

Really Sorry!

i guess you do not see any wifi network ssid from it with any position of the switch?

wouldn't the wifi LED light up if wifi was active in some way?