OpenWrt Forum Archive

Topic: TP-Link Archer C2 AC750 support

The content of this topic has been archived between 30 Mar 2018 and 5 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi guys,
i built a new binary for our device, it's based on the OpenWrt trunk instead of LEDE due to better soc wireless driver.
MT7610E driver is included as kernel module and now it's LuCi manageable too! The 5ghz LuCi support works excellent in ap mode, a part some view bugs (maybe some options shouldn't work).

Steps how to build a sysupgrade image! (highly suggest to compile under Debian Jessie 32bit with all prerequisites):

With ArcherC2 profile the following packages are selected by default: kmod-mt7610e, uci2dat, luci-mtk-wifi, wireless-tools, luci

Here you can find a sysupgrade binary to use only up an existing openwrt system (for first flash read all posts and use yoq's factory image via tftp, be careful damn!)
github.com/zaccareal/openwrt-archer-c2/releases

i'll try to refine the code for manageable 5ghz driver, soon i'll add the possibility to create more interface and the STA/WDS mode support, obviously it's appreciated help to improve the code smile
The community did a great work on this board it would be nice if someone update the wiki with tftp flash trick and unbrick technique.
Let me know if something is wrong.
Thanks to all!

(Last edited by zaccaria on 12 Sep 2017, 17:59)

Thank you so much smile i will try with this repo

@zaccaria i have use your release, but when i try to donwload and install something on the router it says
satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-serial:
*      kernel (= 4.4.14-1-5616196ae8f3aaba70ef256bd4ea1ce1) *
* opkg_install_cmd: Cannot install package kmod-usb-serial.
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-serial-wwan:
*      kernel (= 4.4.14-1-5616196ae8f3aaba70ef256bd4ea1ce1) *
* opkg_install_cmd: Cannot install package kmod-usb-serial-wwan.
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-serial-option:
*      kernel (= 4.4.14-1-5616196ae8f3aaba70ef256bd4ea1ce1) *
* opkg_install_cmd: Cannot install package kmod-usb-serial-option.

(Last edited by xabson13 on 11 Sep 2017, 19:48)

Kmods and kernel should compiled together due to a checksum that must matches, you have to build your own system so you can add all you need

ok, will try, anything else must be compiled?

zaccaria wrote:

Steps how to build a sysupgrade image! (highly suggest to compile under Debian Jessie 32bit with all prerequisites):

  • Clone my repo github.com/zaccareal/openwrt-archer-c2

  • Update and install feeds

  • Run make menuconfig and set Ralink RT288x/RT3xxx > MT7620 > TP-Link ArcherC2

  • Run make

You have to build your own whole image, i can't provide you a specific binary for you
Please read here wiki.openwrt.org/doc/howto/build

@zaccaria Why don't you issue a pull request to get this device officially supported?

Could You share final image.bin file? Not everyone can build it.

I have finally got around to pulling one of my C2s from my network and replacing it with the C2 that I was having trouble flashing. This one flashed straight away, no problem.

I have installed openwrt-ramips-mt7620-ArcherC2-squashfs-sysupgrade.bin.zip from github.com/zaccareal/openwrt-archer-c2/releases and that went smoothly too.

Now I need to enable the 5ghz WiFi but was not sure how to do that.
Would I still need to install the wifi5G.tar.gz from earlier in the thread or is there something else that I am missing further on?

I see the advice "to make it works you have only to uncomment lines in Local Startup script and reboot to take effect"
But I don't see anything in /etc/rc.local to un-comment?
Where should I be looking?

@tmo26
It would be awesome, the problems are two: the raw patch for gigabit switch needs some adjustments for the newer lede's kernel(anyway is not a real problem), and second i got a lot of trouble with mt7620 soc wireless drivers in LEDE stable/trunk(disconnections, poor signal ....), actually the best choice is the openwrt trunk that keeps a stable compat-wireless package, i'll check the Daniel Golle staging tree for updates. git.lede-project.org/?p=lede/dangole/staging.git
And i don't think that my ugly changes wuold be accepted in a pull request smile

@kafarowski
Here is a sysupgrade image to use up an existing openwrt system
github.com/zaccareal/openwrt-archer-c2/releases

@halucigenia
Driver is included, enable it directly through Luci if the new radio don't show up post your dmesg
i.imgur.com/ewno2Qi.png

(Last edited by zaccaria on 25 Sep 2017, 00:11)

zaccaria wrote:

Driver is included, enable it directly through Luci if the new radio don't show up post your dmesg
i.imgur.com/ewno2Qi.png

I don't see it, just the generic MAC80211...

What am I looking for in dmesg?

(Last edited by halucigenia on 25 Sep 2017, 16:13)

@halucigenia
It seems there is a mistake on the configuration check in the wifi script (so you should start with a fresh install without keep configurations), anyway follow those steps:

  • Check on dmesg if driver is loaded

  • Run this command through console:

wifi detect >> /etc/config/wireless

or simply add this configuration in /etc/config/wireless

config wifi-device rai0
    option type rai0
    option vendor ralink
    option band 5G
    option channel 0
    option autoch 2
    option disabled 1

config wifi-iface default_rai0
    option device rai0
    option ifname rai0
    option network lan
    option mode ap
    option ssid OpenWrt_5G
    option encryption none

(Last edited by zaccaria on 26 Sep 2017, 15:26)

zaccaria wrote:

@halucigenia
It seems there is a mistake on the configuration check in the wifi script (so you should start with a fresh install without keep configurations), anyway follow those steps:

  • Check on dmesg if driver is loaded

dmesg | grep 80211
[   10.990502] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 5390, rev 0500 detected
[   10.998432] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 7620 detected
[   11.006277] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'

Does that mean that the driver is not loading and I will have to reinstall?

wifi detect


returns nothing

cat /etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option txpower '20'
        option country 'GB'
        option disabled '0'
        option htmode 'HT20'

config wifi-iface
        option ssid '***'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid '00:0C:43:76:20:28'
        option key '***'
        option wds '1'
        option network 'lan'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option encryption 'none'
        option wds '1'
        option network 'lan'
        option ssid '***'

I also have a WDS station and ap on that same radio.
Would setting that up have interfered with the 5Ghz wifi.

I guess that I will have to reinstall and check before I start configuring it again.

OK I did a re-install and I see the 5Ghz radio now. smile

zaccaria wrote:

Hi guys,
i built a new binary for our device, it's based on the OpenWrt trunk instead of LEDE due to better soc wireless driver.
MT7610E driver is included as kernel module and now it's LuCi manageable too! The 5ghz LuCi support works excellent in ap mode, a part some view bugs (maybe some options shouldn't work).

Steps how to build a sysupgrade image! (highly suggest to compile under Debian Jessie 32bit with all prerequisites):

With ArcherC2 profile the following packages are selected by default: kmod-mt7610e, uci2dat, luci-mtk-wifi, wireless-tools, luci

Here you can find a sysupgrade binary to use only up an existing openwrt system (for first flash read all posts and use yoq's factory image via tftp, be careful damn!)
github.com/zaccareal/openwrt-archer-c2/releases

i'll try to refine the code for manageable 5ghz driver, soon i'll add the possibility to create more interface and the STA/WDS mode support, obviously it's appreciated help to improve the code smile
The community did a great work on this board it would be nice if someone update the wiki with tftp flash trick and unbrick technique.
Let me know if something is wrong.
Thanks to all!

Thanks for the awesome work mate! I followed your instructions, but I've compiled with client and WDS support in 5Ghz. But apparently I can't make it work. Any one could help me?

norulez.nikita wrote:
dob71 wrote:
norulez.nikita wrote:

Is these 2 symbols "ap" in 5ghz .ko driver means that it support only ap mode ?

Take a look at the Makefile for that driver code. It appears that the client functionality is not compiled in:

#AP-Client support, default y
CONFIG_MT7610_AP_APCLI=n

Ok, i compiled driver with sta and wds options:
Installation is same as previous compiled driver by yoq.
Wireless config file located at /etc/Wireless/iNIC/iNIC_ap.dat

How to configure STA mode after driver installation:
1)Load our driver:

insmod /mt7610_ap.ko

2)Bring up rai0 interface. It allows us to bring up apclii0 interface (for STA mode). Then bring up apclii0 interface:

ifconfig rai0 up
ifconfig apclii0 up

3)Let's configure new connection to needed gateway. We must configure apclii0 interface:

iwpriv apclii0 set ApCliEnable=0 
iwpriv apclii0 set ApCliAuthMode=WPA2PSK 
iwpriv apclii0 set ApCliEncrypType=AES
iwpriv apclii0 set ApCliSsid="YourSSID"
iwpriv apclii0 set ApCliWPAPSK=YourPassword
iwpriv apclii0 set ApCliEnable=1 

This example for WPA2PSK Auth Mode with AES Encryption (I think it's best way to secure home network). You can also configure another Auth methods and another encryption protocols. First we disabling apclii0 interface for configuring, then we enabling it for use with our settings.
4)After these 3 steps the router will connect to our gateway. you can check it with  iwconfig apclii0:

root@Bridge_Kitchen:~# iwconfig apclii0
apclii0   RTWIFI SoftAP  ESSID:"Bogoslovskie (5Ghz)"
          Mode:Managed  Channel=36  Access Point: 70:4D:7B:15:66:CC
          Bit Rate=65 Mb/s

5)Now we need to link our apclii0 with network interface to configure dhcp client or static connection.
Create wwan interface int /etc/config/network (you can give it any name you like):

config interface 'wwan'
        option proto 'dhcp'
        option ifname 'apclii0'

Restart your network (/etc/init.d/network restart) and you will see working connection in ifconfig smile
You can make relayd pseudobridge to prevent double nat in your network. See this page:
6)Now we gonna apply everything at startup. Just add all the above to /etc/rc.local file.
Remember that rai0 interface is organizing wifi network, after configure apclii0 take down rai0 interface if you want client mode only:

ifconfig rai0 down

I'm trying to use this module to put my mode on Client mode and then setup Realayd. But even tough I'm copy pasting your instructions the router can't seem to associate with the main device. I was wondering if it was a problem with the Channel that stays at Channel 36 even tough I changed it to 161. Could you help me?

yamilife wrote:

I'm trying to use this module to put my mode on Client mode and then setup Realayd. But even tough I'm copy pasting your instructions the router can't seem to associate with the main device. I was wondering if it was a problem with the Channel that stays at Channel 36 even tough I changed it to 161. Could you help me?

Just found out that I had to change CountryRegion and CountryRegionABand to get to channel 161. And I got connected on Client mode! Did you manage to get a relayd connection? Could you share your config?

Sorry guys,
is the release provide for all the C2 AC750 versions (V1->V5) or just for the V1 as written on zaccaria's github ( github.com/zaccareal/openwrt-archer-c2 )

I've tried to read trough the past pages but I couldn't really find this information.
Thanks

Hello guys.

First of all i am a noob.

I just flashed that sysupgrade.bin from above and now the leds are flashing. Is my router dead? I can reflasg stock in any way?

Hver 1

Thanks

youtube.com/watch?v=NcQT2808Jn8

edit1: i've used tfpd32 to transfer latest firmware, but renamed to ArcherC2V1_tp_recovery.bin to the router. Now the power led remains on. Any other steps"?

(Last edited by piff on 15 Oct 2017, 13:36)

Hi,

I just want to say that I have flashed my four C2's according to instructions above and it went fine!

I started with flashing stock forware with ArcherC2V1_tp_recovery.bin (according to post 124), then updating it from Luci with openwrt-ramips-mt7620-ArcherC2-squashfs-sysupgrade.bin (from post 261), then customizing it to become a dumb AP. Everything works fine and both 2.4GHz and 5GHz work better than in stock firmware! There are some minor glitches in Luci for 5GHz WiFi though: it is not reporting associated stations etc.

Warning! Stock routers will sometimes refuse to be flashed from TFTP and say "block #### timed out" etc. It is probably cheap Flash memory controller unable to swallow the new firmware quickly enough. I succeeded by configuring Ethernet speed down to 10Mbit full-duplex when re-flashing. It might take a dozen of attempts even then.


Minor question: is there any way to upgrade "wpad" and "hostapd-common" in this C2 release by packages from LEDE? As we all know, WPA2 has been broken and guys at LEDE have patched the relevant packages to make routers immune to KRACK attack...

(Last edited by Grund_Grunf on 17 Oct 2017, 12:05)

Hello,

I successfully flashed the latest release from zaccaria. I can see the 5 Ghz network with my Wifi devices but I cannot connect to this network The devices stuck when they try to get an IP address. 2.4 Ghz network is working fine and all devices can conncet to it.

Any hints?


Edit: The mode of the 5 GHz network is set to Access Point. After enabling the network, it is shown that the network is operating in client mode while the 2.5 Ghz network is operating as a master.


Edit2: Now it's working. Don't know why....

Thx
Zilon

(Last edited by Zilon on 19 Oct 2017, 18:55)

I installed stock US on a C2 running openwrt using tftp method. I think the router became bricked because the device is EU not US, and I installed the US stock image (from archer website). I read on this thread about someone managing to unbrick their device without soldering the chip by using a cha341 usb programmer and a soic8 clip. Well, I bought those, connected it up, but whenever I flash the stock .bin file using cha341 programmer software, it returns an error. Can anyone help?

My routers current behavior: I turn on the usb. The only light showing is the Power light. Everything else is off. The router also doesn't recognize any ethernet ports. If I connect my pc to the router nothing happens.

(Last edited by uchihi6 on 21 Oct 2017, 21:33)

To setup extroot I guess I would have to compile the image myself to include a few packages, right?
Or can extroot not work with the current state of the build for our device?